Welcome to the Agilent N8300A Help

Welcome to the
Agilent N8300A Help

Last Updated: March 28, 2008

Notices

This online help describes how to use the Agilent N8300A Wireless Networking Test Set and its Applications. The Table of Contents on the left, provides access to all of the information contained within this online help.

The N8300A is a one-box RF parametric test set targeting manufacturing and design engineers who need a standard-compliant 802.16e and 802.16d physical layer (PHY) test tool for mobile WiMAX Tx and Rx applications. Based on an architecture comprising an integrated Vector Signal Analyzer (VSA) and Vector Signal Generator (VSG), the N8300A provides a graphical user interface, a SCPI interface and consistency of software and measurements with industry leading WiMAX R&D test tools that enables fast test development.

The help is organized into the following sections:

  • N8300A Wireless Networking Test Set Help

  • N6301A 802.16 OFDMA Measurement Application Help

  • N6301 802.16 OFDM Measurement Application Help

For pricing and availability, brochures and datasheets for this test set, visit the product page:

  • http://www.agilent.com/find/n8300a

"WiMAX" is a trademark of the WiMAX Forum.

© Agilent Technologies, Inc. 2007-2008


N8300A Wireless Networking Test Set Help

Agilent N8300A Wireless Networking Test Set Help

Last Updated: March 11, 2008

This online help describes how to use the Agilent N8300A Wireless Networking Test Set. The Table of Contents on the left, provides access to all of the information contained within this online help.

The help is organized into the following sections:

  • Getting Started provides introductory information on using the test set, for example, guidelines for protecting the test set and its data, descriptions of the front panel and connectors, and basic troubleshooting.

  • SCPI Commands documents all of the test set's platform remote commands that control functions such as setting the GPIB address, and access to the test set's memory.

  • Front Panel Operation includes information about using the test set manually.

© Agilent Technologies, Inc. 2007-2008


Getting Started

This book provides introductory information on using the test set, for example, guidelines for protecting the test set and its data, descriptions of the front panel and connectors, and basic troubleshooting.

For more details, refer to the topics in this section.

To view a printable version of this Getting Started Guide in Adobe Acrobat format (.pdf), click here.


Installation and Setup

This book provides information on items such as turning on the test set, navigating Windows without a mouse, and power requirements.

For more details, refer to the information below and the other topics in this section.

Technical Documentation

Getting Started | Turn on process, Windows XP use/configuration, Front and rear panel
Help File | Descriptions of front panel key functionality and the corresponding SCPI commands. May also include some concept information. Also contains the Getting Started information in online format.

The product documentation can be found a number of ways. It is:

  1. A printed version of the Getting Started Guide that ships with your test set.

  2. Accessed through the product Help system

  3. On the product website:

    http://www.agilent.com/find/n8300a

Agilent Technologies N8300A Test Set

The N8300 hardware is used with the N6301A Measurement Application which must be purchased separately. It uses Microsoft Windows XP and is an open system.

Operating system settings have been optimized for the best performance. Modification of these settings may degrade test set performance and measurement speed. Those that can be safely modified are described in Test Set Configuration .

The N8300A is an Open Windows environment, so you can install non-approved software on the test set. However, installation of non-approved software may affect test set performance. Agilent does not warrant the performance with non-approved software installed.


Initial Inspection

To avoid hazardous electrical shock, do not perform electrical tests when there are signs of shipping damage to any portion of the outer enclosure (covers, panels, connectors).

Inspect the shipping container for damage. If the shipping container or cushioning material is damaged, it should be kept until the contents of the shipment have been checked for completeness and the test set has been checked mechanically and electrically. If the contents are incomplete or if there is mechanical damage or defects notify the nearest Agilent Technologies office. If the shipping container is damaged, or the cushioning material shows signs of stress, notify the carrier as well as the Agilent Technologies office. Keep the shipping material for carrier's inspection.

Item | Description
Getting Started Guide | Provides first-time power on instructions, licensing information, operating system information, and general hardware information.
Power Cable (See AC power Cord) | Connection for test set power.

Shipping Problems?

If the shipping materials are damaged or the contents of the container are incomplete:

  • Contact the nearest Agilent Technologies office to arrange for repair or replacement (see Returning a Test Set for Service ). You will not need to wait for a claim settlement.

  • Keep the shipping materials for the carrier's inspection.

  • If you must return a test set to Agilent Technologies, use the original (or comparable) shipping


Turning on the Test Set the First Time

Initial power-on requires:

  • Powering On the Test Set

  • Accepting the End-User License Agreement (EULA) Screen

  • Setting System Date and Time

  • Anti-virus Software and Firewalls

TIP

You can get automatic electronic notification of new firmware releases and other product updates/information by subscribing to the Agilent Technologies Test & Measurement E-Mail Notification Service for Agilent instruments at
http://www.agilent.com/find/notifyme

If you do not have a USB mouse available you may want to refer to Navigating Windows Without a Mouse.

Powering On the Test Set

  1. Ensure that the short BNC cable supplied with your test set is connected from the SOURCE 10 MHz OUT connector to the ANALYZER 10 MHz IN connector on the test set's rear panel. Also, you must ensure that the USB cable supplied is connected from one of the test set's four upper USB ports to the USB port on the lower right of the test set's rear panel. These BNC and USB connections are shown in the following graphic.

  2. Position the test set so that you have easy access to the power cord and plug it in.

If this product is not used as specified, the protection provided by the equipment could be impaired. This product must be used in a normal condition (in which all means for protection are intact) only.

  3. Press the power switch (located in the lower left-hand corner of the test set's front panel) to turn the test set on. See Front Panel Features.

  4. The test set can require >5 minutes to power-on. This time is affected by the Windows XP boot-up time and by the number of measurement applications that you are pre-loading.

Allow the test set to warm-up for 30 minutes before making a calibrated measurement. To meet its specifications, the test set must meet the operating temperature requirements.

Accepting the End-User License Agreement (EULA) Screen

The License Agreement screen asks you to accept the terms of the End-User License Agreement for Windows XP. You must accept this agreement to continue the Windows XP installation and configuration. If you do not accept this agreement, the test set shuts down and the next time you turn it on the Windows XP Setup Wizard starts from the beginning again.

For more information about the End-User License Agreement for Windows XP, see the Questions and answers about the End-User License Agreement topic in the Microsoft Windows XP Help and Support Center.

If you have connected a USB mouse, position the cursor appropriately and use the left mouse button to navigate the License Agreement screen.

If you do not have a mouse available to navigate the screen, then use the test set front panel keys as follows:

  1. Press the Tab key to select the License Agreement text box.

  2. Use the up and down arrow keys, or rotate the knob to read the agreement.

  3. Press the Tab key again. This accesses I don't accept this agreement. You need to press the up arrow to select I accept this agreement.

  4. Press Select, or Tab then Enter to finish this screen and move to the Date and Time Settings screen.

Setting System Date and Time

The Date and Time Settings screen is used to set the appropriate date, time and time zone If you have connected a USB mouse, position the cursor and use the left mouse button to navigate the Date and Time Settings screen. Alternatively, the procedure for navigating this screen using a USB keyboard or the front panel is as follows:

  1. Press the Tab (tab right or tab left) key to move between items in the Date and Time Settings screen. (The settings include the Date, Time, and Time Zone boxes, the Automatically adjust clock for daylight saving changes check box, and the Next button).

  2. Use the left and right arrow keys to move between different parts of the item (for example, month, day, year, and hour, minute, seconds).

  3. Use the up and down arrow keys to scroll through the different values available for the selected item (for example, month, day).

  4. Use the Space key to select or clear the ”Automatically adjust clock for daylight saving changes” check box when it is the active item.

  5. When you have completed the date and time settings, press Enter, or Tab then Enter to finish this screen and continue the Windows XP Setup Wizard.

Anti-virus Software and Firewalls

No anti-virus software is shipped with the test set. It is recommended that you install anti-virus software if your test set will be connected to a network. Check with your IT department for their recommendations. See the section 3rd Party Software Verified by Agilent for information about software that has been tested by Agilent.

The test set is shipped with the Windows XP firewall enabled. Do not modify the default network settings as this may cause the test set to not operate properly.


Licensing New Measurement Application Software

Additional measurement application software can be ordered after your initial purchase of the test set. The licenses themselves are downloaded from the license website onto the memory stick so they can be loaded into the test set.

Licenses can be installed using any available USB memory stick. In this case, we recommend that the latest version of the test set software be installed. (Use a 5 MB or larger memory stick.) This ensures that the measurement application being licensed and activated is already installed and is the most current version.

A license key is usually for one test set model/serial number combination. The license key will only install itself on that test set.

No calibration is required after a measurement application installation.

Installation Procedure over USB

  1. Redeem the Option Upgrade Entitlement Certificate by following the instructions on the Certificate.

  2. After redeeming your Option Upgrade Entitlement Certificate you will receive an e-mail with an attached License File.

  3. Locate a USB storage device and save the .lic file to the root directory of the USB storage device.

  4. Connect the USB storage device to any of the USB ports on the test set.

  5. The test set automatically reads the license file. (This may take a few minutes) When the license is installed, the Agilent License Manager will display a ”Successful License Installation” message.

  6. Alternatively the license file can be manually installed over USB or LAN by placing the license file in the following folder on the test set.

C:\Program Files\Agilent\licensing

Installation Procedure over SCPI

The SCPI command required to install the license is:

SYSTem:LKEY <feature>, <license key>

Example:

SYST:LKEY "N6301A-1FP", "02F501B3270CCD737555A8A17B279D73E039BB95E001246AFD087436F9F9C1EFDFBEEBB26EBDFA970CCB"

Verify the Installation

  1. Press System, Show, System to display the list of Installed Applications.

  2. Verify that the new Application appears in the list.

If you require further assistance, please contact the Agilent support team.

Online assistance: http://www.agilent.com/find/assist

If you do not have access to the Internet, contact your local Agilent Technologies Sales and Service Office, or if in the United States, call 1-800-829-4444.


Navigating Windows Without a Mouse

See also the section Windows Shortcuts and Miscellaneous Tasks in the Getting Started Guide book on Using Microsoft Windows XP.

Key Presses | Actions
Esc | Exits/closes a Windows dialog box (does not exit an Application window)
Enter | Does the current ”default action”. If a menu item or a button is currently ”highlighted”, then the Enter key will activate that menu item or button.
Alt | Moves focus/control to the pull down menus bar in the active Window
Right Arrow | In pull-down menu: opens the next menu to the right, or opens a submenu In a dialog box: selects an option button
Left Arrow | In pull-down menu: opens the next menu to the left, or opens a submenu In dialog box: selects an option button
Up Arrow | In pull-down menu: Moves to next selection up in the menu In dialog box: selects an option button
Down Arrow | In pull-down menu: Moves to next selection down in the menu In dialog box: selects an option button
Tab | In dialog box: moves to the next/previous field
Del | Deletes the currently selected item
Alt + Tab | Switches between the next/previous Application
Alt + Enter | Shows the Properties of the currently selected item
Alt + Esc | Cycles through items in the order that they had been opened
Backspace | In My Computer or Windows Explorer: move up one level In Internet Explorer: works like the BACK arrow key
Ctrl + Left arrow | Moves to the left one word at a time
Ctrl + Right arrow | Moves to the right one word at a time
Ctrl + Tab | In dialog box: moves to the next/previous Tab location
Alt + Space | Opens the window control menu for the currently active window, allowing you to minimize, maximize, move and restore (size) the window
Ctrl + Esc | Opens the Windows Start Menu
Ctrl + Alt + Delete | Opens the Windows Task Manager


Power Requirements

The N8300A Wireless Networking Test set requires a power source of 100/120V ac and 220/240V ac single phase. Line frequency is 50-60Hz. The rated power consumption is 270W maximum.

There is an IEC 60320-1 mains inlet provided on the rear of the N8300A for connection to mains power via the supplied power cord set. The only physical installation of your Agilent test set is a connection to a power source. Line voltage does not need to be selected.

The N8300A Wireless Networking Test set operates from a voltage source of 100/120V ac and 220/240V ac single phase and requires no switching or change of fuse. The test set does not contain customer serviceable fuses.

This instrument has been designed and tested in accordance with IEC publication 61010-1:2001, Safety Requirements for Electrical Equipment for Measurement, Control, and Laboratory Use, and has been supplied in a safe condition. The instruction documentation contains information and warnings that must be followed by the user to ensure safe operation and to maintain the instrument in a safe condition.

This is a Safety Class 1 Product (provided with a protective earthing ground
incorporated in the power cord). The mains plug shall only be inserted in a
socket outlet provided with a protective earth contact. Any interruption of
the protective conductor inside or outside of the product is likely to make
the product dangerous. Intentional interruption is prohibited. (IEC 348
clauses 17.3.3c & 17.3.4)

Failure to ground the test set properly can result in personal injury. Before
turning on the test set, you must connect its protective earth terminals to
the protective conductor of the main power cable. Insert the main power
cable plug into a socket outlet that has a protective earth contact only. DO
NOT defeat the earth-grounding protection by using an extension cable,
power cable, or autotransformer without a protective ground conductor.

This product is designed for use in Installation Category II and Pollution Degree 2 per
IEC 61010 Second Edition and IEC 664 respectively.

This test set has autoranging line voltage input. ensure the supply voltage does not vary more than +/- 10% from the specified range.
The Mains wiring and connectors shall be compatible with the connector used in the
premise electrical system. Failure, to ensure adequate earth grounding by not using
the correct components may cause product damage, and serious injury.

AC Power Cord

The N8300A Wireless Networking Test Set is supplied with a three wire power cable. Different cables are available for different power mains configurations.

If this product is not used as specified, the protection provided by the
equipment could be impaired. This product must be used in a normal
condition (in which all means for protection are intact) only.

Install the test set so that the detachable power cord is readily identifiable and easily reached by the operator. The detachable power cord is the test set disconnecting device. It disconnects the mains circuits from the mains supply before other parts of the test set. The front panel switch is only a standby switch and is not a LINE switch. Alternatively, an externally installed switch or circuit breaker (which is readily identifiable and is easily reached by the operator) may be used as a disconnecting device.

Always use the three-prong AC power cord supplied with this product. Failure to ensure adequate earth grounding by not using this cord can cause product damage.


Test Set Location and Rack Mounting Requirements

Locating the test set

Make sure that both the fan inlet area and the exhaust vent area are not obstructed. The minimal clearance required is 2 inches for these vents on the sides of the test set. Lack of adequate clearance can result in excessive audible noise. This is because airflow restrictions cause additional airflow noise and cause the fans to speed up so they can draw in enough air for the required cooling.

The test set has plastic feet for convenience in bench operation.

Cooling and Rack Mounting

Ventilation Requirements

When operating the N8300A, do not position the equipment so as to block the cooling holes or impair the airflow. Allow at least 100 mm between the N8300A and other objects.

When installing the instrument in a cabinet, the convection into and out of the instrument must not be restricted. The ambient temperature (outside the cabinet) must be lest than the maximum operating temperature of the instrument by 4 degrees C for every 100 Watts dissipated in the cabinet. If the total power dissipated in the cabinet is greater then 800 Watts, then forced convection must be used.

Do not rack mount the N8300A test set side by side with another N8300 test set, or an instrument with side to side ventilation. Make sure that the exhaust air from the first unit is directed away from the inlet of the second unit. If the pre-heated air from the first unit is directed into the second test set, it results in excessive operating temperatures in the second unit and can cause instrument failures.


Test Set Maintenance

Cleaning the test set

To prevent electrical shock, disconnect the Agilent Technologies model N8300A from mains before cleaning. Use a dry cloth to clean the external case parts. Do not attempt to clean internally.

No Operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electric shock do not remove covers.

Battery Information

The test set uses a lithium battery located on the CPU board. This is not an operator replaceable part. See Returning a Test Set for Service . Replaceable parts must be approved or supplied by Agilent Technologies.

You can order the service documentation for the test set through your Agilent Sales and Service office.

Danger of explosion if battery is incorrectly replaced. Replace only with the same or equivalent type recommended. Discard used batteries according to the manufacturer's instructions.

Do not throw batteries away but collect as small chemical waste.


Protecting Against Electrostatic Discharge

Electrostatic discharge (ESD) can damage or destroy electronic components (the possibility of unseen damage caused by ESD is present whenever components are transported, stored, or used).

Test Equipment and ESD

To help reduce ESD damage that can occur while using test equipment:

  • Before connecting any coaxial cable to an test set connector for the first time each day, momentarily short the center and outer conductors of the cable together.

  • Personnel should be grounded with a 1 MW resistor-isolated wrist-strap before touching the center pin of any connector and before removing any assembly from the test set.

  • Be sure that all instruments are properly earth-grounded to prevent build-up of static charge.

Do not use these first three techniques when working on circuitry with a voltage potential greater than 500 volts.

  • Perform work on all components or assemblies at a static-safe workstation.

  • Keep static-generating materials at least one meter away from all components.

  • Store or transport components in static-shielding containers.

  • Always handle printed circuit board assemblies by the edges. This reduces the possibility of ESD damage to components and prevent contamination of exposed plating.

Additional Information about ESD

For more information about ESD and how to prevent ESD damage, contact the Electrostatic Discharge Association (http://www.esda.org). The ESD standards developed by this agency are sanctioned by the American National Standards Institute (ANSI).


Upgrading the Measurement Application in the Test Set

This topic explains how to upgrade the application software on the test set:

  • Equipment Required

  • To Perform The Upgrade

Equipment Required

  • An Agilent N8300A to be upgraded

  • A USB mouse

  • A USB keyboard

  • A USB memory stick containing the new version of the application

To Perform The Upgrade

  1. If the test set is not running, start it.

  2. Connect the USB mouse and keyboard into the test set (install any device drivers that Windows requires).

  3. When the WiMax measurement application is running, close it by clicking the Close button at the top-right corner of the application window. Click on ”Yes” when you are asked if you want to shut down the application.

  4. Connect the USB memory stick into one of the USB ports on the test set, and wait for the system to recognize the device.

  5. Start Windows Explorer by clicking My Computer from the Start menu.

  6. Navigate to the folder on the memory stick that contains the new version of the application. Then, right-click the application and choose ”Run as&ldots;”

  7. In the Run As dialog box, select ”The following user”. Set the user to Administrator and type the password. By default this password is set to ”agilent4u”.

  8. Click OK to start the N8300A installation program.

  9. Click ”Next” to display the license agreement screen.

  10. Click ”I accept the terms of the license agreement” then ”Next” to get to the install page.

  11. Click install and the installation will start.

  12. When the installation is complete, click ”Finish”.

  13. Installation is now complete. You may start the new application by double-clicking the ”Launch” icon on the desktop.


Front and Rear Panel Features

This section provides information on the test set's front and rear panel features and symbols, along with display annotations.

For more details, refer to the topics in this section.


Front Panel Features

The display, keys, RF, and USB connectors are located on the front panel. The test set includes a number of keys and a Cursor Control knob that enable you to navigate Windows without connecting a USB mouse and keyboard. However, you can use the test set more easily and efficiently when a USB mouse and keyboard are connected.

Click on the keys and connectors in the picture to learn more about them.

ANALYZER SETUP Keys

These keys set the parameters used for making measurements in the current Mode and Measurement.

Back Space Key

Press this key to delete the previous character when entering alphanumeric information. It also works as the Back key in Help and Explorer windows.

Ctrl Key

Ctrl works the same as a pc keyboard. Use it to navigate in Windows applications, or to select multiple items in lists.

Delete Key

Press this key to delete files, or to perform other deletion tasks.

Enter and Arrow Keys

The Enter key terminates data entry when either no unit of measure is needed, or you want to use the default unit.

The arrow keys:

  • Increment and decrement the value of the current measurement selection.

  • Navigate help topics.

  • Navigate, or make selections, within Windows dialogs.

  • Navigate within forms used for setting up measurements.

  • Navigate within tables.

The arrow keys cannot be used to move a mouse pointer around on
the display.

Full Screen Key

Pressing this key turns off the softkeys to maximize the graticule display area.

Headphones Output

Headphones can be used to hear any available audio output.

Help Key

Opens the test set's online help system at the Welcome page.

Knob

Increments and decrements the value of the current active function.

Local/Cancel/(Esc) Key

If you are in remote operation, Local:

  • returns test set control from remote back to local (the front panel).

  • turns the display on (if it was turned off for remote operation).

  • can be used to clear errors. (Press the key once to return to local control, and a second time to clear error message line.)

If you have not already pressed the units or Enter key, Cancel exits the currently selected function without changing its value.

Esc works the same as it does on a pc keyboard. It:

  • exits Windows dialogs

  • resets input overloads

  • clears errors

  • aborts printing

  • cancels operations.

MARKER Keys

Markers are often available for a measurement, to measure a very specific point/segment of data within the range of the current measurement data.

MEASUREMENT Keys

These keys select the Mode, and the Measurement within the mode. They also control the initiation and frequency of measurement.

Menu/ (Alt) Key

Alt works the same as a pc keyboard. Use it to change control focus in Windows pull-down menus.

Menu Keys

Key labels appear to the left of the menu keys to identify the current function of each key. The displayed functions are dependent on the currently selected Mode and Measurement, and are directly related to the most recent key press.

Numeric Keys

Enters a specific numeric value for the current function. Entries appear on the upper left of the display, in the measurement information area.

Power Standby On/Off Key

Turns the test set on. A green light indicates power on. A yellow light indicates standby mode.

The front-panel switch is a standby switch, not a LINE switch
(disconnecting device). The test set continues to draw power even
when the line switch is in standby.

The main power cord can be used as the system disconnecting device.
It disconnects the mains circuits from the mains supply.

Probe Power

Supplies power for external high frequency probes and accessories.

Return Key

Exits the current menu and returns to the previous menu.

RF IN/OUT 50 Ohm Connector

This Type-N connector provides an RF signal path out of the test set, and is always used as the RF input. The maximum input level is +25 dBm peak.

RF OUTPUT 50 Ohm Connector

This Type-N connector is an optional path for all RF signals out of the test set. The maximum input level is +33 dBm peak.

Select / Space Key

Select is also the Space key and it has typical pc functionality. For example, in Windows dialogs, it selects files, checks and unchecks check boxes, and picks radio button choices. It opens a highlighted Help topic.

Speaker Control Keys

Enables you to increase or decrease the speaker volume, or mute it.

Tab Keys

Use these keys to move between fields in Windows dialogs.

USB Connectors

Standard USB 2.0 ports, Type A. Connect to external peripherals such as a mouse,
keyboard, DVD drive, or hard drive.

UTILITY Keys

These keys control system-wide functionality like:

  • test set configuration information and I/O setup,

  • printer setup and printing,

  • file management, save and recall,

  • test set presets.

Window Control Keys

These keys select between single or multiple window displays. They zoom the current window to fill the data display, or change the currently selected window. They can be used to switch between the Help window navigation pane and the topic pane.

Overview of Key Types

The keys labeled FREQ Channel, System, and Marker Function are all examples of front-panel keys. Most of the dark or light gray keys access menus of functions that are displayed along the right side of the display. These displayed key labels are next to a column of keys called menu keys.

Menu keys list functions based on which front-panel key was pressed last. These functions are also dependant on the current selection of measurement application (Mode) and measurement (Meas).

If a menu key function's numeric value can be changed, it is called an active function. The function label of the active function is highlighted after that key has been selected. For example, press AMPTD Y Scale. This calls up the menu of related amplitude functions. Note the function labeled Reference Level (the default selected key in the Amplitude menu) is highlighted. Reference Level also appears in the upper left of the display in the measurement information area. The displayed value indicates that the function is selected and its value can now be changed using any of the data entry controls.

Some menu keys have multiple choices on their label like On/Off or Auto/Man. The different choices are selected by pressing the key multiple times. Take an Auto/Man type of key as an example. To select the function, press the menu key and notice that Auto is underlined and the key becomes highlighted. To change the function to manual, press the key again so that Man is underlined. If there are more than two settings on the key, keep pressing it until the desired selection is underlined.

When a menu first appears, one key label will be highlighted to show which key is the default selection. If you press Marker Function, the Marker Function Off key is the menu's default key, and it will be highlighted. Some of the menu keys are grouped together by a yellow bar running behind the keys near the left side. When you press a key within the yellow bar region, such as Marker Noise, the highlight will move to that key to show it has been selected. The keys that are linked by the yellow bar are related functions, and only one of them can be selected at any one time. For example, a marker can only have one marker function active on it. So if you select a different function it turns off the previous selection. If the current menu is two pages long, the yellow bar could include keys on the second page of keys.

In some key menus, a key label will be highlighted to show which key has been selected from multiple available choices. And the menu is immediately exited when you press one of the other keys. For example, when you press the Select Trace key (in the Trace/Detector menu), it will bring up its own menu of keys. The Trace 1 key will be highlighted. When you press the Trace 2 key, the highlight moves to that key and the screen returns to the Trace/Detector menu.

If a displayed key label shows a small solid-black arrow tip pointing to the right, it indicates that additional key menus are available. If the arrow tip is not filled in solid then pressing the key the first time selects that function. Now the arrow is solid and pressing it again will bring up an additional menu of settings.


Display Annotations

This section describes the display annotation as it is on the Measurement Application display. Other measurement application modes will have some annotation differences.

Item

Description

Function Keys

1

Measurement bar - Shows general measurement settings
and information.

Indicates single/continuous measurement.

Some measurements include limits that the data is tested
against. A Pass/Fail indication may be shown in the lower
left of the measurement bar.

All the keys in the Analyzer Setup part of
the front panel.

2

Active Function (measurement bar) - when the current
active function has a settable numeric value, it is shown
here.

Currently selected front panel key.

3

Banner - shows the name of the selected measurement
application and the measurement that is currently running.

Mode, Meas

4

Measurement title (banner) - shows title information for the
current Measurement, or a title that you created for the
measurement.

Meas

View/Display, Display, Title

5

Settings panel - displays system information that is not
specific to any one application.

  • Input/Output status - RLTS indicate Remote, Listen, Talk, SRQ

  • Input impedance and coupling

  • Selection of external frequency reference

  • Setting of automatic internal alignment routine

Local and System, I/O Config

Input/Output, Amplitude, System and others

6

Active marker frequency, amplitude or function value

Marker

7

Settings panel - time and date display.

System, Control Panel

8

Key labels that change based on the most recent key press.

Softkeys

9

Displays information, warning and error messages.
Message area - single events, Status area - conditions

10

Measurement settings for the data currently being
displayed in the graticule area.

Keys in the Analyzer Setup part of the
front panel.


Rear Panel Features

The test set's rear panel provides multiple connector types which are listed in this topic in alphabetical order.

You must ensure that the short BNC cable supplied with your test set is connected from the SOURCE 10 MHz OUT connector to the ANALYZER 10 MHz IN connector on the test set's rear panel. Also, you must ensure that the USB cable supplied is connected from one of the test set's four upper USB ports to the USB port on the lower right of the test set's rear panel. These BNC and USB connections are shown in the following graphic.

ANALYZER 10 MHz IN

Permanently connected to the SOURCE 10 MHz OUT connector.

ANALYZER 10 MHz OUT

An output of the test set's internal 10 MHz frequency reference signal. It is used to lock the frequency reference of other test equipment to the test set.

ANALYZER TRIG IN

Allows external triggering of measurements.

ANALYZER TRIG OUT

A trigger output used to synchronize other test equipment with the test set. Configurable from the Input/Output keys.

AM

A BNC connector for inputting an AM signal.

AUX I/O

Not functional for this release.

BNC3

Not functional for this release.

DIGITAL BUS I/0

Not functional for this release.

EXT REF IN

Input for a 1 to 50 MHz external frequency reference signal.

EVENT 1

Not functional for this release.

EXT CLK

Not functional for this release.

FM

A BNC connector for inputting an FM signal.

GPIB

A General Purpose Interface Bus (GPIB, IEEE 488.1) connection that can be used for remote test set operation.

I INPUT

Not functional for this release.

I OUT Q OUT, I OUT, Q OUT

Not functional for this release.

Q INPUT

Not functional for this release.

LAN

A TCP/IP Interface that is used for remote test set operation.

LAN port for Agilent Internal Use Only

An interface for use with Agilent Signal Studio.

Line Power Input

The AC power connection. See the product specifications for more details.

MONITOR

Allows connection of an external VGA monitor.

PAT TRIG

Not functional for this release.

PULSE

A BNC connector for inputting a pulsed signal (+1V = on; 0V = off).

SOURCE 10 MHz OUT

Outputs the 10 MHz reference signal used by the internal timebase. Permanently connected to the ANALYZER 10 MHz IN port.

SOURCE REF IN

Not functional for this release.

SOURCE TRIG IN

Not functional for this release.

SOURCE TRIG OUT

Not functional for this release.

SWEEP OUT

This is a multiple use connector. For signal routing selections.

USB Connectors

USB-A: There are four Hi-Speed USB connectors in the centre area of the rear panel, and two front panel Hi-Speed USB connectors for use with high-speed products (480 Mbps). Use the universal serial bus (USB) connectors to connect USB devices to the test set (for example, mouse, keyboard, external storage device).

Mini-USB: This port is located on the lower right of the test set's rear panel. In order for the test set to operate correctly, you must use the supplied USB cable to connect this connector to one of the four Hi-Speed USB connectors in the centre area of the rear panel.

USB-B: USB TMC (test and measurement class) connects to an external PC controller to control the test set and for data transfers over a 480 Mbps link.

You can connect or disconnect USB devices without shutting down or restarting the test set. Note that before you disconnect a USB device, you need to inform Windows that you are ejecting, removing, or unplugging it, by using the Safely Remove Hardware item [image] in the notification area. (The notification area is located at the far right of the taskbar.)

Note, the test set will attempt to boot from a USB storage device connected to one of the USB connectors, therefore ensure that any USB storage devices are disconnected before turning on the test set.


Front and Rear Panel Symbols

This symbol is used to indicate power ON (green LED).

This symbol is used to indicate power STANDBY mode (yellow LED).

~

This symbol indicates the input power required is AC.

The instruction documentation symbol. The product is marked with this symbol when it is necessary for the user to refer to instructions in the documentation.

The CE mark is a registered trademark of the European Community.

The C-Tick mark is a registered trademark of the Australian Spectrum Management Agency.

This is a marking of a product in compliance with the Canadian

Interference-Causing Equipment Standard (ICES-001).

This is also a symbol of an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).

The CSA mark is a registered trademark of the Canadian Standards Association International.

This symbol indicates separate collection for electrical and electronic equipment mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive 2002/96/EC).

To return unwanted products, contact your local Agilent office, or see
http://www.agilent.com/environment/product/ for more information.

The out position of a bi-stable push control switch

The In position of a bi-stable push control switch

Indicates a Protective Conductor Terminal that must be connected to earth ground before operating the equipment &endash; protects against electrical shock in case of a fault.

Warning

Warning denotes a hazard. It calls attention to a procedure which, if not correctly performed or adhered to, could result in injury or loss of life. Do not proceed beyond a warning note until indicated conditions are fully understood and met.

Caution

Caution denotes a hazard. It calls attention to a procedure which, if not correctly performed or adhered to, could result in damage to or destruction of the instrument. Do not proceed beyond a caution note until the indicated conditions are fully understood and met.


Test Set Configuration

The topics in this book describe the Microsoft Windows XP configuration and the settings used with the Agilent test set software. It includes information about changing some of the system settings. And it describes the Windows operating system configuration and the software installations that are present on the Hard Disk Drive when the test set leaves the factory.

The front panel of the test set has been designed with the keys needed to navigate windows for: accessing menus, traversing in dialogs, selecting items, and depressing displayed buttons. It is possible to use the front panel for changing Windows XP configuration items, but it is much easier to perform these tasks with a USB mouse and external keyboard. For specifics on navigating using the front panel, see the front panel description.

For more details, refer to the topics in this section.


Customer Installation of Software

      Installation of Other 3rd Party Software

      The N8300A is an Open Windows environment, so you can install non-approved software on the test set. However, installation of non-approved software may affect test set performance. Agilent does not warrant the performance of the N8300A with non-approved software installed.

      Before installing any additional programs on the test set, you should exit the Measurement application.

      Also, you must not remove any applications or programs that are installed on the test set when it is shipped from the factory.

      If you install programs other than those which Agilent has tested, it could cause problems with the test set's application. If this happens, you should try uninstalling the program that has caused the problem, or try changing the program's configuration. If this does not correct the problem, you may have to use the Agilent Recovery System to reinstall the test set's system software.


User Accounts

Administrator Login

The Administrator account ships from the factory with the password ”agilent4u”. Using the Administrator account you can perform the following operations:

  • Install software

  • Configure network and printer access

  • Access all files on the test set

  • Add or change user accounts and passwords

  • Change Windows settings

  • Run any application

User Login

The default user account that ships from the factory is ”Instrument” with the password ”measure4u”. This user is a member of the Power Users group. Using the test set account you can perform the following operations:

  • Install software

  • Configure network and printer access

  • Access files on the test set that are accessible to the Power Users group

  • Run applications that are accessible to the Power Users group

AgilentOnly user account

The test set contains a user account called ”AgilentOnly” that can be used by Agilent's customer support in the event that the Administrator password was changed and has since been lost/forgotten. You must not remove or modify the AgilentOnly account.

Agilent Service user accounts

User accounts are defined for Agilent's use if it is necessary to service the test set.

Customer creation of accounts

You can create additional user accounts and decide on the level of security granted to any new user accounts created. For example, the level of security can be assigned as administrator, power user, user, backup operators. User names are not case sensitive but passwords are case sensitive.

For the measurement software to operate the user account executing the software must be assigned Administrator or Power User privileges. Otherwise, the measurement software will not operate correctly.

It is Agilent's expectation that each user's My Documents folder is mapped to the D: drive. This is to avoid overwriting the user's data in the event the Agilent Recovery must be performed. Also, this facilitates convenient backup by copying the contents of the D: drive to external media. All users accounts created by the factory already have My Documents mapped to the D: drive. Please map all new users My Documents folders to the D: drive.


Windows Configuration

The Windows settings have been optimized for the best measurement performance. Any modifications to these settings may degrade test set performance and measurement speed. In general, most Windows System settings (typically set through the Windows Control Panel) should not be modified. Those that can be safely modified are listed below.

To recover from problems caused by changing Windows systems settings, you may have to reinstall the Windows system and test set application using the Agilent Recovery process.

Settings That Can Be Changed

You may change the following Windows settings or administrative tasks (available from the Windows Control Panel) to select your personal preferences.

Before changing any Windows System settings, exit the test set application.

You May Use
This Feature

To Do This...

Configure Microsoft Automatic Updates.

Install and configure an Anti Virus program.

Setup new test set user accounts.

To recover from problems caused by changing Windows systems settings, you may have to reinstall the Windows system and test set application using the Agilent Recovery process.

Add the test set to a network.

Install and configure a printer.

Set the time and date.

Modify System Properties, Advanced Tab settings of Performance, Adjust for
Best Performance. Leave all other settings unchanged.

Settings That Must Not Be Changed

Avoid changing any settings in this section. Changes to the following settings may degrade test set performance, screen displays, and measurement speed.

Do NOT Use
This Feature

To Do This...

Do not change Power Options. (Power Scheme, Power Button, Hibernate)

Do not modify System Properties, Hardware Tab settings (Device Manager,
Drivers).
Do not modify System Properties, Advanced Tab settings (Performance, User
Profiles, Startup and Recovery, Environment Variables, Error Reporting)

Do not remove installed Fonts.

Do not change the following Display Settings:

  • Screen Saver settings

  • The screen resolution, 1024 x 768

  • DPI setting from Normal size (96 DPI)

Do not delete or modify the ”AgilentOnly” user account.

In addition, DO NOT:

  • Add, delete, or modify hard-disk drive partitions.

  • Delete or modify Agilent registry entries.

  • Change the contents of any directories containing the name ”Agilent”

  • Stop these services:

    — The MSSQL$CDF service or uninstall the ”Microsoft SQL Server Desktop Engine”
    — The IIS server or tamper with any virtual directories (or their contents) that came

    configured with the test set.
    (Statement about IIS? - Disable if concerned about security AND will not be using
    Advanced features of Licensing, etc.)

  • Uninstall these libraries, interfaces, or programs:

    — The Agilent I/O Libraries
    — The .NET Framework or any Hotfixes or Service Packs for the .NET Framework
    — The ”Microsoft Visual J# .NET Redistributable Package 1.1"
    — Programs that begin with ”Agilent”
    — The Adobe Acrobat Reader

  • Modify

    — The Agilent I/O Library ”GPIB27”, ”GPIB28” interfaces shown as configured test set I/O in the Agilent Connection Expert or I/O Config.


Configuring Printers

Printers are configured using the Microsoft Windows Control Panel. It is easily accessed from the Windows Start menu or from under the front panel System key. This setup process is most easily done using a USB Mouse and an External Keyboard. If you don't have a mouse it can be done using front panel keys, and you might want to reference the section on Navigating Windows Without a Mouse .

When setting up a new printer, you may need to load the printer driver (unless you are using a network printer that your IT department has set up to include the driver). The manufacturer of the printer supplies the driver software and process. That may require that you attach an external USB disk drive. An alternative is to connect the test set to the LAN and download the driver from the printer manufacturer's internet site.


Configuring LAN

Hostname

The Computer Name, or hostname, is pre-configured from the factory. It must be a unique name such that it will not conflict with other equipment on your LAN. The pre-configured Computer Name is N8300Axxxxxxxxx, where xxxxxxxxx is the last 9 digits of the test set's serial number.

To change the Computer Name consult the Microsoft Windows XP Help and Support Center.

IP Address & Gateway

The test set is pre-configured to obtain an IP Address using DHCP. The IP Address and Gateway can be changed. Consult the Microsoft Windows XP Help and Support Center to configure the LAN.


Windows Security

Microsoft recommends the following three steps to ensure the test set's Windows XP operating system is protected:

  1. Use an internet firewall.

  2. Get the latest critical Windows updates.

  3. Use up-to-date antivirus software.

To check the status or make changes in the security settings for you test set, open the Windows Security Center, click Start, Control Panel, and then click Security Center.

The window may look slightly different on your test set.

Windows Firewall

The test set is shipped with the Windows Firewall enabled.

The window may look slightly different on your test set.

Windows Firewall Exceptions for programs and ports have been added to allow proper operation of the test set over a network. Modifying these settings may cause the test set to not operate properly.

Automatic Updates

The default test set setting is to automatically check for critical Windows Updates, notify you, download the updates and install them, if the test set has internet access.

You can change the configuration of the Microsoft Automatic Updates. You can choose not to have automatic updates. Then you can manually update Windows by accessing Internet Explorer and from the Tools menu select Windows Update.

Be aware that downloading and installing Windows Updates can be network and CPU usage intensive (impacting the test set performance) and some Windows Updates will automatically reboot the test set. It is recommended that Windows Updates be performed when the test set is not in normal use.

Virus Protection

There is no antivirus software included with your test set. Antivirus application software has been tested to be compatible with the test set. See the section on 3rd Party Software Verified by Agilent in the test set Configuration chapter for Anti-Virus software that has been tested by Agilent.

Having antivirus software installed may have a slight impact on the test set performance.

Spyware Protection

There is no anti-spyware software installed on the test set.


System Maintenance

Backup

It is recommended that you have a regular backup strategy. Your IT department may already have a backup strategy in place which is suitable for the test set and its data. Using the Agilent Recovery system in conjunction with a regular backup strategy should allow full recovery of the test set data.

Windows XP has a Backup utility that you can use to archive files and folders in case of a hard disk drive failure. See the Microsoft Windows XP Help and Support Center for more information on this utility. You can also use third party backup utilities. However, you must ensure that this third party software is compatible with the test set's system software. See Customer Installation of Software for more information.

When performing backups, we recommend that you backup the data to an external storage device connected to the network or one of the test set's USB connectors. Also, you should perform backups at times when the test set is not being used for normal operations as it may impact the test set's overall performance.

System Restore

Windows XP contains capability to restore the system to a previous point in time. System Restore is enabled with default settings as provided by Microsoft. However, System Restore is not 100% successful. Therefore it is not the recommended method to backup the test set. System Restore has not been tested to verify successful restoring.

Disk Defragmenting

Over time the test set's hard disk will become fragmented. Windows XP has a Disk Defragmenter utility that you can use to defragment the hard disk. See the Microsoft Windows XP Help and Support Center for more information on this utility.

Running Disk Defragmenter should be performed when the measurement application is not running. Measurement throughput will be significantly impacted while disk defragmentation is in process.


Hard Drive Partitioning and Use

The drive is partitioned into 3 sections: C:, D: and E:

  • The C: partition contains the Windows XP operating system and software installed by Agilent.
    This is an Open System which means you can install additional software, and these should be installed on the C: drive. However, only a limited set of software applications are tested for use with the Agilent measurement software. The installation and/or use of other software is not warranted, and could interfere with the operation of the measurement software. If test set repair is ever needed, the Agilent version of the C: drive is the only part of the test set software that is restored by the Agilent Recovery process. You will have to reload any other software that you have added in the test set.

  • The D: partition is reserved for data storage. The User Accounts that are configured by Agilent have their My Documents folder mapped to the D: drive. This is for the convenience of backing-up the measurement data. You should always back-up the data on the D: drive to an external device. This allows you to restore the data if you ever need to replace the hard drive.

  • The E: partition is reserved for Agilent's use. The primary use of the E: drive is for housing the Calibration and Alignment data. Do not change or overwrite the files on this drive. This could cause your test set to not meet specifications, or even to stop functioning correctly. Do not use this drive for data storage. It is also recommended that you back up the contents of this drive to an external device.


Hard Drive Recovery Process

The Agilent Recovery System can be used to repair errors on the test set's C: drive partition, or to restore the original factory configuration of the system software. The Agilent Recovery System is stored in a separate hidden hard disk drive partition.

Repairing errors on the hard disk drive may result in loss of data or files. If you need more information about the Windows ”chkdsk” error repair process, see the chkdsk documentation in the Microsoft Windows XP Help and Support Center.

Restoring the original factory system software does not restore any of the following items:

  • Windows system configurations that were made after the test set was shipped from the

  • factory. For example, Windows and Service Pack updates, user accounts, and windows configuration settings. After an Agilent Recovery, these configurations will have to be redone.

  • Additional software that was installed after the test set was shipped from the factory. After an Agilent Recovery, that software will need to be re-installed.

  • Any data or programs saved on the D: or E: drives.

  • Any upgrades that were made to the Agilent measurement application software.

It is recommended that you use a regular back up strategy. Your IT department may already have a back up strategy in place which is suitable for the test set and its data. See the System Maintenance section. Using the Agilent Recovery System in conjunction with a regular back up strategy should allow you to fully recover the test set software and data.

It is recommended that routine backups of the test set information be performed to keep current archives of the test set information. This will allow a full recovery of the test set information after the test set recovery system operations are performed. See the ”Backing Up the test set Information” section for more details.

Using the test set Recovery System:

  1. Make sure the test set is turned off.

  2. Turn on the test set.

  3. After the ”Agilent Technologies” screen is displayed

Then the following screen contents will be displayed for 3 seconds.

  4. Press the down arrow key to move the highlight to ”Agilent Recovery System”, press the Enter key.

  5. When the Agilent Recovery System has booted, follow the on-screen instructions to perform the desired recovery operations.

  6. After exiting the Agilent Recovery System, the test set will reboot. If the original factory test set system has been restored, the test set will re-execute the Turning on the Test Set the First Time process.

  7. Additional recovery steps may be required to fully recover the system to a more current working state. This could involve restoring your own backups of the test set configuration, including re-installing applications, data, and performing system customizations.

Configuring Recovery Prompt Timing

You can configure the time at which the test set power-up process waits for the selection of the recovery process by performing the following steps:

  1. Get to My Computer, Properties

  2. Select ”Advanced” tab

  3. In the ”Startup and Recovery” section, select ”Settings”

  4. Under the ”System Startup” section, you can either uncheck ”Time to display list of operating systems:” or change the seconds to delay for it.

You must be logged in as an administrator in order to change these settings. See User Accounts for more information.


Using Microsoft Windows XP

The topics in this section provide information about using the test set remotely, capturing displays and windows, and shortcut keys for use with Windows.

The capabilities described in this section are Microsoft Windows XP features. The discussion provided here gives some guidelines for using the capabilities with the test set. You will have to refer to the Windows XP help documentation for more information. Your version of Windows may not match these instructions exactly.
You need an external keyboard and mouse to fully use these features.

For more details, refer to the topics in this section.


Remote Desktop: Using the N8300A Remotely

Windows Remote Desktop is recommended for remote control of the test set. It offers fully-interactive control, that is almost identical to direct face-to-face control of the test set.

The Remote Desktop functionality is a Microsoft Windows XP capability. The following discussion provides some guidelines for using this capability with the test set. You will have to refer to the Windows XP help documentation for more information. As Windows evolves, these instructions may no longer be exact.

You need an external keyboard and mouse to fully use this functionality.

For more details, refer to the topics in this section.


Overview of Remote Desktop Operation

Using the Remote Desktop functionality of the test set allows you to control and interact with the test set from a remote desktop client computer, as though you were sitting in front of the test set.

When you have configured the test set for remote connectivity, and configured a separate computer to act as a remote desktop client computer, you can send commands to the test set from the remote desktop client computer, and you can see the test set Display on the screen of the remote desktop client computer.

This Section provides full details of how to set up the test set for remote connectivity, and also how to set up a computer running any 32-bit version of Microsoft Windows as a remote desktop client computer.

Basic Setup for Remote Desktop Operation


Setting Up Remote Desktop Operation

Setting Up the Test Set

Before the test set may be controlled via a Remote Desktop Connection, it must be set up to allow connection from a remote computer.

To perform this operation successfully, you must have Administrator level access to the test set.

To perform setup, do the following:

  1. Open the Windows Control Panel, by either:

  • from the test set Application, pressing System, Control Panel..., or,

  • from the Windows Desktop, clicking Start, Control Panel.

  2. If the Control Panel appears with ”Category View”, click Performance and Maintenance, then click System. If the Control Panel appears with ”Classic View”, double-click System.

  3. Select the Remote Tab of the System dialog.

  4. A Warning Message appears, informing you that it may be necessary to configure your internet connection sharing or personal firewall to permit Remote Desktop connections. The details of such configuration are beyond the scope of this document.

  5. In the ”Remote Desktop” section of the dialog, check the ”Allow users to connect remotely to this computer” checkbox.

  6. 6 Click the ”Select Remote Users...” button, then follow the on-screen instructions to add users. All users who have Administrative level access are listed as already having permission. You should also ensure that the ”Instrument” user is on the list of allowed remote users.

Setting Up the Remote Computer

The procedure depends on whether the Remote Computer to be set up is running Windows XP, or another version of Microsoft Windows.

Remote Computer running Windows XP Windows XP includes the Remote Desktop Connectivity Client software, so no additional setup is required.

Remote Computer running another Version of Windows You can use any 16-bit version of Windows (Windows 95, 98, ME, NT4, or 2000) to install and run the Client software for Remote Desktop Connectivity. However, you need to have available a Windows XP installation CD-ROM, because that contains the Client software. You can also use Windows Vista as a client operating system.

The following instructions relate to software provided by Microsoft Corporation. Agilent offers no warranty regarding the operation of such software. The procedure described here may be changed by Microsoft at some future time.

To install the Client software, do the following:

  1. When the Welcome Screen appears, select Perform additional tasks.

  2. From the ”What do you want to do?” screen, select Set up Remote Desktop Connection.

  3. The ”Remote Desktop Connection InstallShield Wizard” appears. Click Next to begin the installation, and follow the on screen instructions provided by the Wizard.

  4. Once the Remote Desktop Client Software is installed, you can access it via the Windows Start menu, under All Programs > Accessories > Communications > Remote Desktop Connection.


Running a Remote Desktop Session

Initializing a Remote Desktop Session

In order to initialize a Remote Desktop Session, you need to know the ”Computer Name” of the test set. This information can be shown on the test set display by following the procedure in the Section How To Locate the Computer Name of the Test Set .

After setting up both the test set and the Remote Computer for Remote Desktop Connectivity, as described in the Section Setting Up Remote Desktop Operation , you are ready to start a Remote Desktop session.

To start a Remote Desktop session from the remote computer:

  1. Click Start > All Programs > Accessories > Communications > Remote Desktop Connection.

  2. A Remote Desktop Connection dialog appears.

In the box titled Computer, enter the Computer Name of the test set. (For instructions on how to obtain this, see the Section How To Locate the Computer Name of the Test Set .)

  3. Click Connect.

  4. Log in to the test set. In the login dialog that appears, enter the login account name and password. The default account name is ”Instrument” and the default password is ”measure4u,” but note that these parameters may be changed by test set users.

Only the current User or an Administrator can remotely log into the test set. To see who the current user of the test set is, press Ctrl+Esc on the test set until you can view the current user name on the Start menu. If no one is currently logged into the test set, any valid test set user can remotely log in.

  5. The test set Display appears on the screen of the remote desktop client computer. Because the test set Front Panel keys are not available when using the test set remotely, three alternative methods are available to mimic the functions of the Front Panel keys, as detailed in the Sections, Popup Menus for Remote Desktop Operation , and Keycode Commands for Remote Desktop Operation.

Setting Remote Desktop Options

Clicking the Options button in the Remote Desktop Connection dialog displays the Options dialog:

The Options dialog has several tabs. Generally, the default settings are correct. However, there are some restrictions on particular settings under certain tabs, as listed below.

  • Under the General tab, ensure that the Computer Name, User name and Domain name are correctly set. You may choose to enter the password and save it for future sessions, by checking the Save my password box.

  • The information displayed under the Display tab is as shown below:

  • Under Remote desktop size, you may select the size of the window in which the test set display will appear. Do not select any size smaller than 1024 x 768 pixels. Selecting a remote desktop size smaller than 1024 x 768 results in the test set display not being fully visible. In such circumstances, scroll bars do not appear, so portions of the display are not accessible.

  • Under Colors, you may select any setting that uses 15 bits or more. Selecting a color setting that uses fewer than 15 bits results in dithering and incorrect color rendition of the remote desktop window.

  • The information displayed under the Experience tab is as shown below:

To optimize the performance of the Remote Desktop session, choose the appropriate connection format from the drop-down list box.

Ending a Remote Desktop Session

There are two ways to disconnect the remote computer from the test set, ending the Remote Desktop session.

  1. If the remote desktop window is full-screen, click the X at the right of the connection bar that appears at the top center of the window. If the remote desktop window is not full-screen, click the red X box at the right of the window's title bar. In both cases, a dialog appears, asking you to confirm that you wish to disconnect. Click OK to disconnect.

  2. Move the cursor to the bottom left of the remote desktop window, to cause the taskbar to appear. Click Start, then click the red Disconnect button at the lower right of the Start menu (this corresponds to the Shut Down button in a non-remote Windows session). A dialog appears, asking you to confirm that you wish to disconnect. Click Disconnect to disconnect.

Popup Menus for Remote Desktop Operation

Right-clicking the mouse over the application display window pops up the following menu hierarchy, which may be used as alternatives to the Front Panel keys.

The function of each selection in the popup menu is generally identical to that of the corresponding Front Panel key. There are certain additional items, as listed below:

  • Exit. Selecting this item closes the Application software.

  • Utility > Page Setup. Selecting this item opens a printer setup dialog.

The popup menus are also available when using the test set directly, provided that a mouse or other pointing device is attached to it.

Keycode Commands for Remote Desktop Operation

When using the test set in Remote Desktop mode, the following combinations of remote keyboard keys can be used to mimic the front panel of the test set.

Keycode Commands

To mimic the following Front Panel key: | Press these keys on the Remote Computer keyboard:
AMPTD Y Scale | Ctrl+Shift+A
Auto Couple | Ctrl+Shift+C
Bk Sp | Backspace
BW | Ctrl+Alt+B
Cancel (Esc) | Esc
Cont | Ctrl+Alt+C
Ctrl | Ctrl
Decrease Audio Volume | the Volume Control slider
Del | Delete
Down Arrow | Down Arrow
Enter | Enter (Return)
File | Ctrl+F
FREQ Channel | Ctrl+Shift+F
Full Screen | Ctrl+Shift+B
Help | F1
Increase Audio Volume | the Volume Control slider
Input/Output | Ctrl+Shift+O
Left Arrow | Left Arrow
Marker | Ctrl+Alt+K
Marker -> | Ctrl+Alt+N
Marker Function | Ctrl+Alt+F
Meas | Ctrl+Alt+M
Meas Setup | Ctrl+Alt+U
Menu (Alt) | Alt
Mode | Ctrl+Shift+M
Mode Preset | Ctrl+M
Mode Setup | Ctrl+Shift+E
Mute | the Mute checkbox under the Volume Control
Next Window | Ctrl+Shift+N
Peak Search | Ctrl+Alt+P
Print | Ctrl+P
Quick Save | Ctrl+Q
Recall | Ctrl+R
Restart | Ctrl+Alt+R
Return | Ctrl+Shift+R
Right Arrow | Right Arrow
Save | Ctrl+S
Select | Space Bar
Single | Ctrl+Alt+S
Softkey 1 | Ctrl+Shift+F1
Softkey 2 | Ctrl+Shift+F2
Softkey 3 | Ctrl+Shift+F3
Softkey 4 | Ctrl+Shift+F4
Softkey 5 | Ctrl+Shift+F5
Softkey 6 | Ctrl+Shift+F6
Softkey 7 | Ctrl+Shift+F7
Source | Ctrl+Alt+U
Source Control | Ctrl+Shift+E
SPAN X Scale | Ctrl+Shift+S
Split Screen | Ctrl+Shift+L
Sweep/Control | Ctrl+Shift+W
System | Ctrl+Shift+Y
Tab | Tab
Trace/Detector | Ctrl+Alt+T
Trigger | Ctrl+Shift+T
Up Arrow | Up Arrow
User Preset | Ctrl+U
View/Display | Ctrl+Shift+V
Zoom | Ctrl+Shift+Z
1 | 1a
2 | 2a
3 | 3a
4 | 4a
5 | 5a
6 | 6a
7 | 7a
8 | 8a
9 | 9a
– | Use the – key to enter a negative value, as appropriatea
. (Decimal Point) | . (Period)a
0 (Zero) | 0 (Zero) a

  1. For remote keyboards that feature a numeric keypad, use either the appropriate

    numeric keypad key or the main keypad key.

The effect of pressing Ctrl+Alt+Delete on the keyboard of the remote computer always applies to the remote computer, and not to the test set. Generally, the effect of pressing this key combination is to display the Windows Task Manager. Therefore, pressing this key combination on the remote computer does not allow you to reboot the test set.


How To Locate the Computer Name of the Test Set

To connect a remote desktop client computer to the test set, you need to know its ”Computer Name.” The Computer Name can be displayed as follows:

From the Agilent Application:

  1. On the test set Front Panel, press System, Show, System.

  2. A page listing various parameters appears. The test set's Computer Name is shown in the list alongside the title ”Computer Name”.

From the Windows Desktop (with a mouse attached to the test set):

  1. Click Start, Control Panel.

  2. If the Control Panel window appears in Category View, click Performance and Maintenance, then System, to display the System Properties dialog. If the Control Panel appears in Classic View, double-click System to display the System Properties dialog.

  3. Click on the Computer Name tab of the System Properties dialog.

  4. To close the System Properties dialog, click Cancel.

From the Windows Desktop (without a mouse attached to the test set):

  1. Press Ctrl+Esc to display the Windows Start menu, then use the Up Arrow or Down Arrow keys to select the Control Panel item. Press Enter to open the Control Panel dialog.

  2. If the Control Panel window appears in Category View, press Tab to select Performance and Maintenance, then press Tab to select System. The System Properties dialog is displayed. If the Control Panel appears in Classic View, press Tab to select System, then press Enter, to display the System Properties dialog.

  3. Press Ctrl+Tab until the Computer Name tab is selected. The Computer Name is displayed under ”Full computer name.”

  4. To close the System Properties dialog, press Tab to select the Cancel button, then press Enter.

  5. To close the Control Panel dialog, press Alt+Select to open the drop-down File menu, then press the Down Arrow until the Close menu item is selected. Press Enter to close the Control Panel dialog.


Capturing/Printing Displays and Windows

This capture/print functionality is a Microsoft Windows XP capability. The following discussion provides some guidelines for using this capability with the test set. You will have to refer to the Windows XP help documentation for more information.

You need an external keyboard and mouse to use this feature.

Save the Desktop:

  1. Capture the entire desktop by pressing the external keyboard Print Screen key. This saves the

  2. desktop on the Windows clipboard.

  3. Open a graphics software program like Microsoft Paint.

  4. Paste the clipboard contents into the program. (Ctrl + v)

  5. Save the image in a file.

Save the Current Active Window:

  1. Click on the window you want to capture (activate it).

  2. Capture the window by pressing the keys on the external keyboard Alt + Print Screen key. This

  3. saves the active window on the Windows clipboard.

  4. Open a graphics software program like Microsoft Paint.

  5. Paste the clipboard contents into the program. (Ctrl + v)

  6. Save the image in a file.


Windows Shortcuts and Miscellaneous Tasks

This section provides a list of windows shortcuts (key combinations) that are useful when you operate the test set without an attached mouse and keyboard. (See also Navigating Windows Without a Mouse .) Although these shortcuts are available in any Windows XP system, they are not commonly used when a mouse and keyboard are attached.

This section also includes details of certain windows tasks that may be required from time to time when using or configuring the test set.

Windows Shortcuts (Key Combinations)

You can use the following combinations of front panel keys to perform basic windows tasks when using the test set without an attached mouse and keyboard.

Windows Shortcut Key Combinations

To do the following: | Press:
Display the Windows Start Menu | Ctrl+Esc
Cycle through all open applications | Alt+Tab
Select the first menu of a menu bar | Alt
Move through menu headings | Left Arrow, Right Arrow
Open (drop down) a menu | Down Arrow
Move through items in an expanded menu | Up Arrow, Down Arrow
Close the current menu selection | Esc
Cancel the current menu bar selection | Alt
Open an application's control menu (usually the left-most menu on the menu bar, starting with File) | Alt+Select
In a dialog: move between tabs | Ctrl+Tab
In a dialog: move forward through dialog box items | Tab
In a dialog: move backward through dialog box items | Shift+Tab
In a dialog: open a list box | Alt+Down Arrow
In a dialog list box or check box: select or deselect items | Select
In a dialog list box or check box: select or deselect one item at a time | Shift+Up Arrow, Shift+Down Arrow
In My Computer, expand a selected folder | Enter
In My Computer, open a folder one level up from the current folder | Bk Sp

Example: Navigating an Application Menu without a Mouse or Keyboard

This example uses Microsoft Excel, but you can use a similar sequence of operations to select and execute any menu item of any application.

To select and execute the item Sheet > Rename option from the Format menu in the menu bar shown below

perform the following operations:

  1. With the focus in the appropriate window, press Alt to select the File menu in the menu bar.

  2. Use the Right Arrow and Left Arrow keys to move horizontally to the Format menu.

  3. Press Down Arrow to expand the Format menu.

  4. Use the Down Arrow and Up Arrow keys to move vertically to the Sheet menu item.

  5. Press Right Arrow to expand the Sheet sub-menu.

  6. The Rename sub-menu item appears already selected. (If another item in the same sub-menu is required, use the Down Arrow and Up Arrow keys to move vertically to that item.)

  7. Press Enter to execute the selected action.

Windows Taskbar: Auto-hide

The Windows taskbar should always be in the auto-hide mode when using the test set application. If the taskbar is not set to auto-hide, the lower part of the test set display is obscured by the taskbar.

If a mouse is attached to the test set, and you move the mouse cursor to the bottom of the display (either deliberately or accidentally), the taskbar automatically appears. Provided that the taskbar is in auto-hide mode, you can make it disappear again by moving the mouse cursor away from the bottom of the screen.

If at any time the Windows taskbar is inadvertently set to the non-auto-hide mode, you can restore the auto-hide behavior by doing the following:

  1. Click Start > Control Panel. If not using a mouse, press Ctrl+Esc.

  2. If the Control Panel window appears in Classic View, click Taskbar and Start Menu. If the Control Panel window appears in Category View, click Appearance and Themes > Taskbar and Start Menu. If not using a mouse, use the shortcut key combinations specified in the Section Windows Shortcuts (Key Combinations) to make these selections.

  3. The Taskbar and Start Menu Properties dialog appears. Select the Taskbar tab.

  4. Check the Auto-hide the taskbar check box. If not using a mouse, press Tab repeatedly until the auto-hide option is selected, then press Select to toggle the check box state.

  5. Click or select OK to apply the change and close the dialog.

The Windows Startup Folder

All Windows XP systems include a special folder, called the Startup folder. If a program, or a shortcut to a program, is placed in the Startup folder (either by Windows itself, or by a third-party application, or by any user), that program automatically runs every time Windows is restarted.

When your test set is first configured by Agilent, shortcuts to the appropriate application software and supporting programs are placed in the Startup folder. The exact contents of the Startup folder depends on the options you purchased with your test set.

You should never delete items that appear in the Startup folder, or move any item from the Startup folder to another folder. Deleting or moving any item in the Startup folder may cause applications not to start automatically when Windows is restarted, or may cause certain options to be unavailable when using the test set.

If you wish to view the contents of the Startup folder, do one of the following:

  • Either click Start, All Programs, then select Startup, or,

  • Click Start, My Computer, then navigate to the folder C:\Documents and Settings\All Users\Start Menu\Programs\Startup. (Note that additional startup items may also appear in the corresponding startup folder for the user that is currently logged on. For example, the startup folder for the administrator user is C:\Documents and Settings\administrator\Start Menu\Programs\Startup.)


Troubleshooting

This book provides contact information for Agilent service centers, and troubleshooting information that is applicable to the test set hardware, operating system, and test set application.

For more details, refer to the topics in this section.

No operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electrical shock do not remove covers.


Check the Basics

  • Is there power at the receptacle?

  • Is the test set turned on? Check to see if the green LED beside the power switch is on. Also, listen for internal fan noise to determine if the test set cooling fans are running.

  • If other equipment, cables, and connectors are being used with your test set, make sure they are connected properly and operating correctly.

  • Is the Measurement Application running? If not, there is a software launch shortcut/icon on the desktop.

  • Does the Measurement Application have the focus? (That is, is the blue window banner highlighted?) If not, move focus to the application with Alt-Tab.

  • Review the measurement procedures being performed when the problem first appeared. Are all of the settings correct?

  • If the test set is not functioning as expected, return the test set to a known state by pressing Mode Preset.

Some test set settings are not affected by a Preset. If you wish to reset the test set settings, press System, Power On, Restore Power On Defaults.

  • Is the measurement being performed, and the results that are expected, within the specifications and capabilities of the test set? Refer to the specifications for your test set. Refer to http://www.agilent.com/find/n8300a).

  • If the test set is not communicating via the LAN connection, check for the presence of blinking yellow LEDs on the rear panel LAN connector. If the receive LED is not blinking, check the LAN cable and LAN integrity.

  • Check if the external frequency reference is selected but not available. Verify that it is selected by pressing Input/Output, Freq Ref In. If External is selected, changing the setting to Sense allows the test set to sense the presence of an external reference and use it only if it is available. The frequency of the reference should be set correctly.

  • If you are using a Windows program, other than the test set application, you may notice it running slow. Place the test set application in single sweep/measurement.

TIP

You can get automatic electronic notification of new firmware releases and other product updates/information by subscribing to the Agilent Technologies Test & Measurement E-Mail Notification Service for your test set at http://agilent.com/find/notifyme


Problems with Microsoft Windows XP

The Microsoft Windows XP operating system settings have been optimized for the best performance. Modification of these settings may degrade test set performance and measurement speed. Those that can be safely modified are described in Test Set Configuration.

The N8300A is an Open Windows environment, so you can install software on the test set. However, installation of non-approved software may affect test set performance. Agilent does not warrant the performance with non-approved software installed.


Returning a Test Set for Service

Calling Agilent Technologies

Agilent Technologies has offices around the world to provide you with complete support for your test set. To obtain servicing information or to order replacement parts, contact the nearest Agilent Technologies office listed below. In any correspondence or telephone conversations, refer to your test set by its product number, full serial number, and software revision.

Press System, Show, System, and the product number, serial number, and software revision information will be displayed on your test set screen. A serial number label is also attached to the rear panel of the test set.

Locations for Agilent Technologies

Online assistance: http://www.agilent.com/find/assist

United States (tel) 1 800 829 4444 (fax) 1 800 829 4433 | Latin America (tel) (305) 269 7500 (fax) (305) 269 7599 | New Zealand (tel) 0 800 738 378 (fax) 64 4 495 8950
Canada (tel) 1 877 894 4414 (fax) (905) 282-6495 | Japan (tel) (81) 426 56 7832 (fax) (81) 426 56 7840 | Asia Pacific (tel) (852) 3197 7777 (fax) (852) 2506 9284
Europe (tel) (31 20) 547 2323 (fax) (31 20) 547 2390 | Australia (tel) 1 800 629 485 (fax) (61 3) 9210 5947

Read the Warranty

Please read and become familiar with the terms of your test set’s warranty.

If your test set is covered by a separate maintenance agreement, please be familiar with its terms.

Service Options

Agilent Technologies offers several optional maintenance plans to service your test set after the warranty has expired. Call your Agilent Technologies office for full details.

If you want to service the test set yourself after the warranty expires, you can purchase the service documentation that provides all necessary test and maintenance information.

You can order the service documentation, Option 0BW (assembly level troubleshooting information) through your Agilent Technologies office.

Service Tag

When you are returning an test set to Agilent Technologies for service, fill out and attach one of the blue service tags provided at the end of this chapter. Please be as specific as possible about the problem. If you have recorded any error messages that appeared on the display, have completed a functional test, or have any other specific data on the performance of your test set, please include a copy of this information. An example of the tag is shown below.

Packaging the Test Set

Use original packaging or comparable. It is best to pack the unit in the original factory packaging materials if they are available.

Analyzer damage can result from using packaging materials other than those specified. Never use styrene pellets in any shape as packaging materials. They do not adequately cushion the equipment or prevent it from shifting in the carton. They cause equipment damage by generating static electricity and by lodging in the test set louvers, blocking airflow.

You can repackage the test set with commercially available materials, as follows:

  1. Attach a completed service tag to the test set.

  2. Wrap the test set in antistatic plastic to reduce the possibility of damage caused by electrostatic discharge.

  3. Use a strong shipping container. The carton must be both large enough and strong enough to accommodate the test set. A double-walled, corrugated cardboard carton with 159 kg (350 lb) bursting strength is adequate. Allow at least 3 to 4 inches on all sides of the test set for packing material.

  4. Surround the equipment with three to four inches of packing material and prevent the equipment from moving in the carton. If packing foam is not available, the best alternative is plastic bubble-pak. This material looks like a plastic sheet filled with 1-1/4 inch air bubbles. Use the pink-colored bubble which reduces static electricity. Wrapping the equipment several times in this material should both protect the equipment and prevent it from moving in the carton.

  5. Seal the shipping container securely with strong nylon adhesive tape.

  6. Mark the shipping container ”FRAGILE, HANDLE WITH CARE” to assure careful handling.

  7. Retain copies of all shipping papers.


SCPI Commands (Test Set)

SCPI Commands

This book provides details of the test set (platform) SCPI commands. These SCPI commands control test set configuration that is applicable to all applications that run on the test set. Application-specific SCPI commands are described in different sections of this help file such as SCPI Commands (802.16 OFDMA).

For a complete list of the test set (platform) SCPI commands, see Listing of Commands (Test Set).

Test Set Configuration

  • DISPlay Subsystem to configure the display mode and display brightness.

  • HCOPy Subsystem to control the setup of plotting and printing to an external device.

  • INSTrument Subsystem to identify and select logical instruments by either name or number.

  • MMEMory Subsystem to access to the test set’s memory and storage devices.

  • STATus Subsystem to interact with the test set's status registers.

  • SYSTem Subsystem to switch applications and configure GPIB address settings.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands


Listing Of Commands (Test Set)

This topic lists all of the available test set (platform) SCPI commands in the N8300A Wireless Communications Test Set. These SCPI commands control test set configuration that is applicable to all applications that run on the test set. Application-specific SCPI commands are described in different sections of this help file such as SCPI Commands (802.16 OFDMA).

It is recommended that you print this topic because it provides a useful syntax reference for all of the available General Purpose Application commands. To print:

  • Click the Print icon [image] on the toolbar above, or

  • Right-click in this topic pane and select Print...

The SCPI commands in this topic are categorized by subsystem:

  • DISPlay Subsystem

  • HCOPy Subsystem

  • INSTrument Subsystem

  • MMEMory Subsystem

  • STATus Subsystem

  • SYSTem Subsystem

  • IEEE 488.2 Common Commands

DISPlay Subsystem

  • DISPlay:BACKlight[?]

  • DISPlay:BACKlight:INTensity[?]

  • DISPlay:ENABle[?]

  • DISPlay:ENABle:OPRiority[?]

HCOPy Subsystem

  • HCOPy:ABORt

  • HCOPy[:IMMediate]

INSTrument Subsystem

  • INSTrument:CATalog?

  • INSTrument:DEFault

  • INSTrument:NSELect[?]

  • INSTrument[:SELect][?]

MMEMory Subsystem

  • MMEMory:CATalog?

  • MMEMory:CDIRectory

  • MMEMory:COPY

  • MMEMory:DATA

  • MMEMory:DELete

  • MMEMory:LOAD:STATe

  • MMEMory:LOAD:TRACe

  • MMEMory:LOAD:ZMAP

  • MMEMory:MDIRectory

  • MMEMory:MOVE

  • MMEMory:RDIRectory

  • MMEMory:STORe:RESults

  • MMEMory:STORe:SCReen

  • MMEMory:STORe:SCReen:THEMe

  • MMEMory:STORe:STATe

  • MMEMory:STORe:TRACe

  • MMEMory:STORe:ZMAP

STATus Subsystem

  • STATus:OPERation:CONDition?

    • STATus:QUEStionable:INTegrity:CONDition?

      SYSTem Subsystem

      • SYSTem:APPLication:CATalog[:NAME]?

      • SYSTem:APPLication:CATalog[:NAME]:COUNt?

      • SYSTem:APPLication:CATalog:OPTion?

      • SYSTem:APPLication:CATalog:REVision?

      • SYSTem:APPLication[:CURRent][:NAME]?

      • SYSTem:APPLication[:CURRent]:OPTion?

      • SYSTem:APPLication[:CURRent]:REVision?

      • SYSTem:COMMunicate:GPIB[:SELF]:ADDRess[?]

      • SYSTem:COMMunicate:LAN:ADDRess[?]

      • SYSTem:COMMunicate:LAN:DGATeway[?]

      • SYSTem:COMMunicate:LAN:HNAMe?

      • SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle[?]

      • SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

      • SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle[?]

      • SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle[?]

      • SYSTem:COMMunicate:USB:CONNection?

      • SYSTem:COMMunicate:USB:PACKets?

      • SYSTem:COMMunicate:USB:STATus?

      • SYSTem:DATE

      • SYSTem:DEFault

      • SYSTem:ERRor[:NEXT]?

      • SYSTem:ERRor:VERBose[?]

      • SYSTem:HELP:HEADers?

      • SYSTem:HID?

      • SYSTem:KLOCk[?]

      • SYSTem:LKEY

      • SYSTem:LKEY:DELete

      • SYSTem:LKEY:LIST?

      • SYSTem:OPTions?

      • SYSTem:PDOWn

      • SYSTem:PON:ETIMe?

      • SYSTem:PON:MODE[?]

      • SYSTem:PON:TIME?

      • SYSTem:PON:TYPE[?]

      • SYSTem:PRESet

      • SYSTem:PRESet:PERSistent

      • SYSTem:PRESet:USER

      • SYSTem:PRESet:USER:ALL

      • SYSTem:PRESet:USER:SAVE

      • SYSTem:PRINt:THEMe[?]

      • SYSTem:PUP

      • SYSTem:TIME

      • SYSTem:VERSion?

      IEEE 488.2 Common Commands

      • *CLS

      • *ESE

      • *ESR?

      • *IDN?

      • *OPC

      • *OPT?

      • *RCL

      • *RST

      • *SAV

      • *SRE

      • *SRE?

      • *STB?


DISPlay Subsystem

Description

The DISPlay subsystem is used to configure the test set's display mode, display brightness and to capture images of the screen. Use of the DISPlay subsystem is not required to set or query any data or results.

For details of the DISPlay commands refer to the DISPlay topic in this section.


DISPlay

These commands configure the test set's front panel display.

  • DISPlay:BACKlight[?]

  • DISPlay:BACKlight:INTensity[?]

  • DISPlay:ENABle[?]

  • DISPlay:ENABle:OPRiority[?]

DISPlay:BACKlight[?]

Sets/queries whether to turn the backlight on or off. This setting interacts with settings under the Windows "Power" menu.

Setting Range: ON | OFF

Query Range: ON | OFF

*RST Setting: ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

DISPlay:BACKlight ON

Turns on the backlight.

DISPlay:BACKlight:INTensity[?]

Sets/queries the backlight intensity. It goes from 0 to 100 where 100 is full on and 0 is off. This value is independent of the values set under the Backlight on/off key.

Setting Range: 0 to 100

Query Range: 0 to 100

*RST Setting: 100

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

DISPlay:BACKlight:INTensity 50

Sets the backlight intensity to 50.

DISPlay:ENABle[?]

Sets/queries whether to turn the display on or off, including the display drive circuitry and the backlight.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

DISPlay:ENABle?

Queries the display state.

DISPlay:ENABle:OPRiority[?]

Sets/queries the priority of the application process.

Setting Range: 1 to 5

Query Range: 1 to 5

*RST Setting: 2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

DISPlay:ENABle:OPRiority 3

Sets the application process priority to 3.


HCOPy Subsystem

The Hard COPy subsystem is used to control the setup of plotting and printing to an external device.

For details of the HCOPy commands refer to the HCOPy topic in this section.


HCOPy

These commands control the setup of plotting and printing to an external device.

  • HCOPy:ABORt

  • HCOPy[:IMMediate]

HCOPy:ABORt

Aborts an HCOPy request.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

HCOPy:ABORt

Aborts an HCOPy request.

HCOPy[:IMMediate]

Sends a screen dump to the default printer.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

HCOPy

Sends a screen dump to the default printer.


INSTrument Subsystem

The INSTrument subsystem provides a mechanism to identify and select logical instruments by either name or number.

For details of the INSTrument commands refer to the INSTrument topic in this section.


INSTrument

Last Updated: March 28, 2008

These commands identify and select logical instruments by either name or number.

  • INSTrument:CATalog?

  • INSTrument:DEFault

  • INSTrument:NSELect[?]

  • INSTrument[:SELect][?]

INSTrument:CATalog?

Returns a string containing a comma separated list of names of all the installed and licensed measurement modes (applications). These names can only be used with the :INSTrument[:SELect] command.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INSTrument:CATalog?

Returns a string containing a comma separated list of names of all the installed and licensed applications.

INSTrument:DEFault

Resets the state for the currently active mode by resetting the mode persistent settings to their factory default values, clearing mode data and by performing a Mode Preset. This function will never cause a mode switch. This function performs a full preset for the currently active mode; whereas, Mode Preset performs a partial preset. Restore Mode Defaults does not affect any system settings. System settings are reset by Restore System Defaults. This function does reset mode data; as well as settings.

Clears all pending OPC bits. The Status Byte is set to 0.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INSTrument:DEFault

Resets the state for the currently active application.

INSTrument:NSELect[?]

Sets/queries the measurement mode by its mode number. The actual available choices depend upon which applications are installed in your instrument.

Setting Range: 75 (for WIMAXOFDMA) | 80 (for WIMAXOFDM)

Query Range: 75 | 80

*RST Setting: Not affected by *RST.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INSTrument:NSELect 75

Sets the measurement mode to WiMax OFDMA.

INSTrument[:SELect][?]

Sets/queries the available measurement applications.

Setting Range: WIMAXOFDMA | WIMAXOFDM

Query Range: WIMAXOFDMA | WIMAXOFDM

*RST Setting: Not affected by *RST.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INSTrument?

Queries the available measurement applications.


MMEMory Subsystem

Description

The MMEMory subsystem gives you access to the test set’s memory and storage devices.

For details of the MMEMory commands refer to the MMEMory topic in this section.


MMEMory

These commands provide access to the test set's memory and to the storage devices.

  • MMEMory:CATalog?

  • MMEMory:CDIRectory

  • MMEMory:COPY

  • MMEMory:DATA

  • MMEMory:DELete

  • MMEMory:LOAD:STATe

  • MMEMory:LOAD:TRACe

  • MMEMory:LOAD:ZMAP

  • MMEMory:MDIRectory

  • MMEMory:MOVE

  • MMEMory:RDIRectory

  • MMEMory:STORe:RESults

  • MMEMory:STORe:SCReen

  • MMEMory:STORe:SCReen:THEMe[?]

  • MMEMory:STORe:STATe

  • MMEMory:STORe:TRACe

  • MMEMory:STORe:ZMAP

MMEMory:CATalog?

Queries the contents of the current directory. Returns a binary Block containing the contents of the directory as ASCII text, separated by CR/LF. The first digit states the number of digits following. The digits following give the total number of characters in the list of filenames.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:CATalog?

Queries the contents of the current directory.

MMEMory:CDIRectory <directory_name>
MMEMory:CDIRectory?

Sets/queries the default directory for a mass memory file system. The <directory_name> parameter is a string. The contents of the <directory_name> parameter are dependent on the file system being accessed.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:CDIRectory "Mydata"

Changes the current directory to Mydata.

MMEMory:COPY <source_file>,<destination_file>[,<source_file>][,<destination_file>]

Copies an existing file to a new file.

Two forms of parameters are allowed. The first form has two parameters. In this form, the first parameter specifies the source file, and the second parameter specifies the destination file.

The second form has four parameters. In this form, the first and third parameter specify the file_names. The second and fourth parameters specify the <msus>. The first pair of parameters specifies the source file. The second pair specifies the destination file. An error is generated if the source file does not exist. An error may be generated if the destination file already exists.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:COPY "myfile1.txt","myfile2.txt"

Copies myfile1.txt to myfile2.txt.

MMEMory:DATA <file_name>,<data>
MMEMory:DATA? <file_name>

Loads <data> into the file <file_name>. <data> is in 488.2 block format. The <file_name> is string data.

The query returns the <data> associated with <file_name> in 488.2 block format.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:DATA? "myfile1.txt"

Returns the datablock associated with myfile1.txt.

MMEMory:DELete <file_name>[,<msus>]

Removes a file from the specified mass storage device. The <file_name> parameter specifies the file_name to be removed. When the test set has multiple attached mass storage devices, you select the mass storage device you want using the mass storage unit specifier <msus>, for example "C:".

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:DELete "myfile1.txt"

Removes myfile1.txt from the default mass storage device.

MMEMory:LOAD:STATe <filename>

Recalling State function first must verify the file is recallable in the current instrument by checking the software version and model number of the instrument. If everything matches, a full recall proceeds by aborting the currently running measurement, and then loading the State from the saved state file to as close as possible to the context in which the save occurred.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:LOAD:STATe "myState.state"

Recalls the file myState.state on the default path

MMEMory:LOAD:TRACe TRACE1|TRACE2|TRACE3|TRACE4|TRACE5|TRACE6,<filename>

Recalling Trace first must verify the file is recallable in this instrument by checking instrument software version and model number, since it includes State. If everything matches, a full recall proceeds by aborting the currently running measurement, loads the state from the saved state file to as close as possible to the context in which the save occurred.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:LOAD:TRACe TRACE2,"myState.trace"

Recalls the file myState.trace on the default path; if it is a "single trace" save file, that trace is loaded to trace 2.

MMEMory:LOAD:ZMAP <filename>

Recalls the Zone Map data from the file you specify on the default directory to the Custom Map for the Modulation Analysis measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:LOAD:ZMAP "myZoneMap.omf"

Recalls the Zone Map data from the file myZoneMap.omf on the default directory to the Custom Map for Modulation Analysis measurement.

MMEMory:MDIRectory

Creates a directory.

Setting Range: string in " " representing a directory

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:MDIRectory "RESULTS"

Creates a directory named "results".

MMEMory:MOVE <source_file>,<destination_file> | <source_file>, source_msus, <destination_file>, <destination_msus>

Moves an existing file to another file name.

Two forms of the parameter are allowed. The first form has two parameters. In this form the first parameter, <source_file>, specifies the file to be renamed, and the second parameter, <destination_file>, specifies the new name of the file.

The move operation is performed on the default mass storage device.

The second form has four parameters. The first two parameters, <source_file> and <source_msus>, specify the file name and storage device of the source file and the second two parameters, <destination_file> and <destination_msus>, specify the new file name and new storage device for the source file.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

Moves myfile1.txt to myfile3.txt

MMEMory:MOVE "myfile1.txt","myfile3.txt"

MMEMory:RDIRectory <directory_name>

Removes an existing directory specified by <directory_name> from the mass memory file system. The <directory_name> is string data.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:RDIRectory "Mydata"

Removes the Mydata directory from the mass memory file system.

MMEMory:STORe:RESults <filename>

Saves the results from the current measurement to the specified file in the default path.

If the file already exists, the file will be overwritten. Using the C: drive is strongly discouraged, since it runs the risk of being overwritten during a test set software upgrade. Both single and double quotes are supported for any filename parameter over remote.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:RESults "myResults.csv"

Saves the results from the current measurement to the file myResults.csv in the default path.

MMEMory:STORe:SCReen <filename>

Accesses a menu of function that enable you to choose the theme to be used when saving the screen image. The Themes option is the same as the Themes option under the Display and Page Setup dialogs. It allows the user to pick between themes to be used when saving the screen image.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:SCReen "myScreen.png"

Saves the screen image to myScreen.png.

MMEMory:STORe:SCReen:THEMe[?]

Sets/queries the theme to be used when saving the screen image. The Themes option is the same as the Themes option under the Display and Page Setup dialogs. It allows the user to pick between themes to be used when saving the screen image.

Setting Range: TDColor | TDMonochrome | FCOLor | FMONochrome

Query Range: TDC | TDM | FCOL| FMON

*RST Setting:

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:SCReen:THEMe TDColor

Sets the theme to 3D color.

MMEMory:STORe:STATe <filename>

Saves all of the State of the currently active mode plus the system level Input/Output settings to the specified file. While the save is being performed, the floppy icon shows up in the settings bar near the Continuous/Single sweep icon. After the save completes, the Advisory Event "File <register number> saved" is displayed.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:STATe "myState.state"

Saves the file myState.state on the default path.

MMEMory:STORe:TRACe TRACE1|TRACE2|TRACE3|TRACE4|TRACE5|TRACE6|ALL,<filename>

This key initiates the save of the .trace file. All of the State of the currently active mode plus the system level Input/Output settings are saved to the specified file as well as all of the trace data, including internal flags set in the file indicating which trace is to be saved.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:TRACe TRACE1,"myState.trace"

Saves the file myState.trace on the default path and flags it as a "single trace" file with Trace 1 as the single trace (even though all of the traces are in fact stored).

MMEMory:STORe:TRACe ALL,"myState.trace"

Saves the file myState.trace on the default path and flags it as an "all traces" file.

MMEMory:STORe:ZMAP <filename>

Saves the current Zone Map as 89601 compatible file type

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MMEMory:STORe:ZMAP "myZoneMap.omf"

Saves current Zone Map as 89601 compatible file type.


STATus Subsystem

The STATus subsystem controls the SCPI-defined status reporting structures. Each status register has a set of five commands used for querying or masking that particular register.

Numeric values for bit patterns can be entered using decimal or hexadecimal representations. (i.e. 0 to 32767 is equivalent to #H0 to #H7FFF. It is also equal to all ones, 111111111111111) See the SCPI Basics information about using bit patterns for variable parameters.

For details of the STATus commands refer to the topics in this section.


STATus:OPERation

These commands control and query the OPERation status register.

  • STATus:OPERation:CONDition?

STATus:OPERation:CONDition?

Queries the decimal value of the sum of the bits in the Status Operation Condition register. The data in this register is continuously updated and reflects the current conditions.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

STATus:OPERation:CONDition?

Queries the decimal value of the sum of the bits in the Status Operation Condition register.


STATus:QUEStionable

These commands control and query the QUEStionable status register.

  • STATus:QUEStionable:INTegrity:CONDition?

STATus:QUEStionable:INTegrity:CONDition?

Queries the decimal value of the sum of the bits in the Questionable Integrity Condition register. NOTE: The data in this register is continuously updated and reflects the current conditions.

  • If bit 4 (decimal 16) is set, the input signal is too high and the power range setting should be increased.

  • If bit 4 is clear, then the input is not over-range.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

STATus:QUEStionable:INTegrity:CONDition?

Queries the decimal value of the sum of the bits in the Questionable Integrity Condition register.


SYSTem Subsystem

Description

The SYSTem subsystem contains a number of commands that are not related to measurement operations. For example, commands for switching applications and configuring GPIB address settings are included in this subsystem.

For details of the SYSTem commands refer to the SYSTem subsystems in this section.


SYSTem:APPLication

This command sets and queries test set application parameters.

  • SYSTem:APPLication:CATalog[:NAME]?

  • SYSTem:APPLication:CATalog[:NAME]:COUNt?

  • SYSTem:APPLication:CATalog:OPTion?

  • SYSTem:APPLication:CATalog:REVision?

  • SYSTem:APPLication[:CURRent][:NAME]?

  • SYSTem:APPLication[:CURRent]:OPTion?

  • SYSTem:APPLication[:CURRent]:REVision?

SYSTem:APPLication:CATalog[:NAME]?

Queries a list of Model Numbers for the installed and licensed applications (Modes).

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:CATalog?

Queries a list of Model Numbers for the installed and licensed applications (Modes).

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Queries the number of installed and licensed applications (Modes).

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:CATalog:COUNt?

Queries the number of installed and licensed applications (Modes).

SYSTem:APPLication:CATalog:OPTion? <model>

Queries a list of Options for the provided Model Number.

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:CATalog:OPTion? `N8300A'

Queries a list of Options for the provided Model Number.

SYSTem:APPLication:CATalog:REVision? <model>

Queries the Revision of the provided Model Number.

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:CATalog:REVision? `N8300A'

Queries the Revision of the provided Model Number.

SYSTem:APPLication[:CURRent][:NAME]?

Returns a string which is the Model Number of the currently selected application (mode).

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication?

Returns a string which is the Model Number of the currently selected application (mode).

SYSTem:APPLication[:CURRent]:OPTion?

Returns a string which is the Options list of the currently selected application (mode).

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:OPTion?

Returns a string which is the Options list of the currently selected application (mode).

SYSTem:APPLication[:CURRent]:REVision?

Returns a string which is the Revision of the currently selected application (mode).

*RST Setting: Not affected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:APPLication:REVision?

Returns a string which is the Revision of the currently selected application (mode).


SYSTem:COMMunicate

These commands configure the test set's GPIB address, LAN and USB settings.

  • SYSTem:COMMunicate:GPIB[:SELF]:ADDRess[?]

  • SYSTem:COMMunicate:LAN:ADDRess[?]

  • SYSTem:COMMunicate:LAN:DGATeway[?]

  • SYSTem:COMMunicate:LAN:HNAMe?

  • SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle[?]

  • SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

  • SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle[?]

  • SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle[?]

  • SYSTem:COMMunicate:USB:CONNection?

  • SYSTem:COMMunicate:USB:PACKets?

  • SYSTem:COMMunicate:USB:STATus?

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess[?]

Sets/queries the GPIB remote address of the test set.

Setting Range: 0 to 30

Query Range: 0 to 30

*RST Setting: This is unaffected by Preset but is set to 15 on a "Restore System Defaults->Misc"

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:GPIB:ADDRess 17

Sets the GPIB remote address of the test set to 17.

SYSTem:COMMunicate:LAN:ADDRess[?]

Sets/queries the LAN address of the test set.

Setting Range: Any valid IP address.

Query Range: Any valid IP address.

*RST Setting:

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:ADDRess?

Queries the LAN address of the test set.

SYSTem:COMMunicate:LAN:DGATeway[?]

Sets/queries the IP address of the LAN gateway.

Setting Range: Any valid IP address.

Query Range: Any valid IP address.

*RST Setting: Unaffected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:DGATeway?

Queries the IP address of the LAN gateway.

SYSTem:COMMunicate:LAN:HNAMe?

Queries the host name of the test set.

Query Range: Any valid host name.

*RST Setting: Unaffected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:HNAMe?

Queries the host name of the test set.

SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle[?]

Sets/queries the SICL server capability On or Off, enabling you to limit SCPI access over LAN through the SICL server. (SICL IEEE 488.2 protocol.)

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: This is unaffected by Preset, but is set to ON during a "Restore System Defaults->Misc"

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle 1

Turns on the SICL server capability.

SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

Returns the TCP/IP port number of the control socket associated with the SCPI socket session. This query enables you to obtain the unique port number to open when a device clear is to be sent to the instrument. Every time a connection is made to the SCPI socket, the instrument creates a peer control socket. The port number for this socket is random. The user must use this command to obtain the port number of the control socket. To force a device clear on this socket, open the port and send the string "DCL " to the instrument. If this SCPI command is sent to a non SCPI Socket interface, then 0 is returned.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

Returns the TCP/IP port number of the control socket associated with the SCPI socket session.

SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle[?]

Sets/queries the capability of establishing Socket LAN sessions On or Off. This allows you to limit SCPI access over LAN through socket sessions.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: This is unaffected by Preset, but is set to ON during a "Restore System Defaults->Misc"

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle OFF

Turns off Socket LAN session capability.

SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle[?]

Sets/queries the SCPI LAN telnet capability On or Off allowing you to limit SCPI access over LAN through telnet.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: This is unaffected by Preset, but is set to ON during a "Restore System Defaults->Misc

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle?

Queries the current setting of the SCPI LAN telnet capability.

SYSTem:COMMunicate:USB:CONNection?

Queries the speed of USB connection:

  • NONE - Indicates no USB connection has been made.

  • LSPeed - Indicates a USB low speed connection (1.5 Mbps). Note: this is reserved for future use, the T+M488 protocol is not supported on low speed connections.

  • HSPeed - Indicates that a USB high speed connection (480 Mbps) has been negotiated.

  • FSPeed - Indicates that a USB full speed connection (12 Mbps) has been negotiated.

Query Range: NONE | LSP | HSP | FSP

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:USB:CONNection?

Queries the speed of USB connection.

SYSTem:COMMunicate:USB:PACKets?

Queries the number of packets received and transmitted on the USB bus.

Two integers are returned. The first is the number of packets received since application invocation, the second is the number of packets transmitted since application invocation. If no packets have been received or transmitted the response is 0,0. The packet count is initialized to 0,0 when the test set application is started.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:USB:PACKets?

Queries the number of packets received and transmitted on the USB bus.

SYSTem:COMMunicate:USB:STATus?

Queries the current status of the USB connection:

  • SUSPended (Indicates that the USB bus is currently in its suspended state)

  • ACTive (Indicates that the USB device is in the active state. When the device is in the active state, it is receiving periodic start of frames but it isn't necessarily receiving or transmitting data.)

Query Range: SUSP | ACT

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:COMMunicate:USB:STATus?

Queries the current status of the USB connection


SYSTem:DATE

  • SYSTem:DATE

SYSTem:DATE "<year>,<month>,<day>"
SYSTem:DATE[?]

The recommended access to the Date, Time, and Timezone of the instrument is through the Windows native control (Control Panel or accessing the Task Bar). You may also access this information remotely, as shown in this command and Time (below).Sets or queries the date in the instrument.

Setting Range: A comma separated string representing the date in year, month, and day format.

Query Range: A comma separated string representing the date in year, month, and day format.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:DATE "2007,12,19"

Sets the date to 19th December 2007.


SYSTem:DEFault

  • SYSTem:DEFault

SYSTem:DEFault

Provides incremental initialization of the system setting groups along with supporting a comprehensive reset of the entire instrument back to a factory default state. The menu selections are the groups of system settings and when one is selected, that particular group of system settings is reset back to their default values. The menu options are: Input/Output Settings, Power On, Alignments, Misc, All Modes, and All.

Setting Range: [ALL] | ALIGn | INPut | MISC | MODes | PON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:DEFault

Restores the system setting default values.


SYSTem:ERRor

These commands provide information about the test set's error/event queue.

  • SYSTem:ERRor[:NEXT]?

  • SYSTem:ERRor:VERBose[?]

SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the next item and removes it from the queue. The response returns the error/event code number and the string. If the queue is empty, the response is 0,"No error".

Setting Range: A comma separated error/event code number, string pair.

Query Range: A comma separated error/event code number, string pair.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:ERRor?

Queries the error/event queue for the next item and removes it from the queue.

SYSTem:ERRor:VERBose[?]

Sets/queries whether or not the SCPI data stream is to be displayed when a SCPI error is detected, showing the characters which stimulated the error and several of the characters preceding the error.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: This is unaffected by *RST but is set to OFF on a "Restore System Defaults->Misc"

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:ERRor:VERBose ON

Turns on the display of the SCPI data stream.


SYSTem:HELP

  • SYSTem:HELP:HEADers?

SYSTem:HELP:HEADers?

Outputs a list of the valid SCPI commands for the currently selected Mode.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:HELP:HEADers?

Returns a list of the valid SCPI commands for the currently selected Mode.


SYSTem:HID

  • SYSTem:HID?

SYSTem:HID?

Returns the value of the host ID as a string.

*RST Setting: Unaffected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:HID?

Returns the value of the host ID as a string.


SYSTem:KLOCk

  • SYSTem:KLOCk[?]

SYSTem:KLOCk[?]

Disables the instrument keyboard to prevent local input when the instrument is controlled remotely. An annunciator reading "K" for `Klock" alerts the local user that the keyboard is locked. Klock is similar to the GPIB Local Lockout function; namely that no front panel keys are active with the exception of the Power Standby key. (The instrument is allowed to be turned-off if Klock is ON.) The Klock command is used in remote control situations where Local Lockout cannot be used. Although primary intent of Klock is to lock-out the front panel, it will lock-out externally connected keyboards through USB. Klock has no effect on externally connected pointing devices (mice). The front panel `Local' key (Cancel/Esc) has no effect if Klock is ON.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: Initialized to OFF at startup, unaffected by *RST

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:KLOCk 1

Turns on the keyboard lock.


SYSTem:LKEY

These commands provide information about the licenses installed in the test set.

  • SYSTem:LKEY

  • SYSTem:LKEY:DELete

  • SYSTem:LKEY:LIST?

SYSTem:LKEY <"OptionInfo">, <"LicenseInfo">
SYSTem:LKEY? <"OptionInfo">

The <"OptionInfo"> contains the feature and the version. You must specify the feature but can omit the version. If you omit the version, the system regards it as the latest one. Because the system knows which version is supported for each feature.

The <"LicenseInfo"> contains the signature, the expiration date, and serial number for transport if transportable. You must specify the signature, but you can omit the other information. If you omit the expiration date, the system regards it as permanent. If you omit the serial number, the system regards it as non-transportable. As a result, this supports backward compatibility.

The query returns the <"LicenseInfo"> if the license is valid, null otherwise.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Examples:

SYSTem:LKEY "N6301A-1FP", "B043920A51CA"

SYSTem:LKEY "N6301A-1FP,1.00", "5D71E9BA814C,21-dec-2007"

SYSTem:LKEY:DELete <"OptionInfo">,<"LicenseInfo">

The <"OptionInfo"> contains the feature and the version. You must specify the feature but can omit the version. If you omit the version, the system regards it as the latest one, if more than one version is installed.

The <"LicenseInfo"> contains the signature, the expiration date, and whether or not be transportable. You must specify the signature, but you can omit the other information. If you omit the expiration date, the system regards it as permanent. If you omit the transportability, the system regards it as non-transportable. As a result, this supports backward compatibility.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:LKEY:DELete "N6301A-1FP", "B043920A51CA"

SYSTem:LKEY:LIST?

Returns an <arbitrary block data> of all the installed instrument licenses. The format of each license is as follows:

<Feature>,<Version>,<Signature>,<Expiration Date>,<Serial Number for Transport>

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:LKEY:LIST?

Returns an <arbitrary block data> of all the installed instrument licenses.


SYSTem:OPTions

  • SYSTem:OPTions?

SYSTem:OPTions?

Returns the installed options that pertain to the test set.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:OPTions?

Returns the installed options that pertain to the test set.


SYSTem:PDOWn

  • SYSTem:PDOWn

SYSTem:PDOWn

Turns off the test set.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PDOWn

Turns off the test set.


SYSTem:PON

These commands set and query power-on information.

  • SYSTem:PON:ETIMe?

  • SYSTem:PON:MODE[?]

  • SYSTem:PON:TIME?

  • SYSTem:PON:TYPE[?]

SYSTem:PON:ETIMe?

Returns the elapsed on-time since 1st power-on (odometer).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PON:ETIMe?

Returns the elapsed on-time since 1st power-on (odometer).

SYSTem:PON:MODE[?]

Opens a Mode Menu that lists the available modes and enables the user to select which Mode to be the power-on mode. This Mode Menu is a 1-of-N list of available modes; not the Mode Menu under the Mode front-panel key. They will look the same, but have very different behavior. This Mode will be used for Power On Mode Preset and Restore System Defaults All. The factory will load a default power-on mode using what modes are installed in the instrument and the precedence table documented in the Power-On Mode section.

Setting Range: WIMAXOFDMA

Query Range: WIMAXOFDMA

*RST Setting: This is unaffected by *RST but is set on a "Restore System Defaults->All" to the default power-on mode.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PON:MODE WIMAXOFDMA

SYSTem:PON:TIME?

Queries the time since the present application start-up in seconds.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PON:TIME?

Queries the time since the present application start-up in seconds.

SYSTem:PON:TYPE[?]

Sets/queries the power on type. The Power On menu key enables you to select how the instrument should power on. The options are: Mode Preset, User Preset and Last State.

Setting Range: MODE | USER | LAST | PRESet

Query Range: MODE | USER | LAST | PRES

*RST Setting: This is unaffected by *RST but is set on a "Restore System Defaults->All"

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PON:TYPE LAST

Sets the power on type to Last State.


SYSTem:PRESet

These commands perform preset operations.

  • SYSTem:PRESet

  • SYSTem:PRESet:PERSistent

  • SYSTem:PRESet:USER

  • SYSTem:PRESet:USER:ALL

  • SYSTem:PRESet:USER:SAVE

SYSTem:PRESet

Performs a system preset. *RST is preferred over :SYST:PRES for remote operation. *RST does a Mode Preset as done by this command and it sets the measurement mode to Single measurement rather than Continuous for optimal remote control throughput.

Clears all pending OPC bits. The Status Byte is set to 0.

A Mode Preset will cause the currently running measurement to be aborted and cause the default measurement to be active. Mode Preset gets the mode to a consistent state with all of the default couplings set.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRESet

Performs a system preset.

SYSTem:PRESet:PERSistent

Restores all system defaults.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRESet:PERSistent

Restores all system defaults.

SYSTem:PRESet:USER

Performs a user preset. User Preset behaves similarly to Recall State in that it recalls a hidden Save State file with the exception that User Preset will never cause a mode switch. Recalling a Save State file may cause a mode switch, if the Save State file was saved while in a different mode. There is a User Preset file per mode. The User Preset file is a Save State file. User Preset sets the state of currently active mode back to the state that was previously saved for this mode using the Save User Preset menu key or the SYST:PRES:USER:SAVE command. Each mode will have no knowledge of another user preset file from any other mode or how to invoke them. The user has no control over the user preset filename and has no direct access to the user preset file.

Clears all pending OPC bits. The Status Byte is set to 0.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRESet:USER

Performs a user preset.

SYSTem:PRESet:USER:ALL

Performs a user preset all modes operation. User Preset All Modes behaves similarly to Power On User Preset, since it recalls all of the User Preset files for each mode, switches to the power-on mode and activates the saved measurement from the power-on mode User Preset file.

Clears all pending OPC bits. The Status Byte is set to 0.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRESet:USER:ALL

Performs a user preset all modes operation.

SYSTem:PRESet:USER:SAVE

Saves the currently active mode and its state. The way the user recalls this User Preset file is by pressing the User Preset menu key or sending the SYST:PRES:USER remote command. This same state is also saved by the Save State function.

SYSTem:PRESet:USER:SAVE creates the same file as if the user requested a *SAV or a MMEM: STOR:STAT, except User Preset Save does not allow the user to specify the filename or the location of the file.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRESet:USER:SAVE

Saves the currently active mode and its state.


SYSTem:PRINt

  • SYSTem:PRINt:THEMe[?]

SYSTem:PRINt:THEMe[?]

Sets/queries the print theme. The graphical user interface contains a selection for choosing the Theme to use when printing. An equivalent remote command is provided. Refer to the View/Display section for more detail on Themes.

Setting Range: TDColor | TDMonochrome | FCOLor | FMONochrome

Query Range: TDC | TDM | FCOL | FMON

*RST Setting: FCOLor (Not part of *RST, but is reset by Restore Misc Defaults or Restore System Defaults All and survives subsequent running of the modes)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PRINt:THEMe TDMonochrome

Sets the print theme to 3D monochrome.


SYSTem:PUP

  • SYSTem:PUP

SYSTem:PUP

Reboots the test set.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:PUP

Reboots the test set.


SYSTem:TIME

  • SYSTem:TIME

SYSTem:TIME "<hour>,<minute>,<second>"
SYSTem:TIME?

Sets/queries the time in the test set.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:TIME?

Queries the time in the test set.


SYSTem:VERSion?

  • SYSTem:VERSion?

SYSTem:VERSion?

Returns the SCPI version number with which the test set complies. The SCPI industry standard changes regularly. This command indicates the version used when the test set SCPI commands were defined.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SYSTem:VERSion?

Returns the SCPI version number with which the test set complies.


IEEE 488.2 Common Commands

  • *CLS

  • *ESE

  • *ESR?

  • *IDN?

  • *OPC

  • *OPT?

  • *RCL

  • *RST

  • *SAV

  • *SRE

  • *SRE?

  • *STB?

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. This command also clears and closes the error message screen on the test set's display.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14. *IDN? is used to retrieve information about the test set in ASCII format.

*IDN? returns information about the test set in the following order:

  • Manufacturer (Agilent Technologies)

  • Model number (N8300A)

  • Serial number

  • Firmware Version

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option has a unique name, that name is returned with the query.

*RCL

The *RCL command recalls the specified register. If the specified register does not exist an error occurs. This command accepts an <nr1> of 0 and upwards.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

*SAV

The *SAV command saves the specified register. If the specified register already exists it is overwritten. This command accepts an <nr1> of 0 and upwards. The only limits to the number of registers you can save is the available disk space.

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.


Front Panel Operation (Test Set)

Front Panel Operation

The test set can be operated using front panel controls and a large video display to perform test set configuration functions. The Help key provides documentation on how to use the test set. Save and Recall utilities provide a way to return to frequently used setups.

For general information about operating the test set from the front panel, refer to the books and topics in this section.

Related Topic: Front Panel Operation (802.16 OFDMA)


Utility Functions

This book provides details of the front-panel key functions that are accessible when you are using any of the measurements available in this application.

For more details, refer to the books and topics in this section.

81


System

Opens a menu of keys that access various configuration menus and dialogs.

Key Path: System

SCPI Command: None

For details of the System items, refer to the topics in this section.


Show

Opens a menu of choices that enable you to select the information window you want to view.

Key Path: System

SCPI Command: None

For details of the items in this menu, refer to the topics in this section.


Errors

There are two modes for the Errors selection, History and Status.

Errors does not automatically refresh; you must press the Refresh button or leave the screen and return to it to refresh it.

History brings up a screen displaying the event log in chronological order, with the newest event at the top.

The history queue can hold up to 100 messages (if a message has a repeat count greater than 1 it only counts once against this number of 100). Note that this count bears no relation to the size of the SCPI queue. If the queue extends onto a second page, a scroll bar appears to allow scrolling with a mouse. Time is displayed to the second.

Status brings up a screen summarizing the status conditions currently in effect. Note that time is displayed to the second.

The fields on the Errors display are:

  • Type (unlabeled): Displays the icon identifying the event or condition as an error or warning.

  • ID: Displays the error number.

  • Message: Displays the message text.

  • Repeat (RPT): This field shows the number of consecutive instances of the event, uninterrupted by other events. In other words, if an event occurs 5 times with no other intervening event, the value of repeat will be 5.
    If the value of Repeat is 1 the field does not display. If the value of Repeat is >1, the time and date shown are those of the most recent occurrence. If the value of repeat reaches 999,999 it stops there.

  • Time: Shows the most recent time (including the date) at which the event occurred.

SCPI Command: SYSTem:ERRor[:NEXT]?

Next Page

Next Page and Previous Page softkeys move the user between pages of the log, if it fills more than one page. These keys are grayed out in some cases:

If on the last page of the log, the Next Page key is grayed out
If on the first page of the log, the Previous Page key is grayed out.

If there is only one page, both keys are grayed out.

Key Path: Show, Show Errors

Previous Page

See Next Page.

History

The History and Status keys select the Errors view. The Status key has a second line which shows a number in [square brackets]. This is the number of currently open status items.

Key Path: System, Show, Show Errors

Status

See History.

Verbose SCPI On/Off

This is a capability that will allow the SCPI data stream to be displayed when a SCPI error is detected, showing the characters which stimulated the error and several of the characters preceding the error.

Key Path: System, Show, Show Errors

SCPI Command: SYSTem:ERRor:VERBose[?]

Refresh

When pressed, refreshes the Show Errors display.

Key Path: System, Show, Show Errors

Clear Error Queue

This clears all errors in all error queues.

NOTE

Clear Error Queue does not affect the current status conditions.

Mode Preset does not clear the error queue.

Restore System Defaults will clear all error queues.

*CLS only clears the queue if it is sent remotely and *RST does not affect any error queue.

Switching modes does not affect any error queues.

Key Path: System, Show, Show Errors


System (Show)

The System screen is formatted into three groupings: product descriptive information, options tied to the hardware, and software products:

The Previous Page is grayed-out if the first page of information is presently displayed. The Next Page softkey is grayed-out if the last page is information is presently displayed.

Key Path: System, Show


Hardware

Show Hardware

The Hardware screen is used to view details of the installed hardware. The screen is formatted into two groupings: product descriptive information and hardware information. The hardware information is listed in a table format:

<Product Name> <Product Description>

Product Number: N8300A

Serial Number: US44240924

Firmware Revision: A.01.00

Computer name: <hame>

Host ID: N8300A,US44220924

Assembly Name | Part # | Serial # | Matl Rev | Bd Rev | OF Rev | Hw Id | Misc Analog IF E441060104 7804400066 003 0 A 15 1.0.0.0

The Previous Page is grayed-out if the first page of information is presently displayed. The Next Page softkey is grayed-out if the last page is information is presently displayed.

Mode: All

Preset: Off

Key Path: System, Show


LXI

This key shows you the product number, serial number, firmware revision, computer name, IP address, Host ID, LXI Class, LXI Version, MAC Address, and the Auto-MDIX Capability.

Key Path: System, Show

LAN Reset

This key resets the LAN connection.


Power On (System)

The Power On softkey enables you to select how the test set should power on. The options are: Mode Preset, User Preset and Last State.

Mode: All

Key Path: System

SCPI Command: SYSTem:PON:TYPE[?]

For details of the items in this menu, refer to the following information.

Mode Preset

Sets Power On to Mode Preset. When the test set is powered on in Mode Preset, it will perform a Mode Preset to all modes in the test set and it will wake up in the power-on mode. It will not affect any settings beyond what a normal Mode Preset affects.

Mode: All

Key Path: System, Power On

SCPI Command: SYSTem:PON:TYPE[?]

User Preset

Sets Power On to User Preset. When the test set is powered on in User Preset, it will User Preset each mode and switch to the power-on mode. Power On User Preset will not affect any settings beyond what a normal User Preset affects. NOTE: An test set could never power up for the first time in User Preset.

Mode: All

Key Path: System, Power On

SCPI Command: SYSTem:PON:TYPE[?]

Last State

Sets Power On to Last. When the test set is powered on, it will put all modes in the last state they were in prior to when the test set was put into Power Standby and it will wake up in the mode it was last in prior to powering off the test set. The saving of the active mode prior to shutdown happens behind the scenes when a controlled shutdown is requested by using the front panel power Standby key or by using the remote command SYSTem:PDOWn. The non-active modes are saved as they are deactivated and recalled by Power On Last State.

NOTE: An test set could never power up for the first time in Last.

NOTE: If line power to the test set is interrupted, for example by pulling the line cord plug or by switching off power to a test rack, Power On Last State will not work properly. For more information see Power Standby (Instrument Shutdown).

Mode: All

Key Path: System, Power On

SCPI Command: SYSTem:PON:TYPE[?]

Restriction and Notes: Power on Last State only works if the user has done a controlled
shutdown prior to powering on in Last. If a controlled shutdown is not
done when in Power On Last State, the test set will power up in the
last active mode, but it may not power up in the active mode's last state.
If an invalid mode state is detected, a Mode Preset will occur. To control
the shutdown under remote control use the SYSTem:PDOWn command.

Power On Mode

This softkey brings up a Mode Menu that lists the available modes and enables the user to select which Mode to be the power-on mode. This Mode Menu is a 1-of-N list of available modes; not the Mode Menu under the Mode front-panel key. They will look the same, but have very different behavior.
This Mode will be used for Power On Mode Preset and Restore System Defaults All. The factory will load a default power-on mode using what modes are installed in the test set and the precedence table documented in the Power-On Mode section.

Mode: All

Key Path: System, Power On

SCPI Command: SYSTem:PON:MODE[?]

Restore Power On Defaults

This selection causes the Power On Type and Power On Mode settings to be a reset to their default value. This level of Restore System Defaults does not affect any other system settings, mode settings and does not cause a mode switch. The Power On softkey under the Restore System Defaults menu causes the same action.

If you press any key other than OK or Enter, it is construed as a Cancel, because the only path that will actually cause the reset to be executed is through OK or Enter.

Key Path: System, Power On

SCPI Command: SYSTem:DEFault


I/O Config

Activates a menu for identifying and changing the I/O configuration for remote control.

Key Path: System

For details of the items in this menu, refer to the topics in this section.


GPIB Address

Selects the GPIB remote address. NOTE: Changing the Address on the GPIB port requires all further
communication to use the new address.

Mode: All

Key Path: System, I/O Config

Saved State: This is unaffected by Preset but is set to 18 on a ”Restore System
Defaults->Misc”

SCPI Command: SYSTem:COMMunicate:GPIB[:SELF]:ADDRess[?]


SCPI LAN Menu

Activates a menu for identifying and changing the SCPI over LAN configuration. There are a number of different ways to send SCPI remote commands to the test set over LAN. It can be a problem to have multiple users simultaneously accessing the test set over the LAN. These keys limit that somewhat by disabling the telnet, socket, and/or SICL capability.

Key Path: System, I/O Config

SCPI Telnet

Turns the SCPI LAN telnet capability On or Off allowing you to limit SCPI access over LAN through telnet.

Mode: All

Key Path: System, I/O Config, SCPI LAN

SCPI Command: SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle[?]

SCPI Socket

Turns the capability of establishing Socket LAN sessions On or Off. This allows you to limit SCPI access over LAN through socket sessions.

Mode: All

Key Path: System, I/O Config, SCPI LAN

SCPI Command: SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle[?]

SCPI Socket Control Port (remote command only)

Returns the TCP/IP port number of the control socket associated with the SCPI socket session. This query enables you to obtain the unique port number to open when a device clear is to be sent to the test set. Every time a connection is made to the SCPI socket, the test set creates a peer control socket. The port number for this socket is random. The user must use this command to obtain the port number of the control socket. To force a device clear on this socket, open the port and send the string ”DCL” to the test set.

If this SCPI command is sent to a non SCPI Socket interface, then 0 is returned.

Mode: All

SCPI Command: SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

SICL Server

Turns the SICL server capability On or Off, enabling you to limit SCPI access over LAN through the SICL server. (SICL IEEE 488.2 protocol.)

Mode: All

Key Path: System, I/O Config, SCPI LAN

SCPI Command: SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle[?]

SCPI Default Settings

Parameter | Description | Setting
Maximum Connections | The maximum number of connections that can be accessed simultaneously | 5
Instrument Name | The name (same as the remote SICL address) of your test set | inst0
Instrument Logical Unit | The unique integer assigned to your test set when using SICL LAN | 8
Emulated GPIB Name | The name (same as the remote SICL address) of the device used when communicating with your test set | gpib7
Emulated GPIB Logical Unit | The unique integer assigned to your device when it is being controlled using SICL LAN | 8
Emulated GPIB Address | The emulated GPIB address assigned to your transmitter tester when it is a SICL server (the same as your GPIB address) | 18


Reset Web Password

The embedded webserver contains certain capability which are password protected; modifying the LAN configuration of the test set, and access to web pages that can change the settings of the test set. The default password from the factory is 'agilent' (without the quotes). The control provided here is the means to set the web password as the user desires, or to reset the password to the factory default.

Selecting Reset web password brings up a control for resetting the password as the user desires, or to the factory default. An external keyboard is required to change the password from the factory default of 'agilent' or to set a new password that contains alphabetic characters. The control is:

If this control is entered without an external keyboard or mouse connected, you can cancel the control by pressing the Cancel (ESC) front-panel key.

Mode: All

Key Path: System, I/O Config


Restore Defaults (System)

Provides incremental initialization of the system setting groups along with supporting a comprehensive reset of the entire test set back to a factory default state. The menu selections are the groups of system settings and when one is selected, that particular group of system settings is reset back to their default values. The menu options are: Input/Output Settings, Power On, Alignments, Misc, All Modes, and All.

Mode: All

Key Path: System

Saved State: No

SCPI Command: SYSTem:DEFault

Input/Output Settings

Causes the group of settings and data associated with Input/Output front panel key to be a reset to their default values. This level of Restore System Defaults does not affect any other system settings, mode settings and does not cause a mode switch.

Confirmation is required to restore the Input/Output setting. The confirmation dialog is:

Key Path: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

Power On

This selection causes the Power On settings to be a reset to their default value. This level of Restore System Defaults does not affect any other system settings, mode settings and does not cause a mode switch. The Power On settings and their default values are Power On Type reset to Mode Preset and Power On Mode reset to whatever the factory set as its default value.

Confirmation is required to restore the factory default values. The confirmation dialog is:

Key Path: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

Align

This selection causes the Alignment system settings to be a reset to their default values. This does not affect any Alignment data stored in the system. This level of Restore System Defaults does not affect any other system settings, mode settings and does not cause a mode switch.

After performing this function, it may impact the auto-alignment time of the test set until a new alignment baseline has been established.

Confirmation is required to restore the factory default values. The confirmation dialog is:

Key Path: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

Misc

This selection causes miscellaneous system settings to be reset to their default values. With this reset, you lose the GPIB address and it is reset to 18, so this should be used with caution. This level of Restore System Defaults does not affect any other system settings, mode settings and does not cause a mode switch. This miscellaneous group contains the rest of the settings that have not been part of the other Restore System Defaults groups. The following table is a complete list of settings associated with this group:

Miscellaneous Setting | Default Value
Verbose SCPI | Off
GPIB Address | 18
Auto File Name Number | 000
Save Type | State
State Save To | Register 1
Screen Save To | SCREEN000.png
DISP:ENABle | ON
Full Screen | Off
SCPI Telnet | ON
SCPI Socket | ON
SILC Server | ON
Display Intensity | 100
Display Backlight | ON
Display Theme | TDColor
System Annotation | ON
The SYST:PRES:TYPE | MODE

Confirmation is required to restore the factory default values. The confirmation dialog is:

Key Path: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

All Modes

This selection resets all of the modes in the test set back to their default state just as a Restore Mode Defaults does and it switches the test set to the power-on mode and causes the default measurement for the power-on mode to be active. This level of Restore System Defaults does not affect any system settings, but it does affect the state of all modes and does cause a mode switch unless the test set was already in the power-on mode. Confirmation is required to restore the factory default values. The confirmation dialog is:An All Mode will cause the currently running measurement to be aborted,
mode switch to the power-on mode and activate the default measurement
for the power-on mode. It gets the mode to a consistent state with all of
the default couplings set.

Mode: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

All

This is the catastrophic function that does a comprehensive reset of ALL test set settings to their factory default values. It resets all of the system setting groups, causes a Restore Mode Defaults for all modes in the test set and switches back to the power-on mode. It does not affect the User Preset file or any user saved files.

Confirmation is required to restore the factory default values. The confirmation dialog is:

Key Path: System, Restore System Defaults

SCPI Command: SYSTem:DEFault

An All will cause the currently running measurement to be aborted and
get all modes to a consistent state, so it is unnecessary to couple any
settings.


Control Panel

Opens the Windows Control Panel.

Key Path: System


Licensing (System)

Opens the license explorer.

For Help on this key, select Help in the menu bar at the top of the license explorer window.

Key Path: System

SCPI Commands: SYSTem:LKEY, SYSTem:LKEY:DELete, SYSTem:LKEY:LIST?, SYSTem:HID?


Suspend Source

Suspends the VISA lock over the arbitrary waveform generator. You cannot perform any operations with the source while it is suspended. Press Resume Source to stop the suspension.

Mode: All

Key Path: System, More

SCPI Command: SOURce:SUSPend


Suspend Analyzer

Releases the application visa lock on the test set so that other applications (such as glacier) can use it. You cannot perform any operations with the analyzer while it is suspended. Press Resume Analyzer to stop the suspension. In addition, it is recommended that you perform a Preset operation after the analyzer has been suspended.

Mode: All

Key Path: System, More

SCPI Command: [:SENSe]:SUSPend


Quick Save

The Quick Save front-panel key repeats the last save in the directory. If the last save was to a register, Quick Save saves the State of the currently active mode to the next register. If the last register was register 6, it wraps around to register 1.

If the last save was to a file, Quick Save repeats the last type of save in the last save directory by creating a unique filename using the Auto File Naming algorithm. If the Quick Save is pressed when the test set is powered up for the first time prior to pressing the Save front panel key, the Quick Save saves State to Register 1.

Key Path: Quick Save


Save

Save functionality is common across multiple Modes and Measurements. These common features are described in this section.

The Save feature prompts you to essentially answer the questions: What do you want to save? And where do you want to save it? Once these questions are answered the save can occur. The options in this menu answer the question, ”What do you want to save?”

Accesses a menu that provides the save type options. The Save Type options are State, Trace, Data, or a Screen Image depending on the active mode.

Key Path: Save

For details of the items in this menu, refer to the topics in this section.


State

Selects State as the save type and accesses a menu that provides the options of where to save. You can save either to a register or a file. This softkey will not actually cause the save until the location is chosen.
Saving the state is the only way to save this exact measurement context for the current active mode. The entire state of the active mode is saved in a way that when a recall is requested, the mode will return to as close as possible the context in which the save occurred. This includes all settings and data for only the current active mode.

It should be noted that the Input/Output settings will be saved when saving State, since these settings plus the state of the mode best characterize the current context of the mode, but the mode independent System settings will not be saved.

This softkey will not actually cause the save, since the save feature still needs to know where to save the state. Pressing this key will bring up the Save State menu that provides the user with these options.
For rapid saving, the State menu lists registers to save to, or the user can select a file to save to. Once they pick the destination of the save in the State menu, the save will occur.

Key Path: Save

For details of the items in this menu, refer to the topics in this section.


Register 1 thru Register 6

Selecting any one of these register softkeys causes the State of the currently active mode to be saved to the specified Register. Only the State save type supports writing to registers. The other save types can only write to files. The registers are provided for rapid saving and recalling, since you do not need to specify a filename or navigate to a file. Each of the register softkeys annotates whether it is empty or at what date and time it was last modified.

These 6 registers are all that is available from the front panel for all modes in the test set. There are not 6 registers available for each mode. From remote, 127 Registers are available. Registers are files that are visible to the user in the same folder as other State Files.

Key Path: Save, State


To File

Accesses a menu that enables you to select the location for saving the State. This menu is similar to a standard Windows®Save As dialog.

The default path for all State Files is:

My Documents\<mode name>\state

where <mode name> is the parameter used to select the mode with the INST:SEL command (for example, SA for the Spectrum Analyzer). This path is the Save In: path in the Save As dialog for all State Files when they first enter this dialog.

The Save As dialog is loaded with the file information related to the State Save Type. The filename is filled in using the auto file naming algorithm for the State Save Type and is highlighted. Also, the only files that are visible are the *.state files and the Save As type is *.state, since .state is the file suffix for the State Save Type.

Key Path: Save, State


Save As

Accesses a menu that enables you to select the location where you can save the State. This menu is a standard Windows® dialog with Save As softkeys. The Save As dialog is loaded with the file information related to the State Save Type. The filename is filled in using the auto file naming algorithm for the State Save Type and is highlighted.

The Save As dialog is loaded with the file information related to the State Save Type. The filename is filled in using the auto file naming algorithm for the State Save Type and is highlighted.

The default path for all State Files is:

My Documents\<mode name>\state

where <mode name> is the parameter used to select the mode with the INST:SEL command (for example, SA for the Spectrum Analyzer).

This path is the Save In: path in the Save As dialog for all State Files when they first enter this dialog.
The only files that are visible are the *.state files and the Save As type is *.state, since .state is the file suffix for the State Save Type.

Key Path: Save, State

Save

Saves all of the State of the currently active mode plus the system level Input/Output settings to the specified file.

While the save is being performed, the floppy icon shows up in the settings bar near the Continuous/Single sweep icon. After the save completes, the Advisory Event ”File <register number> saved” is displayed.

Key Path: Save, State, To File…

SCPI Command: MMEMory:STORe:STATe

Restriction and Notes: If the file already exists, the file will be overwritten. Using the C: drive is strongly discouraged, since it runs the risk of being overwritten during a test set software upgrade. Both single and double quotes are supported for any filename parameter over remote. Auto return to the State menu and the Save As dialog goes away.


Save As Dialog and Menu

The Save As is a standard Windows dialog and has Save As menu key menu. Each key in this menu key menu corresponds to the selectable items in the Save As dialog box. The menu keys can be used for easy navigation between the selections within the dialog or the standard Tab and Arrow keys can be used for dialog navigation. When the user navigates to this selection, they have already constrained their Save Type and now they want to specify to which file to direct the save.

The Save As dialog is loaded with the file information related to whatever Save Type the user has previously specified. The filename is filled in using the auto file naming algorithm for the specific Save Type.

The Save As dialog will have the last path loaded into the Save In: for the specific save file type. User specified paths are remembered and persist through subsequent runs of the mode. These remembered paths are mode specific and are reset back to the default using Restore Mode Defaults.

Save

Performs the actual save to the specified file of the selected type. The act of saving does not affect the currently running measurement and does not require you to be in single measurement mode to request a save. It performs the save as soon as the currently running measurement is in the idle state; when the measurement completes. This ensures the State or Data that is saved includes complete data for the current settings. The save only waits for the measurement to complete when the state or data that depends on the measurement setup is being saved. The save happens immediately when exporting corrections or when saving a screen image.

If the file already exists, a dialog will popup with corresponding menu keys that allows you to replace the existing file with an OK or to Cancel the request.

While the save is being performed, the floppy icon shows up in the settings bar near the Continuous/Single icon. After the save completes, the corresponding register menu key annotation is updated with the date the time and the message "File <file name> saved" appears in the message bar.

Restriction and Notes: If the file already exists, the File Exist dialog pops up and allows the user to replace it or not by selecting the Yes or No menu keys that appear with the dialog. (For more details, refer to the File Services PD). Then the key causes an auto return and Save As dialog goes away.

Advisory Event "File <file name> saved" after save is complete.

File/Folder List

Enables you to navigate to the center of the dialog that contains the list of files and folders. Once here you can get information about the file.

Key Path: Save, <various>, Save As..., 2

Restriction and Notes: Pressing this key navigates the user to the files and folders list in the center of the dialog.

File Name

Brings up the Alpha Editor as shown in the screen image. Use the knob to choose the letter to add and the Enter front panel key to add the letter to the file name. In addition to the list of alpha characters, this editor includes a Space menu key and a Done menu key. The Done menu key completes the filename, removes the Alpha Editor and returns back to the File Open dialog and menu, but does not cause the save to occur. You can also use Enter to complete the file name entry and this will cause the save to occur.

Key Path: Save, <various>, Save As..., 3

Restriction and Notes: Brings up the Alpha Editor. Editor created file name is loaded in the File name field of the Save As dialog.

Save As Type

This key corresponds to the Save As Type selection in the dialog. It follows the standard Windows® supported Save As Type behavior. It shows the current file suffix that corresponds to the type of file you have selected to save. If you navigated here from saving State, "State File (*.state)" is in the dialog selection and is the only type available under the pull down menu. If you navigated here from saving Trace, "Trace+State File (*.trace)" is in the dialog selection and is the only type available under the pull down menu. If you navigated here from exporting a data file, "Data File (*.csv)" is in the dialog and is available in the pull down menu. Modes can have other data file types and they would also be listed in the pull down menu.

Key Path: Save, <various>, Save As..., 4

Restriction and Notes: Pressing this key causes the pull down menu to list all possible file types available in this context. All types available are loaded in a 1-of-N menu key for easy navigation.

Up One Level

This key corresponds to the icon of a folder with the up arrow that is in the tool bar of the dialog. It follows the standard Windows® supported Up One Level behavior. When pressed, it causes the file and folder list to navigate up one level in the directory structure.

Key Path: Save, <various>, Save As..., 5

Restriction and Notes: When pressed, the file and folder list is directed up one level of folders and the new list of files and folders is displayed.

Create New Folder

This key corresponds to the icon of a folder with the "*" that is in the tool bar of the dialog. It follows the standard Windows® supported Create New Folder behavior. When pressed, a new folder is created in the current directory with the name New Folder and allows you to enter a new folder name using the Alpha Editor.

Key Path: Save, <various>, Save As..., 6

Restriction and Notes: Creates a new folder in the current folder and lets the user fill in the folder name using the Alpha Editor.

Cancel

This key corresponds to the Cancel selection in the dialog. It follows the standard Windows supported Cancel behavior. It causes the current Save As request to be cancelled.

Key Path: Save, <various>, Save As..., 7

Restriction and Notes: Pressing this key causes the Save As dialog to go away and auto return.


Screen Image

Accesses a menu of functions that enable you to specify a format and location for the saved screen image.

Pressing Screen Image brings up the 2 key dialogs and their corresponding menu –Themes and Save As. When the user navigates to this selection, they have already determined they are saving a Screen Image and now they want to specify how to layout the page prior to saving and to which file to direct the save. The resulting screen image file cannot be recalled.

Key Path: Save, 3


Themes

Accesses a menu of function that enable you to choose the theme to be used when saving the screen image.

The Themes option is the same as the Themes option under the Display and Page Setup dialogs. It allows the user to pick between themes to be used when saving the screen image.

Key Path: Save, Screen Image, 1

SCPI Command: MMEMory:STORe:SCReen:THEMe[?], SYSTem:DEFault

Restriction and Notes: If the file already exists, the file will be overwritten. Using the C: drive is strongly discouraged, since it runs the risk of being overwritten during a test set software upgrade. Both single and double quotes are supported for any filename parameter over remote. Auto return to the State menu and the Save As dialog goes away.

3D Color

Selects a standard color theme with each object filled, shaded and colored as designed.

Key Path: Save, Screen Image, Themes, 1

SCPI Command: MMEMory:STORe:SCReen:THEMe[?]

3D Monochrome

Selects a format that is like 3D color but shades of gray are used instead of colors.

Key Path: Save, Screen Image, Themes, 2

SCPI Command: MMEMory:STORe:SCReen:THEMe[?]

Flat Color

Selects a format that is best when the screen is to be printed on an ink printer.

Key Path: Save, Screen Image, Themes, 3

SCPI Command: MMEMory:STORe:SCReen:THEMe[?]

Flat Monochrome

Selects a format that is like Flat Color. But only black is used (no colors, not even gray), and no fill.

Key Path: Save, Screen Image, Themes, 4

SCPI Command: MMEMory:STORe:SCReen:THEMe[?]


Save As (Screen Image)

Accesses a menu that enables you to select the location where you can save the Screen Image. This menu is a standard Windows® dialog with Save As menu keys. The Save As dialog is loaded with the file information related to the Screen Image Type. The filename is filled in using the auto file naming algorithm for the Screen Image Type and is highlighted. The only files that are visible are the *.png files and the Save As Type is *.png, since .png is the file suffix for the Screen Image Type.

The default path for Screen Images is

My Documents\<mode name>\screen.

where <mode name> is the parameter used to select the mode with the INST:SEL command (for example, SA for the Spectrum Analyzer).

This path is the Save In: path in the Save As dialog for all Screen Files when the user first enters this dialog.

Key Path: Save, Screen Image, 2

Save

Saves the screen image to the specified file using the selected theme. The image that is saved is the measurement display prior to when the Save As dialog appeared. The save is performed immediately and does not wait until the measurement is complete.

Key Path: Save, Screen Image, Save As..., 1

SCPI Command: MMEMory:STORe:SCReen

Restriction and Notes: If the file already exists, the file will be overwritten. Using the C: drive is strongly discouraged, since it runs the risk of being overwritten during a instrument software upgrade. Both single and double quotes are supported for any filename parameter over remote.

Auto return to the Screen Image menu and the Save As dialog goes away.

Advisory Event "File <file name> saved" after save is complete.


Recall

Recall functionality is common across multiple Modes and Measurements. These common features are described in this section.

The Recall feature prompts you to answer the questions: What do you want to recall? And to where do you want to recall it? Once these questions are answered the recall can occur. The options in this menu answer the question ”What do you want to Recall?” The options are State, Trace and Data. (Screen Image can be saved, but not recalled.) The default paths for Recall are data type dependent and are the same as for Save.

Key Path: Recall


State (Recall)

Accesses a menu that enables you to recall a State that has previously been saved. Recalling a saved state returns the test set as close as possible to the mode context and may cause a mode switch if the file selected is not for the current active mode. A State file can be recalled from either a register or a file. Once you pick the source of the recall in the State menu, the recall will occur.

When this key is pressed, the user has determined what they want to recall is State. Recalling State is used to return as close as possible to the mode context of the save. Recalling State may cause a mode switch if the file selected is not for the currently active mode. This softkey will not actually cause the recall, since the recall feature still needs to know from where to recall the state. State can be recalled from either a register or a file. Pressing this key will bring up the State menu that provides the user with the options of where to retrieve the state. For quick recalls, the State menu lists 6 registers to recall from or the user can select a file to recall from.

Key Path: Recall, 1


Register 1 thru Register 6 (Recall)

Selecting any one of these register keys causes the State of the mode from the specified Register to be recalled. Only the Recall Type of State supports reading from registers. The other Recall Types can only read from files. Each of the register keys annotates whether it is empty or at what date and time it was last modified.

Registers are shared by all modes, so recalling from any one of the 6 registers may cause a mode switch to the mode that was active when the save to the Register occurred.

After the recall completes, the message ”Register <register number> recalled” appears in the message bar.

Selecting any one of these register softkeys: Register 1, Register 2, Register 3, Register 4, Register 5, Register 6 causes the state of the mode from the specified Register to be recalled. The registers are provided for easy saving and recalling, since the user does not have to specify a filename or navigate to a specific file. The date will follow the format specified in the Date Format setting under the Control Panel. The time will show hours, minutes and seconds.

Key Path: Recall, State, 1

Key Path: Recall, State, 2

Key Path: Recall, State, 3

Key Path: Recall, State, 4

Key Path: Recall, State, 5

Key Path: Recall, State, 6


From File\File Open

Brings up the File Open standard Windows® dialog and its corresponding File Open key menu.

When you first enter this dialog, the State File default path is in the LookIn: box in this File Open dialog. The File Open dialog is loaded with the file information related to the State Save Type. The first *.state file is highlighted. The only files that are visible are the *.state files and the Files of type is *.state, since .state is the file suffix for the State Save Type.

Key Path: Recall, State, 7

Open

Recalling State function first must verify the file is recallable in the current test set by checking the software version and model number of the test set. If everything matches, a full recall proceeds by aborting the currently running measurement, and then loading the State from the saved state file to as close as possible to the context in which the save occurred. You can open state files from any mode, so recalling a State File switches to the mode that was active when the save occurred. After switching to the mode of the saved state file, mode settings and data (if any for the mode) are loaded with values from the saved file. The saved measurement of the mode becomes the newly active measurement and the data relevant to the measurement (if there is any) is recalled.

If there is a mismatch between file version or model number or test set version or model number, the recall still tries to recall as much as possible and it returns a warning message of what it did.

Key Path: Recall, State, From File…, 1

SCPI Command: MMEMory:LOAD:STATe

No Trace data is loaded when recalling a State File. Measurements that support loading of trace data will include a Trace key in the Recall menu and will load State + Trace data from .trace files under that key.

The state of a mode includes all of the variables affected by doing a full preset. It not only recalls Mode Preset settings, but it also recalls all of the mode persistent settings and data if the mode has either. Each mode determines whether data is part of mode state and if the mode has any persistent settings. Recall State also recalls all of the Input/Output system settings, since they are saved with each State File for each mode.

The Recall State function does the following:

  • Verifies that the file is recallable on this test set using the version number and model number.
    Aborts the currently running measurement.

  • Clears any pending operations.

  • Switches to the mode of the selected Save State file.

  • Sets mode State and Input/Output system settings to the values in the selected Saved State file.
    Limits settings that differ based on model number, licensing or version number.

  • Makes the saved measurement for the mode the active measurement.

  • Clears the input and output buffers.

  • Status Byte is set to 0.

  • Executes a *CLS


File Open Dialog and Menu

The File Open is a standard Windows dialog and has a File Open key menu. Each key in this menu corresponds to the selectable items in the File Open dialog box. The menu keys can be used for easy navigation between the selections within the dialog or the standard Tab and Arrow keys can be used for dialog navigation. When you navigate to this selection, you have already limited the file recall type and now you want to specify which file to open.


Data (Mode Specific) (Recall)

Importing a data file is a way to replace current measurement data with data that was previously saved from this measurement or from other measurements that produce the same type of data. This import feature also allows the user to import data from different modes that produce the same type of data. The Import Menu will only includes Data Types that are supported by the current mode. And, Based on the currently active measurement, Data Types that are not relevant to the currently active measurement may be grayed out in the menu.

Since the commonly exported data files are in .csv format, the data can be edited by the user prior to importing. This allows the user to export a data file, manipulate the data in Excel (the most common PC Application for manipulating .csv files) and then import it.

When this key is pressed, the user has determined that they want to Import Data. Each mode determines what data it will allow to be exported and imported based on what data it produces. Importing Data loads measurement data from the specified file into the destination implied by the Import Data Type selected. The one data type that is available to all modes is Amplitude Corrections. The other data that is typically available in all modes is Measurement Results, but Measurement Results can not be imported. Other examples of mode specific Import Data are Traces and Limits which are Import Data associated with the Swept SA measurement in Spectrum Analyzer mode.

The mode specific Import Data can be grayed out depending on the specific measurement that is running within the mode. For example, when in the SA mode and in the ACP measurement, the Trace Import Data is grayed out, since a trace (Trace1, Trace2, …) is not relevant when the ACP measurement is running.

Selecting an Import Data softkey will not actually cause the importing to occur, since the recall feature still needs to know from where to get the data. Pressing the Open key in this menu brings up the Open dialog and Open menu that provides you with the options from where to recall the data. Once a filename has been selected or entered in the Open menu, the recall will occur.

Key Path: Recall, 2


Zone Map (Recall)

Zone Map

A map file contains zone definitions that will help simplify making measurements of frequently used signals. The OFDMA frame structure can contain multiple-zone definitions for the uplink and downlink subframes and multiple data burst allocations. You can recall map files in which you have saved complicated OFDMA frame analysis zone definitions; this can save you time and ensure the accuracy of repeat measurements. Map files are also useful for recreating measurement settings so they can be used by other users.

Zone map data is not available from all Measurements. In that case, the key will be grayed out. The key will not show if no measurements in the Mode support it.

Key Path: Recall, Data


Open...1

Open...

Last Updated: March 11, 2008

Pressing File Open brings up the File Open standard Windows dialog and the File Open key menu. When the user navigates to this selection, they have already determined they are recalling a specific Data Type and now they want to specify which file to open.

When you first enter this dialog, the path is in the Look In: field in this File Open dialog depends on which import data type you navigated here from.

The only files that are visible are those specific to the file type being recalled.

Key Path: Recall, Data

Restrictions and Notes: Brings up Open dialog for recalling a <mode specific> Save Type


Open

The import starts by checking for errors. Then the import can start. For all data types, the actual import starts by aborting the currently running measurement. Then the import does data type specific behavior:

Trace Import: A trace cannot be imported if the trace points in the file do not match the sweep points in the mode. If this happens, an error is generated. When a trace is imported, then Trace Update is always turned OFF for that trace and Trace Display is always turned ON. The trace file has meta data. If the meta data in the file does not match the corresponding SA state, the dirty marker is displayed.

SCPI Command: MMEMory:LOAD:ZMAP


Preset

  • Mode Preset

  • How-To Preset

  • Restore Mode Defaults

  • *RST (Remote Command Only)

Mode Preset

The Mode preset is the most common way to get the active mode back to a known state. It will keep you in the currently active mode and reset the mode settings to their mode preset state. It will never cause a mode switch. It does a partial preset. It does not affect any mode persistent settings or any system settings.

The Mode Preset does the following for the currently active mode:

  • Aborts the currently running measurement.

  • Brings up the default menu for the mode, with no active function.

  • Sets Measurement settings to their preset values for the active mode only.

  • Activates the default measurement.

  • Brings up the default menu for the mode.

  • Clears the input and output buffers.

  • Sets Status Byte to 0.

Key Path: Front-panel key

SCPI Command: SYSTem:PRESet

How-To Preset

The table below shows all possible presets, their corresponding SCPI commands and front panel access. Instrument settings depend on the current measurement context. Some settings are local to the current measurement, some are global (common) across all the measurement in the current mode, and some are global to all the available modes. In a similar way, restoring the settings to their preset state can be done within the different contexts.

The Auto Couple front panel key is a Meas local key. It sets all Auto/Man parameter couplings in the measurement to Auto. Any Auto/Man selection that is local to the other measurements in the mode will not be affected by Auto Couple.

The Meas Preset key is a Meas local key. Meas Preset resets all the variables local to the current measurement except the persistent ones.

The Mode Preset (front-panel key on front panel) resets all the current mode's Meas local and Meas global variables except the persistent ones.

The Restore Mode Defaults key resets ALL the Mode variables (and all the Meas global and Meas local variables), including the persistent ones.

Type Of Preset | SCPI Command | Front Panel Access
Auto Couple | COUPle | Auto Couple front-panel key
Meas Preset | CONFigure:<Measurement> | Meas Setup Menu
Mode Preset | SYSTem:PRESet | Mode Preset (green key)
Restore Mode Defaults | INSTrument:DEFault | Mode Setup Menu
Restore All Mode Defaults | SYSTem:DEFault MODes | System Menu; Restore System Default Menu
*RST | *RST | not possible (Mode Preset with Single)
Restore Input/Output Defaults | SYSTem:DEFault INPut | System Menu; Restore System Default Menu
Restore Power On Defaults | SYSTem:DEFault PON | System Menu; Restore System Default Menu
Restore Alignment Defaults | SYSTem:DEFault ALIGn | System Menu; Restore System Default Menu
Restore Miscellaneous Defaults | SYSTem:DEFault MISC | System Menu; Restore System Default Menu
Restore All System Defaults | SYSTem:DEFault [ALL] SYSTem:PRESet:PERSistent (bc) | System Menu; Restore System Default Menu
User Preset | SYSTem:PRESet:USER | User Preset Menu
User Preset All Modes | SYSTem:PRESet:USER:ALL | User Preset Menu
Power On Mode Preset | SYSTem:PON:TYPE MODE | System Menu
Power On User Preset | SYSTem:PON:TYPE USER | System Menu
Power On Last State | SYSTem:PON:TYPE LAST | System Menu

Restore Mode Defaults

Restore Mode Defaults resets the state for the currently active mode by resetting the mode persistent settings to their factory default values, clearing mode data and by performing a Mode Preset. This function will never cause a mode switch. This function performs a full preset for the currently active mode; whereas, Mode Preset performs a partial preset. Restore Mode Defaults does not affect any system settings. System settings are reset by Restore System Defaults. This function does reset mode data; as well as settings.

Key Path: Mode Setup

SCPI Command: INSTrument:DEFault

*RST (Remote Command Only)

*RST is equivalent to SYST:PRES;:INIT:CONT OFF which is a Mode Preset in Single measurement state. This remote command is preferred over Mode Preset remote command SYST:PRES, as optimal remote programming occurs with the test set in single measurement state.

SCPI Command: *RST


User Preset

User Preset behaves similarly to Recall State in that it recalls a hidden Save State file with the exception that User Preset will never cause a mode switch. Recalling a Save State file may cause a mode switch, if the Save State file was saved while in a different mode. There is a User Preset file per mode. The User Preset file is a Save State file. User Preset sets the state of currently active mode back to the state that was previously saved for this mode using the Save User Preset softkey or the SYST:PRES:USER:SAVE command. Each mode will have no knowledge of another user preset file from any other mode or how to invoke them. The user has no control over the user preset filename and has no direct access to the user preset file.

User Preset recalls a mode's state which includes all of the variables affected by doing a Mode Preset. It not only recalls Mode Preset settings, but it also recalls all of the mode persistent settings. User Preset also recalls all of the Input/Output system settings.

If a Save User Preset has not been done at any time, User Preset recalls the default user preset file for the currently active mode. The default user preset files are created at power-on when each mode detects there is no user preset file, so there will never be a scenario when there is no user preset file to restore. For each mode, the default user preset state is the same state that would be saved if a Save User Preset is performed in each mode right after doing a Restore Mode Default and after a Restore Input/Output Settings Defaults.

Note: When the test set is secured, all of the user preset files are converted back to their default user preset files.

User Preset does the following:

  • Aborts the currently running measurement.

  • Sets the mode state to the values defined by Save User Preset.

  • Makes the saved measurement for the currently running mode the active measurement.

  • Brings up the saved menu for the power-on mode.

  • Clears the input and output buffers.

  • Sets the Status Byte to 0.

Key Path: User Preset

SCPI Command: SYSTem:PRESet:USER

User Preset All Modes

User Preset All Modes behaves similarly to Power On User Preset, since it recalls all of the User Preset files for each mode, switches to the power-on mode and activates the saved measurement from the power-on mode User Preset file.

Note: When the test set is secured, all of the user preset files are converted back to their default user preset files.

User Preset does the following:

  • Aborts the currently running measurement.

  • Switches the Mode to the power-on mode.

  • Restores the User Preset files for each mode.

  • Makes the saved measurement for the power-on mode the active measurement.

  • Brings up the saved menu for the power-on mode.

  • Clears the input and output buffers.

  • Sets the Status Byte to 0.

Key Path: User Preset

SCPI Command: SYSTem:PRESet:USER:ALL

Save User Preset

Save User Preset saves the currently active mode and its state. The way the user recalls this User Preset file is by pressing the User Preset softkey or sending the SYST:PRES:USER remote command. This same state is also saved by the Save State function.

Key Path: User Preset

SCPI Command: SYSTem:PRESet:USER:SAVE


File

Opens a menu of keys which access various standard and custom Windows dialogs. Pressing any other front-panel key exits any of these dialogs.

  • File Explorer

  • Page Setup

  • Print

  • Exit

File Explorer

Opens the standard Windows File Explorer. Pressing any front panel key closes the Explorer application.
File Explorer opens up in My Documents. (Note: My Documents must be located on the user data partition.).

Page Setup

Refer to your Microsoft Windows Operating System manual.

Print Theme – Remote Command

The graphical user interface contains a selection for choosing the Theme to use when printing. An equivalent remote command is provided. Refer to the View/Display section for more detail on Themes.

SCPI Command: SYSTem:PRINt:THEMe

Print

Refer to your Microsoft Windows Operating System manual.

Exit

This key, when pressed, will exit the test set Application. A dialog box will be used to confirm that the user intended to exit the application:

Mode: All

Key Path: File, Exit


Print

The Print front-panel key is equivalent to performing a File, Print, OK. It immediately performs the currently configured Print to the current printer.

Key Path: Front-panel key


Window Control Keys

The test set provides three front-panel keys for controlling windows. They are Multi Window, Zoom, and Next Window. These are all ”immediate action” keys.

Multi-Window

The Multi Window front-panel key is not used at this time. It is there to support future functionality.

Key Path: Front-panel key

Zoom

Zoom is a toggle function. Pressing once Zooms the selected window; pressing again un-zooms.
When Zoom is on for a window, that window will get the entire primary display area. The zoomed window, since it is the selected window, is outlined in green.

Zoom is local to each Measurement. Each Measurement remembers its Zoom state. The Zoom state of each Measurement is part of the Mode's state.

The state of zoom, and which window is zoomed, is saved in State.

Data acquisition and processing for the other windows continues while a window is zoomed, as does all SCPI communication with the other windows.

Key Path: Front-panel key

Next Window

This key selects the next window of the current view.

When this key is selected in Help mode, it toggles focus between the table of contents window and the topic pane window.

Selected Window

One and only one primary window is always selected.

The selected window has the focus; as far as the user is concerned, all key presses are going to that window.

If a window is not selected, its boundary is gray. The selected window has a green boundary.
Only primary windows may be selected.

If a primary window in a multi-window display is zoomed it is still outlined in green. If there is only one primary window, the green outline is not used. This allows the user to distinguish between a zoomed window and a display with only one primary window.

The selected window is local to each Measurement. Each Measurement remembers which window is selected. The selected window for each Measurement is remembered in Mode state.

If you have a mouse and you click on a window, that window is selected.

Navigating Windows

When the Next Window key is pressed, the next window in the order of precedence (see below) becomes selected. If the selected window was zoomed, the next window will also be zoomed.

The window navigation does NOT use the arrow and select keys. Those are reserved for navigation within a window.

Window precedence

The standard precedence that is used for primary windows is left/right top/bottom; that is, in the 4 primary-window case, window 1 is the top left, window 2 is the top right, window 3 is the bottom left, window 4 is the bottom right.


Mouse and Keyboard Control

If you do not have access to the test set front-panel, there are several ways that a mouse and PC Keyboard can give you access to functions normally accessed using the front panel keys.

Right-Click

If the user plugs in a mouse and right-clicks on the test set screen, a menu will appear as below:

Placing the mouse on one of the rows marked with a right arrow symbol will cause that row to expand, as for example below where the mouse is hovered over the ”Setup” row:

This method can be used to access any of the front-panel keys on the front panel by using a mouse; as for example if the user is accessing the test set through Remote Desktop.

The array of keys thus available is shown below:

PC Keyboard

If you have a PC keyboard plugged in (or via Remote Desktop), certain keycodes on the PC keyboard map to front-panel keys on the GPSA front panel. These keycodes are shown below in both pictorial and table format:

Keycode Commands

To mimic the following Front Panel key: | Press these keys on the Remote Computer keyboard:
AMPTD Y Scale | Ctrl+Shift+A
Auto Couple | Ctrl+Shift+C
Bk Sp | Backspace
BW | Ctrl+Alt+B
Cancel (Esc) | Esc
Cont | Ctrl+Alt+C
Ctrl | Ctrl
Decrease Audio Volume | the Volume Control slider
Del | Delete
Down Arrow | Down Arrow
Enter | Enter (Return)
File | Ctrl+F
FREQ Channel | Ctrl+Shift+F
Full Screen | Ctrl+Shift+B
Help | F1
Increase Audio Volume | the Volume Control slider
Input/Output | Ctrl+Shift+O
Left Arrow | Left Arrow
Marker | Ctrl+Alt+K
Marker -> | Ctrl+Alt+N
Marker Function | Ctrl+Alt+F
Meas | Ctrl+Alt+M
Meas Setup | Ctrl+Alt+U
Menu (Alt) | Alt
Mode | Ctrl+Shift+M
Mode Preset | Ctrl+M
Mode Setup | Ctrl+Shift+E
Mute | the Mute checkbox under the Volume Control
Next Window | Ctrl+Shift+N
Peak Search | Ctrl+Alt+P
Print | Ctrl+P
Quick Save | Ctrl+Q
Recall | Ctrl+R
Restart | Ctrl+Alt+R
Return | Ctrl+Shift+R
Right Arrow | Right Arrow
Save | Ctrl+S
Select | Space Bar
Single | Ctrl+Alt+S
Softkey 1 | Ctrl+Shift+F1
Softkey 2 | Ctrl+Shift+F2
Softkey 3 | Ctrl+Shift+F3
Softkey 4 | Ctrl+Shift+F4
Softkey 5 | Ctrl+Shift+F5
Softkey 6 | Ctrl+Shift+F6
Softkey 7 | Ctrl+Shift+F7
Source | Ctrl+Alt+U
Source Control | Ctrl+Shift+E
SPAN X Scale | Ctrl+Shift+S
Split Screen | Ctrl+Shift+L
Sweep/Control | Ctrl+Shift+W
System | Ctrl+Shift+Y
Tab | Tab
Trace/Detector | Ctrl+Alt+T
Trigger | Ctrl+Shift+T
Up Arrow | Up Arrow
User Preset | Ctrl+U
View/Display | Ctrl+Shift+V
Zoom | Ctrl+Shift+Z
1 | 1a
2 | 2a
3 | 3a
4 | 4a
5 | 5a
6 | 6a
7 | 7a
8 | 8a
9 | 9a
– | Use the – key to enter a negative value, as appropriatea
. (Decimal Point) | . (Period)a
0 (Zero) | 0 (Zero)a

  1. For remote keyboards that feature a numeric keypad, use either the appropriate

    numeric keypad key or the main keypad key.

The effect of pressing Ctrl+Alt+Delete on the keyboard of the remote computer always applies to the remote computer, and not to the test set. Generally, the effect of pressing this key combination is to display the Windows Task Manager. Therefore, pressing this key combination on the remote computer does not allow you to reboot the test set.


Test Set (N8300A)

N8300A Wireless Networking Test Set Release Information

Last Updated: March 28, 2008

This table provides an overview of the release information for the N8300A Wireless Networking Test Set and its applications.

It details what license revision is required for each of the applications within each version of the program. The license revision detailed, is the revision required to access all the application's features. Older licences are still valid in newer program versions but you may not have access to all the application's features. You can click on the links at the top of each column to get more detailed information.

Description | Licence Required
N8300A Wireless Networking Test Set | N/A
N6301A 802.16 OFDMA | N6301A-1FP
N6301A 802.16 OFDM | N6301A-2FP


Test Set (N8300A)

N8300A Wireless Networking Test Set Release Notes

Last Updated: March 28, 2008

This topic explains what applications were upgraded at each release of the N8300A Wireless Networking Test Set Program.

  • N8300A Initial Release

N8300A Release A.01.50

Applications

  • N6301A 802.16 OFDM Measurement application was introduced. Click here for more information on this application

  • N6301A 802.16 OFDMA Measurement application was enhanced with extra measurements and additional measurement results. Click here for more information on this application

N8300A Initial Release

Applications

  • N6301A 802.16 OFDMA Measurement Application was introduced. Click here for more information on this application.

Related Information: Upgrading the Measurement Application in the Test Set


Test Set (N8300A)

N6301A 802.16 OFDMA Measurement Application Release Notes

Last Updated: March 28, 2008

This topic describes features and functionality that are part of the N6301A 802.16 OFDMA Measurement Application Release Notesreleases. This topic contains the original features, as well as enhancements that have been added in subsequent releases and known problems that have been fixed. It also details what license enables the features.

  • N6301A 802.16 OFDMA Measurement Application Version A.01.50

  • N6301A 802.16 OFDMA Measurement Application Version A.01

N6301A 802.16 OFDMA Measurement Application Version A.01.50

The following modifications were made:

  • The Spectrum Emissions Mask measurement was added

  • The Adjacent Channel Power measurement was added

  • Additional measurement results - IQ Gain Imbalance and IQ Quadrature Error - were added to the EVM measurement

  • The Spectral Mask measurement was removed from the front panel display, but is still available from SCPI. Agilent recommends that customers use the new Spectrum Emissions Mask measurement instead of the Spectral Mask measurement in new code

N6301A 802.16 OFDMA Measurement Application Version A.01

The N6301A 802.16 OFDMA Measurement Application was introduced. For all the Help associated with this application click here.

802.16 OFDMA features that are enabled by the N6301A-1FP License

Measurements

  • Introduced the OFDMA Modulation Analysis, Power Stat CCDF, Spectral Mask, and Waveform measurements.


802.16 OFDMA (N6301A)

N6301A 802.16 OFDM Measurement Application Release Notes

Last Updated: March 28, 2008

This topic describes features and functionality that are part of the N6301A 802.16 OFDM Measurement Application Release Notesreleases. This topic contains the original features, as well as enhancements that have been added in subsequent releases and known problems that have been fixed. It also details what license enables the features.

  • N6301A 802.16 OFDM Measurement Application Version A.01.50

N6301A 802.16 OFDM Measurement Application Version A.01.50

The N6301A 802.16 OFDM Measurement Application was introduced. For all the Help associated with this application click here.

802.16 OFDM features that are enabled by the N6301A-2FP License

Measurements

  • Introduced the OFDM Modulation Analysis, Power Stat CCDF, Spectral Mask, Waveform and Adjacent Channel Power measurements.


N6301A 802.16 OFDMA Measurement Application Help

802.16 OFDMA (N6301A)

N6301A 802.16 OFDMA Measurement Application Help

Last Updated: March 28, 2008

This online help describes how to use the Agilent N6301A 802.16 OFDMA Measurement Application. The Table of Contents on the left, provides access to all of the information contained within this online help.

The help is organized into the following sections:

  • Programming provides individual programming examples for the measurements in this application.

  • SCPI Commands provides details on all of the SCPI syntax available to control this application by remote program.

  • Front Panel Operation provides reference information about the application's screens.

© Agilent Technologies, Inc. 2007-2008


SCPI Commands (802.16 OFDMA)

This book provides details of the SCPI commands in the N6301A 802.16 OFDMA Measurement Application. For details of these commands refer to the subsystems in this section. Alternatively, for a complete list of the SCPI commands in this application, see Listing of Commands (802.16 OFDMA).

Measurement Control

  • CALCulate Subsystem to perform data processing on measurement results.

  • CONFigure Subsystem to perform high level configuration functions.

  • FETCh Subsystem to get measurement results.

  • FORMat Subsystem to set a data format for transferring numeric and array information.

  • INITiate Subsystem to start a measurement.

  • MEASure? Subsystem to make measurements using the factory default test set settings.

  • READ? Subsystem to make measurements and retrieve the results.

  • [:SENSe] Subsystem for controls that directly affect device-specific settings of the device.

RF Control

  • SOURce Subsystem to control the test set's RF generator.

Related Topic: SCPI Commands (Test Set)


Listing Of Commands (802.16 OFDMA)

This topic lists all of the available SCPI commands in the N6301A 802.16 OFDMA Measurement Application.

It is recommended that you print this topic because it provides a useful syntax reference for all of the available General Purpose Application commands. To print:

  • Click the Print icon [image] on the toolbar above, or

  • Right-click in this topic pane and select Print...

The SCPI commands in this topic are categorized by subsystem:

  • CALCulate Subsystem

  • CONFigure Subsystem

  • FETCh Subsystem

  • FORMat Subsystem

  • INITiate Subsystem

  • MEASure Subsystem

  • READ Subsystem

  • [:SENSe] Subsystem

  • SOURce Subsystem

  • TRIGger Subsystem

CALCulate Subsystem

  • CALCulate:CLIMits:FAIL?

  • CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:BURSt[1]|2:NUMBer?

  • CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

  • CALCulate:EVM:BURSt[1]|2:SHAPe[?]

  • CALCulate:EVM:BURSt[1]|2:STATe[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

  • CALCulate:EVM:BURSt:TYPE[:SELect][?]

  • CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

  • CALCulate:EVM:EQUalizer:TMODe[?]

  • CALCulate:EVM:INFormation:BURSt[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

  • CALCulate:EVM:MAP:CUSTom:NAME[?]

  • CALCulate:EVM:MAP:DETect

  • CALCulate:EVM:MAP:SELect:FECCode[?]

  • CALCulate:EVM:MAP:SELect:TYPE[?]

  • CALCulate:EVM:MARKer:AOFF

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SUBCarrier[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SYMBol[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:EVM:MS:PBASe[?]

  • CALCulate:EVM:PILot[?]

  • CALCulate:EVM:PILot:TRACk:AMPLitude[?]

  • CALCulate:EVM:PILot:TRACk:PHASe[?]

  • CALCulate:EVM:PILot:TRACk:TIMing[?]

  • CALCulate:EVM:PINDex[?]

  • CALCulate:EVM:SPECtrum[?]

  • CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

  • CALCulate:EVM:SUBChannel:MASK[?]

  • CALCulate:EVM:SWEep:OFFSet[?]

  • CALCulate:EVM:SYMBol:ADJust[?]

  • CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:ZONE[?]

  • CALCulate:EVM:ZONE:INTerval[?]

  • CALCulate:EVM:ZONE:OFFSet[?]

  • CALCulate:PSTatistic:MARKer:AOFF

  • CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:PSTatistic:NSELect[?]

  • CALCulate:PSTatistic:STORe:REFerence

  • CALCulate:SMASk:LCOMpensatio[?]

  • CALCulate:SMASk:MDEFinition[?]

  • CALCulate:WAVeform:MARKer:AOFF

  • CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12[:SET]:RLEVel

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

CONFigure Subsystem

  • CONFigure?

  • CONFigure:EVM

  • CONFigure:EVM:NDEFault

  • CONFigure:PSTatistic

  • CONFigure:PSTatistic:NDEFault

  • CONFigure:SMASk

  • CONFigure:SMASk:NDEFault

  • CONFigure:WAVeform

  • CONFigure:WAVeform:NDEFault

    FETCh Subsystem

    When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

    1. Initiate the measurement using the appropriate INIT:<meas_name> command.

    2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

    3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

    The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

    • FETCh:EVM{0:20}?

    • FETCh:PSTatistic{0:4}?

    • FETCh:SMASk{0:3}?

    • FETCh:WAVeform{0:2}?

    FORMat Subsystem

    • FORMat[:TRACe][:DATA][?]

    • FORMat:BORDer[?]

    INITiate Subsystem

    When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

    1. Initiate the measurement using the appropriate INIT:<meas_name> command.

    2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

    3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

    The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

    • INITiate:CONTinuous[?]

    • INITiate:CONTinuous:OPRiority[?]

    • INITiate:EVM

    • INITiate[:IMMediate]

    • INITiate:PAUSe

    • INITiate:PSTatistic

    • INITiate:RESTart

    • INITiate:RESume

    • INITiate:SMASk

    • INITiate:WAVeform

    MEASure Subsystem

    When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

    1. Initiate the measurement using the appropriate INIT:<meas_name> command.

    2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

    3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

    The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

    • MEASure:EVM{0:20}?

    • MEASure:PSTatistic{0:4}?

    • MEASure:SMASk{0:3}?

    • MEASure:WAVeform{0:2}?

    READ Subsystem

    When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

    1. Initiate the measurement using the appropriate INIT:<meas_name> command.

    2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

    3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

    The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

    • READ:EVM{0:20}?

    • READ:PSTatistic{0:4}?

    • READ:SMASk{0:3}?

    • READ:WAVeform{0:2}?

    [:SENSe] Subsystem

    • [:SENSe]:EVM:AVERage:COUNt[?]

    • [:SENSe]:EVM:AVERage[:STATe][?]

    • [:SENSe]:EVM:AVERage:TCONtrol[?]

    • [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

    • [:SENSe]:EVM:TRIGger:SOURce[?]

    • [:SENSe]:FREQuency:CENTer[?]

    • [:SENSe]:POWer:RANGe[?]

    • [:SENSe]:POWer[:RF]:PCENter

    • [:SENSe]:PSTatistic:COUNts[?]

    • [:SENSe]:PSTatistic:GAUSsian[:STATe][?]

    • [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

    • [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

    • [:SENSe]:PSTatistic:RTRace[:STATe][?]

    • [:SENSe]:PSTatistic:SWEep:CYCLes[?]

    • [:SENSe]:PSTatistic:SWEep:TIME[?]

    • [:SENSe]:PSTatistic:TRIGger:SOURce[?]

    • [:SENSe]:RADio:STANdard[?]

    • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

    • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

    • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

    • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

    • [:SENSe]:RADio:STANdard:DEVice[?]

    • [:SENSe]:RADio:STANdard:DRATio[?]

    • [:SENSe]:RADio:STANdard:FDURation[?]

    • [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

    • [:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

    • [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

    • [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

    • [:SENSe]:RESume

    • [:SENSe]:ROSCillator:SOURce?

    • [:SENSe]:ROSCillator:SOURce:TYPE[?]

    • [:SENSe]:SMASk:MASK[:STATe][?]

    • [:SENSe]:SMASk:SWEep:TIME[?]

    • [:SENSe]:SMASk:TRIGger:SOURce[?]

    • [:SENSe]:SMASk:WTYPe[?]

    • [:SENSe]:SUSPend

    • [:SENSe]:WAVeform:AVERage:COUNt[?]

    • [:SENSe]:WAVeform:AVERage[:STATe][?]

    • [:SENSe]:WAVeform:AVERage:TCONtrol[?]

    • [:SENSe]:WAVeform:AVERage:TYPE[?]

    • [:SENSe]:WAVeform:PONLy[:STATe][?]

    • [:SENSe]:WAVeform:SWEep:TIME[?]

    • [:SENSe]:WAVeform:TRIGger:SOURce[?]

    SOURce Subsystem

    • SOURce:CALibration[:USER]

    • SOURce:CALibration:DCFM

    • SOURce:CALibration:IQ:DC

    • SOURce:CALibration:IQ:DEFault

    • SOURce:CALibration:IQ:FULL

    • SOURce:CALibration:IQ:START[?]

    • SOURce:CALibration:IQ:STOP[?]

    • SOURce:CALibration:IQ:TYPE[?]

    • SOURce:MMEMory:CATalog?

    • SOURce:MMEMory:COPY

    • SOURce:MMEMory:DATA

    • SOURce:MMEMory:DATA:UNPRotected

    • SOURce:MMEMory:DELete[:NAME]

    • SOURce:MMEMory:DELete:NVWFm

    • SOURce:MMEMory:DELete:WFM

    • SOURce:OUTPut[:STATe][?]

    • SOURce:POWer:ALC[:STATe][?]

    • SOURce:POWer:ATTenuation[?]

    • SOURce:POWer:ATTenuation:AUTO[?]

    • SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

    • SOURce:RADio:ARB[:STATe][?]

    • SOURce:RADio:ARB:CLOCk:SRATe[?]

    • SOURce:RADio:ARB:DONE?

    • SOURce:RADio:ARB:MARKer[:SET]

    • SOURce:RADio:ARB:MARKer:CLEar

    • SOURce:RADio:ARB:MARKer:CLEar:ALL

    • SOURce:RADio:ARB:MARKer:ROTate

    • SOURce:RADio:ARB:MDEStination:ALCHold[?]

    • SOURce:RADio:ARB:MDEStination:PULSe[?]

    • SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

    • SOURce:RADio:ARB:RSCaling[?]

    • SOURce:RADio:ARB:SEQuence[:MWAVeform]

    • SOURce:RADio:ARB:TRIGger[:SOURce][?]

    • SOURce:RADio:ARB:TRIGger:TYPE[?]

    • SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

    • SOURce:RADio:ARB:WAVeform

    • SOURce:RESume

    • SOURce:SUSPend

    TRIGger Subsystem

    • TRIGger:EVM[:SEQuence]:SOURce[?]

    • TRIGger[:SEQuence]:EXTernal:DELay[?]

    • TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

    • TRIGger[:SEQuence]:HOLDoff[?]

    • TRIGger[:SEQuence]:HOLDoff:STATe[?]

    • TRIGger:PSTatistic[:SEQuence]:SOURce[?]

    • TRIGger[:SEQuence]:RFBurst:DELay[?]

    • TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

    • TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

    • TRIGger[:SEQuence]:RFBurst:SLOPe[?]

    • TRIGger[:SEQuence]:SLOPe[?]

    • TRIGger:SMASk[:SEQuence]:SOURce[?]

    • TRIGger:WAVeform[:SEQuence]:SOURce[?]


CALCulate Subsystem (802.16 OFDMA)

CALCulate Subsystem

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example, the CALCulate subsystem uses the markers to find the peaks and to read back their values in the Spectrum Monitor.

For details of the CALCulate commands refer to the topics in this section.


CALCulate:CLIMits

This command provides limit fail summary information. This function is available after the measurement result data is collected.

  • CALCulate:CLIMits:FAIL?

CALCulate:CLIMits:FAIL?

Queries a summary of all the individual LIMit:FAILs. If any of the individual LIMit:FAILs have a non-zero value, indicating a failure, the composite FAIL query returns a 1. If there are no failures then a 0 is returned. When all the failed LIMits have been CLEared, then the composite FAIL is also cleared. This query is useful if you only need to know whether a limit has passed or failed.

This query checks for the pass/fail result in the following measurements:

  • OFDMA Modulation Analysis

Query Range: 0 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:CLIMits:FAIL?

Returns a summary pass/fail indication of the individual limit results.


CALCulate:EVM (802.16 OFDMA)

CALCulate:EVM

These commands provide data processing functions for Modulation Analysis (EVM) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:BURSt[1]|2:NUMBer?

  • CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

  • CALCulate:EVM:BURSt[1]|2:SHAPe[?]

  • CALCulate:EVM:BURSt[1]|2:STATe[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

  • CALCulate:EVM:BURSt:TYPE[:SELect][?]

  • CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

  • CALCulate:EVM:EQUalizer:TMODe[?]

  • CALCulate:EVM:INFormation:BURSt[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

  • CALCulate:EVM:MAP:CUSTom:NAME[?]

  • CALCulate:EVM:MAP:DETect

  • CALCulate:EVM:MAP:SELect:FECCode[?]

  • CALCulate:EVM:MAP:SELect:TYPE[?]

  • CALCulate:EVM:MARKer:AOFF

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SUBCarrier[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SYMBol[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:EVM:MS:PBASe[?]

  • CALCulate:EVM:PILot[?]

  • CALCulate:EVM:PILot:TRACk:AMPLitude[?]

  • CALCulate:EVM:PILot:TRACk:PHASe[?]

  • CALCulate:EVM:PILot:TRACk:TIMing[?]

  • CALCulate:EVM:PINDex[?]

  • CALCulate:EVM:SPECtrum[?]

  • CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

  • CALCulate:EVM:SUBChannel:MASK[?]

  • CALCulate:EVM:SWEep:OFFSet[?]

  • CALCulate:EVM:SYMBol:ADJust[?]

  • CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:ZONE[?]

  • CALCulate:EVM:ZONE:INTerval[?]

  • CALCulate:EVM:ZONE:OFFSet[?]

CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

Sets/queries the Data Modulation Type to be used.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

Query Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

*RST Setting: QPSKR1BY2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:MODulation:TYPE QPSKR1BY2

Sets the Data Modulation Type to QPSK-1/2.

CALCulate:EVM:BURSt[1]|2:NUMBer?

Queries the number of bursts to be measured. In the auto-detect mode, this parameter changes when detection is performed correctly. In the predefined-mode, this parameter is calculated from the map file.

BURSt1 is for BS, 2 for MS. Default is BS.

Query Range: <nr1>

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt2:NUMBer?

Queries the number of bursts to be measured for the second burst.

CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

Sets/queries whether to automatically set boosting levels, or to use the values that are specified for the bursts.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:POWer:MAP OFF

Turns off the automatic setting of boosting levels.

CALCulate:EVM:BURSt[1]|2:SHAPe[?]

Sets/queries wrapped or rectangle burst shapes.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: WRAPped | RECTangle

Query Range: WRAP | RECT

*RST Setting: RECTangle

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SHAPe WRAPped

Sets the burst shape to wrapped.

CALCulate:EVM:BURSt[1]|2:STATe[?]

Sets/queries multiple data bursts for analysis when it is set to On.

BURSt1 is for BS, 2 for MS. Default is BS.

The number of elements is determined by the Number of Bursts provided by the CALCulate:EVM:BURSt[1]|2:NUMBer? query.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:STATe?

Queries the burst state for the modulation analysis measurement.

CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

Sets/queries the number of the subchannel logical interval for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

Query Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SUBChannel:INTerval 1

Sets the number of the subchannel logical interval for the burst region to 1.

CALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

Sets/queries the number of the Subchannel logical offset for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to Number of subchannels on current zone - 1

Query Range: 0 to Number of subchannels on current zone - 1

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SUBChannel:OFFSet 1

Sets the Subchannel logical offset for burst 1 to 1.

CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

Sets/queries the number of the OFDMA symbol interval for the burst position.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

Query Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt2:SYMBol:INTerval?

Queries the number of the OFDMA symbol interval for burst 2.

CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

Sets/queries the number of the OFDMA symbol offset for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 500

Query Range: 0 to 500

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SYMBol:OFFSet 1

Sets the OFDMA symbol offset for burst 1 to 1.

CALCulate:EVM:BURSt:TYPE[:SELect][?]

Sets/queries a method of burst analysis. You can choose between the burst map method or the single burst method.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: MAP | SINGle | UZONe

Query Range: MAP | SING | UZON

*RST Setting: MAP

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:TYPE UZONe

Sets the burst analysis method to Uniform Zone (Manual).

CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

Sets/queries whether the spectral flatness result trace is smoothed.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:EQUalizer:SMOothing ON

Turns on smoothing for the spectral flatness result.

CALCulate:EVM:EQUalizer:TMODe[?]

When demodulating the 802.16 OFDMA signal, the analyzer uses an equalizer to correct for linear impairments in the signal path, such as multi-path. The analyzer supports three different methods to initialize, or "train", the equalizer: Preamble Only, Preamble, Data & Pilots and Preamble & Pilots Only. Selecting an appropriate method can help isolate problems that contribute to increased RCE (EVM).

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: SEQuence | SDATa | SPILot

Query Range: SEQ | SDAT | SPIL

*RST Setting: SDATa

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:EQUalizer:TMODe SDATa

Sets the training method to Preamble, Data & Pilots.

CALCulate:EVM:INFormation:BURSt[?]

Sets/queries which burst's info is returned by MEASure|READ|FETCh:EVM10?

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to CALC:EVM:BURS:COUN?

Query Range: 1 to :CALC:EVM:BURS:COUN?

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:INFormation:BURSt 2

Sets the information relating to burst 2 to be returned by the MEASure|READ|FETCh:EVM10? queries.

CALCulate:EVM:LIMit[1]|2:FERRor[?]

Sets/queries the limit in ppm for the absolute Frequency Error measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 100

Query Range: 0 to 100

*RST Setting: 2.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit2:FERRor 4.00

Sets the limit in ppm for the absolute Frequency Error measurement pass/fail test to 4.00 ppm for burst 2.

CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

Sets/queries the limit state for the absolute Frequency Error measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:FERRor:STATe OFF

Turns off limits for the absolute Frequency Error measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:IQOFfset[?]

Sets/queries the limit in relative amplitude for the I/Q Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -15 dB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:IQOFfset 0

Sets a limit of 0 in relative amplitude for the I/Q Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

Sets/queries the limit state for the I/Q Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:IQOFfset:STATe OFF

Turns off limits for the I/Q Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:PRCE[?]

Sets/queries the limit for the Peak RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:PRCE -50

Sets the limit for the Peak RCE measurement pass/fail test to -50 dBm.

CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

Sets/queries the limit state for the Peak RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:PRCE:STATe 1

Turns on limits for the Peak RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RCEPilot[?]

Sets/queries the limit for the Pilot RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RCEPilot -50

Sets the limit for the Pilot RCE measurement pass/fail test to -50.

CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

Sets/queries the limit state for the Pilot RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RCEPilot:STATe?

Queries the limit state for the Pilot RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RRCE[?]

Sets/queries the limit for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE -50

Sets the limit for the RMS RCE measurement pass/fail test to -50.

CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

Sets/queries the limit mode for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:AUTO OFF

Sets the limit mode for the RMS RCE measurement pass/fail test to Manual.

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

Sets/queries the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -20.5

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA16:R1B2 -10.0

Sets the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -10.0.

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

Sets/queries the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -24.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4 -10.0

Sets the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test to -10.0.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

Sets/queries the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 15

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R1B2

Sets the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

Sets/queries the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R2B3 -20

Sets the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

Sets/queries the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R3B4 -20

Sets/queries the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

Sets/queries the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 15

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2 -25

Sets the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -25.

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

Sets/queries the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QPSK:R3B4?

Queries the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

Sets/queries the limit state for the RMS EVM measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:STATe OFF

Turns off limits for the RMS EVM measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

Sets/queries the lower limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -2,-4,0,0,0,0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt -2,-4,0,0,0,0

Sets the lower limit level at the start subcarrier for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

Sets/queries the lower limit state at the start subcarrier for the selected offset.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe?

Queries the lower limit state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

Sets/queries the lower mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -2, -4, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP?

Queries the lower mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

Sets/queries the lower mask limit auto/manual state at the stop subcarrier state for the selected offset. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO AUTO,AUTO,AUTO,AUTO,AUTO,AUTO

Sets the lower mask limit auto/manual state at the stop subcarrier state to Auto for all offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

Sets/queries which offset side will be measured.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: BOTH | NEGative | POSitive, BOTH | NEGative |POSitive, BOTH |NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive

Query Range: BOTH | NEG | POS, BOTH | NEG |POS, BOTH |NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS

*RST Setting: BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE?

Queries which offset side will be measured.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

Sets/queries the start subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 1, 210, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt?

Queries the start subcarrier for the currently selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

Sets/queries the start subcarrier state for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe ON, ON, ON, OFF, OFF, OFF

Sets the start subcarrier state for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

Sets/queries the stop subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: 210, 420, 0, 0, 0, 0

*RST Setting: 210, 420, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP?

Queries the stop subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

Sets/queries the upper limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: 2, 2, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt 2, 2, 0, 0, 0, 0

Sets the upper limit level at the start subcarrier for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

Sets/queries the upper limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe?

Queries the upper limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

Sets/queries the upper mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: 2, 2, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP?

Queries the upper mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

Sets/queries the upper mask limit auto/manual state at the stop subcarrier for the selected offset. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, and results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Sets the upper mask limit auto/manual state at the stop subcarrier for the all offsets to Auto.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

Sets/queries the lower limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt?

Queries the lower limit level at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

Sets/queries the lower limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe 1, 0, 0, 0, 0, 0

Sets the lower limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

Sets/queries the lower mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP -0.1, -0.1, 0.00, 0.00, 0.00, 0.00

Sets the lower mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

Sets/queries the lower mask limit auto/manual state at the stop subcarrier for the selected offset. If set to Auto, the Lower Mask Stop power level limit is coupled to Lower Mask Start, which results in a flat limit line. If set to Man, Lower Mask Start and Lower Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO AUTO,AUTO,AUTO,AUTO,AUTO,AUTO

Sets the lower mask limit auto/manual state at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

Sets/queries which offset side will be measured.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: BOTH | NEGative | POSitive, BOTH | NEGative |POSitive, BOTH |NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive

Query Range: BOTH | NEG | POS, BOTH | NEG |POS, BOTH |NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS

*RST Setting: BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Sets which offset side will be measured for the 6 offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

Sets/queries the start subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt?

Queries the start subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

Sets/queries the start subcarrier state for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe 0, 1, 0, 0, 0, 0

Sets the start subcarrier state for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

Sets/queries the stop subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 420, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP?

Queries the stop subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

Sets/queries the upper limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt 0.1, 0.1, 0.00, 0.00, 0.00, 0.00

Sets the upper limit level at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

Sets/queries the upper limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe?

Queries the upper limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

Sets/queries the upper mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP?

Queries the upper mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

Sets/queries the upper mask limit auto/manual state at the stop subcarrier for the selected offset. The upper mask limit ranges from -100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Sets the upper mask limit auto/manual state at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:TOFFset[?]

Sets/queries the limit for the Time Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 100e-3

Query Range: 0 to 100e-3

*RST Setting: 1e-6

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:TOFFset?

Queries the limit for the Time Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

Sets/queries the limit state for the Time Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:TOFFset:STATe 1

Sets the limit state for the Time Offset measurement pass/fail test to OFF.

CALCulate:EVM:MAP:CUSTom:NAME[?]

Sets/queries the customized Map name.

Setting Range: Uppercase, Lowercase, Numeric, Symbol

Query Range: Uppercase, Lowercase, Numeric, Symbol

*RST Setting: Default Map

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:CUSTom:NAME "Agilent"

Sets the customized Map name to Agilent.

CALCulate:EVM:MAP:DETect

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:DETect

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

CALCulate:EVM:MAP:SELect:FECCode[?]

Sets/queries the coding type of the forward error correction that is used to decode the DL-MAP burst.

Setting Range: CC (Convolutional Code)|CTC (Conv Turbo Code)

Query Range: CC (Convolutional Code)|CTC (Conv Turbo Code)

*RST Setting: CC

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:SELect:FECCode CTC
Sets the coding type that is used for decoding the DL-MAP burst to Convolutional Turbo Code.

CALCulate:EVM:MAP:SELect:TYPE[?]

Sets/queries the Zone Definition which defines the zone information.

Setting Range: AUTO | CUSTom | FCH

Query Range: AUTO | CUST | FCH

*RST Setting: CUSTom

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:SELect:TYPE?

Queries the Zone Definition.

CALCulate:EVM:MARKer:AOFF

Turns all markers off.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer:AOFF

Turns all markers off.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

Sets/queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: Result dependant on Markers setup and signal source.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum

Places the marker 2 on the trace point with the maximum y-axis value for that marker's trace.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

Moves the selected marker to the next peak to the left of the current marker.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer5:MAXimum:LEFT

Moves marker 5 to the next peak to the left of the current marker.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

Moves the selected marker to the peak that has the next highest amplitude that is less than the marker's current value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum:NEXT

Moves marker 2 to the peak that has the next highest amplitude that is less than the marker's current value.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

Moves the selected marker to the next peak to the right of the current marker.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum:RIGHt

Moves marker 2 to the next peak on the right of the current marker.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

Moves the selected marker to the minimum y-axis value of the current trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer6:MINimum

Moves marker 6 to the minimum y-axis value of the current trace.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries the marker control mode.

If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

Default Active Function: The active function for the selected marker's current control mode. Note that if the current control mode is Off, there is no active function, and the active function is set to Off.

Active Function Display:

  • the marker Chip value in the IQ Measured Polar graph

  • the marker X axis value in any other graph

The value entered in the active function area will display the marker value to its full entered precision.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer10:PTPeak

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the marker that the selected marker will be relative to (that is, its reference marker).

A marker cannot be relative to itself so that choice is grayed out, and if sent from SCPI generates error –221: ”Settings conflict; marker cannot be relative to itself.”

When queried a single value will be returned (the specified marker numbers relative marker). A marker cannot be relative to itself so that choice is grayed out, and if sent from SCPI generates error –221: ”Settings conflict; marker cannot be relative to itself.”

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer7:REFerence?

Queries the marker that marker 7 will be relative to (that is, its reference marker).

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is Off to On, or 1, puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer3:STATe ON

Sets marker 3 to Normal mode and places it at the center of the screen.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Accesses a menu that allows you to assign a specified marker to the designated trace. Symbol Traces means that three traces for I/Q polar, Symbol Error Carrier, Symbol Error Symbol, Symbol Power Carrier, and Symbol Power Symbol can be assigned. If used, a marker pointer is placed on each trace. In this case, the three pointers will move at the same time, as coupled markers, whenever the X position of the Symbol Traces changes.

Setting Range: SYMBol | POLar | EVCarrier | RECarrier | EVSymbol | RESymbol | PCARrier | RPCarrier | PSYMbol | RPSymbol | FLATness | DFLatness | PVT | SPECtrum

Query Range: SYMB | POL | EVC | REC | EVS | RES | PCAR | RPC | PSYM | RPS | FLAT | DFL | PVT | SPEC

*RST Setting: SYMB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:TRACe?

Queries the currently assigned trace for marker 2.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. It has no effect if the control mode is Off, but is the SCPI equivalent of entering an X value if the control mode is Normal or Delta.

If no suffix is sent it will use the fundamental units for the current marker X Axis Scale. If a suffix is sent that does not match the current marker X Axis Scale unit, an ”Invalid suffix” error will be generated. The query returns the marker's absolute X Axis value if the control mode is Normal, or the offset from the marker's reference marker if the control mode is Delta. The query is returned in the fundamental units for the
current marker X Axis scale: Hz for Frequency and Inverse Time, seconds for Period and Time. If the marker is Off the response is not a number (NAN).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are set to Off, so a Marker X Axis Value query will return a not a number (NAN)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer3:X?

Queries the marker 3 X Axis value in the current marker X Axis Scale unit.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

The query returns the marker's absolute X Axis value in trace points if the control mode is Normal, or the offset from the marker's reference marker in trace points, if the control mode is Delta. The value is returned as a real number, not an integer, corresponding to the translation from X Axis Scale units to trace points (see ”Fractional Trace Points”, above). If the marker is Off the response is not a number (NAN).

After a preset, all markers are set to Off, so Marker X Axis Value query will return a not a number (NAN).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are set to Off, so a Marker X Axis Value query will return a not a number (NAN)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer4:X:POSition?

Queries the X position of marker 4 in trace points.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SUBCarrier[?]

Sets/queries the marker X subcarrier in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -2147483648 to 2147483647

Query Range: -2147483648 to 2147483647

*RST Setting: After a preset, all markers are set to Off, so Marker X Axis Subcarrier Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer10:X:SUBCarrier?

Queries the X subcarrier in trace points for marker 10.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SYMBol[?]

Sets/queries the marker X symbol in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -2147483648 to 2147483647

Query Range: -2147483648 to 2147483647

*RST Setting: After a preset, all markers are set to Off, so Marker X Axis Symbol Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer9:X:SYMBol 1

Sets X symbol in trace points to 1 for marker 9.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Queries the marker Y Axis value in the current marker Y Axis unit.

Query Range: -9.9E+37 to 9.9E+37

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer11:Y?

Queries the Y Axis value for marker 11 in the current marker Y Axis unit.

CALCulate:EVM:MS:PBASe[?]

Sets/queries the Uplink Permbase number for MS measurement. This parameter is needed to determine subcarrier allocation.

Setting Range: 0 to 69

Query Range: 0 to 69

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MS:PBASe 1

Sets the Uplink Permbase number for the MS measurement to 1.

CALCulate:EVM:PILot[?]

Sets/queries whether or not to include the Pilot in RCE calculations.

Setting Range: INCLude | EXCLude

Query Range: INCL | EXCL

*RST Setting: EXCLude

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot INCLude

Sets the Pilot to be included in RCE calculations.

CALCulate:EVM:PILot:TRACk:AMPLitude[?]

Sets/queries whether the analyzer tracks amplitude changes in the pilot subcarriers. When Track Amplitude is selected, the analyzer applies pilot subcarrier amplitude error correction to the pilot and data subcarriers. This is in addition to Track Phase and Track Timing error correction, if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:AMPLitude 1

Sets the analyzer to track amplitude changes in the pilot subcarriers.

CALCulate:EVM:PILot:TRACk:PHASe[?]

Sets/queries whether the analyzer tracks phase changes in the pilot subcarriers. When Track Phase is selected, the analyzer applies pilot subcarrier phase error correction to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Timing error correction if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:PHASe 0

Turns off phase change tracking in the pilot subcarriers.

CALCulate:EVM:PILot:TRACk:TIMing[?]

Sets/queries whether the analyzer tracks timing changes in the pilot subcarriers. Track Timing applies pilot subcarrier timing error correction (frequency offset correction) to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Phase error correction if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:TIMing?

Queries whether or not the analyzer is set to track timing changes in the pilot subcarriers.

CALCulate:EVM:PINDex[?]

Sets/queries the number that the Preamble Index specifies for the preamble sequence of the downlink subframe

Setting Range: 0 to 113

Query Range: 0 to 113

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PINDex 1

Sets the Preamble Index to 1.

CALCulate:EVM:SPECtrum[?]

Sets/queries a spectrum to either normal or to inverted for demodulation related measurements. If set to INVert, the upper and lower spectrums are swapped. The invert function conjugates the spectrum, which is equivalent to taking the negative of the quadrature component in demodulation. The correct setting (Normal or Invert) depends on whether the signal at the input of the instrument has a high or a low side mix.

Setting Range: INVert | NORMal

Query Range: INV | NORM

*RST Setting: NORMal

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SPECtrum INVert

Sets the spectrum to inverted for demodulation related measurements.

CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

Sets/queries the Measurement Interval to calculate the average power for each subcarrier.

Setting Range: PAMBle | ALL

Query Range: PAMB | ALL

*RST Setting: ALL

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SPECtrum:AMPFlatness:INTerval?

Queries the Measurement Interval used for calculating the average power for each subcarrier.

CALCulate:EVM:SUBChannel:MASK[?]

Sets/queries which subchannel groups are allocated to the segment. The DL PUSC zone definition provides 6 subchannel groups which specify the number of used subchannels and how they are mapped to subcarriers for analysis of DL-PUSC data bursts.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 1, 1, 1, 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SUBChannel:MASK 1, 1, 1, 1, 1, 1

Sets the subchannel groups allocated to the segment.

CALCulate:EVM:SWEep:OFFSet[?]

Sets/queries the timing offset of the capture interval in frames. If the Capture Interval is 1 frame, Meas Offset is fixed at "0". If Average is set to On, the frame that is analyzed does not take into account this offset value during averaging. After this measurement is complete, changing the offset value will result in running post-processing to analyze the offset frame; the measurement results are then updted.(only for non-averaged results).

Setting Range: 0 to Capture Interval - 1

Query Range: 0 to Capture Interval - 1

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SWEep:OFFSet?

Queries the timing offset of the capture interval in frames.

CALCulate:EVM:SYMBol:ADJust[?]

Sets/queries the adjustment of the "useful symbol time period" (TFFT) within the "OFDMA extended symbol time period" (TS). Symbol Timing Adjust shifts the start of the TFFT period to earlier in the TS time period. You specify the amount of TFFT shift as a percentage of the TFFT length.

Setting Range: -12.5% to - 0%

Query Range: -12.5% to - 0%

*RST Setting: -3.125%

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SYMBol:ADJust -3.100

Sets/queries the adjustment of the "useful symbol time period" (TFFT) to -3.100%.

CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

Sets/queries the Data Modulation Type to be used.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

Query Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

*RST Setting: QPSKR1BY2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:UZONe:MODulation:TYPE?

Queries the Data Modulation Type.

CALCulate:EVM:ZONE[?]

Sets/queries the zone definition to be used.

Setting Range: 1 to a value determined by current map

Query Range: 1 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE 1

Sets the zone definition to 1.

CALCulate:EVM:ZONE:INTerval[?]

Sets/queries the zone definition to be used.

Setting Range: 1 to a value determined by current map

Query Range: 1 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE:INTerval?

Queries the zone definition.

CALCulate:EVM:ZONE:OFFSet[?]

Sets/queries the Zone Offset in symbols.

Setting Range: 0 to a value determined by current map

Query Range: 0 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE:OFFSet?

Queries the Zone Offset.


CALCulate:PSTatistic (802.16 OFDMA)

CALCulate:PSTatistic

These commands provide data processing functions for Power Stat CCDF (PST) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:PSTatistic:MARKer:AOFF

  • CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:PSTatistic:NSELect[?]

  • CALCulate:PSTatistic:STORe:REFerence

CALCulate:PSTatistic:MARKer:AOFF

Turns off all markers.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:AOFF

Turns off all markers.

CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

Sets/queries marker coupling. When this function is invoked, moving any marker causes an "equal X Axis movement" of every other marker which is active. By "equal X Axis movement" we mean that the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) is preserved, as is the X Axis value of the marker being moved (in the same fundamental X-axis units). NOTE: This may result in markers going off screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:COUPle

Turns on marker coupling.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries a marker type for a given marker.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer2:MODE POSition

Sets marker 5 to position mode.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the reference marker that the selected marker will be relative to (that is, its reference marker).

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer12:REFerence 6

Sets the reference marker for marker 12 to marker 6.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is Off to On, or 1, puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer5:STATe?

Queries the state of marker 5.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Sets/queries the specified marker to the designated trace.

Setting Range: MEASured | GAUSsian | REFerence

Query Range: MEAS | GAUS | REF

*RST Setting: MEASured

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer3:TRACe GAUSsian

Sets marker 3 to the gaussian trace.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. This function has no effect if the control mode is Off, but is the remote command equivalent of entering an X value if the control mode is Normal or Delta. The value is set using relative amplitude.

Setting Range: 0.0 to 50.0

Query Range: 0.0 to 50.0

*RST Setting: After a preset, all Markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:X?

Queries the marker X Axis value in the current marker X Axis Scale unit.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points.

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all Markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:X:POSition?

Queries the marker X position in trace points.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Sets/queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer7:Y?

Queries the Y Axis value for marker 7.

CALCulate:PSTatistic:NSELect[?]

Sets/queries the selected marker.

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:NSELect 12

Selects marker 12.

CALCulate:PSTatistic:STORe:REFerence

Copies the currently measured curve as the user-definable reference trace. The captured data will remain until the other mode is chosen. Pressing this key also refreshes the reference trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:STORe:REFerence

Copies the currently measured curve as the user-definable reference trace.


CALCulate:SMASk (802.16 OFDMA)

CALCulate:SMASk

These commands provide data processing functions for Spectral Mask (SMAS) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:SMASk:LCOMpensatio[?]

  • CALCulate:SMASk:MDEFinition[?]

CALCulate:SMASk:LCOMpensatio[?]

Sets/queries loss or gain in the test fixture. A negative value compensates for a loss and a positive value compensates for a gain.

Setting Range: -999 dBm to 999 dBm

Query Range: -999 dBm to 999 dBm

*RST Setting: 0 dbm

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:SMASk:LCOMpensatio -20

Compensates for a 20 dBm loss.

CALCulate:SMASk:MDEFinition[?]

Allows you to define a custom mask. Spectral mask measurements detailing the percentage of failing points will be made relative to this mask. Mask definitions are relative to the centre frequency and must cover the range -30 MHz to +30 MHz

Setting Range: <mask points>: An array (comma delimited) of the offset frequency (from the center) and the absolute amplitude pairs to be connected to create the custom mask.

Query Range: Returns the current set of <mask points>

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:SMASk:MDEFinition -30e6,-20,30e6,-15

Produces a mask consisting of two points connected at -30 MHz, -20 dBm and +30 MHz, -15 dBm.


CALCulate:WAVeform (802.16 OFDMA)

CALCulate:WAVeform

These commands provide data processing functions for Waveform (WAV) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:WAVeform:MARKer:AOFF

  • CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12[:SET]:RLEVel

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

CALCulate:WAVeform:MARKer:AOFF

Turns off all markers.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer:AOFF

Turns off all markers.

CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

Toggles the state of the markers to be coupled On or Off. When this function is true (On), moving any marker causes an equal X axis movement of every other marker which is not Off. "Equal X axis movement" refers to the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) and the X Axis value of the marker being moved (in the same fundamental x-axis units) are preserved.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

Sets/queries the marker control function type to, Marker Noise, Band/Interval Power, Band Interval Density, or Marker Function Off.

Setting Range: BPOWer | BDENsity | OFF

Query Range: BPOWer | BDENsity | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

Sets/queries the left edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]

Sets/queries the right edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

Sets/queries the right edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult[?]

Queries the marker Y Axis value in the current marker Y Axis unit.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace and accesses a menu that enables you to select to do a minimum peak search.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

Moves the selected marker to the minimum y-axis value on the current trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries the marker control mode to Normal, Delta, Fixed or Off.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the marker that the selected marker will be relative to (that is, its reference marker).

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12[:SET]:RLEVel

Sets the reference level to the marker Y value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is OFF to state ON or 1 puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Sets/queries the specified marker to the designated trace.

Setting Range: RFENvelope | IQ

Query Range: RFENvelope | IQ

*RST Setting: RFEN

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. It has no effect if the control mode is Off, but is the SCPI equivalent of entering an X value if the control mode is Normal or Delta.

Setting Range: 9.9E+37 to 9.9E+37

Query Range: 9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SPAN[?]

Sets/queries the width of the frequency span for the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 10% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Queries the marker Y Axis value in the current marker Y Axis unit.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:


CONFigure Subsystem (802.16 OFDMA)

CONFigure Subsystem

Description

The CONFigure subsystem is used to perform high level configuration functions.

For details of the CONFigure commands, refer to the CONFigure topic in this section.


802.16 OFDMA (N6301A)

CONFigure (802.16 OFDMA)

Last Updated: March 28, 2008

These commands perform high level configuration functions.

  • CONFigure?

  • CONFigure:ACPower

  • CONFigure:ACPower:NDEFault

  • CONFigure:EVM

  • CONFigure:EVM:NDEFault

  • CONFigure:PSTatistic

  • CONFigure:PSTatistic:NDEFault

  • CONFigure:SMASk

  • CONFigure:SMASk:NDEFault

  • CONFigure:SEMask

  • CONFigure:SEMask:NDEFault

  • CONFigure:WAVeform

  • CONFigure:WAVeform:NDEFault

CONFigure?

Queries the name of the measurement that is currently running.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure?

Queries the name of the measurement that is currently running.

CONFigure:ACPower

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:ACPower

Restores all the measurement parameters to their default values.

CONFigure:ACPower:NDEFault

Stops the current measurement and changes to the Adjacent Channel Power measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:ACPower:NDEFault

Stops the current measurement and changes to the Adjacent Channel Power measurement.

CONFigure:EVM

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:EVM

Restores all the measurement parameters to their default values.

CONFigure:EVM:NDEFault

Stops the current measurement and changes to the EVM measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Setting Range:

Query Range:

*RST Setting:

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:EVM:NDEFault

Stops the current measurement and changes to the EVM measurement.

CONFigure:PSTatistic

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:PSTatistic

Restores all the measurement parameters to their default values.

CONFigure:PSTatistic:NDEFault

Stops the current measurement and changes to the Power Stat CCDF measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:PSTatistic:NDEFault

Stops the current measurement and changes to the Power Stat CCDF measurement.

CONFigure:SEMask

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:SEMask

Restores all the measurement parameters to their default values.

CONFigure:SEMask:NDEFault

Stops the current measurement and changes to the Spurious Emissions Mask measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:SEMask:NDEFault

Stops the current measurement and changes to the Spurious Emissions Mask measurement.

CONFigure:SMASk

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:SMASk

Restores all the measurement parameters to their default values.

CONFigure:SMASk:NDEFault

Stops the current measurement and changes to the Spectral Mask measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:SMASk:NDEFault

Stops the current measurement and changes to the Spectral Mask measurement.

CONFigure:WAVeform

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:WAVeform

Restores all the measurement parameters to their default values.

CONFigure:WAVeform:NDEFault

Stops the current measurement and changes to the Waveform measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:WAVeform:NDEFault

Stops the current measurement and changes to the Waveform measurement.


FETCh Subsystem (802.16 OFDMA)

FETCh? Subsystem

Description

The FETCh? query is a function that allows you to query results from a measurement that was previously INITiated. It does NOT begin a measurement. If no measurement is in progress it returns the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query hangs until the results are available, or the measurement fails or times out. The exact results returned by a FETCh? depends on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands, FETCh? is the primary way for you to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow you to send commands and not wait for completion.

For details of the FETCh? commands refer to the FETCh? subsystems in this section.

For details on commands that are used to perform data processing on measurement results, refer to the CALCulate Subsystem.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDMA (N6301A)

FETCh:ACPower?

This command returns results for the Adjacent Channel Power measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:ACPower{1:3}?

FETCh:ACPower{1:3}?

Queries the Adjacent Channel Power measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

FETCh:ACP3?

Returns 24 limit result values.


FETCh:EVM? (802.16 OFDMA)

802.16 OFDMA (N6301A)

FETCh:EVM?

Last Updated: March 28, 2008

This command returns results for the Modulation Analysis measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:EVM{0:21}?

FETCh:EVM{0:21}?

Queries the Modulation Analysis measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • Max Peak RMS RCE Subcarrier Number - an integer number at which the peak RCE is detected

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Averaged RMS RCE of Unmodulated subcarriers in % - a floating point number in %. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Max RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Max RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged RSSI- a floating point number in dBm.

  • Max RSSI - a floating point number in dBm

  • Standard Deviation of RSSI- a floating point number in dBm.

  • Averaged FFT Total Power - a floating point number in dBm.

  • Max FFT Total Power - a floating point number in dBm.

  • Standard Deviation of FFT Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • PRBS - an integer number

  • IDCell - an integer number

  • Segment - an integer number

  • Mean Transmit Power - a floating point number in dBm.

  • Nominal BW - a floating point number in Hz.

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • Averaged Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Averaged Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Standard Deviation of Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns 0.

  • Standard Deviation of Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble Physical CINR for Reuse type 1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary data for the active Data Burst. The shown Data Burst Number is designated by the parameter :CALCulate:EVM:INFormation:BURSt?. The array consists of following elements:

  • Burst Type(int)

  • 0 = Normal, 1 = FCH, 2 = DL-MAP

  • Data Modulation Format

  • 0 = QPSK-1/2

  • 1 = QPSK-3/4

  • 9 = QPSK-Unknown

  • 10 = 16QAM-1/2

  • 11 = 16QAM-3/4

  • 19 = 16QAM-Unknown

  • 20 = 64QAM-1/2

  • 21 = 64QAM-2/3

  • 22 = 64QAM-3/4

  • 29 = 64QAM-Unknown

  • Boosting Level in dB

  • Subchannel Offset

  • Subchannel Interval

  • Symbol Offset

  • Symbol Interval

  • Burst power in dBm

  • RCE of whole burst in dB

  • RCE of data portion in dB

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: IQ information:

    • Average IQ Quadrature Error

    • Peak IQ Quadrature Error

    • IQ Quadrature Error Stadndard Deviation

    • Average IQ Gain Imbalance

    • Peak IQ Gain Imbalance

    • IQ Gain Imbalance Standard Deviation

Note 1: if averaging is switched off or the average count is 1, then the average and peak values will be the same as each other and the standard deviations will be reported as -999.0

Note 2: Future releases may add further results to the end of this list. You should write your code in a way that can handle this.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

FETCh:EVM19?

Returns the FFT Spectrum trace results.


FETCh:PSTatistic? (802.16 OFDMA)

FETCh:PSTatistic?

Last Updated: March 11, 2008

This command returns results for the Power Stat CCDF measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:PSTatistic{0:4}?

FETCh:PSTatistic{0:4}?

Queries the Power Stat CCDF measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10. Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FETCh:PSTatistic?

Returns 10 scalar results.


802.16 OFDMA (N6301A)

FETCh:SEMask?

Last Updated: March 28, 2008

This command returns results for the Spectrum Emissions Mask measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:SEMask{1:12}?

FETCh:SEMask{1:12}?

Queries the Spectrum Emissions Mask measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dBc)

    • 12. Absolute integrated power on the negative offset A (dBm)

    • 13. Relative peak power on the negative offset A (dBc)

    • 14. Absolute peak power on the negative offset A (dBm)

    • 15. Peak power offset frequency from the center frequency in the negative offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dBc)

    • 17. Absolute integrated power on the positive offset A (dBm)

    • 18. Relative peak power on the positive offset A (dBc)

    • 19. Absolute peak power on the positive offset A (dBm)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dBc)

    • …

    • 69. Absolute peak power on the positive offset F (dBm)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Total power reference (dBm)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. –999.0

PSD Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dB).

    • 12. Absolute integrated power on the negative offset A (dBm/Hz).

    • 13. Relative peak power on the negative offset A (dB)

    • 14. Absolute peak power on the negative offset A (dBm/Hz)

    • 15. Peak power offset frequency from the center frequency in the negative

    • offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dB).

    • 17. Absolute integrated power on the positive offset A (dBm/Hz).

    • 18. Relative peak power on the positive offset A (dB)

    • 19. Absolute peak power on the positive offset A (dBm/Hz)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dB).

    • …

    • 69. Absolute peak power on the positive offset F (dBm/Hz)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Power spectral density reference (dBm/Hz)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. Returns the band power result (the peak power of the signal in the ref channel)


FETCh:SMASk? (802.16 OFDMA)

FETCh:SMASk?

Last Updated: March 11, 2008

This command returns results for the Spectral Mask measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:SMASk{0:3}?

FETCh:SMASk{0:3}?

Queries the Spectral Mask measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FETCh:SMASk1?

Returns the percentage of points failing the mask.


FETCh:WAVeform? (802.16 OFDMA)

FETCh:WAVeform?

Last Updated: March 11, 2008

This command returns results for the Waveform measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:WAVeform{0:2}?

FETCh:WAVeform{0:2}?

Queries the Waveform measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FETCh:WAVeform2?

Returns trace point values of the entire captured signal envelope trace data.


FORMat Subsystem (802.16 OFDMA)

FORMat Subsystem

Description

The FORMat subsystem is used to set a data format for transferring numeric and array information. This data format is used for both command and response data by those commands that are specifically designated to be affected by the FORMat subsystem.

For details of the FORMat commands, refer to the FORMat topic in this section.


FORMat (802.16 OFDMA)

FORMat

These commands set a data format for transferring numeric and array information.

  • FORMat[:TRACe][:DATA][?]

  • FORMat:BORDer[?]

FORMat[:TRACe][:DATA][?]

Sets/queries the format of the trace data input and output across any remote port.

Setting Range: ASCii | REAL,32 | REAL,64

Query Range: ASC | REAL,32 | REAL,64

*RST Setting: ASCii

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FORMat?

Queries the format of the trace data input and output across any remote port.

FORMat:BORDer[?]

Sets/queries the binary data byte order for data transfer and other queries. It controls whether binary data is transferred in normal or swapped mode.

Setting Range: NORMal | SWAPped

Query Range: NORM | SWAP

*RST Setting: NORMal

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FORMat:BORDer SWAPped

Sets the binary data byte order for data transfer and other queries to swapped.


INITiate Subsystem (802.16 OFDMA)

INITiate Subsystem

Last Updated: March 28, 2008

Description

The INITiate subsystem is used to:

  • Start (activate) measurements.

  • Turn measurements off.

For details of the INITiate commands refer to the INITiate topic in this section.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


INITiate (802.16 OFDMA)

802.16 OFDMA (N6301A)

INITiate

Last Updated: March 28, 2008

These commands allow you to start and stop measurements.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • INITiate:ACPower

  • INITiate:CONTinuous[?]

  • INITiate:CONTinuous:OPRiority[?]

  • INITiate:EVM

  • INITiate[:IMMediate]

  • INITiate:PAUSe

  • INITiate:PSTatistic

  • INITiate:RESTart

  • INITiate:RESume

  • INITiate:SEMask

  • INITiate:SMASk

  • INITiate:WAVeform

INITiate:ACPower

Initiates (starts) the Adjacent Channel Power measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:ACPower

Initiates (starts) the Adjacent Channel Power measurement.

INITiate:CONTinuous[?]

Sets the test set for Continuous measurement operation. The single/continuous state affects all measurements.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF (Note: SYST:PRESet sets INIT:CONT to ON)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:CONTinuous?

Queries the single/continuous state.

INITiate:CONTinuous:OPRiority[?]

Sets/queries the priority of the application process.

Setting Range: 1 to 5

Query Range: 1 to 5

*RST Setting: 2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:CONTinuous:OPRiority 3

Sets the priority of the application process to 3.

INITiate:EVM

Initiates (starts) the EVM measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:EVM

Initiates (starts) the EVM measurement.

INITiate[:IMMediate]

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

INITiate:PAUSe

Pauses a measurement after the current data acquisition is complete.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:PAUSe

Pauses a measurement after the current data acquisition is complete.

INITiate:PSTatistic

Initiates (starts) the Power Stat CCDF measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:PSTatistic

Initiates (starts) the Power Stat CCDF measurement.

INITiate:RESTart

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:RESTart

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

INITiate:RESume

Resumes the measurement from the point it was at when paused.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:RESume

Resumes the measurement from the point it was at when paused.

INITiate:SEMask

Initiates (starts) the Spurious Emissions Mask measurement.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:SEMask

Initiates (starts) the Spurious Emissions Mask measurement.

INITiate:SMASk

Initiates (starts) the Spectral Mask measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:SMASk

Initiates (starts) the Spectral Mask measurement.

INITiate:WAVeform

Initiates (starts) the Waveform measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:WAVeform

Initiates (starts) the Waveform measurement.


MEASure? Subsystem (802.16 OFDMA)

MEASure? Subsystem

Description

The MEASure? subsystem allows you to make measurements using the factory default test set settings.

For details of the MEASure? commands refer to the MEASure? subsystems in this section.

For details on commands that are used to perform data processing on measurement results, refer to the CALCulate Subsystem.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDMA (N6301A)

MEASure:ACPower?

Last Updated: March 28, 2008

This command allows you to make Adjacent Channel Power measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:ACPower{1:3}?

MEASure:ACPower{1:3}?

Make an Adjacent Channel Power measurement using the factory default settings.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

MEASure:ACP3?

Initiates an adjacent channel power measurement with default settings and returns 24 limit result values.


MEASure:EVM? (802.16 OFDMA)

MEASure:EVM?

Last Updated: March 28, 2008

This command allows you to make Modulation Analysis measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:EVM{0:21}?

MEASure:EVM{0:21}?

Makes an EVM measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data of Capture Interval, as a series of trace point values. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • Max Peak RMS RCE Subcarrier Number - an integer number at which the peak RCE is detected

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Averaged RMS RCE of Unmodulated subcarriers in % - a floating point number in %. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Max RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Max RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged RSSI- a floating point number in dBm.

  • Max RSSI - a floating point number in dBm

  • Standard Deviation of RSSI- a floating point number in dBm.

  • Averaged FFT Total Power - a floating point number in dBm.

  • Max FFT Total Power - a floating point number in dBm.

  • Standard Deviation of FFT Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • PRBS - an integer number

  • IDCell - an integer number

  • Segment - an integer number

  • Mean Transmit Power - a floating point number in dBm.

  • Nominal BW - a floating point number in Hz.

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • Averaged Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Averaged Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Standard Deviation of Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns 0.

  • Standard Deviation of Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble Physical CINR for Reuse type 1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary data for the active Data Burst. The shown Data Burst Number is designated by the parameter :CALCulate:EVM:INFormation:BURSt?. The array consists of following elements:

  • Burst Type(int)

  • 0 = Normal, 1 = FCH, 2 = DL-MAP

  • Data Modulation Format

  • 0 = QPSK-1/2

  • 1 = QPSK-3/4

  • 9 = QPSK-Unknown

  • 10 = 16QAM-1/2

  • 11 = 16QAM-3/4

  • 19 = 16QAM-Unknown

  • 20 = 64QAM-1/2

  • 21 = 64QAM-2/3

  • 22 = 64QAM-3/4

  • 29 = 64QAM-Unknown

  • Boosting Level in dB

  • Subchannel Offset

  • Subchannel Interval

  • Symbol Offset

  • Symbol Interval

  • Burst power in dBm

  • RCE of whole burst in dB

  • RCE of data portion in dB

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: IQ information:

    • Average IQ Quadrature Error

    • Peak IQ Quadrature Error

    • IQ Quadrature Error Stadndard Deviation

    • Average IQ Gain Imbalance

    • Peak IQ Gain Imbalance

    • IQ Gain Imbalance Standard Deviation

Note 1: if averaging is switched off or the average count is 1, then the average and peak values will be the same as each other and the standard deviations will be reported as -999.0

Note 2: Future releases may add further results to the end of this list. You should write your code in a way that can handle this.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

MEASure:EVM18?

Returns the Demod Bit trace.


MEASure:PSTatistic? (802.16 OFDMA)

MEASure:PSTatistic?

Last Updated: March 11, 2008

This command allows you to make Power Stat CCDF measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:PSTatistic{0:4}?

MEASure:PSTatistic{0:4}?

Makes a Power Stat CCDF measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10.Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MEASure:PSTatistic0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


802.16 OFDMA (N6301A)

MEASure:SEMask?

Last Updated: March 28, 2008

This command returns results for the Spectrum Emissions Mask measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:SEMask{1:12}?

MEASure:SEMask{1:12}?

Make a Spectrum Emissions Mask measurement using the factory default settings.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dBc)

    • 12. Absolute integrated power on the negative offset A (dBm)

    • 13. Relative peak power on the negative offset A (dBc)

    • 14. Absolute peak power on the negative offset A (dBm)

    • 15. Peak power offset frequency from the center frequency in the negative offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dBc)

    • 17. Absolute integrated power on the positive offset A (dBm)

    • 18. Relative peak power on the positive offset A (dBc)

    • 19. Absolute peak power on the positive offset A (dBm)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dBc)

    • …

    • 69. Absolute peak power on the positive offset F (dBm)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Total power reference (dBm)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. –999.0

PSD Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dB).

    • 12. Absolute integrated power on the negative offset A (dBm/Hz).

    • 13. Relative peak power on the negative offset A (dB)

    • 14. Absolute peak power on the negative offset A (dBm/Hz)

    • 15. Peak power offset frequency from the center frequency in the negative

    • offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dB).

    • 17. Absolute integrated power on the positive offset A (dBm/Hz).

    • 18. Relative peak power on the positive offset A (dB)

    • 19. Absolute peak power on the positive offset A (dBm/Hz)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dB).

    • …

    • 69. Absolute peak power on the positive offset F (dBm/Hz)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Power spectral density reference (dBm/Hz)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. Returns the band power result (the peak power of the signal in the ref channel)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

MEASure:SEM1?

Returns 82 results.


MEASure:SMASk? (802.16 OFDMA)

MEASure:SMASk?

Last Updated: March 11, 2008

This command allows you to make Spectral Mask measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:SMASk{0:3}?

MEASure:SMASk{0:3}?

Makes a Spectral Mask measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MEASure:SMASk?

Returns the percentage of points failing the mask.


MEASure:WAVeform (802.16 OFDMA)

MEASure:WAVeform

This command allows you to make Waveform measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:WAVeform{0:2}?

MEASure:WAVeform{0:2}?

Makes a Waveform measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

MEASure:WAVeform0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


READ? Subsystem (802.16 OFDMA)

READ? Subsystem

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.

  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .

  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.

  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDMA (N6301A)

READ:ACPower?

This command makes Adjacent Channel Power measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:ACPower{1:3}?

READ:ACPower{1:3}?

Queries the Adjacent Channel Power measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

READ:ACP3?

Initiates an adjacent channel power measurement and returns 24 limit result values.


READ:EVM? (802.16 OFDMA)

READ:EVM?

Last Updated: March 28, 2008

This command makes Modulation Analysis measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:EVM{0:21}?

READ:EVM{0:21}?

Provides a sequential method to make EVM measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data of Capture Interval, as a series of trace point values. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • Max Peak RMS RCE Subcarrier Number - an integer number at which the peak RCE is detected

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Averaged RMS RCE of Unmodulated subcarriers in % - a floating point number in %. This measurement is based on the requirement of IEEE Std 802.16 2004-Cor1, section 8.4.12.3.4.

  • Max RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Max RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in dB - a floating point number in dB.

  • Standard Deviation of RMS RCE of Unmodulated subcarriers in % - a floating point number in %.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged RSSI- a floating point number in dBm.

  • Max RSSI - a floating point number in dBm

  • Standard Deviation of RSSI- a floating point number in dBm.

  • Averaged FFT Total Power - a floating point number in dBm.

  • Max FFT Total Power - a floating point number in dBm.

  • Standard Deviation of FFT Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • PRBS - an integer number

  • IDCell - an integer number

  • Segment - an integer number

  • Mean Transmit Power - a floating point number in dBm.

  • Nominal BW - a floating point number in Hz.

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • Averaged Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Averaged Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, returns 999.0.

  • Max Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, returns 999.0.

  • Standard Deviation of Preamble RCE (EVM) in dB - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns 0.

  • Standard Deviation of Preamble RCE (EVM) in % - a floating point number in percentage. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble Physical CINR for Reuse type 1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for R1 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • Averaged Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Max Preamble PCINR for R3 - a floating point number in dB. If Radio Device is MS, returns -999.0.

  • Standard Deviation of Preamble PCINR for Reuse type 3 - a floating point number in dB. If Radio Device is MS, Average State is OFF, or Average Number is 1, returns -999.0.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary data for the active Data Burst. The shown Data Burst Number is designated by the parameter :CALCulate:EVM:INFormation:BURSt?. The array consists of following elements:

  • Burst Type(int)

  • 0 = Normal, 1 = FCH, 2 = DL-MAP

  • Data Modulation Format

  • 0 = QPSK-1/2

  • 1 = QPSK-3/4

  • 9 = QPSK-Unknown

  • 10 = 16QAM-1/2

  • 11 = 16QAM-3/4

  • 19 = 16QAM-Unknown

  • 20 = 64QAM-1/2

  • 21 = 64QAM-2/3

  • 22 = 64QAM-3/4

  • 29 = 64QAM-Unknown

  • Boosting Level in dB

  • Subchannel Offset

  • Subchannel Interval

  • Symbol Offset

  • Symbol Interval

  • Burst power in dBm

  • RCE of whole burst in dB

  • RCE of data portion in dB

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: IQ information:

    • Average IQ Quadrature Error

    • Peak IQ Quadrature Error

    • IQ Quadrature Error Stadndard Deviation

    • Average IQ Gain Imbalance

    • Peak IQ Gain Imbalance

    • IQ Gain Imbalance Standard Deviation

Note 1: if averaging is switched off or the average count is 1, then the average and peak values will be the same as each other and the standard deviations will be reported as -999.0

Note 2: Future releases may add further results to the end of this list. You should write your code in a way that can handle this.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:EVM19?

Returns the FFT Spectrum trace results.


READ:PSTatistic? (802.16 OFDMA)

READ:PSTatistic?

Last Updated: March 11, 2008

This command makes Power Stat CCDF measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:PSTatistic{0:4}?

READ:PSTatistic{0:4}?

Provides a sequential method to make Power Stat CCDF measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10. Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:PSTatistic4?

Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace.


802.16 OFDMA (N6301A)

READ:SEMask?

This command makes Spectrum Emissions Mask measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:SEMask{1:12}?

MEASure:SEMask{1:12}?

Make a Spectrum Emissions Mask measurement using the factory default settings.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dBc)

    • 12. Absolute integrated power on the negative offset A (dBm)

    • 13. Relative peak power on the negative offset A (dBc)

    • 14. Absolute peak power on the negative offset A (dBm)

    • 15. Peak power offset frequency from the center frequency in the negative offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dBc)

    • 17. Absolute integrated power on the positive offset A (dBm)

    • 18. Relative peak power on the positive offset A (dBc)

    • 19. Absolute peak power on the positive offset A (dBm)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dBc)

    • …

    • 69. Absolute peak power on the positive offset F (dBm)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Total power reference (dBm)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. –999.0

PSD Reference Mode

  • 1 (or not specified). 82 comma-separated results, in the following order:

    • 1. Reserved for the future use, returns –999.0

    • 2. Absolute power at the center frequency (reference) area (dBm)

    • 3. Reserved for the future use, returns –999.0

    • 4. Reserved for the future use, returns –999.0

    • 5. Peak frequency in the center frequency (reference) area (Hz)

    • 6. Reserved for the future use, returns –999.0

    • 7. Reserved for the future use, returns –999.0

    • 8. Reserved for the future use, returns –999.0

    • 9. Reserved for the future use, returns –999.0

    • 10. Reserved for the future use, returns –999.0

    • 11. Relative integrated power on the negative offset A (dB).

    • 12. Absolute integrated power on the negative offset A (dBm/Hz).

    • 13. Relative peak power on the negative offset A (dB)

    • 14. Absolute peak power on the negative offset A (dBm/Hz)

    • 15. Peak power offset frequency from the center frequency in the negative

    • offset A (Hz)

    • 16. Relative integrated power on the positive offset A (dB).

    • 17. Absolute integrated power on the positive offset A (dBm/Hz).

    • 18. Relative peak power on the positive offset A (dB)

    • 19. Absolute peak power on the positive offset A (dBm/Hz)

    • 20. Peak power offset frequency from the center frequency in the positive

    • offset A (Hz)

    • 21. Relative integrated power on the negative offset B (dB).

    • …

    • 69. Absolute peak power on the positive offset F (dBm/Hz)

    • 70. Peak power offset frequency from the center frequency in the positive offset F (Hz)

    • 71. Minimum margin from limit line on the negative offset A (dB)

    • 72. Minimum margin from limit line on the positive offset A (dB)

    • 73. Minimum margin from limit line on the negative offset B (dB)

    • 74. Minimum margin from limit line on the positive offset B (dB)

    • 75. Minimum margin from limit line on the negative offset C (dB)

    • 76. Minimum margin from limit line on the positive offset C (dB)

    • 77. Minimum margin from limit line on the negative offset D (dB)

    • 78. Minimum margin from limit line on the positive offset D (dB)

    • 79. Minimum margin from limit line on the negative offset E (dB)

    • 80. Minimum margin from limit line on the positive offset E (dB)

    • 81. Minimum margin from limit line on the negative offset F (dB)

    • 82. Minimum margin from limit line on the positive offset F (dB)

  • 2. Returns the displayed frequency domain spectrum trace data.

  • 3. Returns the displayed frequency domain absolute limit trace data

  • 4. Returns the displayed frequency domain relative limit trace data

  • 5. Returns 14 comma-separated scalar values (in dBm) of the absolute integrated power of the segment frequencies:

    • 1. Power spectral density reference (dBm/Hz)

    • 2. Reserved for the future use, returns –999.0

    • 3. Absolute integrated power at negative offset frequency (A)

    • 4. Absolute integrated power at positive offset frequency (A)

    • …

    • 13. Absolute integrated power at negative offset frequency (F)

    • 14. Absolute integrated power at positive offset frequency (F)

  • 6. Returns 14 comma-separated scalar values (in dBc) of the integrated power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Relative integrated power at negative offset frequency (A)

    • 4. Relative integrated power at positive offset frequency (A)

    • …

    • 13. Relative integrated power at negative offset frequency (F)

    • 14. Relative integrated power at positive offset frequency (F)

  • 7. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 8. Returns 14 comma-separated pass/fail test results (0=passed, or 1=failed) determined by testing the minimum margin point from the limit line that is determined each offset's Limits setting.

Note: This results (N=8) are the same as N=7 result.

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 9. Returns 14 comma-separated scalar values of frequency (in Hz) that have peak power in each offset:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. Negative offset frequency (A)

    • 4. Positive offset frequency (A)

    • …

    • 13. Negative offset frequency (F)

    • 14. Positive offset frequency (F)

  • 10. Returns 14 comma-separated scalar values (in dBm) of the absolute peak power of the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 11. Returns 14 comma-separated scalar values in dBc of the peak power relative to the carrier at the segment frequencies:

    • 1. Reserved for the future use, returns –999.0

    • 2. Reserved for the future use, returns –999.0

    • 3. At negative offset frequency (A)

    • 4. At positive offset frequency (A)

    • …

    • 13. At negative offset frequency (F)

    • 14. At positive offset frequency (F)

  • 12. Returns the band power result (the peak power of the signal in the ref channel)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

READ:SEM1?

Returns 82 results.


READ:SMASk? (802.16 OFDMA)

READ:SMASk?

Last Updated: March 11, 2008

This command makes Spectral Mask measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:SMASk{0:3}?

READ:SMASk{0:3}?

Provides a sequential method to make Spectral Mask measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:SMASk?

Returns the percentage of points failing the mask.


READ:WAVeform? (802.16 OFDMA)

READ:WAVeform?

Last Updated: March 11, 2008

This command makes Waveform measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:WAVeform{0:2}?

READ:WAVeform{0:2}?

Provides a sequential method to make Waveform measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:WAVeform0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


[:SENSe] Subsystem (802.16 OFDMA)

[:SENSe] Subsystem

Description

The [:SENSe] setup commands are divided into several sections. Each section or subsystem deals with controls that directly affect device-specific settings of the device and not those related to the signal-oriented characteristics.

For details of the [:SENSe] commands refer to the [:SENSe] subsystems in this section.


SENSe:ACPower?

802.16 OFDMA (N6301A)

[:SENSe]:ACPower

Last Updated: March 28, 2008

These commands control the operation of the Adjacent Channel Power measurement

  • [:SENSe]:ACPower:AVERage:COUNt

  • [:SENSe]:ACPower:AVERage[:STATe]

  • [:SENSe]:ACPower:AVERage:TCONtrol

  • [:SENSe]:ACPower:BANDwidth:INTegration[1]|2

  • [:SENSe]:ACPower:BANDwidth[:RESolution]

  • [:SENSe]:ACPower:BWIDth:INTegration[1]|2

  • [:SENSe]:ACPower:BWIDth[:RESolution]

  • [:SENSe]:ACPower:CARRier[1]|2:AUTO[:STATe]

  • [:SENSe]:ACPower:CARRier[1]|2:COUNt

  • [:SENSe]:ACPower:CARRier[1]|2:CPSD

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BANDwidth[:INTegration]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BWIDth[:INTegration]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:COUPle

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:FILTer:ALPHa

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:METHod

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:PPResent

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:WIDTh

  • [:SENSe]:ACPower:CARRier{1:2}[:POWer]

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier:AUTO

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency:AUTO

  • [:SENSe]:ACPower:FILTer[:RRC]:ALPHa

  • [:SENSe]:ACPower:FILTer[:RRC][:STATe]

  • [:SENSe]:ACPower:FREQuency:SPAN

  • [:SENSe]:ACPower:FREQuency:SPAN:FULL/nquery/

  • [:SENSe]:ACPower:FREQuency:SPAN:PREVious/nquery/

  • [:SENSe]:ACPower:LIMit[:STATe]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:ABSolute

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BANDwidth[:INTegration]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BWIDth[:INTegration]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST[:FREQuency]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RCARrier

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RPSDensity

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:STATe

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:TEST

  • [:SENSe]:ACPower:SWEep:BANDwidth[:RESolution]

  • [:SENSe]:ACPower:SWEep:BWIDth[:RESolution]

  • [:SENSe]:ACPower:SWEep:TIME

  • [:SENSe]:ACPower:TRIGger:SOURce

  • [:SENSe]:ACPower:TYPE

  • [:SENSe]:ACPower:WTYPe

[:SENSe]:ACPower:AVERage:COUNt[?]

Sets/queries the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Setting Range: 1 to 10000

Query Range: 1 to 10000

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage:COUNt 100

Sets the number of data acquisitions that will be averaged to 100.

[:SENSe]:ACPower:AVERage[:STATe][?]

Sets/queries the averaging state for the Adjacent Channel Power measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage ON

Turns on averaging for the ACP measurement.

[:SENSe]:ACPower:AVERage:TCONtrol[?]

Sets/queries the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: REPeat

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage:TCONtrol EXPonential

Sets termination control to exponential for the averaging function.

[:SENSe]:ACPower:BANDwidth|BWIDth:INTegration[1]|2[?]

Sets/queries the bandwidth of the "main" signal, that is the integration bandwidth used for the channel power.

INTegration1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 10kHz to 60MHz

Query Range: 10kHz to 60MHz

*RST setting: 10MHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:BWIDwidth:INTegration 12.0 MHz

Sets the integration bandwidth for the central signal to be 12MHz

[:SENSe]:ACPower:BANDwidth|BWIDth[:RESolution][?]

Sets/queries the resolution bandwidth used for the measurement.

Note that because of an FFT size change, this measurement can be made significantly faster than the default settings by using a resolution bandwidth of 110kHz.

Setting Range: 10kHz to 8MHz

Query Range: 10kHz to 8MHz

*RST setting: 100kHz

Example:

ACPower:BANDwidth:RESolution?

Queries the resolution bandwidth used for the measurement.

[:SENSe]:ACPower:CARRier[1]|2:AUTO[:STATe][?]

Sets/queries the multi-carrier power reference mode.

When set to Auto, the carrier power result reflects the measured power value in the selected reference carrier.

When set to Man, the result is referenced to the last measured value, or you may specify the reference for the multi-carrier power measurement. Relative values are displayed, referenced to the “Power Reference” value

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST setting: 1

Example:

ACPower:CARRier2:AUTO on

Sets the carrier power reference for uplink bursts to the measurement power in the selected reference carrier.

[:SENSe]:ACPower:CARRier[1]|2:COUNt[?]

Sets/queries the number of carriers to be measured.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 1 to 12

Query Range: 1 to 12

*RST setting: 1

Example:

ACPower:CARRier2:COUNt?

Queries the number of uplink carriers being measured.

[:SENSe]:ACPower:CARRier[1]|2:CPSD[?]

Sets/queries the power spectral density in the carrier (main channel) that is used to compute the relative power spectral density values for the offsets when Meas Type is set to PSD Ref.

When the PSD Ref state is set to Auto, this will be set to the measured carrier power spectral density.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -999dBm to 999dBm

Query Range: -999dBm to 999dBm

*RST setting: 0dBm

Example:

ACPower:CARRier2:CPSD 25dBm

Sets the carrier PSD to 25dBm

[:SENSe]:ACPower:CARRier[1]|2:LIST:BANDwidth|BWIDth[:INTegration][?]

Sets/queries the Measurement Noise Bandwidth used to calculate the power in the carriers.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 10kHz to 60MHz (per carrier)

Query Range: 10kHz to 60MHz (per carrier)

*RST Setting: 10MHz

Example:

SENSe:ACPower:CARRier2:LIST:BANDwidth 10MHz

Sets the bandwidth for a single carrier to 10MHz

[:SENSe]:ACPower:CARRier[1]|2:LIST:COUPle[?]

Sets/queries the carrier coupling settings state. If set to "on", couples carrier settings to carrier #1. The coupled parameters are Carrier Power Preset, Carrier Spacing, Measurement Noise Bandwidth, Method and Filter Alpha

When a setting is changed, the couple is set to Man automatically.

Carrier #1 is always set to couple and cannot be changed.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST setting: 1

Example:

SENSe:ACPower:CARRier2:LIST:COUPle?

Queries the carrier coupling settings state for uplink analysis

[:SENSe]:ACPower:CARRier[1]|2:LIST:FILTer:ALPHa[?]

Sets/queries the alpha value for the filter used in the current carrier configuration

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0.01 to 1.00

Query Range: 0.01 to 1.00

*RST setting: 0.22

Example:

SENSe:ACPower:CARRier2:LIST:FILTer:ALPHa 0.5

Sets the RRC filter's alpha value to 0.5

[:SENSe]:ACPower:CARRier[1]|2:LIST:METHod[?]

Sets/queries the carrier configuration method settings.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: IBW | RRC

Query Range: IBW | RRC

*RST setting: IBW

Example:

SENSe:ACPower:CARRier:LIST:METHod?

Queries the carrier configuration method settings for the base station measurement

[:SENSe]:ACPower:CARRier[1]|2:LIST:PPResent[?]

Configures the carriers for this measurement, or queries their configuration. It allows spaces to be inserted between carriers. Carriers with the power present parameter set to Yes are carriers, and those with the power present parameter set to No are spaces. Each carrier power present is set to Yes or No. The individual carriers can be set by selecting the desired carrier on the carrier menu key using the up down arrows, the knob, or numeric keypad, then toggling the carrier power present using the carrier power present menu key.

The query for this parameter returns the current values for all of the carriers. If a carrier is defined as having no power present, the power displayed will be relative to the reference carrier, otherwise the absolute power will be displayed.

If you change the carrier power present to no and that carrier is currently configured as the reference carrier, the next carrier to the left (or the right if there are no carriers to the left) will be assigned as the reference carrier. This also applies to the scenario where there are only two carriers configured as having power present and you configure only one carrier to have no power present.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: YES | NO

Query Range: YES | NO

*RST Setting: YES

Example:

SENSe:ACPower:CARRier2:LIST:PPResent?

Queries the carrier configuration for the uplink signal

[:SENSe]:ACPower:CARRier[1]|2:LIST:WIDTh[?]

Sets/queries the width of the carrier spacing. This will be the value applied to all the current slots, whether they are carriers or spaces.

Enter each carrier spacing value individually by selecting the desired carrier on the carrier menu key using the up down arrows, knob or numeric keypad, then enter the carrier width using the carrier spacing menu key.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 to 45MHz

Query Range: 0 to 45MHz

*RST Setting: 5MHz

Example:

SENSe:ACPower:CRRier:LIST:WIDTh 20MHz

Sets the carrier spacing width width to 20MHz

[:SENSe]:ACPower:CARRier[1]|2[:POWer][?]

Sets/queries the multi-carrier power reference value. This value is coupled to the value of the auto state.

When set to Auto, the carrier power result reflects the measured power value in the selected reference carrier.

When set to Man, the result is referenced to the last measured value, or you may specify the reference for the multi-carrier power measurement. Relative values are displayed, referenced to the "Power Reference" value.

This setting is only used when only when the Meas Type is TPRef.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -200dBm to 200dBm

Query Range: -200dBm to 200dBm

*RST Setting: 0dBm

Example:

SENSe:ACPower:CARRier2:POWer -20dBm

Sets the uplink reference value to -20dBm

[:SENSe]:ACPower:CARRier[1]|2:RCARrier[?]

Sets/queries the reference carrier. Relative power measurements are made from the reference carrier. Only has any effect if the reference carrier auto state is set to off.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 1 to number of available carriers

Query Range: 1 to number of available carriers

*RST Setting: 1

Example:

SENSe:ACPower:CARRier:RCARrier 5

Set the reference carrier for downlink measurements to carrier 5

[:SENSe]:ACPower:CARRier[1]|2:RCARrier:AUTO[?]

Sets/queries the reference carrier auto state.

If set to "on", the measurement selects the carrier with the highest power as the reference carrier and the Reference Carrier result is updated. If a value is entered when Reference Carrier auto state is set to "on", the reference carrier auto state is set to "off".

If set to "off", the value that you enter for the Reference Carrier is used as the reference carrier.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 1

Example:

SENSe:ACPower:CARRier2:AUTO 1

Switches on automatic detection of the reference carrier for uplink measurements

[:SENSe]:ACPower:CARRier[1]|2:RCFRequency[?]

Sets/queries the reference carrier frequency.

Changing the value of this setting only has any effect if the reference frequency auto state is set to "off".

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 2.15GHz to 3.8GHz

Query Range: 2.15GHz to 3.8GHz

Example:

SENSe:ACPower:CARRier:RCFRequency?

Queries the reference carrier frequency for a downlink measurement

[:SENSe]:ACPower:CARRier[1]|2:RCFRequency:AUTO[?]

Sets/queries the reference frequency auto state.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

If this setting is "on", the Reference Carrier Frequency is set thus:

Ref Freq1 = Instrument Center Frequency - (Total of all Carrier Widths / 2)

Ref Freq2 = Ref Freq1 + (Total of all Carrier Widths up to Ref Carrier)

Ref Freq = Ref Freq2 + (0.5 * Carrier Width of Ref Carrier)

If this setting is set to "off" and the reference carrier frequency changes the reference frequency is calculated using the following three steps;

Ctr Freq1 = Ref Freq - (0.5 * Carrier Width of Ref Carrier)

Ctr Freq2 = Ctr Freq1 - (Total of all Carrier Widths up to Ref Carrier)

Ctr Freq = Ctr Freq2 + (Total of all Carrier Widths / 2)

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 1

Example:

SENSe:ACPower:CARRier2:RCFRequency:AUTO 0

Switches off automatic reference frequency calculation for an uplink measurement

[:SENSe]:ACPower:FILTer[:RRC]:ALPHa[?]

Sets/queries the alpha value for the RRC filter

Setting Range: 0.01 to 1.00

Query Range: 0.01 to 1.00

*RST Setting: 0.22

Example:

SENSe:ACPower:FILTer:RRC:ALPHa 0.5

Sets the alpha value for the RRC filter to 0.5

[:SENSe]:ACPower:FILTer[:RRC][:STATe][?]

Sets/queries whether to use RRC filtering of the carriers and all adjacent channels. The alpha value (roll off) for the filter will be set to the value of the Filter Alpha parameter

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 0

Example:

SENSe:ACPower:FILTer:RRC:STATE?

Queries whether filtering is being used.

[:SENSe]:ACPower:FREQuency:SPAN[?]

Sets/queries the frequency span of the adjacent channel power measurement

Setting Range: 50MHz to 120MHz

Query Range: 50MHz to 120MHz

*RST Setting: 60MHz

Example:

SENSe:ACPower:FREQuency:SPAN 50e6

Sets the frequency span to 50MHz

[:SENSe]:ACPower:FREQuency:SPAN:FULL

Sets the frequency span to its maximum value.

Example:

SENSe:ACPower:FREQuency:SPAN:FULL

Sets the frequency span to its maximum value.

[:SENSe]:ACPower:FREQuency:SPAN:PREVious

Sets the span to the previous span setting. If no previous span value exists, then the span will remain unchanged.

Example:

[:SENSe]:ACPower:FREQuency:SPAN:PREVious

Sets the span to the previous span setting

[:SENSe]:ACPower:LIMit[:STATe][?]

Sets or queries whether limits checking is performed on the carriers

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 0

Example:

SENSe:ACPower:LIMit:STATe 1

Switches limit checking on

[:SENSe]:ACPower:OFFSet[1]|2:LIST:ABSolute[?]

Sets or queries the limits used for the measurement. There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -200dBm to 50dBm per offset

Query Range: -200dBm to 50dBm per offset

*RST Setting: 50, 50, 50, 50, 50, 50

Example:

SENSe:ACPower:OFFSet1:LIST:ABSolute?

Queries the list of power limits. Returns six values.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:BANDwidth|BWIDth[:INTegration][?]

Sets or queries the integration bandwidths for the offsets used in the measurement. There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 10kHz to 60Mhz per offset

Query Range: 10kHz to 60Mhz per offset

*RST Setting: 10MHz,10MHz,10MHz,10MHz,10MHz,10MHz

Example:

SENSe:ACPower:OFFSet1:LIST:BANDwidth:INTegration 10e6,10e6,10e6,10e6,10e6,10e6

Sets all six offsets to 10MHz integration bandwidths

[:SENSe]:ACPower:OFFSet[1]|2:LIST[:FREQuency][?]

Sets or queries the frequency difference between the center of the main channel and the center of the carrier. Setting the frequency offset to zero has the same effect as switching the offset off.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 to 50MHz per offset

Query Range: 0 to 50Mhz per offset

*RST Setting: 10MHz,20MHz,0,0,0,0

Example:

SENSe:ACPower:OFFSet1:LIST:FREQuency?

Queries the offset frequencies. Returns six values.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:RCARrier[?]

Sets or queries the offset power limits expressed relative to the carrier power.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -150 to 50 dB per offset

Query Range: -150 to 50 dB per offset

*RST Setting: -50,-60,0,0,0,0

Example:

SENSe:ACPower:OFFSet1:LIST:RCARrier -40,-50,0,0,0,0

Sets the limits to -40 and -50 dB relative to the center carrier power.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:RPSDensity[?]

Sets or queries the offset power limits expressed as power spectral density, relative to the centre carrier's PSD.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -150 to 50 dB per offset

Query Range: -150 to 50 dB per offset

*RST Setting: -25,-35,0,0,0,0

Example:

SENSe:ACPower:OFFSET2:LIST:RPSDensity?

Queries the current power limits on the uplink. Returns six results

[:SENSe]:ACPower:OFFSet[1]|2:LIST:STATe[?]

Turns limit checking for each offset On or Off, or queries whether limits testing is being performed.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: OFF | 0 | ON | 1 (for each offset)

Query Range: 0 | 1 (for each offset)

*RST Setting: 1,1,0,0,0,0

Example:

Switch limits checking on for offsets 1, 2 and 3

SENSe:ACPower:OFFSet:LIST:STATe 1,1,1,0,0,0

[:SENSe]:ACPower:OFFSet[1]|2:LIST:TEST[?]

Sets or queries the method used to test whether a signal is within allowed limits.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Each offset is set to one of the following values:

  • Absolute - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit.

  • Relative - Fail is shown if one of the relative ACP measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

  • AND - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit AND one of the relative ACPR measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

  • OR - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit OR one of the relative ACP measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

Setting Range: ABSolute | RELative | AND | OR

Query Range: ABSolute | RELative | AND | OR

*RST Setting: RELative,RELative,RELative,RELative,RELative,RELative

Example:

SENSe:ACPower:OFFSet2:LIST:TEST?

Queries the test methods used for testing the uplink signal. Returns six values.

[:SENSe]:ACPower:SWEep:BANDwidth|BWIDth[:RESolution][?]

Sets or queries the resolution bandwidth used for the measurement.

Setting Range: 10kHz to 8MHz

Query Range: 10kHz to 8MHz

*RST Setting: 100kHz

Example:

SENSe:ACPower:SWEep:BWIDth 110kHz

Sets the resolution bandwidth 10 110kHz

[:SENSe]:ACPower:SWEep:TIME[?]

Sets or queries the acquisition length used for the measurement.

Setting Range: 1us to 5ms

Query Range: 1us to 5ms

*RST Setting: 1ms

Example:

SENSe:ACPower:SWEep:TIME 3ms

Sets the acquisition duration to 3ms

[:SENSe]:ACPower:TRIGger:SOURce[?]

Sets/queries the trigger source for the Adjacent Channel Power measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SENSe:ACPower:TRIGger:SOURce EXTernal

Sets the trigger source to External for the ACP measurement.

[:SENSe]:ACPower:TYPE[?]

Sets or queries the reference used for the measurement. Total Pwr Ref (TPR) sets the reference to the total carrier power. PSD Ref (PSDR) sets the reference to the power spectral density of the carrier.

Setting Range: TPR | PSDR

Query Range: TPR | PSDR

*RST Setting: TPR

Example:

SENSe:ACPower:TYPE PSDR

Sets the reference type to PSD.

[:SENSe]:ACPower:WTYPe[?]

Sets or queries the FFT window type used in the measurement.

Setting Range: GAUSsian | HANNing | FLATtop | UNIForm

Query Range: GAUS | HANN | FLAT | UNIF

*RST Setting: GAUS

Example:

SENSe:ACPower:WTYPe?

Queries the FFT window type used for the measurement


[:SENSe]:EVM (802.16 OFDMA)

[:SENSe]:EVM

These commands control averaging, capturing and triggering settings for the Modulation Analysis measurement.

  • [:SENSe]:EVM:AVERage:COUNt[?]

  • [:SENSe]:EVM:AVERage[:STATe][?]

  • [:SENSe]:EVM:AVERage:TCONtrol[?]

  • [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

  • [:SENSe]:EVM:TRIGger:SOURce[?]

[:SENSe]:EVM:AVERage:COUNt[?]

Sets/queries the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Setting Range: 1 to 10000

Query Range: 1 to 10000

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

EVM:AVERage:COUNt 100

Sets the number of data acquisitions that will be averaged to 100.

[:SENSe]:EVM:AVERage[:STATe][?]

Sets/queries the averaging state for the EVM measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

EVM:AVERage ON

Turns on averaging for the EVM measurement.

[:SENSe]:EVM:AVERage:TCONtrol[?]

Sets/queries the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: REPeat

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

EVM:AVERage:TCONtrol EXPonential

Sets termination control to exponential for the averaging function.

[:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

Sets/queries the data capture length in frames that will be used in the acquisition. If Average is set to On, all capture data are analyzed and their results are averaged until the average number count is reached.

Setting Range: 1

Query Range: 1

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

EVM:CAPTure:TIME?

Queries the data capture length in frames that will be used in the acquisition.

[:SENSe]:EVM:TRIGger:SOURce[?]

Sets/queries the trigger source for the EVM measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

EVM:TRIGger:SOURce RFBurst

Sets the trigger source for the EVM measurement to RF Burst.


[:SENSe]:FREQuency (802.16 OFDMA)

[:SENSe]:FREQuency

  • [:SENSe]:FREQuency:CENTer[?]

[:SENSe]:FREQuency:CENTer[?]

Sets/queries the center frequency of the spectrum analyzer.

Setting Range: 2.15 GHz to 3.8 GHz

Query Range: 2.15 GHz to 3.8 GHz

*RST Setting: 2.42 GHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FREQuency:CENTer 2.80GHz

Sets the center frequency to 2.8 GHz.


[:SENSe]:POWer (802.16 OFDMA)

802.16 OFDMA (N6301A)

[:SENSe]:POWer

Last Updated: March 28, 2008

These commands control the input power range.

  • [:SENSe]:POWer:RANGe[?]

[:SENSe]:POWer:RANGe[?]

Sets/queries the input power range.

Setting Range: -60 to 25 dBm

Query Range: -60 to 25 dBm

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

POWer:RANGe -20DBM

Sets the input power range to -20 dBm.


[:SENSe]:PSTatistic (802.16 OFDMA)

[:SENSe]:PSTatistic

These commands provide device-specific settings for the Power Stat CCDF measurement.

  • [:SENSe]:PSTatistic:COUNts[?]

  • [:SENSe]:PSTatistic:GAUSsian[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

  • [:SENSe]:PSTatistic:RTRace[:STATe][?]

  • [:SENSe]:PSTatistic:SWEep:CYCLes[?]

  • [:SENSe]:PSTatistic:SWEep:TIME[?]

  • [:SENSe]:PSTatistic:TRIGger:SOURce[?]

[:SENSe]:PSTatistic:COUNts[?]

Sets/queries the accumulated number of sampling points for data acquisition. The range is 1.000 kpt (k point) to 2.00000 Gpt (G point) with 1 kpt resolution. Counts couples to Meas Cycles. When the value for counts is changed, the Meas Cycles value will be (Counts / SamplingFrequency * MeasInterval).

Setting Range: 1000 to 2000000000

Query Range: 1000 to 2000000000

*RST Setting: 10000000

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:COUNts 5001

Sets the accumulated number of sampling points for data acquisition to 5001.

[:SENSe]:PSTatistic:GAUSsian[:STATe][?]

Sets/queries the Gaussian trace display state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0| 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:GAUSsian OFF

Turns off the gaussian trace.

[:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

Sets/queries the Auto Rules for IF Gain. When Auto is active, the IF Gain is set to High Gain under any of the following conditions:

  • The input attenuator is set to 0 dB,

  • the preamp is turned On, or

  • the Max Mixer Level is 20 dBm or lower.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:IF:GAIN:AUTO ON

Turns on auto rules for IF Gain.

[:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

Sets/queries the range of IF gain. On sets the high gain option, which allows for better noise level measurements and Off sets low gain when measuring large signals.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:IF:GAIN 1

Turns on the high gain option.

[:SENSe]:PSTatistic:RTRace[:STATe][?]

Sets/queries the reference trace display state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:RTRace ON

Turns on the reference trace.

[:SENSe]:PSTatistic:SWEep:CYCLes[?]

Sets/queries the number of measurement cycles to calculate power statistic data. This number couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval). When the counts value cannot be divided by (Sampling Frequency * MeasInterval), this value is displayed as a decimal fraction.

Setting Range: 1 to a value dependant on the 1 sampling frequency

Query Range: 1 to a value dependant on the 1 sampling frequency

*RST Setting: Depends on the sampling frequency

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:SWEep:CYCLes?

Queries the number of measurement cycles to calculate power statistic data.

[:SENSe]:PSTatistic:SWEep:TIME[?]

Sets/queries the number of data points to be used as the measurement interval. This value couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

Setting Range: 100.0 us to 10.0 ms

Query Range: 100.0 us to 10.0 ms

*RST Setting: 1.0 ms

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:SWEep:TIME 2 ms

Sets the number of data points to 2.0 ms for the measurement interval.

[:SENSe]:PSTatistic:TRIGger:SOURce[?]

Sets/queries the trigger source for the Power Stat CCDF measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

PSTatistic:TRIGger:SOURce RFBurst

Sets the trigger source to RF Burst for the Power Stat CCDF measurement.


[:SENSe]:RADio (802.16 OFDMA)

[:SENSe]:RADio

These commands allow you to change various OFDMA parameters.

  • [:SENSe]:RADio:STANdard[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

  • [:SENSe]:RADio:STANdard:DEVice[?]

  • [:SENSe]:RADio:STANdard:DRATio[?]

  • [:SENSe]:RADio:STANdard:FDURation[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

  • [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

[:SENSe]:RADio:STANdard[?]

Sets/queries the radio standard.

Setting Range: WM80216E05 | WIBRO

Query Range: WM80216E05 | WIBRO

*RST Setting: WM80216E05

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard WIBRO

sets the radio standard to WiBro.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

Sets/queries the bandwidth ratio. Bandwidth ratio is defined as the ratio between the OFDMA FFT sample rate and the nominal channel bandwidth. The 802.16 Standard specifies that the BW Ratio be set to 8/7 or 28/25 depending on the nominal bandwidth of the test signal.

Setting Range: R8BY7 | R28BY25

Query Range: R8BY7 | R28BY25

*RST Setting: R28BY25

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:BWRatio R8BY7

Sets the bandwidth ratio to 8/7.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

Sets/queries the bandwidth ratio - fractional number parameter. This parameter is represented as a fractional number that contains two values; the first value is the numerator and the second is the denominator value of the BW Ratio. This functionality is only available with SCPI control and is recommended only for the advanced user.

Setting Range: 1 to 1000

Query Range: 1 to 1000

*RST Setting: 28,25

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:BWRatio:FRACtion 11,10

Sets the bandwidth ratio - fractional number parameter to numerator 11 and denominator 10.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

Sets/queries the FFT size parameter. OFDMA supports a scalable frame structure where the FFT size scales with bandwidth to keep subcarrier spacing fixed. Four FFT "NFFT" sizes are specified by the OFDMA standard: 128, 512, 1024 and 2048.

Setting Range: 128, 512, 1024, 2048

Query Range: 128, 512, 1024, 2048

*RST Setting: 1024

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:NFFT?

Queries the FFT size parameter.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

Sets/queries the nominal bandwidth parameter. This specifies the nominal channel bandwidth. OFDMA supports a scalable frame structure where the FFT size scales according to the bandwidth to keep subcarrier spacing fixed. The OFDMA standard specifies four FFT "NFFT" sizes" (128, 512, 1024 and 2048) and, in addition, supports many nominal bandwidths. You can use the Preset to Standard to set the Nominal Bandwidth to a standard default value or you can specify an arbitrary value with this command.

Setting Range: 31.25 kHz to 200 MHz

Query Range: 31.25 kHz to 200 MHz

*RST Setting: 10 MHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:VALue 9.996 MHz

Sets the nominal bandwidth parameter to 9.996 MHz.

[:SENSe]:RADio:STANdard:DEVice[?]

Sets/queries the device to be used.

Setting Range: BTS | MS

Query Range: BTS | MS

*RST Setting: BTS

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:DEVice MS

Sets the device to mobile station.

[:SENSe]:RADio:STANdard:DRATio[?]

Downlink Ratio, expressed as a percentage, is the ratio of the downlink subframe length (including the TTG) to the frame length. Downlink Ratio defines where the uplink subframe starts relative to the start of the frame. A 30% Downlink Ratio means that 30% of the frame length is downlink subframe and 70% is uplink subframe.

Setting Range: 0% to 100%

Query Range: 0% to 100%

*RST Setting: 50.0%

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:DRATio 49.0

Sets the downlink ratio to 49%.

[:SENSe]:RADio:STANdard:FDURation[?]

The Frame Duration parameter specifies OFDMA frame duration in units of time. You can use the Radio Standard or Radio Device preset to set the Frame Duration to a value specified in the OFDMA standard or you can specify an arbitrary value manually in the Frame Duration parameter.

Setting Range: 2 ms to 20 ms

Query Range: 2 ms to 20 ms

*RST Setting: 5.0 ms

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:FDURation?

Queries the Frame Duration parameter value.

[:SENSe]:RADio:STANdard:GINTerval:RATio[?]

IEEE 802.16 OFDMA supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary.

Setting Range: R1BY32 | R1BY16 | R1BY8 | R1BY4

Query Range: R1BY32 | R1BY16 | R1BY8 | R1BY4

*RST Setting: R1BY8

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:GINTerval:RATio?

Queries the current guard interval setting.

[:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

IEEE 802.16 OFDMA supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary. For advanced user, the Guard Interval can be set to a value other than the standard values (1/4, 1/8, 1/16 or 1/32). This parameter is represented as a fractional number that contains two values; the first value is the numerator and the second is the denominator value of the Guard Interval. NOTE: This functionality is only available with SCPI control and is recommended only for the advanced user.

Setting Range: 0 to 1000

Query Range: 0 to 1000

*RST Setting: 1, 8

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:GINTerval:RATio:FRACtion 3, 18

Sets the guard interval as a fractional number 3 (numerator), 18 (denominator)

[:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

Sets/queries the WiBro mode.

Setting Range: B4M375 | B8M75 | B17M5

Query Range: B4M375 | B8M75 | B17M5

*RST Setting: B8M75

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:WIBRo B4M375

Sets the WiBro mode to B4M375.

[:SENSe]:RADio:STANdard:Y05[:PROFile][?]

Sets/queries the 802.16e-2005 mode. This changes a range of settings which includes FFT, BW ratio, guard interval, frame duration and DL ratio.

Setting Range: B1M25 | B3M5 | B5M | B7M | B8M75 | B10M | B14M | B15M | B17M5 | B20M | B28M

Query Range: B1M25 | B3M5 | B5M | B7M | B8M75 | B10M | B14M | B15M | B17M5 | B20M | B28M

*RST Setting: B10M (802.16e-2005 mode)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RADio:STANdard:Y05 B3M5

Sets/queries the 802.16e-2005 mode to B3M5.


[:SENSe]:RESume (802.16 OFDMA)

[:SENSe]:RESume

  • [:SENSe]:RESume

[:SENSe]:RESume

Regains the application visa lock on the test set so that other applications (such as glacier) can use it.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RESume

Regains the application visa lock on the test set.


[:SENSe]:ROSCillator (802.16 OFDMA)

[:SENSe]:ROSCillator

These commands set and query reference settings.

  • [:SENSe]:ROSCillator:SOURce?

  • [:SENSe]:ROSCillator:SOURce:TYPE[?]

[:SENSe]:ROSCillator:SOURce?

Returns the current switch setting. This means:

  • If it was set to SENSe but there is no external reference so the instrument is actually using the internal reference, then this query returns INTernal and not SENSe.

  • If it was set to SENSe and there is an external reference present, the query returns EXTernal and not SENSe.

  • If it was set to EXTernal, then the query returns "EXTernal"

  • If it was set to INTernal, then the query returns INTernal

Setting Range: EXTernal | INTernal | SENSe

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

ROSCillator:SOURce?

Returns the current switch setting.

[:SENSe]:ROSCillator:SOURce:TYPE[?]

Sets/queries the frequency reference as being the internal reference, external reference or sensing the presence of an external reference. When the frequency reference is set to internal, the internal 10 MHz reference is used even if an external reference is connected.

Setting Range: INTernal | EXTernal | SENSe

Query Range: INT | EXT | SENS

*RST Setting: This is unaffected by Preset but is set to SENSe on a "Restore Input/Output Defaults" or "Restore System Defaults->All".

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

ROSCillator:SOURce:TYPE EXTernal

Sets the frequency reference to External.


[:SENSe]:SEMask

802.16 OFDMA (N6301A)

[SENSe]:SEMask

These commands control the operation of the Spurious Emissions Mask (SEM) measurement

  • [:SENSe]:SEMask:AVERage:COUNt

  • [:SENSe]:SEMask:AVERage[:STATe]

  • [:SENSe]:SEMask:BANDwidth{1:2}:INTegration

  • [:SENSe]:SEMask:BANDwidth{1:2}[:RESolution]

  • [:SENSe]:SEMask:BWIDth{1:2}:INTegration

  • [:SENSe]:SEMask:BWIDth{1:2}[:RESolution]

  • [:SENSe]:SEMask:CARRier:AUTO[:STATe]

  • [:SENSe]:SEMask:CARRier:CPSD

  • [:SENSe]:SEMask:CARRier[:POWer]

  • [:SENSe]:SEMask:FILTer[:RRC]:ALPHa

  • [:SENSe]:SEMask:FILTer[:RRC][:STATe]

  • [:SENSe]:SEMask:FREQuency{1:2}:SPAN

  • [:SENSe]:SEMask:LCOMpensatio

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:BANDwidth:IMULti

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:BWIDth:IMULti

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:FREQuency:STARt

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:FREQuency:STOP

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:RATTenuation

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:SIDE

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STARt:ABSolute

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STARt:RCARrier

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STATe

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STOP:ABSolute

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STOP:ABSolute:COUPle

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STOP:RCARrier

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:STOP:RCARrier:COUPle

  • [:SENSe]:SEMask:OFFSet{1:2}:LIST:TEST

  • [:SENSe]:SEMask:SWEep{1:2}[:TIME]

  • [:SENSe]:SEMask:TRIGger:SOURce

  • [:SENSe]:SEMask:TYPE

  • [:SENSe]:SEMask:WTYPe/nquery/

  • [:SENSe]:SMASk:AVERage:COUNt

  • [:SENSe]:SMASk:AVERage[:STATe]

  • [:SENSe]:SMASk:AVERage:TCONtrol

  • [:SENSe]:SMASk:MASK[:STATe]

  • [:SENSe]:SMASk:SWEep:TIME

  • [:SENSe]:SMASk:TRIGger:SOURce

  • [:SENSe]:SMASk:WTYPe

[:SENSe]:SEMask:AVERage:COUNt[?]

Sets/queries the number of data acquisitions that will be averaged. After the specified number of average counts, the measurement stops.

Setting Range: 1 to 10000

Query Range: 1 to 10000

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SENSe:SEMask:AVERage:COUNt 100

Sets the number of data acquisitions that will be averaged to 100.

[:SENSe]:SEMask:AVERage[:STATe][?]

Sets/queries the averaging state for the SEM measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SENSe:SEMask:AVERage ON

Turns on averaging for the SEM measurement.

[:SENSe]:SEMask:BANDwidth|BWIDth[1]|2:INTegration[?]

Sets/queries the integration bandwidth used to calculate the power in the reference channel.

BANDwidth1 or BWIDth1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 10kHz to 10MHz

Query Range: 10kHz to 10Mhz

*RST Setting: 10MHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SENSe:SEMask:BWIDth1:INTegration 100e3

Sets the integration bandwidth to 100kHz

[:SENSe]:SEMask:BANDwidth|BWIDth[1]|2[:RESolution][?]

Sets/queries the resolution bandwidth used to calculate the power in the reference channel.

BANDwidth1 or BWIDth1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 10kHz to 8MHz

Query Range: 10kHz to 8Mhz

*RST Setting: 100kHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SENSe:SEMask:BWIDth1:RESolution?

Queries the resolution bandwidth used for downlink measurements

[:SENSe]:SEMask:CARRier:AUTO:STATe[?]

Sets/queries the auto carrier power state for the measurement. When this is set "on", the measured carrier reference power used to compute the relative power values for the offsets. When set to "off", the result takes on the last measured value, or can be manually entered.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:CARRier:AUTO off

Switches automatic carrier reference power calculation off.

[:SENSe]:SEMask:CARRier:CPSD[?]

Sets/queries the power spectral density in the carrier (main channel) that is used to compute the relative power spectral density values for the offsets when the measurement type is set to PSD Reference. When the PSD Reference auto state is set "on", this will be set to the measured carrier power spectral density.

Setting Range: -900 to 900

Query Range: -900 to 900

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:CARRier:CPSD?

Queries the power spectral density used to computer the relative PSD

[:SENSe]:SEMask:CARRier[:POWer][?]

Sets/queries the power in the carrier (reference channel) that will be used to compute the relative power values for the offsets. When the auto carrier power state is set to "on", this is set to the measured carrier reference power. When set to "off", the result takes on the last measured value, or can be manually entered.

Setting Range: -200dBm to 200dBm

Query Range: -200dBm to 200dBm

*RST Setting: 0 dBm

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:CARRier:POWer -10

Sets the reference channel value to -10dBm

[:SENSe]:SEMask:FILTer[:RRC]:ALPHa[?]

Sets/queries the alpha value for the RRC Filter.

Setting Range: 0.01 to 1.0

Query Range: 0.01 to 1.0

*RST Setting: 0.22

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:FILTer:ALPHa 0.3

Sets the alpha value to 0.3

[:SENSe]:SEMask:FILTer[:RRC][:STATe][?]

Sets/queries the measurement method. Sets the measurement method

  • Integ BW mode (parameter value 0) enables you to set the channel integration bandwidth.

  • RRC Weight mode (parameter value 1) selects Root Raised Cosine (RRC) filtering of the carriers and all adjacent channels. The alpha value (rolloff) for the filter is set to the value of the Filter Alpha parameter

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:FILT 1

Switches the measurement into RRC weight mode

[:SENSe]:SEMask:FREQuency[1]|2:SPAN[?]

Sets/queries the span used to calculate the power in the reference channel.

FREQuency1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 1kHz to 50MHz

Query Range: 1kHz to 50MHz

*RST Setting: 10MHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:FREQ:SPAN 12MHz

Sets the span used to calculate the power in the reference channel to 12MHz

[:SENse]:SEMask:LCOMpensation[?]

Sets/queries a loss compensation value for the current frequency, to account for losses such as fixture loss.

Setting Range: -999 to 999dB

Query Range: -999 to 999dB

*RST Setting: 0dB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:LCOM -10

Sets the loss compensation value to -10dBm

[:SENSe]:SEMask:OFFSet[1]|2:LIST:BANDwidth|BWIDth:IMULti[?]

Sets/queries the multiplier value used when measuring each offset. The Meas BW value is the multiplier applied to the Res BW to define the bandwidth to integrate over when calculating the power for the offsets.

There should always be six arguments, or six results from the query.

FREQuency1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 1 to 1000 for each offset

Query Range: 1 to 1000 for each offset

*RST Setting: 1,10,10,10,10,10

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:OFFSet1:LIST:BWID:IMUL?

Queries the multipliers used when measuring each offset on the uplink.

[:SENSe]:SEMask:OFFSet[1]|2:LIST:FREQuency:STARt[?]

Sets/queries the offset start frequency for each offset (assumed to be symmetrical around the center frequency). There are six offsets.

FREQuency1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 10kHz to (stop frequency - 100Hz) (for that offset)

Query Range: 10kHz to (stop frequency - 100Hz) (for that offset)

*RST Setting: 5.05e6, 6.5e6, 1.04999e7, 1.15e7, 1.55e7, 2.05e7

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:OFFSet2:LIST:FREQuency:START?

Queries the list of start frequencies

[:SENSe]:SEMask:OFFSet[1]|2:LIST:FREQuency:STOP[?]

Sets/queries the offset stop frequency for each offset (assumed to be symmetrical around the center frequency). There are six offsets.

FREQuency1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: (start frequency + 100Hz) to 10kHz (for that offset)

Query Range: (start frequency + 100Hz) to 10kHz (for that offset)

*RST Setting: 5.95e6, 9.5e6, 1.05e7, 1.45e7, 1.95e7,2.45e7

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:OFFSet2:LIST:FREQuency:STOP?

Queries the list of stop frequencies

[:SENSe]:SEMask:OFFSet[1]|2:LIST:SIDE[?]

Sets/queries which side offsets to measure. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Each offset can be set to one of

  • NEGative - measure only the negative frequency offset

  • BOTH - measure both positive and negative frequency offsets

  • POSitive - measure only the positive frequency offset

Setting Range: NEGative | BOTH | POSitive for each offset

Query Range: NEG | BOTH | POS

*RST Setting: BOTH,BOTH,BOTH,BOTH,BOTH,BOTH

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:OFFSet1:LIST:SIDE BOTH,POS,POS,NEG,NEG,NEG

Sets the measurement to use both positive and negative frequencies for the first offset, positive only for the next two offsets and negative only for the final three offsets.

[:SENSe]:SEMask:OFFSet[1]|2:LIST:STARt:ABSolute[?]

Sets/queries the absolute power level limit at the start frequency for each offset. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: -200dBm to 50dBm

Query Range: -200dBm to 50dBm

*RST Setting: -13.0, -13.0, -19.0, -25.0, -29.42, -37.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:START:ABS -12,-12,-18,-25,-30,-37

Changes the absolute limits for the start frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:LIST:STARt:RCARrier[?]

Sets/queries the power level limit at the start frequency for each offset relative to the power in the central carrier. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: -200dBm to 50dBm

Query Range: -200dBm to 50dBm

*RST Setting: -30.0,-30.0,-30.0,-30.0,-30.0,-30.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:START:RCAR -20,-20,-20,-20,-20,-20

Changes the relative limits for the start frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:LIST:STATe[?]

Sets/queries whether mask testing is enabled at each offset. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1,1,1,1,1,1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEMask:OFFS:LIST:STATe?

Queries which offsets have limit testing enabled

[:SENSe]:SEMask:OFFSet[1]|2:STOP:ABSolute[?]

Sets/queries the absolute power level limit at the stop frequency for each offset. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: -200dBm to 50dBm

Query Range: -200dBm to 50dBm

*RST Setting: -13.0, -13.0, -19.0, -25.0, -36.16, -37.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:STOP:ABS -12,-12,-18,-25,-30,-37

Changes the absolute limits for the stop frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:STOP:ABSolute:COUPle[?]

Sets/queries whether the stop frequency absolute power limit is coupled to (that is, kept the same as) the start frequency absolute power limit for that offset. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1,1,0,1,0,1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:STOP:ABS:COUPle 1,1,1,1,0,1

Changes the absolute limits coupling settings for the stop frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:LIST:STOP:RCARrier[?]

Sets/queries the power level limit at the stop frequency for each offset relative to the power in the central carrier. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: -200dBm to 50dBm

Query Range: -200dBm to 50dBm

*RST Setting: -30.0,-30.0,-30.0,-30.0,-30.0,-30.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:STOP:RCAR -20,-20,-20,-20,-20,-20

Changes the relative limits for the stop frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:STOP:RCARrier:COUPle[?]

Sets/queries whether the stop frequency relative power limit is coupled to (that is, kept the same as) the start frequency relative power limit for that offset. There are six offsets.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1,1,1,1,1,1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS:LIST:STOP:RCAR:COUPle 1,1,1,1,0,1

Changes the relaitve limits coupling settings for the stop frequency of each offset

[:SENSe]:SEMask:OFFSet[1]|2:LIST:TEST[?]

Sets/queries the logic keys for fail conditions between the measurement results and the test limits for each offset. There are six offsets.

Absolute checks the results against the absolute limit

Relative checks the results against the relative limit

OR checks against both limits, failing if either of the limits is broken

AND will only display a fail if both of the limits are broken

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: ABSolute | RELative | AND | OR (per offset)

Query Range: ABS | REL | AND | OR (per offset)

*RST Setting: ABS,ABS,ABS,ABS,ABS,ABS

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SEM:OFFS2:LIST:TEST?

Queries the testing mode for uplink measurements

[:SENSe]:SEMask:SWEep[1]|2[:TIME][?]

Sets or queries the acquisition length used for the measurement.

OFFSet1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 1us to 5ms

Query Range: 1us to 5ms

*RST Setting: 1ms

Example:

SENSe:SEMask:SWEep:TIME 3ms

Sets the acquisition duration to 3ms

[:SENSe]:SEMask:TRIGger:SOURce[?]

Sets/queries the trigger source for the Spurious Emissions Mask measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SENSe:SEMask:TRIGger:SOURce EXTernal

Sets the trigger source to External for the SEM measurement.

[:SENSe]:SEMask:TYPE[?]

Sets or queries the reference used for the measurement. Total Pwr Ref (TPR) sets the reference to the total carrier power. PSD Ref (PSDR) sets the reference to the power spectral density of the carrier.

Setting Range: TPR | PSDR

Query Range: TPR | PSDR

*RST Setting: TPR

Example:

SENSe:SEMask:TYPE PSDR

Sets the reference type to PSD.

[:SENSe]:SEMask:WTYPe[?]

Sets or queries the FFT window type used in the measurement.

Setting Range: GAUSsian | HANNing | FLATtop | UNIForm

Query Range: GAUS | HANN | FLAT | UNIF

*RST Setting: GAUS

Example:

SENSe:SEMask:WTYPe?

Queries the FFT window type used for the measurement


[:SENSe]:SMASk (802.16 OFDMA)

[:SENSe]:SMASk

These commands provide device-specific settings for the Spectral Mask measurement.

  • [:SENSe]:SMASk:MASK[:STATe][?]

  • [:SENSe]:SMASk:SWEep:TIME[?]

  • [:SENSe]:SMASk:TRIGger:SOURce[?]

  • [:SENSe]:SMASk:WTYPe[?]

[:SENSe]:SMASk:MASK[:STATe][?]

Sets/queries the operating state of the mask.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SMASk:MASK OFF

Turns off the mask.

[:SENSe]:SMASk:SWEep:TIME[?]

Sets/queries how long the measurement is performed.

Setting Range: 1.000 us to 5.192 ms

Query Range: 1.000 us to 5.192 ms

*RST Setting: 2.000000 ms

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SMASk:SWEep:TIME 3.0 ms

Sets the sweep time to 3.0 ms.

[:SENSe]:SMASk:TRIGger:SOURce[?]

Sets/queries the trigger source for the Spectral Mask measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SMASk:TRIGger:SOURce RFBurst

Sets the trigger source for the Spectral Mask measurement to RF Burst.

[:SENSe]:SMASk:WTYPe[?]

Sets/queries the window type for the spectral mask measurement.

Setting Range: GAUSsian | FLATtop | HANNing | UNIForm

Query Range: GAUS | FLAT | HANN | UNIF

*RST Setting: GAUSsian

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SMASk:WTYPe?

Queries the window type for the spectral mask measurement.


[:SENSe]:SUSPend (802.16 OFDMA)

[:SENSe]:SUSPend

  • [:SENSe]:SUSPend

[:SENSe]:SUSPend

Releases the application visa lock on the test set so that other applications (such as glacier) can use it.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SUSPend

Releases the application visa lock on the test set.


[:SENSe]:WAVeform (802.16 OFDMA)

[:SENSe]:WAVeform

These commands provide device-specific settings for the Waveform measurement.

  • [:SENSe]:WAVeform:AVERage:COUNt[?]

  • [:SENSe]:WAVeform:AVERage[:STATe][?]

  • [:SENSe]:WAVeform:AVERage:TCONtrol[?]

  • [:SENSe]:WAVeform:AVERage:TYPE[?]

  • [:SENSe]:WAVeform:PONLy[:STATe][?]

  • [:SENSe]:WAVeform:SWEep:TIME[?]

  • [:SENSe]:WAVeform:TRIGger:SOURce[?]

[:SENSe]:WAVeform:AVERage:COUNt[?]

Sets/queries the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Setting Range: 1 to 20001

Query Range: 1 to 20001

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:COUNt 20

Sets/queries the number of sweeps (average counts) to 20.

[:SENSe]:WAVeform:AVERage[:STATe][?]

Sets/queries the averaging state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:AVERage ON

Turns on averaging.

[:SENSe]:WAVeform:AVERage:TCONtrol[?]

Sets/queries the averaging mode. When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep. When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: EXPonential

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:TCONtrol REPeat

Sets the averaging mode to repeat.

[:SENSe]:WAVeform:AVERage:TYPE[?]

Sets/queries the type of averaging.

Setting Range: LOG | MAXimum | MINimum | RMS | SCALar

Query Range: LOG | MAX | MIN | RMS | SCAL

*RST Setting: RMS

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:TYPE MAXimum

Sets the type of averaging to Maximum.

[:SENSe]:WAVeform:PONLy[:STATe][?]

Sets/queries the waveform measurement to only return the power result. This makes the measurement quicker.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:PONLy ON

Sets the waveform measurement to only return the power result.

[:SENSe]:WAVeform:SWEep:TIME[?]

Sets/queries how long the measurement is performed. X Scale only changes the representation of the display

Setting Range: 1.000 s to 100.00 s

Query Range: 1.000 s to 100.00 s

*RST Setting: 2.000000 ms

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:SWEep:TIME?

Queries the sweep time.

[:SENSe]:WAVeform:TRIGger:SOURce[?]

Sets/queries the trigger source for the Waveform measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

WAVeform:TRIGger:SOURce EXTernal

Sets the trigger source to External for the Waveform measurement.


SOURce Subsystem (802.16 OFDMA)

SOURce Subsystem

Description

The SOURce subsystem is used to control the test set's RF generator.

For details of the :SOURce commands refer to the :SOURce subsystems in this section.


SOURce:CALibration (802.16 OFDMA)

SOURce:CALibration

These commands perform calibration operations.

  • SOURce:CALibration[:USER]

  • SOURce:CALibration:DCFM

  • SOURce:CALibration:IQ:DC

  • SOURce:CALibration:IQ:DEFault

  • SOURce:CALibration:IQ:FULL

  • SOURce:CALibration:IQ:START[?]

  • SOURce:CALibration:IQ:STOP[?]

  • SOURce:CALibration:IQ:TYPE[?]

SOURce:CALibration[:USER]

Performs an IQ calibration according to the IQ calibration type.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration

Performs an IQ calibration according to the IQ calibration type.

SOURce:CALibration:DCFM

Performs a DCFM or DCΦM calibration depending on the currently active modulation. This calibration eliminates any dc or modulation offset of the carrier signal.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:DCFM

Performs a DCFM or DCΦM calibration depending on the currently active modulation.

SOURce:CALibration:IQ:DC

Performs a one to two second adjustment that is not traceable to a standard. However, it will minimize errors associated with IQ gain, quadrature, and offset voltages. This adjustment minimizes errors for the current signal generator setting and at a single frequency. The DC adjustment is volatile and must be repeated with each signal generator setting change. This command can be sent while the RF On/Off is set to Off and the adjustment will still be valid when the RF is enabled. IQ must be on to perform this adjustment.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:DC

Performs a one to two second adjustment that is not traceable to a standard.

SOURce:CALibration:IQ:DEFault

Restores the original factory calibration data for the internal I/Q modulator.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:DEFault

Restores the original factory calibration data for the internal I/Q modulator.

SOURce:CALibration:IQ:FULL

Performs an adjustment to the I/Q offset, gain and quadrature for the full- frequency range (regardless of the start and stop frequency settings) and stores the results in the signal generator’s firmware.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:FULL

Performs an adjustment to the I/Q offset, gain and quadrature for the full- frequency range (regardless of the start and stop frequency settings) and stores the results in the signal generator’s firmware.

SOURce:CALibration:IQ:START[?]

Sets/queries the start frequency and automatically sets the calibration type to User for an I/Q calibration.

Setting Range: 100 kHz to 6 GHz

Query Range: 100 kHz to 6 GHz

*RST Setting: 100 kHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:START?

Queries the start frequency.

SOURce:CALibration:IQ:STOP[?]

Sets/queries the stop frequency and automatically sets the calibration type to User for an I/Q calibration.

Setting Range: 100 kHz to 6 GHz

Query Range: 100 kHz to 6 GHz

*RST Setting: 1 GHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:STOP?

Queries the stop frequency.

SOURce:CALibration:IQ:TYPE[?]

Sets/queries the IQ calibration type.

Setting Range: DC | USER | FULL

Query Range: DC | USER | FULL

*RST Setting: DC

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:TYPE USER

Sets the IQ calibration type to User.


SOURce:MMEMory (802.16 OFDMA)

802.16 OFDMA (N6301A)

SOURce:MMEMory

Last Updated: March 28, 2008

These commands perform operations on file systems.

  • SOURce:MMEMory:CATalog?

  • SOURce:MMEMory:COPY

  • SOURce:MMEMory:DATA

  • SOURce:MMEMory:DATA:UNPRotected

  • SOURce:MMEMory:DELete[:NAME]

  • SOURce:MMEMory:DELete:NVWFm

  • SOURce:MMEMory:DELete:WFM

SOURce:MMEMory:CATalog?

Outputs a list of the files from the specified file system. The variable "<msus>" (mass storage unit specifier) represents "<file system>".

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:CATalog?

Outputs a list of the files from the specified file system.

SOURce:MMEMory:COPY "NVWFM:<source_file_name>","WFM1:<destination_file_name>"
[,"NVWFM:<source_file_name>"][,"WFM1:<destination_file_name>"]

Allows you to transfer files between volatile memory (WFM1) and non-volatile memory (NVWF1).

When copying files between volatile memory and non-volatile memory on the test set, this command returns immediately to the calling program. However, the work is still being performed in the background. This can result in a timeout in the SCPI parser, incorrectly generating an error message. In order to ensure the command performs as intended, you should set the timeout to a value sufficiently long (the exact value depends on how many files are being copied) and perform a SYST:ERR? query after every copy. This holds off the SCPI until the SOURce:MMEMory:COPY command is complete and the test set is ready to use.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:COPY "NVWFM:16E_10M_DL_PUSC_MULT","WFM1:16E_10M_DL_PUSC_MULT"

Copies the source file from non-volatile to volatile memory.

SOURce:MMEMory:DATA "<file name>",<datablock>
SOURce:MMEMory:DATA? "<file name>"

This command loads <datablock> into the memory location "<file name>". The query returns the <datablock> associated with the "<file name>".

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DATA? "myfile1.txt"

Returns the datablock associated with myfile1.txt.

SOURce:MMEMory:DATA:UNPRotected "<file_name>",<data_block>

Allows you to download data and store it in a file on the instrument with the ability to retrieve it. This command is intended for downloading waveform data; however you can use it to download other types of data. Data_File is the filename. The directory path is not needed. The path "/USER/SECUREWAVE" is implied.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

SOURce:MMEMory:DELete[:NAME] "<file_name>",["<msus>"]

Allows you to delete files from volatile memory (WFM1) or non-volatile memory (NVWF1). This command clears the user file system of "<file name>" with the option of specifying the file system separately. The variable "<msus>" (mass storage unit specifier) represents the file system. If the optional variable "<msus>" is omitted, the file name needs to include the file system extension. You can also use this command to delete sequence files using the prefix SEQ.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Examples:

SOURce:MMEMory:DELete "WFM1:16E_10M_DL_PUSC_MULT"

Removes the file "16E_10M_DL_PUSC_MULT" from volatile memory.

SOURce:MMEMory:DELete "SEQ:16E_PER_1000.seq"

Deletes the sequence file "16E_PER_1000.seq".

SOURce:MMEMory:DELete:NVWFm

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DELete:NVWFm

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

SOURce:MMEMory:DELete:WFM

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DELete:WFM

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).


SOURce:OUTPut (802.16 OFDMA)

SOURce:OUTPut

  • SOURce:OUTPut[:STATe][?]

SOURce:OUTPut[:STATe][?]

Sets/queries operating state of the RF signal present at the RF OUTPUT connector.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:OUTPut?

Queries operating state of the RF signal present at the RF OUTPUT connector.


SOURce:POWer (802.16 OFDMA)

SOURce:POWer

These commands control source power functions.

  • SOURce:POWer:ALC[:STATe][?]

  • SOURce:POWer:ATTenuation[?]

  • SOURce:POWer:ATTenuation:AUTO[?]

  • SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

SOURce:POWer:ALC[:STATe][?]

Sets/queries the automatic leveling control (ALC) circuit state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:POWer:ALC 1

Turns on the automatic leveling control (ALC) circuit.

SOURce:POWer:ATTenuation[?]

Sets/queries the signal generator’s attenuator level. Before setting the attenuator level, set the ”:ATTenuation:AUTO” function to Off which will disable ALC control.

Setting Range: 0 dB to 115 dB

Query Range: 0 dB to 115 dB

*RST Setting: 115 dB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:POWer:ATTenuation 10DB

Sets the signal generator’s attenuator level to 10 dB.

SOURce:POWer:ATTenuation:AUTO[?]

Sets/queries the state of the attenuator auto mode function.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:POWer:ATTenuation:AUTO?

Queries the state of the attenuator auto mode function.

SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

Sets/queries the output power.

Setting Range: -110 dBm to 16 dBm

Query Range: -110 dBm to 16 dBm

*RST Setting: -110 dBm

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:POWer:LEVel:IMMediate:AMPLitude -30

Sets the output power to -30 dBm.


SOURce:RADio (802.16 OFDMA)

SOURce:RADio

These commands configure arbitrary waveform generator functions.

  • SOURce:RADio:ARB[:STATe][?]

  • SOURce:RADio:ARB:CLOCk:SRATe[?]

  • SOURce:RADio:ARB:DONE?

  • SOURce:RADio:ARB:MARKer[:SET]

  • SOURce:RADio:ARB:MARKer:CLEar

  • SOURce:RADio:ARB:MARKer:CLEar:ALL

  • SOURce:RADio:ARB:MARKer:ROTate

  • SOURce:RADio:ARB:MDEStination:ALCHold[?]

  • SOURce:RADio:ARB:MDEStination:PULSe[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

  • SOURce:RADio:ARB:RSCaling[?]

  • SOURce:RADio:ARB:SEQuence[:MWAVeform]

  • SOURce:RADio:ARB:TRIGger[:SOURce][?]

  • SOURce:RADio:ARB:TRIGger:TYPE[?]

  • SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

  • SOURce:RADio:ARB:WAVeform

SOURce:RADio:ARB[:STATe][?]

Sets/queries the arbitrary waveform generator function state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB?

Queries the arbitrary waveform generator function state.

SOURce:RADio:ARB:CLOCk:SRATe[?]

Sets/queries the sample clock rate.

Setting Range: 1 Hz to 100 MHz

Query Range: 1 Hz to 100 MHz

*RST Setting: 100 MHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:CLOCk:SRATe?

Queries the sample clock rate.

SOURce:RADio:ARB:DONE?

Queries if the ARB has finished playing the selected recording.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:DONE?

Queries if the ARB has finished playing the selected recording.

SOURce:RADio:ARB:MARKer[:SET] "<file_name>",<marker>,<first_point>,<last_point>,<skip_count>

Sets/queries a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command. The instrument provides four independent markers. Two of the markers route output signals to rear- panel event connectors, Marker- 1 to Event1 BNC and Marker- 2 to Aux I/O. A marker consists of marker points placed at defined sample points in a waveform segment. This means that a marker point cannot be less than one or greater than the last sample point in the waveform. Marker points are cumulative, so multiple command executions with different range values, without first clearing the existing points, places additional marker points on the waveform. Because of this cumulative behaviour, it is a good practice to clear existing marker points prior to setting new points. This will eliminate unexpected marker pulses. Refer to ”:MARKer:CLEar” and ”:MARKer:CLEar:ALL” for information on clearing marker points.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer "Test_Data",1,40,100,2

Sets marker 1 on the first point, 40, the last point, 100, and every third point (skip 2) between 40 and 100 (assuming the Test_Data file has at least 100 points).

SOURce:RADio:ARB:MARKer:CLEar "<file_name>",<marker>,<first_point>,<last_point>

Clears a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB modulation formats use this command.

Setting Range: <marker>: 1&endash;4 <first_Point>: 1&endash;number of waveform points <last_point>: <first_Point>&endash;number of waveform points

*RST Setting: <marker>: 1 <first_Point>: 1 <last_point>: 200

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:CLEar "Test_Data",1,1,300

Clears marker 1 from the first point through the 300th point in the Test_Data file.

SOURce:RADio:ARB:MARKer:CLEar:ALL "<file_name>",<marker>

Clears all marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command. With all marker points cleared, the event output signal level is set low.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:CLEar:ALL "Test_Data",1

Clears marker 1 from the all waveform points in the Test_Data file.

SOURce:RADio:ARB:MARKer:ROTate "<file_name>",<rotate_count>

Shifts the marker points for all markers in a waveform segment earlier or later by the value of the <rotate_count> variable. The dual ARB player and all of the ARB formats use this command.

Setting Range: &endash; (n &endash; 1) to (n &endash; 1) n = number of points in the waveform

Query Range: &endash; (n &endash; 1) to (n &endash; 1) n = number of points in the waveform

*RST Setting: No rotation

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:ROTate "Test_Data",100

Shifts all markers set in the Test_Data file 100 points later.

SOURce:RADio:ARB:MDEStination:ALCHold[?]

Sets/queries the marker ALC hold function for the selected marker. Use the ALC hold function when you have a waveform signal that incorporates idle periods, or when the increased dynamic range encountered with RF blanking is not desired. The ALC leveling circuitry responds to the marker signal during the marker pulse (marker signal high), averaging the modulated signal level during this period. The ALC hold function operates during the low periods of the marker signal. The marker polarity determines when the marker signal is high. For a positive polarity, this is during the marker points. For a negative polarity, this is when there are no marker points. CAUTION: Incorrect automatic level control (ALC) sampling can create a sudden unlevelled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Setting Range: NONE | M1 | M2 | M3 | M4

Query Range: NONE | M1 | M2 | M3 | M4

*RST Setting: NONE

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MDEStination:ALCHold M1

Sets/queries the marker ALC hold function for marker 1.

SOURce:RADio:ARB:MDEStination:PULSe[?]

Sets/queries the marker pulse/RF blanking function for the selected marker. This function automatically uses the ALC hold function, so there is no need to select both the ALC hold and pulse/RF blanking functions for the same marker. CAUTION The pulse function incorporates ALC hold. Incorrect automatic level control (ALC) sampling can create a sudden unleveled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Setting Range: NONE | M1 | M2 | M3 | M4

Query Range: NONE | M1 | M2 | M3 | M4

*RST Setting: NONE

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MDEStination:PULSe M3

Sets the marker pulse/RF blanking function for marker 3.

SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

Sets/queries the polarity for the selected marker. For a positive marker polarity, the marker signal is high during the marker points. For a negative marker polarity, the marker signal is high during the period of no marker points.

Setting Range: NEGative | POSitive

Query Range: NEG | POS

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MPOLarity:MARKer2?

Queries the polarity for marker 2.

SOURce:RADio:ARB:RSCaling[?]

Sets/queries the scaling value in percent that is applied to a waveform while it is playing. The variable <value> is expressed as a percentage. Runtime scaling does not alter the waveform data file. This feature is used to avoid DAC overflow. The scaling is compensated for at the modulator (that is, when the modulator is the optimized path).

Setting Range: 1% to 100%

Query Range: 1% to 100%

*RST Setting: 70%

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:RSCaling 80

Applies an 80% scaling factor to the selected waveform.

SOURce:RADio:ARB:SEQuence[:MWAVeform] <filename>,<waveform1>,<reps>,NONE|M1|M2|M3|M4|M1M2|
M1M3|M1M4|M2M3|M2M4|M3M4|M1M2M3|M1M2M4|M1M3M4|M2M3M4|M1M2M3M4|ALL,
{,<waveform2>,<reps>,NONE|M1|M2|M3|M4|M1M2|M1M3|M1M4|M2M3|M2M4|M3M4|M1M2M3|M1M2M4|M1M3M4|M2M3M4|M1M2M3M4|ALL,}
SOURce:RADio:ARB:SEQuence[:MWAVeform? <filename>

This command creates a waveform sequence. A waveform sequence is made up of segments and other sequences. Any number of segments, up to a segment count limit of 1024, can be used to create a sequence. The count limit is determined by the number of segments in the waveform sequence. Repeated segments are included in the count limit.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:SEQuence "SEQ:Test_Data","WFM1:ramp_test_wfm",25,M1M4,"WFM1:sine_test_wfm",100,ALL

creates a waveform sequence file named Test_Data. This file consists of the factory- supplied waveform segments, ramp_test_wfm and sine_test_wfm. The waveform is stored in the signal generator’s SEQ: directory.

- The first segment, ramp_test_wfm, has 25 repetitions with markers 1 and 4 enabled.

- The second segment, sine_test_wfm, has 100 repetitions with all four markers enabled.

SOURce:RADio:ARB:TRIGger[:SOURce][?]

Sets/queries the trigger source.

Setting Range: KEY | EXT | BUS

Query Range: KEY | EXT | BUS

*RST Setting: EXT

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger?

Queries the trigger source.

SOURce:RADio:ARB:TRIGger:TYPE[?]

Sets/queries the trigger mode (type) that controls the waveform’s playback.

Setting Range: CONTinuous | SINGle

Query Range: CONT | SING

*RST Setting: CONTinuous

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

Sets/queries the waveform’s response to a trigger signal while using the continuous trigger mode:

  • FREE Turning the ARB format on immediately triggers the waveform. The waveform repeats until you turn the format off, select another trigger, or choose another waveform file.

  • TRIGger The waveform waits for a trigger before play begins. When the waveform receives the trigger, it plays continuously until you turn the format off, select another trigger, or choose another waveform file.

  • RESet The waveform waits for a trigger before play begins. When the waveform receives the trigger, it plays continuously. Subsequent triggers reset the waveform to the beginning. For a waveform sequence, this means to the beginning of the first segment in the sequence.

Setting Range: FREE | TRIGger | RESet

Query Range: FREE | TRIGger | RESet

*RST Setting: FREE

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger:TYPE:CONTinous FREE

Sets the waveform’s response to Free.

SOURce:RADio:ARB:WAVeform "WFM1:file_name"|"SEQ:file_name"
:SOURce:RADio:ARB:WAVeform?

Sets/queries the waveform file or sequence, for the AWG to play. The file must be present in volatile memory (WFM1) or in the SEQ directory. If a file is in non-volatile memory (NVWFM), use the command ”SOUR:MMEM:COPY[:NAME]” to copy the file to WFM1. Any specified values in the header are applied to the ARB upon selection. Unspecified fields in the header cause no change in the ARB state.

Setting Range: "WFM1:file_name" This variable names a waveform file residing in volatile memory (WFM1:). "SEQ:file_name" This variable names a sequence file residing in the catalog of sequence files.

Query Range: "WFM1:file_name" This variable names a waveform file residing in volatile memory (WFM1:). "SEQ:file_name" This variable names a sequence file residing in the catalog of sequence files.

*RST Setting: No waveform selected

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:WAVeform "WFM1:Test_Data"

Selects the file Test_Data from the list of files in volatile waveform memory, WFM1, and applies its file header settings.


SOURce:RESume (802.16 OFDMA)

SOURce:RESume

  • SOURce:RESume

SOURce:RESume

Resumes the VISA lock over the arbitrary waveform generator.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:RESume

Resumes the VISA lock over the arbitrary waveform generator.


SOURce:SUSPend (802.16 OFDMA)

SOURce:SUSPend

  • SOURce:SUSPend

SOURce:SUSPend

Suspends the VISA lock over the arbitrary waveform generator.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

SOURce:SUSPend

Suspends the VISA lock over the arbitrary waveform generator.


TRIGger Subsystem (802.16 OFDMA)

TRIGger Subsystem

The TRIGger subsystem is used to automatically control trigger settings.

For details of the TRIGger commands, refer to the TRIGger topic in this section.


TRIGger (802.16 OFDMA)

TRIGger

These commands set up trigger parameters.

  • TRIGger:EVM[:SEQuence]:SOURce[?]

  • TRIGger[:SEQuence]:EXTernal:DELay[?]

  • TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

  • TRIGger[:SEQuence]:HOLDoff[?]

  • TRIGger[:SEQuence]:HOLDoff:STATe[?]

  • TRIGger:PSTatistic[:SEQuence]:SOURce[?]

  • TRIGger[:SEQuence]:RFBurst:DELay[?]

  • TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

  • TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

  • TRIGger[:SEQuence]:RFBurst:SLOPe[?]

  • TRIGger[:SEQuence]:SLOPe[?]

  • TRIGger:SMASk[:SEQuence]:SOURce[?]

  • TRIGger:WAVeform[:SEQuence]:SOURce[?]

TRIGger:EVM[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the current EVM measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:EVM:SOURce RFBurst

Sets the trigger source for the current EVM measurement to RF Burst.

TRIGger[:SEQuence]:EXTernal:DELay[?]

Controls a time delay during which the analyzer will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the test set in time domain or FFT, but not in swept spans.

Setting Range: -150 ms to 500 ms

Query Range: -150 ms to 500 ms

*RST Setting: 1.000 us

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:EXTernal:DELay 100MS

Sets the time delay to 100 ms.

TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

Sets/queries the external trigger delay state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:EXTernal:DELay:STATe ON

Sets the external trigger delay state to On.

TRIGger[:SEQuence]:HOLDoff[?]

Sets/queries the holdoff time between triggers. When the trigger condition is satisfied, the trigger occurs, the delay begins, and the holdoff time begins. New trigger conditions will be ignored until the holdoff time expires. For a free-running trigger, the holdoff value is the minimum time between triggers.

Setting Range: 0 s to 0.5 s

Query Range: 0 s to 0.5 s

*RST Setting: 100 ms

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:HOLDoff 110MS

Sets the holdoff time between triggers to 110 ms.

TRIGger[:SEQuence]:HOLDoff:STATe[?]

Sets/queries the trigger holdoff state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:HOLDoff:STATe ON

Sets the trigger holdoff state to On.

TRIGger:PSTatistic[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the current Power Stat CCDF measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:PSTatistic:SOURce EXTernal

Sets the the trigger source for the current Power Stat CCDF measurement to external.

TRIGger[:SEQuence]:RFBurst:DELay[?]

Controls a time delay during which the analyzer will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the instrument in time domain or FFT, but not in swept spans.

Setting Range: -150 ms to 500 ms

Query Range: -150 ms to 500 ms

*RST Setting: 1.000 us

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:RFBurst:DELay 1.5US

Sets the time delay to 1.5 microseconds for RF Burst triggering.

TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

Sets/queries the RF Burst trigger delay state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:RFBurst:DELay:STATe ON

Sets the RF Burst trigger delay state to On.

TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

Sets/queries the absolute trigger level for the RF burst envelope. See key notes regarding the relative trigger level.

Setting Range: -200 dBm to 100 dBm

Query Range: -200 dBm to 100 dBm

*RST Setting: -20 dBm

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute -30DBM

Sets the absolute trigger level for the RF burst envelope to -30 dBm.

TRIGger[:SEQuence]:RFBurst:SLOPe[?]

Sets/queries the trigger slope. It is set positive to trigger on a rising edge and negative to trigger on a falling edge.

Setting Range: POSitive | NEGative

Query Range: POSitive | NEGative

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger[:SEQuence]:RFBurst:SLOPe

Sets the RF Burst trigger polarity to positive (triggers on a rising edge).

TRIGger[:SEQuence]:SLOPe[?]

Sets/queries whether to trigger on a positive (rising) or negative (falling) edge. For use with an RF Burst trigger.

Setting Range: POSitive | NEGative

Query Range: POSitive | NEGative

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:SLOPe?

Queries the current trigger slope setting.

[?]

Sets/queries the trigger source for the Spectral Mask measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXTernal | IMMediate | RFBurst

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:SMASk:SOURce IMMediate

Sets the trigger source for the Spectral Mask measurement to immediate.

TRIGger:WAVeform[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the Waveform measurement to external.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXTernal | IMMediate | RFBurst

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

TRIGger:WAVeform[:SEQuence]:SOURce EXTernal

Sets the trigger source for the Waveform measurement to external.


Front Panel Operation (802.16 OFDMA)

Front Panel Operation

The test set can be operated using front panel controls and a large video display to perform generator and analyzer functions and obtain measurement results.

For details of 802.16 OFDMA Application front panel operation, refer to the books and topics in this section.

Related Topic: Front Panel Operation (Test Set)


Analyzer Setup Functions

This section describes generic test set setup functionality. These functions can change depending on the currently selected Measurement. This is common test set functionality information that can be used as reference material to better understand some of the unique features that are available in the different measurements in this mode.

For more details, refer to the topics in this section.

Chapter 3 227


AMPTD Y Scale

Some Amplitude features are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Amplitude front-panel key activates the Amplitude menu and selects Reference Level as the active function.

Ref Value

Sets the value for the absolute power reference. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]

Scale/Div

Sets the units per division of the vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center, or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]

Presel Center

When this key is pressed, the centering of the preselector filter is adjusted to optimize the amplitude accuracy at the frequency of the selected marker. If the selected marker is not on when Presel Center is pressed, the test set will turn on the selected marker, perform a peak search, then perform centering on the marker's center frequency. If the selected marker is already on, and between the start and stop frequencies of the test set, the test set performs the preselector calibration on that marker's frequency. If the selected marker is already on, but outside the frequency range between Start Freq and Stop Freq, the test set will first perform a peak search, then perform centering on the marker's center frequency.

A number of considerations should be observed to ensure proper operation:

  • If the selected marker is already on, the test set will attempt the centering at that marker's frequency.

  • There is no preselector for signals below about 3.6 GHz

  • The preselector can be bypassed (see Input/Output, Preselector On/Off). If it is bypassed, no centering will be attempted in that range.

When centering the preselector, *OPC will not return true until the process is complete and a subsequent measurement has completed, nor will results be returned to a READ or MEASure command. Note further that if the box is in a measurement such as averaging when this happens, the act of centering the preselector will restart averaging but the first average trace will not be taken until the centering is completed.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer[:RF]:PCENter


FREQ Channel

This key accesses a menu allowing you to set Frequency parameters for the current measurement. All measurements in 802.16 OFDMA mode have the same menu structure.

Key Path: Front-panel key

Center Freq

Allows you to specify the center frequency of the spectrum analyzer.

Key Path: FREQ Channel

SCPI Command: [:SENSe]:FREQuency:CENTer[?]

Source Freq

Allows you to set the source frequuency to manual or automatic. If set to manual you can specify the frequency.

Key Path: FREQ Channel


Input/Output

The Input/Output features are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

Other functions related to the input/output connections can be found under Trig (trigger input controls) and System (LAN and other I/O bus configurations) and Amplitude (optional internal preamp).

Virtually all the input/output settings are NOT a part of mode preset. They can be set to their default value by one of the three ways - by using the Restore Input/Output Defaults key on the first page of the input/output menu, by using the System->Restore System Defaults->Input/Output Settings or by using the System -> Restore System Defaults->All. Also, they survive Preset and Power cycle.

A very few of the Input/Output settings do respond to a Mode Preset; for example, if the Calibrator is on it turns off on a Preset, and if DC coupling is in effect it switches to AC on a Preset. These exceptions are made in the interest of reliability and usability, which overrides the need for absolute consistency. Exceptions are noted in the SCPI table for the excepted functions.

Freq Ref In

Specifies the frequency reference as being the internal reference, external reference or sensing the presence of an external reference. When the frequency reference is set to internal, the internal 10 MHz reference is used even if an external reference is connected.

When the frequency reference is set to external, the test set will use the external reference. However, if there is no external signal present, or it is not within the proper amplitude range, an error condition detected message is generated. When the external signal becomes valid, the error is cleared.

If Sense is selected, the test set checks whether a signal is present at the external reference connector and will automatically switch to the external reference when a signal is detected. When no signal is present, it automatically switches to the internal reference. No message is generated as the reference switches between external and internal. The monitoring of the external reference occurs approximately on 1 millisecond intervals, and never occurs in the middle of a measurement acquisition, only at the end of the measurement (end of the request).

If for any reason the test set's frequency reference is not able to obtain lock, Status bit 2 in the Questionable Frequency register will be true and an error condition detected message is generated. When lock is regained, Status bit 2 in the Questionable Frequency register will be cleared and an error message is cleared will be sent.

If an external frequency reference is being used, you must enter the frequency of the external reference if it is not exactly 10 MHz. The External Ref Freq key is provided for this purpose.

Key Path: Input/Output

SCPI Commands: [:SENSe]:ROSCillator:SOURce:TYPE[?], [:SENSe]:ROSCillator:SOURce?

Sense

The external reference is used if a valid signal is sensed at the Ext Ref input. Otherwise the internal reference is used.

Key Path: Input/Output, Freq Ref In

Internal

The internal reference is used.

Key Path: Input/Output, Freq Ref In

Restore Input/Output Defaults

This selection causes the group of settings and data associated with Input/Output key to be a reset to their default values. This level of Restore System Defaults does not affect any other system settings or mode settings and does not cause a mode switch. All the features described in this section are reset using this key.

Key Path: Input/Output


SPAN, X Scale

Span features are unique to each Measurement. See the specific Measurement for more information.
The front panel key accesses keys to control span (or X-axis) settings.

Key Path: Front panel key

Chapter 265


Trace/Detector

Trace/Detector features are unique to each Measurement. See the specific Measurement for more information.

The front panel key accesses keys to control Trace and Detector settings.

Key Path: Front panel key


View/Display

The View/Display key opens up the View menu for the current measurement. This menu includes the Display key for controlling items on the display. The Display functions are common across multiple Modes and Measurements and are described in this section. See each measurement description for information on data views that are unique to that Measurement.

Views are different ways of looking at data, usually different ways of looking at the same data, especially when the data represents a time record that is being digitally processed with an FFT and/or other digital signal processing algorithms. In some modes, like the Spectrum Analyzer mode, we are mostly concerned with swept spectrum analysis, and those views may represent different ways of looking at the same signal.

Key Path: Front-panel key

Display

This is a menu common to all measurements for configuring items on the display. Keys not relevant to a given measurement should be grayed out. Keys not relevant to any measurement in a mode should be blanked. The Display menu settings are specific to the measurement selected under the Meas key, except for those settings under the System Display Settings key.

Key Path: View/Display

Annotation

Turns on/off various parts of the display annotation. The annotation is divided up into four categories:

  • Meas Bar: This is the measurement bar at the top of the screen. When the Meas Bar is off, the graticule area expands to fill the area formerly occupied by the Meas Bar.

  • Screen Annotation: this is the annotation and annunciation around the graticule, including any annotation on lines (such as the display line, the threshold line, etc.). This does NOT include the marker number or the N dB result. When off, the graticule expands to fill the entire graticule area.

  • Trace annotation: these are the labels on the traces, showing their detector (or their math mode).

  • Active Function annotation: this is the active function display in the meas bar, and all of the active function values displayed on softkeys.

Key Path: View/Display, Display

Meas Bar On/Off

This function turns the Measurement Bar on and off, including the settings panel. When off, the graticule area expands to fill the area formerly occupied by the Measurement Bar.

Key Path: View/Display, Display, Annotation

Screen

This controls the display of the annunciation and annotation around the graticule, including any annotation on lines (such as the display line, the threshold line, etc.) and the y-axis annotation. This does NOT include marker annotation (or the N dB result). When off, the graticule expands to fill the entire graticule area, leaving only the 1.5% gap above the graticule as described in the Trace/Detector chapter.

Key Path: View/Display, Display, Annotation

Trace

Turns on and off the labels on the traces, showing their detector (or their math mode) as described in the Trace/Detector section.

If trace math is being performed with a trace, then the trace math annotation will replace the detector annotation.

Key Path: View/Display, Display, Annotation

Active Function Values On/Off

Turns on/off the active function display in the Meas Bar, and all of the active function values displayed on the softkeys.

Note that all of the softkeys that have active functions have these numeric values blanked when this function is on. This is a security feature.

Key Path: View/Display, Display, Annotation

Title

Displays softkeys that enable you to change or clear a title on your display.

Key Path: View/Display, Display

Change Title

Writes a title into the ”measurement name” field in the banner (for example, ”Swept SA”.

Press Change Title to enter a new title through the alpha editor. Press Enter or Return to complete the entry. Press ESC to cancel the entry and preserve your existing title.

The display title will replace the measurement name. It remains for this measurement until you press Change Title again, or you recall a state, or a Preset is performed. A title can also be cleared by pressing Title, Clear Title.

Pressing this key cancels any active function.

When a title is edited the previous title remains intact (it is not cleared) and the cursor goes at the end so that characters can be added or BKSP can be used to go back over previous characters.

Key Path: View/Display, Display, Title

Clear Title

Clears a title from the front-panel display. Once cleared, the title cannot be retrieved. After the title is cleared, the current Measurement Name replaces it in the title bar.

Key Path: View/Display, Display, Title

Graticule

Pressing Graticule turns the display graticule On or Off. It also turns the graticule y-axis annotation on and off.

Key Path: View/Display, Display

System Display Settings

These settings are ”Mode Global” – they affect all modes and measurements and are reset only by Restore Misc Defaults or Restore System Defaults under System.

Key Path: View/Display, Display, System Display Settings

Annotation On/Off

This is a Mode Global override of the meas local annotation settings. When it is OFF, it forces Screen Annotation, Meas Bar, Trace and Active Function Values settings to be OFF for all measurements in all modes. This provides the security based ”annotation off” function of previous analyzers, hence it uses the legacy SCPI. Command.

When it is OFF, Screen, Meas Bar, Trace and Active Function Values keys under the Display, Annotation menu are grayed out and forced to OFF. When it is ON, it allows the local annotation settings to be set on a measurement by measurement basis.

To implement this feature properly will require overriding but not changing the local settings for the current measurement. If the measurement changes, the settings for the new measurement must likewise be overridden but not changed. Then if this function turns off, the settings will be returned to their local values.

Key Path: View/Display, Display, System Display Settings, Annotation

Theme

This key allows you to change the Display theme. This is similar to the Themes selection under Page Setup and Save Screen Image. The four themes are detailed below.

  • TDColor – 3D is the standard color theme with filling and shading

  • TDMonochrome – is similar to 3D color, but only black is used

  • FCOLor – flat color is intended for inkjet printers to conserve ink. It uses a white background instead of black.

  • FMONochrome – is like flat color, but only black is used

Key Path: View/Display, Display, System Display Settings, Theme

Backlight On/Off

Allows you to turn the backlight on or off. This setting interacts with settings under the Windows ”Power” menu.

When the backlight is off, pressing ESC, TAB, SPACE, ENTER, UP, DOWN, LEFT, RIGHT, DEL, BKSP, CTRL, or ALT turns the backlight on without affecting the application. Pressing any other key will turn backlight on and could potentially perform the action as well.

Note that pressing this softkey (Backlight On/Off) will turn the backlight back on, simply because a key has been pressed, and then will turn it back off as the key action is taken. So the display will flash and go back to being off.

Key Path: View/Display, Display, System Display Settings

SCPI Command: DISPlay:BACKlight[?]

Backlight Intensity

An active function used to set the backlight intensity. It goes from 0 to 100 where 100 is full on and 0 is off. This value is independent of the values set under the Backlight on/off key.

Key Path: View/Display, Display, System Display Settings

SCPI Command: DISPlay:BACKlight:INTensity[?]

Full Screen

When Full Screen is pressed the measurement window expands horizontally over the entire test set display. The screen graticule area expands to fill the available display area.

It turns off the display of the softkey labels, however the menus and active functions still work. (Though it would obviously be very hard to navigate without the key labels displayed.) Pressing Full Screen again while Full Screen is in effect cancels Full Screen.

Note that the banner and status lines are unaffected. You can get even more screen area for your data display by turning off the Meas Bar (in the Display menu) which also turns off the settings panel. Full Screen is a Mode Global function. Therefore it is not cancelled by the Preset key.

Key Path: Front panel key


Source

This Source key accesses a menu of functions that enable you to generate signals through the internal Arbitrary Waveform Generator.

RF Output

Toggles the operating state of the RF signal present at the RF OUTPUT connector.

Key Path: Source

SCPI Command: SOURce:OUTPut[:STATe][?]

Amplitude

Sets the output power.

Key Path: Source

SCPI Command: SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

ALC State

This command enables or disables the automatic leveling control (ALC) circuit.

Key Path: Source

SCPI Command: SOURce:POWer:ALC[:STATe][?]

Select Waveform

This command selects a waveform file or sequence, for the AWG to play. The file must be present in volatile memory (WFM1) or in the SEQ directory. If a file is in non-volatile memory (NVWFM), use the command ”SOUR:MMEM:COPY[:NAME]” to copy the file to WFM1. Any specified values in the header are applied to the ARB upon selection. Unspecified fields in the header cause no change in the ARB state.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:WAVeform

Marker Polarity

Sets the polarity for the selected marker. For a positive marker polarity, the marker signal is high during the marker points. For a negative marker polarity, the marker signal is high during the period of no marker points.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

File Seg/Seq

Allows you to select a segment (seg) or sequence (seq) file from the non-volatile memory (NVWFM).

Waveform segments or sequences can only be selected if they are loaded in non-volatile memory.

Key Path: Source

File Load/Store

Allows the user to transfer files from volatile memory (WFM1) to non-volatile memory (NVWF1) or vice versa.

When copying a waveform file from volatile to non- volatile memory, the marker file and file header, associated with the waveform file, will automatically be copied at the same time.

Key Path: Source

SCPI Command: SOURce:MMEMory:COPY

Store Segment To Int Media

Allows you to transfer files from non-volatile memory (NVWF1) to volatile memory (WFM1).

Key Path: Source

Load Segment From Int Media

Allows you to transfer files from volatile memory (WFM1) to non-volatile memory (NVWF1).

Key Path: Source

Store All To Int Media

Allows you to transfer all files from non-volatile memory (NVWF1) to volatile memory (WFM1).

Key Path: Source

Load All From Int Media

Front panel access key allows the user to transfer all files from volatile memory (WFM1) to non-volatile memory (NVWF1).

Key Path: Source

Delete Segment

Allows you to delete files from volatile memory (WFM1) or non-volatile memory (NVWF1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete[:NAME]

Delete All Seg From BBG Mem

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete:WFM

Delete All Seg From Int Mem

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete:NVWFm

Refresh List

Refreshes list of file system showing all arbitrary waveform files stored in non-volatile (NVWFM1) and volatile (WFM1) memory.

Key Path: Source

Delete Sequence

Allows the user to delete sequences from memory.

Key Path: Source

ARB On/Off

Enables or disables the arbitrary waveform generator function.

Although you can configure and engage a CW output, no modulation is available at the RF OUTPUT connector until this command is executed.

Key Path: Source

SCPI Command: SOURce:RADio:ARB[:STATe][?]

ARB Sample Rate

This command adjusts the sample clock rate.

SCPI Command: SOURce:RADio:ARB:CLOCk:SRATe[?]

ARB Runtime Scaling

This command adjusts the scaling value in percent that is applied to a waveform while it is playing. The variable <value> is expressed as a percentage. Runtime scaling does not alter the waveform data file. This feature is used to avoid DAC overflow. The scaling is compensated for at the modulator (that is, when the modulator is the optimized path).

Key Path: Source

SCPI Command: SOURce:RADio:ARB:RSCaling[?]

Trigger Type

This command sets the trigger mode (type) that controls the waveform’s playback.

Triggers control the playback by telling the test set when to play the modulating signal (waveform). Depending on the trigger settings for the test set, the waveform playback can occur once, or continuously.

A trigger signal comprises both positive and negative signal transitions (states), which are also called high and low periods. You can configure the test set to trigger on either state of the trigger signal. It is common to have multiple triggers, also referred to as trigger occurrences or events, occur when the signal generator requires only a single trigger. In this situation, the test set recognizes the first trigger and ignores the rest.

When you select a trigger mode, you may lose the signal (carrier plus modulating) from the RF output until you trigger the waveform. This is because the instrument sets the I and Q signals to zero volts prior to the first trigger event, which suppresses the carrier. After the first trigger event, the waveform’s final I and Q levels determine whether you will see the carrier signal or not (zero = no carrier, other values = carrier visible). At the end of most files, the final I and Q points are set to a value other than zero.

There are four parts to configuring the trigger:

  • Choosing the trigger type, which controls the waveform’s transmission.

  • Setting the waveform’s response to triggers:

  • CONTinuous

  • SINGle

  • Selecting the trigger source (see TRIGger[:SOURce]), which determines how the test set receives its trigger signal, internally or externally.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:TRIGger:TYPE[?]

Trigger Source

This command sets the trigger source.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:TRIGger[:SOURce][?]

Marker Routing

Opens a menu with marker routing options.

Pulse/RF Blank

Enables or disables the marker pulse/RF blanking function for the selected marker.

This function automatically uses the ALC hold function, so there is no need to select both the ALC hold and pulse/RF blanking functions for the same marker.

The pulse function incorporates ALC hold. Incorrect automatic level control (ALC) sampling can create a sudden unleveled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:MDEStination:PULSe[?]

ALC Hold

Enables or disables the marker ALC hold function for the selected marker.

Use the ALC hold function when you have a waveform signal that incorporates idle periods, or when the increased dynamic range encountered with RF blanking is not desired. The ALC leveling circuitry responds to the marker signal during the marker pulse (marker signal high), averaging the modulated signal level during this period.

The ALC hold function operates during the low periods of the marker signal. The marker polarity determines when the marker signal is high. For a positive polarity, this is during the marker points. For a negative polarity, this is when there are no marker points. For setting a marker’s polarity, see SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?].

Incorrect automatic level control (ALC) sampling can create a sudden unlevelled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Set Markers

Accesses a menu with ARB marker options.

Key Path: Source, Set Markers

Marker

Sets the active ARB marker.

Key Path: Source, Set Markers

SCPI Command: SOURce:RADio:ARB:MARKer[:SET]

Set Marker On Points Range

Sets a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command.

The test set provides four independent markers. Two of the markers route output signals to rear- panel event connectors, Marker- 1 to Event1 BNC and Marker- 2 to Aux I/O. A marker consists of marker points placed at defined sample points in a waveform segment. This means that a marker point cannot be less than one or greater than the last sample point in the waveform. Marker points are cumulative, so multiple command executions with different range values, without first clearing the existing points, places additional marker points on the waveform. Because of this cumulative behaviour, it is a good practice to clear existing marker points prior to setting new points. This will eliminate unexpected marker pulses. Refer to ”:MARKer:CLEar” and ”:MARKer:CLEar:ALL” for information on clearing marker points.

For waveforms generated on the test set (baseband generator), the test set automatically places a marker point at the first waveform sample for markers one and two.

NOTE If using the front panel, once <first_point>,<last_point> and <skip_count> have been defined the user must press the ”Apply To Waveform” soft key.

NOTE You can set markers for either positive or negative polarity. The following discussions for this command assume positive marker polarity. When using negative marker polarity, the marker pulses occur during the periods of no marker points.

There are three ways to place marker points using this command:

  • consecutive marker points over a range that collectively create a single marker pulse that spansthe range

  • equally spaced marker points over a range, so that a marker pulse occurs at each sample point that coincides with a marker point (Using this method, you can configure a clock signal by setting the <skip_count> variable to one.)

  • a single marker point placed at a specific sample point in the waveform, which outputs a single pulse relative to the marker point location (To configure a single marker point, set the first and last points to the same number.)

The following list describes the command variables:

  • "<file_name>" This variable specifies the name of the waveform file in volatile waveform memory (WFM1).

  • <marker> This variable selects the marker number; an integer value from one to four.

  • <first_point> This variable defines the first point in the range over which the marker is placed. This number must be greater than or equal to one, and less than or equal to the total number of waveform points.

If you enter a value for either the first marker point or the last marker point that would make the first marker point occur after the last, the last marker point is automatically adjusted to match the first marker point.

  • <last_point> This variable defines the last point in the range over which the marker will be placed. This value must be greater than or equal to the first point, and less than or equal to the total number of waveform points.

  • <skip_count> This variable defines the marker point pattern across the range. A zero value means the marker points occur consecutively across the range. A value greater than zero creates a repeating marker point pattern across the range, where the gap between the marker points is equal to the <skip_count> value. The gaps begin after the first marker point. Each marker point in the pattern, which is only one point wide, produces a marker pulse.

SOURce:RADio:ARB:MARKer[:SET]

Set Marker Off Points Range

Clears a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4).

The AWG and all of the ARB modulation formats use this setting.

Key Path: Source, Set Markers

SCPI Command: SOURce:RADio:ARB:MARKer:CLEar

IQ Calibration

Accesses a menu with calibration options.

Execute Cal

Performs an IQ calibration according to the IQ calibration type.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration[:USER]

Calibration Type

Sets the IQ calibration type.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:TYPE[?]

Start Frequency

Sets the start frequency and automatically sets the calibration type to User for an I/Q calibration.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:START[?]

Stop Frequency

Sets the stop frequency and automatically sets the calibration type to User for an I/Q calibration.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:STOP[?]


Marker Functions

Marker

Some Marker operation is common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Marker key accesses the Marker menu. A marker can be placed on a trace to allow the value of the trace at the marker point to be determined precisely. The functions in this menu include a 1-of-N selection of the control mode Normal, Delta, Fixed, or Off for the selected marker. If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules.

Markers may also be used in pairs to read the difference (or delta) between two data points. They can be used in Marker Functions to do advanced data processing, or to specify operating points in functions like Signal Track and N dB Points.

Marker Fctn

Some Marker Functions are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Marker Function key opens up a menu of keys that allow you to control the Marker Functions of the instrument. Marker Functions perform post-processing operations on marker data. Band Functions are Marker Functions that allow you to define a band of frequencies around the marker. The band defines the region of data used for the numerical calculations. These marker functions also allow you to perform mathematical calculations on trace and marker data and report the results of these calculations in place of the normal marker result.

Unlike regular markers, marker function markers are not placed directly on the trace. They are placed at a location which is relative to the result of the function calculation.

Marker To

Some Marker operation is common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

Peak Search

Pressing the Peak Search key displays the Peak Search menu and places the selected marker on the trace point with the maximum y-axis value for that marker's trace. The Peak Search features allow you to define specific search criteria to determine which signals can be considered peaks, excluding unwanted signals from the search.

If Same as "Next Peak" Criteria is selected, and either Pk Excursion or Pk Threshold are on, a signal must meet those criteria. If no valid peak is found, a message is generated and the marker is not moved. When Highest Peak is on, or both Pk Excursion and Pk Threshold are off, the marker is always placed at the point on the trace with the maximum y-axis value, even if that point is on the very edge of the trace (exception: negative frequencies and signals close to the LO are not searched at all).

Pressing Peak Search with the selected marker off causes the selected marker to be set to Normal at the center of the screen, then a peak search is immediately performed.


Measurement Functions

Some of the content described in this section is not directly applicable to the 802.16 OFDMA Mode. This is common test set functionality information that can be used as reference material. It provides additional information about some of the unique features that are available in the measurements in this mode.

For more details, refer to the topics in this section.

Chapter 5 285


802.16 OFDMA (N6301A)

Meas

Last Updated: March 28, 2008

The information in this section is common to all measurements. For key and remote command information on each measurement, refer to the section which describes the measurement of interest.

Measurements available under the Meas key are specific to the current Mode.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

When viewing Help for measurements, note the following:

You cannot get help for a measurement by pressing one of the measurement softkeys. One way to get help for a measurement is through the Help table of contents, which contains a book for each measurement. To see help for a measurement, click its book in the table of contents. For example, click the “ACP Measurement” book in the table of contents to display help for the ACP measurement.

Operation for some keys differ between measurements. The information displayed in Help
pertains to the current measurement. To see how a key operates in a different measurement, exit Help (press the Cancel Esc key), select the measurement, then reenter Help (press the Help key) and press that key.

Key Path: Front Panel Key

Command Interactions: MEASure, CONFigure, FETCh, INITiate and READ

Each one-button measurement has a group of commands that work together to make the measurement fast, but flexible.

Measurement Group of Commands

Measure Commands

MEASure:<measurement>[n]?

This is a fast single-command way to make a measurement using the factory default test set settings. These are the settings and units that conform to the Mode Setup settings (e.g. radio standard) that you have currently selected.

  • Stops the current measurement (if any) and sets up the test set for the specified measurement using the factory defaults

  • Initiates the data acquisition for the measurement

  • Blocks other SCPI communication, waiting until the measurement is complete before returning results.

  • If the function does averaging, it is turned on and the number of averages is set to 10.

  • After the data is valid it returns the scalar results, or the trace data, for the specified measurement. The type of data returned may be defined by an [n] value that is sent with the command.

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available.

ASCII is the default format for the data output. (Older versions of Spectrum Analysis and Phase Noise mode measurements only use ASCII.) The binary data formats should be used for handling large blocks of data since they are smaller and faster than the ASCII format. Refer to the FORMat:DATA command for more information.

If you need to change some of the measurement parameters from the factory default settings you can set up the measurement with the CONFigure command. Use the commands in the SENSe:<measurement> and CALCulate:<measurement> subsystems to change the settings. Then you can use the READ? command to initiate the measurement and query the results.

If you need to repeatedly make a given measurement with settings other than the factory defaults, you can use the commands in the SENSe:<measurement> and CALCulate:<measurement> subsystems to set up the measurement. Then use the READ? command to initiate the measurement and query results.

Measurement settings persist if you initiate a different measurement and then return to a previous one. Use READ:<measurement>? if you want to use those persistent settings. If you want to go back to the default settings, use MEASure:<measurement>?.

Configure Commands

CONFigure:<measurement>

This command stops the current measurement (if any) and sets up the test set for the specified measurement using the factory default test set settings. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON. If you change any measurement settings after using the CONFigure command, the READ command can be used to initiate a measurement without changing the settings back to their defaults. In the Swept SA measurement in Spectrum Analyzer mode the CONFigure command also turns the averaging function on and sets the number of averages to 10 for all measurements.

:CONFigure:NDEFault<measurement> stops the current measurement and changes to the specified measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

The CONFigure? query returns the current measurement name.

Fetch Commands

FETCh:<measurement>[n]?

This command puts selected data from the most recent measurement into the output buffer. Use FETCh if you have already made a good measurement and you want to return several types of data (different [n] values, for example, both scalars and trace data) from a single measurement. FETCh saves you the time of re-making the measurement. You can only FETCh results from the measurement that is currently active, it will not change to a different measurement. An error is reported if a measurement other than the current one, is specified. If you need to get new measurement data, use the READ command, which is equivalent to an INITiate followed by a FETCh.

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available. The binary data formats should be used for handling large blocks of data since they are smaller and transfer faster then the ASCII format. (FORMat:DATA) FETCh may be used to return results other than those specified with the original READ or MEASure command that you sent.

INITiate Commands

INITiate:<measurement>

This command is not available for measurements in all the test set modes:

  • Initiates a trigger cycle for the specified measurement, but does not output any data. You must then use the FETCh<meas> command to return data. If a measurement other than the current one is specified, the test set will switch to that measurement and then initiate it.

For example, suppose you have previously initiated the ACP measurement, but now you are running the channel power measurement. If you send INIT:ACP? it will change from channel power to ACP and will initiate an ACP measurement.

  • Does not change any of the measurement settings. For example, if you have previously started the ACP measurement and you send INIT:ACP? it will initiate a new ACP measurement using the same test set settings as the last time ACP was run.

  • If your selected measurement is currently active (in the idle state) it triggers the measurement, assuming the trigger conditions are met. Then it completes one trigger cycle. Depending upon the measurement and the number of averages, there may be multiple data acquisitions, with multiple trigger events, for one full trigger cycle. It also holds off additional commands on GPIB until the acquisition is complete.

READ Commands

READ:<measurement>[n]?

  • Does not preset the measurement to the factory default settings. For example, if you have previously initiated the ACP measurement and you send READ:ACP? it will initiate a new measurement using the same test set settings.

  • Initiates the measurement and puts valid data into the output buffer. If a measurement other than the current one is specified, the test set will switch to that measurement before it initiates the measurement and returns results.

For example, suppose you have previously initiated the ACP measurement, but now you are running the channel power measurement. Then you send READ:ACP? It will change from channel power back to ACP and, using the previous ACP settings, will initiate the measurement and return results.

Blocks other SCPI communication, waiting until the measurement is complete before returning the results:

If the optional [n] value is not included, or is set to 1, the scalar measurement results will be returned. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available. The binary data formats should be used when handling large blocks of data since they are smaller and faster then the ASCII format. (FORMat:DATA)


Meas Setup

Last Updated: March 28, 2008

Meas Control features are unique to each Measurement. See the specific Measurement for more information.

Key Path: Front panel key


Mode

Last Updated: March 28, 2008

The Mode key allows you to select the available measurement applications. The application software must be loaded and licensed for it to be available. Measurement applications are a collection of measurement capabilities packaged together to provide an test set personality that is specific to your measurement needs. Each mode software product is ordered separately by Model Number. The default measurement mode is the first listing in the menu.

Key operation can be different between modes. The information displayed in Help is about the current mode.

To access Help for a different Mode you must first exit Help (by pressing the Cancel (Esc) key). Then select the desired mode and re-access Help.

A list of the valid mode choices is returned with the INST:CAT? Query. Once a test set mode is selected, only the commands that are valid for that mode can be executed.

Key Path: Front panel key

SCPI Commands: INSTrument:CATalog?, INSTrument:DEFault, INSTrument:NSELect[?], INSTrument[:SELect][?], SYSTem:APPLication:CATalog[:NAME]?, SYSTem:APPLication:CATalog[:NAME]:COUNt?, SYSTem:APPLication:CATalog:OPTion?, SYSTem:APPLication:CATalog:REVision?, SYSTem:APPLication[:CURRent][:NAME]?, SYSTem:APPLication[:CURRent]:OPTion?, SYSTem:APPLication[:CURRent]:REVision?


Mode Setup

Key Path: Front panel

Radio Device

Allows you to specify the device to be used. Radio device BTS is called BS in the WiMAX-OFDMA mode. BS is used in
front panel and BTS is used for the remote command.

Key Path: Mode Setup

SCPI Command: [:SENSe]:RADio:STANdard:DEVice[?]

Radio Standard

The following standards for WiMAX are supported:

  • IEEE 802.16e–2005

  • WiBro (Korean mobile WiMAX-OFDMA service

Key Path: Mode Setup

SCPI Command: [:SENSe]:RADio:STANdard[?]

Preset Profile

802.16e–2005 mode

Key Path: Mode Setup, Radio Std, 802.16e–2005

SCPI Command: [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

WiBro mode

Key Path: Mode Setup, Radio Std, WiBro

SCPI Command: [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

FFT Size

OFDMA supports a scalable frame structure where the FFT size scales with bandwidth to keep subcarrier spacing fixed. Four FFT ”NFFT” sizes are specified by the OFDMA standard: 128, 512, 1024 and 2048.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

BW Ratio

BW Ratio is defined as the ratio between the OFDMA FFT sample rate and the nominal channel bandwidth. The 802.16 Standard specifies that the BW Ratio be set to 8/7 or 28/25 depending on the nominal bandwidth of the test signal.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

Guard Interval

IEEE 802.16 OFDMA supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

Frame Duration

The Frame Duration parameter specifies OFDMA frame duration in units of time.

You can use the Radio Standard or Radio Device preset to set the Frame Duration to a value specified in the OFDMA standard or you can specify an arbitrary value manually in the Frame Duration parameter.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:FDURation[?]

Downlink Ratio

Downlink Ratio, expressed as a percentage, is the ratio of the downlink subframe length (including the TTG) to the frame length. Downlink Ratio defines where the uplink subframe starts relative to the start of the frame. A 30% Downlink Ratio means that 30% of the frame length is downlink subframe and 70% is uplink subframe.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:DRATio[?]


Restart

The Restart function restarts the current sweep, or measurement, or set of averaged/held sweeps or measurements.

The Restart function is accessed in several ways:

  • Pressing the Restart key

  • Sending the remote command INIT:IMMediate

  • Sending the remote command INIT:RESTart

The Restart function first aborts the current sweep/measurement as quickly as possible. It then resets the sweep and trigger systems, sets up the measurement and initiates a new data measurement sequence with a new data acquisition (sweep) taken once the trigger condition is met.

If the analyzer is in the process of aligning when Restart is executed, the alignment finishes before the restart function is performed.

Even when set for Single operation, multiple sweeps may be taken when Restart is pressed (for example, when averaging/holding is on). Thus when we say that Restart "restarts a measurement," we may mean:

  • It restarts the current sweep

  • It restarts the current measurement

  • It restarts the current set of sweeps if any trace is in Trace Average, Max Hold or Min Hold

  • It restarts the current set of measurements if Averaging, or Max Hold, or Min Hold is on for the measurement depending on the current settings.

With Average/Hold Number (in Meas Setup menu) set to 1, or Averaging off, or no trace in Trace Average or Hold, a single sweep is equivalent to a single measurement. A single sweep is taken after the trigger condition is met; and the analyzer stops sweeping once that sweep has completed. However, with Average/Hold Number >1 and at least one trace set to Trace Average, Max Hold, or Min Hold (SA Measurement) or Averaging on (most other measurements), multiple sweeps/data acquisitions are taken for a single measurement. The trigger condition must be met prior to each sweep. The sweep is stopped when the average count k equals the number N set for Average/Hold Number . A measurement average usually applies to all traces, marker results, and numeric results; but sometimes it only applies to the numeric results.

Once the full set of sweeps has been taken, the analyzer will go to idle state. To take one more sweep without resetting the average count, increment the average count by 1, by pressing the step up key while Average/Hold Number is the active function, or sending the remote command CALC:AVER:TCON UP.

SCPI Status Bits/OPC Dependencies: This is an Overlapped command. The STATus:OPERation register bits 0 through 8 are cleared.
The STATus:QUEStionable register bit 9 (INTegrity sum) is cleared. The SWEEPING bit is set. The MEASURING bit is set.

SCPI Commands: INITiate[:IMMediate], INITiate:RESTart


Cont (Continuous Measurement/Sweep)

Sets the test set for Continuous measurement operation. The single/continuous state is Meas Global so the setting will affect all measurements.

Key Path: Front panel key

SCPI Command: INITiate:CONTinuous[?]

In Swept SA Measurement (Spectrum Analysis Mode):

The test set takes repetitive sweeps, averages, measurements, etc. when in Continuous mode. When the average count reaches the Average/Hold Number the count stops incrementing but the test set keeps sweeping. See the Trace/Detector section for the averaging formula used both before and after the Average/Hold Number is reached. The trigger condition must be met prior to each sweep. The type of trace processing for multiple sweeps, is set under the Trace/Detector key, with choices of Trace Average, Max Hold, or Min Hold.

In Other Measurements/Modes:

With Avg Number (in Meas Setup menu) set to Off or set to On with a value of 1, a sweep is taken after the trigger condition is met; and the test set continues to take new sweeps after the current sweep has completed and the trigger condition is again met. However, with Avg Number set to On with a value >1, multiple sweeps (data acquisitions) are taken for the measurement. The trigger condition must be met prior to each sweep. The sweep is not stopped when the average count k equals the number N set for Avg Number is reached, but the number k stops incrementing. A measurement average usually applies to all traces, marker results, and numeric results. But sometimes it only applies to the numeric results.

If the test set is in Single measurement, pressing the Continuous key does not change k and does not cause the sweep to be reset; the only action is to put the test set into Continuous measurement operation.

If it's already in continuous sweep:

  • the INIT:CONT 1 command has no effect

  • the INIT:CONT 0 command will place the test set in Single Sweep but will have no effect on the current sequence until k=N, at which point the current sequence will stop and the test set will go to the idle state.


Single (Single Measurement/Sweep)

Single sets the test set for Single measurement operation. The single/continuous state is Meas Global, so the setting will affect all the measurements.

Key Path: Front panel key

SCPI Command: INITiate:CONTinuous[?]

See Restart for details on the INIT:IMMediate (Restart) function.

If you are already in single sweep, the INIT:CONT OFF command has no effect. If you are already in Single Sweep, pressing the Single key in the middle of a sweep or if the sweep is not in the idle state (for instance, if you are taking a very slow sweep, or the test set is waiting for a trigger) results in a message.

To take one more sweep without resetting the average count, increment the average count by 1, by pressing the step up key while Average/Hold Number is the active function, or sending the remote command CALC:AVER:TCON UP.

Chapter 319


Sweep/Control

This section describes the keys in the Sweep, Control and Capture menu that are common to multiple Modes and Measurements. See the Measurement descriptions for information on features that are unique.

The Meas Uncal (measurement uncalibrated) warning is given in the Status Bar in
the lower right corner of the screen when the manual sweep time entered is shorter
than what is computed by the test set.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Front panel key

SCPI Commands: INITiate:PAUSe, INITiate:RESume


Trigger

The Trig front panel key accesses the Trigger menu which contains keys to control the selection of the Trigger source and settings.

The Trigger settings are common for all Measurements and these features are described in this section. The selection of the Trigger Source is unique for each Measurement. See the measurement description for information on trigger source and any other unique features.

The trigger functions let you select the trigger settings for a sweep or measurement. When using a trigger source other than Free Run, the test set will begin a sweep only with the selected trigger conditions are met. A trigger event is defined as the point at which your trigger source signal meets the specified trigger level and polarity requirements (if any). In FFT measurements, the trigger controls when the data is acquired for FFT conversion.

For each source in the Trigger menu, a setup menu exists which can be accessed by pressing the key for that trigger source a second time. For example, one press of Video selects the Video trigger as the source. The Video key becomes highlighted and the hollow arrow on the key turns black. Now a second press of the key takes you into the Video Trigger Setup menu. The setup menus (there is one for each trigger source) allow you to set all of the settings for that trigger source as desired. Each source's trigger settings (for example, level, delay and slope) are the same for the Trigger menu, the Gate Source menu, and the Sync Source menu that is part of the Periodic Timer Trigger Setup menu. That is, if Ext1 trigger level is set to 1 v in the Trigger menu, it will appear as 1 v in both the Gate Source and the Sync Source menus. For this reason, the only SCPI node that exists for the settings is the TRIGger[:SEQuence] menu.

The trigger settings are common to all applications (modes). However, each application may have its own ranges and default value settings. Also, some applications may have trigger features that are unavailable because they don't make sense for that particular application.

The trigger source is uniquely selected for each measurement in the application. The trigger source setting is the only trigger parameter that is meas local, applying only to the current measurement.

Key Path: Front-panel key

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

SCPI Status Bits/OPC Dependencies: The Status Operation Register bit 5 ”Waiting for Trigger” is set at the same time as the Sweeping or Measuring bit is set. It is cleared when the trigger actually occurs (that is, after the trigger event occurs and all the applicable trigger criteria have been met).

Trigger Setup Parameters

The following examples show trigger setup parameters using an external trigger source.

Example 1 illustrates the trigger conditions with negative slope and no trigger occurs during trigger Holdoff time.

Example 2 illustrates the trigger conditions with positive slope, trigger delay, and auto trigger time.

Free Run

Pressing this key, when it is not selected, selects free-run triggering. Free run triggering occurs immediately after the sweep/measurement is initiated.

Key Path: Trigger, Free Run

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

External

Pressing this key, when it is not selected, selects an external input signal as the trigger. A new sweep/measurement will start when the external trigger condition is met using the ANALYZER TRIG IN connector on the rear panel.

Pressing this key, when it is already selected, accesses the external trigger setup menu.

Key Path: Trigger, External

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

RF Burst (Wideband)

Pressing this key, when it is not selected, selects the RF Burst as the trigger. A new sweep/measurement will start when an RF burst envelope signal is identified from the signal at the RF Input connector. Pressing this key, when it is already selected, accesses the RF Burst trigger setup menu.

Key Path: Trigger, RF Burst (Wideband)

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

Trigger Level

Sets the absolute trigger level for the RF burst envelope. See key notes regarding the relative trigger level.

Key Path: Trigger, RF Burst (Wideband), Trigger Level

SCPI Command: TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

Trigger Slope

It is set positive to trigger on a rising edge and negative to trigger on a falling edge.

Key Path: Trigger, RF Burst (Wideband), Trig Slope

SCPI Command: TRIGger[:SEQuence]:RFBurst:SLOPe[?]

Trig Delay

Controls a time delay during which the test set will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the test set in time domain or FFT, but not in swept spans.

Key Path: Trigger, RF Burst (Wideband), Trig Delay

SCPI Commands: TRIGger[:SEQuence]:RFBurst:DELay[?], TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

Trig Holdoff

Sets the holdoff time between triggers. When the trigger condition is satisfied, the trigger occurs, the delay begins, and the holdoff time begins. New trigger conditions will be ignored until the holdoff time expires. For a free-running trigger, the holdoff value is the minimum time between triggers.

Key Path: Trigger, Trig Holdoff

SCPI Commands: TRIGger[:SEQuence]:HOLDoff[?], TRIGger[:SEQuence]:HOLDoff:STATe[?]


OFDMA Modulation Analysis Measurement

Invokes Modulation Analysis measurement, including Spectrum Flatness measurement.

For more details, refer to the topics in this section.

Key Path: Meas

SCPI Commands: [:SENSe]:EVM, CONFigure:EVM, CONFigure:EVM:NDEFault, INITiate:EVM, FETCh:EVM{0:20}?, MEASure:EVM{0:20}?, READ:EVM{0:20}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


AMPTD Y Scale (OFDMA Modulation Analysis)

The AMPTD Y Scale key accesses the menus that allows you to set the desired vertical scale and associated settings. The settings available vary depending on the active window focus.

Key Path: Front panel key

Input Range

Allows you to enter the input power range.

Key Path: AMPTD Y Scale, Input Range

SCPI Command: [ :SENSe]:POWer:RANGe[?]


802.16 OFDMA (N6301A)

View/Display (OFDMA Modulation Analysis)

Last Updated: March 11, 2008

Accesses a menu that allows you to select from the following measurement view and display settings:
NOTE: the view setting options depend on the measurement view that is active.

  • I/Q Measured Polar Constellation - Provides a combination view of an I/Q Symbol Constellation graph and the summary data.

  • Zone & Data Burst Info – Provides a combination view of a Zone list table, the selected map graph, and the Data Burst list table.

  • Symbol Error (Quad View) – Provides a combination view of a Symbol Error vs. Subcarrier graph, Symbol Error vs. Symbol graph, I/Q Symbol Constellation graph, and Zone Definition Map graph.

  • Symbol Power (Quad View) – Provides a combination view of a Symbol Power vs. Subcarrier graph, Symbol Power vs. Symbol graph, IQ Measured Constellation, and Zone Definition Map graph.

  • Peak/Average Metrics – Provides a table of the summary for the measurement result and information at the selected burst.

  • Spectral Flatness – Provides a combination view of a Spectral Flatness graph and a Differential Spectral Flatness graph, and summary data.

  • Power vs Time & Spectrum – Provides a combination view of a Power vs Time graph and a Power vs. Spectrum graph.

Key Path: Front panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title

I/Q Measured Polar Constln

Provides a combination view of an I/Q Symbol Constellation graph and the summary data.

Key Path: View/Display

Zone & Data Burst Info

Provides a combination view of a Zone list table, the selected map graph, and the Data Burst list table.

Key Path: View/Display

Symbol Error (Quad View)

Provides a combination view of a Symbol Error vs. Subcarrier graph, Symbol Error vs. Symbol graph, I/Q Symbol Constellation graph, and Zone Definition Map graph.

Key Path: View/Display

Symbol Power (Quad View)

Provides a combination view of a Symbol Power vs. Subcarrier graph, Symbol Power vs. Symbol graph, IQ Measured Constellation, and Zone Definition Map graph.

Key Path: View/Display

Peak/Average Metrics

Provides a table of the summary for the measurement result and information at the selected burst.

Key Path: View/Display

Spectral Flatness

Provides a combination view of a Spectral Flatness graph and a Differential Spectral Flatness graph, and summary data.

Key Path: View/Display, More

Power vs Time & Spectrum

Provides a combination view of a Power vs Time graph and a Power vs. Spectrum graph.

Key Path: View/Display, More

OBW Line

Allows you to display OBW values and range.

Key Path: View/Display, Power vs Spectrum

Inactive Subchannels in EVM

Lets you include the inactive subchannels in the EVM traces (this only applies to Data Burst Analysis mode). This parameter does not affect the EVM calculation. If this parameter is set to ”Include”, the EVM results will include the EVM value of the Unmodulated subchannels, and I/Q Meas will include the Unmodulated subcarriers' constellation.

Key Path: View/Display, I/Q Measured Polar Contln


Trace/Detector (OFDMA Modulation Analysis)

There is no 'Trace/Detector' functionality supported in Modulation Analysis so this front-panel key will display a blank softkey when pressed.

Key Path: Trace Detector


Meas Setup (OFDMA Modulation Analysis)

Accesses menus that allow you to set measurement setup parameters.

Key Path: Front panel key

Avg/Hold Num

Set the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:AVERage:COUNt[?], [:SENSe]:EVM:AVERage[:STATe][?]

Avg Mode

Selects the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

When Measure is set at Cont, data acquisitions will continue indefinitely. After N averages, exponential averaging is used with a
weighting factor of N (the displayed average count stops at N). Exponential averaging weights new data more than old data, which
allows tracking of slow-changing signals.

When Measure is set at Cont, data acquisitions will continue indefinitely. After N averages is reached, all previous result data is
cleared and the average count is set back to 1. This is equivalent to being in Measure Single and pressing the Restart key when the
Single measurement finishes.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:AVERage:TCONtrol[?]

Capture Interval

Sets the data capture length in frames that will be used in the acquisition. If Average is set to On, all capture data are analyzed and their results are averaged until the average number count is reached.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

Meas Offset

Sets the timing offset of the capture interval in frames. If the Capture Interval is 1 frame, Meas Offset is fixed at ”0”. If Average is set to On, the frame that is analyzed does not take into account this offset value during averaging. After this measurement is complete, changing the offset value will result in running post-processing to analyze the offset frame; the measurement results are then updated (only for non-averaged results).

Key Path: Meas Setup

SCPI Command: CALCulate:EVM:SWEep:OFFSet[?]

Limits

Accesses measurement setup limit parameters.

Key Path: Meas Setup

RMS RCE

Accesses RMS RCE measurement setup limit parameters.

Key Path: Meas Setup, Limits

Limits

Sets the limit state for the RMS EVM measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

Composite

Sets the limit for RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Commands: CALCulate:EVM:LIMit[1]|2:RRCE[?], CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

QPSK–1/2

Sets the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

QPSK–3/4

Sets the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

16QAM–1/2

Sets the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

16QAM–3/4

Sets the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

64QAM–1/2

Sets the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

64QAM–2/3

Sets the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

64QAM–3/4

Sets the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

Peak RCE

Sets the limit for the Peak RCE measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:PRCE[?], CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

Pilot RCE

Sets the limit for the Pilot RCE measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:RCEPilot[?], CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

Frequency Error

Sets the limit in ppm for the absolute Frequency Error measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:FERRor[?], CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

Time Offset

Sets the limit for the Time Offset measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:TOFFset[?], CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

I/Q Offset

Sets the limit state for the I/Q Offset measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:IQOFfset[?], CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

Abs Spectral Flatness

Accesses menu that allows you to set absolute spectral flatness measurement setup parameters.

Key Path: Meas Setup, Limits, More

Offset

Selects the offset pairs (upper and lower) that the softkeys affect, and displays the memory selection menu from A to F. The memory selection menu allows you to store up to 5 sets of limit values for the offset pairs, such as Start Subcarrier/ Stop Subcarrier, Upper Mask Start/Upper Mask Stop, and Lower Mask Start/Lower. Press Offset until the letter of the desired offset (A, B, C, D, E, or F) is underlined. Only one selection at a time is shown on this softkey label.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

Start Subcarrier

Specifies the start subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

Stop Subcarrier

Allows you to specify the stop subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

Offset Side

Specifies which offset side will be measured.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

Upper Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

Upper Mask Stop

Sets the upper mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from –100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, and results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

Lower Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

Lower Mask Stop

Sets the lower mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from –100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

Diff Spectral Flatness

Accesses a menu that allows you to set differential spectral flatness measurement setup parameters.

Key Path: Meas Setup, Limits, More

Offset

Selects the offset pairs (upper and lower) that the selected softkeys will affect, and displays the memory selection menu from A to F. The memory selection menu allows you to store up to 5 sets of limit values for the offset pairs, such as Start Subcarrier, Stop Subcarrier, Upper Mask Start, Upper Mask Stop, Lower Mask Start, Lower Mask Stop and Offset Side. Press Offset until the letter of the desired offset (A, B, C, D, E, or F) is underlined. Only one selection at a time is shown on this softkey label.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

Start Subcarrier

Specifies the start subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

Stop Subcarrier

Allows you to specify the stop subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

Offset Side

Specifies which offset side will be measured.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

Upper Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

Upper Mask Stop

Sets the upper mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from –100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

Lower Mask Start

Sets the lower limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

Lower Mask Stop

Sets the lower mask limit at the stop subcarrier for the selected offset. The lower mask limit ranges from –100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Lower Mask Stop power level limit is coupled to Lower Mask Start, which results in a flat limit line. If set to Man, Lower Mask Start and Lower Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

Zone/Data Burst Map

Selects the Zone Definition which defines the zone information.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:MAP:SELect:TYPE[?]

Custom Map

This key displays the name of the custom Zone Burst map currently employed by the Modulation Analysis measurement. If you Recall a Zone Burst Map, the file name will appear on the key label.

Key Path: Meas Setup, Zone/Data Burst Map

Change Map Name

Sets the customized Map name.

Key Path: Meas Setup, More, Zone Data Burst Map, Custom Map

SCPI Command: CALCulate:EVM:MAP:CUSTom:NAME[?]

Auto Detect Now

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

Key Path: Meas Setup, More, Zone Data Burst Map

SCPI Command: CALCulate:EVM:MAP:DETect

Zone Num

Selects the zone definition to be used.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE[?]

Burst Analysis

Selects a method of burst analysis. You can choose between the burst map method or the single burst method.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:BURSt:TYPE[:SELect][?]

Burst Map

Analyzes a frame according to the defined map information.

Key Path: Meas Setup, Data Burst Analysis

Use Defined Boosting Level

Selects whether to automatically set boosting levels, or to use the values that are specified for the bursts.

Key Path: Meas Setup, Data Burst Analysis, Burst Map

SCPI Command: CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

Single Burst

Accesses single burst parameters.

Key Path: Meas Setup, Data Burst Analysis

Subchan Offset

Set the number of the Subchannel logical offset for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: C ALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

Burst Region Subchannel Interval

Set the number of the subchannel logical interval for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

Symbol Offset

Set the number of the OFDMA symbol offset for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

Symbol Interval

Set the number of the OFDMA symbol interval for the burst position.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

Burst Shape

Selects between wrapped or rectangle burst shapes.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SHAPe[?]

Data Mod Type

Selects the Data Modulation Type to be used.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

Uniform Zone

Defines a single burst as a Uniform Zone.

Key Path: Meas Setup, More, Burst Analysis

Data Mod Type

Selects the Data Modulation Type to be used.

Key Path: Meas Setup, More, Burst Analysis, Uniform Zone

SCPI Command: CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

Zone Offset

Allows you to set the Zone Offset in symbols.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE:OFFSet[?]

Zone Interval

Allows you to set Zone Interval in symbols.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE:INTerval[?]

Data Burst Select

The test set allows single or multiple burst analysis. To select all data burst for analysis, press 'All On' key. To select a single data burst for analysis, press 'Single' key on a selected Data Burst Num. To select multiple data bursts for analysis, turn on a selected Data Burst Num.

Key Path: Meas Setup, More

Data Burst Num

Allows you to select multiple data bursts for analysis when it is set to On.

Key Path: Meas Setup, More, Data Burst Select

SCPI Command: CALCulate:EVM:BURSt[1]|2:STATe[?]

All On

Allows you to select all data burst for analysis.

Key Path: Meas Setup, More, Data Burst Select

Single

Allows you to select a single data burst for analysis.

Key Path: Meas Setup, More, Data Burst Select

Preamble Index

Sets the number that the Preamble Index specifies for the preamble sequence of the downlink subframe. This parameter is available only in BS mode.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:PINDex[?]

Subchannel Group Bitmask

Specifies which subchannel groups are allocated to the segment. The DL PUSC zone definition provides 6 subchannel groups which specify the number of used subchannels and how they are mapped to subcarriers for analysis of DL-PUSC data bursts. This parameter is available only in BS mode.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:SUBChannel:MASK[?]

UL Permbase

Sets the Uplink Permbase number for MS measurement. This parameter is needed to determine subcarrier allocation.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:MS:PBASe[?]

Advanced

Accesses advanced features. These features are recommended for use only by advanced users.

Key Path: Meas Setup, More

Pilot in RMS/Pk RCE

Lets you include the Pilot in RCE calculations.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:PILot[?]

Spectrum

Sets a spectrum to either normal or to inverted for demodulation related measurements. If set to INVert, the upper and lower spectrums are swapped.

The invert function conjugates the spectrum, which is equivalent to taking the negative of the quadrature component in demodulation. The correct setting (Normal or Invert) depends on whether the signal at the input of the test set has a high or a low side mix.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:SPECtrum[?]

Symbol Timing Adjust

Symbol Timing Adjust allows you to adjust the ”useful symbol time period” (TFFT) within the ”OFDMA extended symbol time period” (TS). Symbol Timing Adjust shifts the start of the TFFT period to earlier in the TS time period. You specify the amount of TFFT shift as a percentage of the TFFT length.

The extended OFDMA symbol time period (TS) consists of a guard interval (TGI) plus a ”useful symbol time period” (T

FFT). Within the TS, the test set performs the demodulation and data analysis on only one TFFT time period. The Symbol Time Adjust parameter allows you to move the TFFT within the TS.

Typically, the TGI time period is ignored and only the TFFT time period is used. The Symbol Time Adjust parameter causes the demodulation start time to begin earlier within each extended symbol time. The minimum Symbol Time Adjust value is equal to ”-(guard interval)/100”, the maximum value is ”0” (full guard interval).

The Symbol Time Adjust parameter is reset to the default value whenever the Guard Interval is changed. The default value is –3.125%, if the guard interval is 1/16 or greater. The default value is equal to TGI*100/2 (half the guard interval) when the guard interval is less than 1/16.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:SYMBol:ADJust[?]

Pilot Tracking

802.16 OFDMA performs demodulation relative to the data in pilot carriers embedded in the signal. These pilot carriers replace data-carrying elements of the signal and allow some kinds of impairments to be removed or ”tracked out”.

Many impairments will be common to all pilot carriers and can be measured and displayed as ”common pilot error”.

In addition, several specific tracking functions can be individually switched on and off in the demodulation performed by this measurement. This is a very useful troubleshooting approach, since modulation errors can be examined with and without the benefit of particular types of pilot tracking.

Key Path: Meas Setup, More, More, Advanced

Track Amplitude

Track Amplitude specifies whether the test set tracks amplitude changes in the pilot subcarriers. When Track Amplitude is selected, the test set applies pilot subcarrier amplitude error correction to the pilot and data subcarriers. This is in addition to Track Phase and Track Timing error correction, if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:AMPLitude[?]

Track Phase

The Track Phase parameter specifies whether the test set tracks phase changes in the pilot subcarriers. When Track Phase is selected, the test set applies pilot subcarrier phase error correction to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Timing error correction if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:PHASe[?]

Track Timing

The Track Timing parameter specifies whether the test set tracks timing changes in the pilot subcarriers. Track Timing applies pilot subcarrier timing error correction (frequency offset correction) to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Phase error correction if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:TIMing[?]

Equalizer Training

When demodulating the 802.16 OFDMA signal, the test set uses an equalizer to correct for linear impairments in the signal path, such as multi-path. The test set supports three different methods to initialize, or ”train”, the equalizer: Preamble Only, Preamble, Data & Pilots and Preamble & Pilots Only. Selecting an appropriate method can help isolate problems that contribute to increased RCE (EVM).

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:EQUalizer:TMODe[?]

Equalizer Smoothing

This parameter determines whether a spectral flatness result trace are smoothed.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More, More

SCPI Command: CONFigure:EVM


Trigger (OFDMA Modulation Analysis)

Accesses a menu that allows you to set triggering parameters for the current measurement. See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:EVM[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the ”Measurement Functions” section for more information on trigger settings.

Key Path: Trigger


Sweep/Control (OFDMA Modulation Analysis)

Accesses settings that affect the sweep viewed in the display.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Front panel key


Marker (OFDMA Modulation Analysis)

Sets the marker control mode as described under Normal, Delta and Off, below. All interactions and dependencies detailed under the key description are enforced when the remote command is sent.

Key Path: Front panel key

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses a menu that enables you to select the active marker, the reference marker and the trace for the current measurement.

Key Path: Marker

Select Marker

Key Path: Marker

Relative To

Selects the marker that the selected marker will be relative to - its reference marker.

Key Path: Marker, Properties

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Accesses a menu that allows you to assign a specified marker to the designated trace.

Symbol Traces means that three traces for I/Q polar, Symbol Error Carrier, Symbol Error Symbol, Symbol Power Carrier, and Symbol Power Symbol can be assigned. If used, a marker pointer is placed on each trace. In this case, the three pointers will move at the same time, as coupled markers, whenever the X position of the Symbol Traces changes.

Key Path: Marker, Properties

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

All Markers Off

Turns all markers off.

Key Path: Marker, More

SCPI Command: CALCulate:EVM:MARKer:AOFF


Peak Search (OFDMA Modulation Analysis)

Accesses menus that allow you to set peak search parameters.

Key Path: Front panel key

Peak Search

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace.

Key Path: Front panel key

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Next Peak

Moves the selected marker to the peak that has the next highest amplitude that is less than the marker's current value.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

Next Pk Right

Moves the selected marker to the next peak to the right of the current marker.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

Next Pk Left

Moves the selected marker to the next peak to the left of the current marker.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

Marker Delta

Performs the same function as the Delta 1-of-N selection key in the Marker menu. This sets the control mode for the selected marker to Delta mode. The softkey allows you to conveniently perform a peak search and change the marker's control mode to Delta without having to access two separate menus.

Key Path: Peak Search

Pk-Pk Search

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

Min Search

Moves the selected marker to the minimum y-axis value of the current trace.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum


Marker To (OFDMA Modulation Analysis)

There is no 'Marker To' functionality supported in Modulation Analysis so this front-panel key will display a blank softkey when pressed.


Marker Function (OFDMA Modulation Analysis)

There are no 'Marker Functions' supported in Mod Analysis so this front-panel key will display a blank softkey when pressed.


Power Stat CCDF Measurement

Many of the digitally modulated signals now look noise-like in the time and frequency domain. This means that statistical measurements of the signals can be a useful characterization. Power Complementary Cumulative Distribution Function (CCDF) curves characterize the higher level power statistics of a digitally modulated signal. The curves can be useful in determining design parameters for digital communications systems.

The power statistics CCDF measurement can be affected by many factors. For example, modulation filtering, modulation format, combining the multiple signals at different frequencies, number of active codes, and correlation between symbols on different codes with spread spectrum systems will all affect measurement results. These factors are all related to modulation and signal parameters. External factors such as signal compression and expansion by nonlinear components, group delay distortion from filtering, and power control within the observation interval also affect the measurement.

The power measured in power statistics CCDF curves is actually instantaneous envelope power defined by the equation:

P = (I + Q) / Zo

(Where I & Q are the quadrature voltage components of the waveform and Zo is the characteristic impedance).

A CCDF curve is defined by how much time the waveform spends at or above a given power level. The percent of time the signal spends at or above the level defines the probability for that particular power level. For capturing a lower probability down to 0.0001%, this measurement is made in the single mode by pressing Single. To make the power statistics CCDF measurement, the test set uses digital signal processing (DSP) to sample the input signal in the channel bandwidth. The Gaussian distribution line as the band-limited Gaussian noise CCDF reference line, the user-definable reference trace, and the currently measured trace can be displayed on a semi-log graph. If the currently measured trace is above the user reference trace, it means that the higher peak power levels against the average power are included in the input signal.

Key Path: Meas

SCPI Commands: [:SENSe]:PSTatistic, CONFigure:PSTatistic, CONFigure:PSTatistic:NDEFault, INITiate:PSTatistic, FETCh:PSTatistic{0:4}?, MEASure:PSTatistic{0:4}?, READ:PSTatistic{0:4}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


Measurement Results and Views (Power Stat CCDF)

The Power Stat CCDF measurement consists of single view. This is common for both Uplink (MS) and Downlink (BTS). There are two windows, Metrics (left) and graph display (right).

Graph window

Marker Operation: Yes

Corresponding Trace:

  • Yellow: Series of 5001 floating the current measured power stat trace. (n=2) Initially all markers refer this trace.

  • Light Blue: Series of 5001 floating point numbers (in percent) that represent the Gaussian trace. (n=3)

  • Violet: series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. (n=4)

The Gaussian and Reference trace/line can be removed using the features under the Trace/Detector key

Metrics window

Name | Corresponding Results | Explanation
Average Power [dBm] | n=1 1st Average input power | 99.99 dBm
Average Power [%] | n=1 2nd Probability at the average input power leve | 99.99 %
10.0% [dB] | n=1 3rd Power level that has 10% of the power | 99.99 dB
1.0% [dB] | n=1 4th Power level that has 1% of the power | 99.99 dB
0.1% [dB] | n=1 5th Power level that has 0.1% of the power | 99.99 dB
0.01% [dB] | n=1 6th Power level that has 0.01% of the power | 99.99 dB
0.001% [dB] | n=1 7th Power level that has 0.001% of the power | 99.99 dB
Peak [dB] | n=1 9th Peak power | 99.99 dB
Peak[dBm] | This is not available using remote commands. | 99.99 dBm


Span X Scale (Power Stat CCDF)

The SPAN X Scale key accesses the menu to set the desired horizontal scale.

Key Path: Front-panel key

Scale/Div

Enables you to enter a time value to change the horizontal scale.

Key Path: Front-panel key


AMPTD Y Scale (Power Stat CCDF)

Accesses a menu of functions that enable you to set the vertical scale parameters. The parameter values are measurement independent except all Attenuation values, and the Internal Preamp selection that are the same across all measurements.

Key Path: Front panel key

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]


View/Display (Power Stat CCDF)

Accesses a menu of functions that enable you to control the test set display as well as turn the bar graph On and Off.

Key Path: Front-panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see View/Display under ANALYZER SETUP Functions for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see View/Display under ANALYZER SETUP Functions for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title


Trace/Detector (Power Stat CCDF)

Accesses a menu of functions that enable you to control the storage and manipulation of the reference trace, as well as controls the display of the trace data.

Key Path: Front panel key

Store Ref Trace

Copies the currently measured curve as the user-definable reference trace. The captured data will remain until the other mode is chosen. Pressing this key also refreshes the reference trace.

Key Path: Trace/Detector

SCPI Command: CALCulate:PSTatistic:STORe:REFerence

Ref Trace

Toggles the reference trace display between On and Off.

Key Path: Trace/Detector

SCPI Command: [:SENSe]:PSTatistic:RTRace[:STATe][?]

Gaussian Line

Toggles the Gaussian trace display between On and Off.

Key Path: Trace/Detector

SCPI Command: [:SENSe]:PSTatistic:GAUSsian[:STATe][?]


Sweep/Control (Power Stat CCDF)

Enables you to pause the power statistics CCDF measurement after the current data acquisition is complete. When Paused, the label on the menu key changes to Resume. Press the Resume key to resume the measurement where it was when it was paused.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete. When Paused, the label on the key changes to Resume. Press the Resume key to resume the measurement where it was when it was paused.

Key Path: Sweep/Control


Meas Setup (Power Stat CCDF)

Accesses the functions that allow you to change the settings for your measurement requirements.

Key Path: Front panel key

Counts

Sets the accumulated number of sampling points for data acquisition. The range is 1.000 kpt (k point) to
2.00000 Gpt (G point) with 1 kpt resolution. Counts couples to Meas Cycles. When the value for counts is changed, the Meas Cycles value will be (Counts / SamplingFrequency * MeasInterval).

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:COUNts[?]

Meas Cycles

Set the number of measurement cycles to calculate power statistic data. This number couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

When the counts value cannot be divided by (Sampling Frequency * MeasInterval), this value is displayed as a decimal fraction.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:SWEep:CYCLes[?]

Meas Interval

Sets the number of data points to be used as the measurement interval. This value couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:SWEep:TIME[?]

IF Gain

Sets the IF Gain function to Auto, Low Gain or High Gain. These settings affect sensitivity and IF overloads.

Key Path: Meas Setup

IF Gain Auto

Activates the Auto Rules for IF Gain When Auto is active, the IF Gain is set to High Gain under any of the following conditions:

  • the input attenuator is set to 0 dB

  • the preamp is turned On

  • the Max Mixer Level is 20 dBm or lower

For other settings, Auto sets the IF Gain to Off.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

IF Gain State

Selects the range of IF gain. On sets the high gain option, which allows for better noise level measurements and Off sets low gain when measuring large signals.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

Meas Preset

Restores all measurement settings to their default values.

Key Path: Meas Setup

SCPI Command: CONFigure:PSTatistic


Trigger (Power Stat CCDF)

Accesses a menu of functions that enable you to select and control the trigger source for the current measurement

See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:PSTatistic[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the ”Measurement Functions” section for more information on trigger settings.

Key Path: Trigger


Marker (Power Stat CCDF)

Accesses a menu that enables you to select, set up and control the markers for the current measurement. See the Marker Function section for more information.

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Marker Type

Sets the marker control mode to Normal, Delta, Fixed or Off.

If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

The Active function for the selected marker's current control mode is the default active function. If the current control mode is Off, there is no active function and the active function is turned off. The active function display is the marker X axis value entered in the active function area will display the marker value to its full entered precision.

All interactions and dependencies detailed under the key description are enforced when the remote command is sent.

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses the marker properties menu.

Key Path: Marker

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Relative To

Sets the reference marker that the selected marker will be relative to.

Key Path: Marker, Properties

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Assigns the specified marker to the designated trace. The trace choices are: Measured, Gaussian, or Reference.

Key Path: Marker, Properties

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Couple Markers

When this function is true, moving any marker causes an equal X axis movement of every other marker which is not Off. By ”equal X axis movement” we mean that we preserve the difference between each marker's X axis value (in the fundamental x-axis units of the trace that marker is on) and the X axis value of the marker being moved (in the same fundamental x-axis units).

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

All Markers Off

Turns off all markers.

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer:AOFF


Peak Search (Power Stat CCDF)

There is no 'Peak Search' functionality supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


Marker To (Power Stat CCDF)

There is no 'Marker To' functionality supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


Marker Function (Power Stat CCDF)

There are no 'Marker Function' supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


Spectral Mask Measurement

The spectrum mask measures spurious signal levels in terms of absolute power or the percentage of points failing the mask. The default is to measure in percentage terms. When dealing with percentages, returning ’0’ defines the measurement as a pass i.e. there is 0% of points failing the mask.

Key Path: Front panel key

SCPI Commands: [:SENSe]:SMASk, CONFigure:SMASk, CONFigure:SMASk:NDEFault, INITiate:SMASk, FETCh:SMASk{0:3}?, MEASure:SMASk{0:3}?, READ:SMASk{0:3}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


AMPTD Y Scale (Spectral Mask)

Accesses a menu of functions that enable you to set the vertical scale parameters.

Key Path: Front panel key

Ref Value

Sets the absolute power reference value. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]

Scale/Div

Sets the units per division of vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Scale/Div (RF Envelope View)

Sets the scale per division for the RF Envelope result waveform (time domain) measurements in the graph window.

Key Path: AMPTD Y Scale

Scale/Div (I/Q Waveform View)

Sets the scale per division for the I/ Q signal waveform graph.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Ref Position (RF Envelope View)

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off. When the Restart front panel key is pressed, this function automatically determines the scale per division and reference values based on the measurement results.

Key Path: AMPTD Y Scale


Meas Setup (Spectral Mask)

Displays the setup menu keys that enable you to control the parameters for the current measurement.

Key Path: Front panel key

Avg/Hold Number

Sets the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Key Path: Meas Setup

Avg Mode

Enables you to set the averaging mode.

When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep.

When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Key Path: Meas Setup

Avg Type

Selects the type of averaging.

Key Path: Meas Setup

Meas Time

Sets how long the measurement is performed. X Scale only changes the representation of the display.

Key Path: Meas Setup

SCPI Command: [:SENSe]:SMASk:SWEep:TIME[?]

Mask

Accesses a menu that allows you to control the mask.

Key Path: Meas Setup

Loss Comp

Allows you to set loss or gain in the test fixture.

Key Path: Meas Setup, Mask

SCPI Command: CALCulate:SMASk:LCOMpensatio[?]

Mask State

Turns the mask on or off.

Key Path: Meas Setup, Mask

SCPI Command: [:SENSe]:SMASk:MASK[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More

SCPI Command: CONFigure:WAVeform


View/Display (Spectral Mask)

Accesses a menu of functions that enable you to control the test set display as well as turn the bar graph On and Off.

Key Path: Front-panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title


Trigger (Spectral Mask)

Accesses a menu that allows you to set triggering parameters for the current measurement. See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:SMASk[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the Measurement Functions section for more information on trigger settings.

Key Path: Trigger


Waveform Measurement

The waveform measurement is a generic measurement for viewing the input signal waveforms in the time domain. This measurement is how the test set performs the zero span functionality found in traditional spectrum analyzers. Also available under basic waveform measurements is an I/Q window, which shows the I and Q signal waveforms in parameters of voltage versus time to disclose the voltages which comprise the complex modulated waveform of a digital signal.

The waveform measurement can be used to perform general purpose power measurements to a high degree of accuracy as well.

Key Path: Front panel key

SCPI Commands: [:SENSe]:WAVeform, CONFigure:WAVeform, CONFigure:WAVeform:NDEFault, INITiate:WAVeform, FETCh:WAVeform{0:2}?, MEASure:WAVeform{0:2}?, READ:WAVeform{0:2}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


SPAN X Scale (Waveform)

Accesses a menu of functions that enable you to set the horizontal scale parameters.

Key Path: Front panel key

Ref Value

Sets the reference value for time on the horizontal axis. When Auto Scaling is set to On, the displayed plots use a Scale/Div value determined by the test set, based on the measurement result.

Key Path: SPAN X Scale

Scale/Div

Sets the horizontal scale by changing a time value per division.

Key Path: SPAN X Scale

Ref Position

Sets the reference position for the X axis to either Left, Center or Right.

Key Path: SPAN X Scale

Auto Scaling

Toggles the scale coupling function between On and Off.

Key Path: SPAN X Scale


AMPTD Y Scale (Waveform)

Accesses a menu of functions that enable you to set the vertical scale parameters.

Key Path: Front panel key

Ref Value

Sets the absolute power reference value. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Ref Value (RF Envelope View)

Sets the Y Scale reference value (in dBm) when the RF Envelope View is active. By default, the measurement determines the reference value with Auto Scaling. Entering a reference value manually turns Auto Scaling off.

Key Path: AMPTD Y Scale

Ref Value (I/Q Waveform View)

Sets the Y Scale reference value (in volts) when the I/Q Waveform View is active. By default, the measurement determines the reference value with Auto Scaling. Entering a reference value manually turns Auto Scaling off.

Key Path: AMPTD Y Scale

Scale/Div

Sets the units per division of vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Scale/Div (RF Envelope View)

Sets the scale per division for the RF Envelope result waveform (time domain) measurements in the graph window.

Key Path: AMPTD Y Scale

Scale/Div (I/Q Waveform View)

Sets the scale per division for the I/ Q signal waveform graph.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Ref Position (RF Envelope View)

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off. When the Restart front panel key is pressed, this function automatically determines the scale per division and reference values based on the measurement results.

Key Path: AMPTD Y Scale


View/Display (Waveform)

Display

Accesses a menu of functions that enable you to set the display parameters. See Display in the Analyzer Setup Functions section for more information.


Trace/Detector (Waveform)

There is no 'Trace/Detector' functionality supported in the Waveform measurement. The front panel key will display a blank menu key when pressed.


Meas Setup (Waveform)

Displays the setup menu keys that enable you to control the parameters for the current measurement.

Key Path: Front panel key

Avg/Hold Number

Sets the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Key Path: Meas Setup

SCPI Commands: [:SENSe]:WAVeform:AVERage:COUNt[?], [:SENSe]:WAVeform:AVERage[:STATe][?]

Avg Mode

Enables you to set the averaging mode.

When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep.

When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:AVERage:TCONtrol[?]

Avg Type

Selects the type of averaging.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:AVERage:TYPE[?]

Meas Time

Sets how long the measurement is performed. X Scale only changes the representation of the display.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:SWEep:TIME[?]

Power Only

Sets the waveform measurement to only return the power result. This makes the measurement quicker.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:PONLy[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More

SCPI Command: CONFigure:WAVeform


Trigger (Waveform)

Accesses a menu of functions that enable you to select and control the trigger source for the current measurement

See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:WAVeform[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the Measurement Functions section for more information on trigger settings.

Key Path: Trigger


Sweep/Control (Waveform)

Accesses settings that affect the sweep viewed in the display.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Sweep/Control


Marker (Waveform)

Accesses a menu that enables you to select, set up and control the markers for the current measurement. See the Marker Function section for more information.

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Marker Type

Sets the marker control mode to Normal, Delta, Fixed or Off.

All interactions and dependencies detailed under the key description are enforced when the remote command is sent. If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

The default active function is the active function for the currently selected marker control mode. If the current control mode is Off, there is no active function and the active function is turned off.

Key Path: Marker

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses a menu that enables you to select the active marker, the reference marker and the trace for the current measurement.

Key Path: Marker

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Relative To

Selects the marker the selected marker will be relative to (its reference marker).

Key Path: Marker, Properties

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Assigns the specified marker to the designated trace.

Key Path: Marker, Properties

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Couple Markers

Toggles the state of the markers to be coupled On or Off. When this function is true (On), moving any marker causes an equal X axis movement of every other marker which is not Off. ”Equal X axis movement” refers to the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) and the X Axis value of the marker being moved (in the same fundamental x-axis units) are preserved.

Key Path: Marker, More

SCPI Command: CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

All Markers Off

Turns all markers off.

Key Path: Marker, More

SCPI Command: CALCulate:WAVeform:MARKer:AOFF


802.16 OFDMA (N6301A)

Peak Search (Waveform)

Last Updated: March 28, 2008

Min Search

Moves the selected marker to the minimum y-axis value on the current trace.

Key Path: Peak Search

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum


Marker To (Waveform)

There is no 'Marker To' functionality supported in Waveform measurements. The front-panel key will display a blank menu key when pressed.


Marker Function (Waveform)

Accesses a menu of marker functions that perform post-processing operations on markers based on the measurement specifications. Marker functions are distinct from Measurement functions, which automatically perform complex sequences of setup, data acquisition, and display operations in order to measure specified signal characteristics. Marker Functions are specified for each individual marker and may be turned on individually for each marker.

The Marker Function menu controls which marker functions are turned on and allows you to adjust the setup parameters for each function. These parameters include the following, but only one parameter can be assigned to a given marker:

  • Marker Noise

  • Band/Interval Power

  • Band/Interval Density

  • Marker Function Off

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker Function

Marker Function Type

Sets the marker control function type to, Marker Noise, Band/Interval Power, Band Interval Density, or Marker Function Off.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

Band Adjust

Accesses a menu that enables you to set the frequency span width and the left and right edge, or time values, for the band or interval of the selected marker.

Key Path: Marker Function

Band/Interval Span for Time Domain

Sets the width of the frequency span for the selected marker. Changing the Band/Interval Span necessarily changes the Band/Interval Left and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

Band/Interval Left for Time Domain

Sets the left edge frequency or time value for the band of the selected marker. Changing the Band/Interval Left necessarily changes the Band/Interval Span and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

Band/Interval Right for Time Domain

Sets the right edge frequency or time value for the band of the selected marker. Changing the Band/Interval Left necessarily changes the Band/Interval Span and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]


802.16 OFDMA (N6301A)

Programming (802.16 OFDMA)

Last Updated: March 28, 2008

The test set is programmable through GPIB.

For details on programming specific measurements, see the individual programming examples in this section.

For details on any specific SCPI command, see SCPI Commands (802.16 OFDMA).


802.16 OFDMA (N6301A)

Programming Examples for Individual Measurements (802.16 OFDMA)

Last Updated: March 28, 2008

This book provides individual programming examples for specific measurements in the N6301A OFDMA Measurement Application. Refer to the topics in this section for more details.


802.16 OFDMA (N6301A)

Programming a Burst Power Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlevel> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:WAVeform

// Setup for WAVeform Trigger

:SENSE:WAVeform:TRIGger:SOURce RFBurst

:TRIGger:SEQuence:RFBurst:LEVel:ABSolute <triglev> dBm

:TRIGger:SEQuence:RFBurst:DELay 10 us

:TRIGger:SEQuence:RFBurst:DELay:STATe ON

:TRIGger:SEQuence:SLOPe POS

:TRIGger:SEQuence:HOLDoff 50 us

:TRIGger:SEQuence:HOLDoff:STATe ON

//Set to Single Mode

:INITiate:CONTinuous OFF

:SENSe:WAVeform:SWEep:TIME <meastime>

// Results should be quicker if we only display the Power results

:SENSe:WAVeform:PONLy:STATe ON

// Start The measurement

:INIT:WAVeform

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:WAVeform1?


802.16 OFDMA (N6301A)

Programming a CW Power Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlevel> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:WAVeform

// Setup for WAVeform Trigger

:SENSE:WAVeform:TRIGger:SOURce IMMediate

//Set to Single Mode

INITiate:CONTinuous OFF

:SENSe:WAVeform:SWEep:TIME <meastime>

// Results should be quicker if we only display the Power results

:SENSe:WAVeform:PONLy:STATe ON

// Start The measurement

:INIT:WAVeform

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:WAVeform1?


802.16 OFDMA (N6301A)

Programming a Modulation Analysis Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlevel> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:EVM

// Setup for Trigger

:SENSE:EVM:TRIGger:SOURce RFBurst

:TRIGger:SEQuence:RFBurst:LEVel:ABSolute <triglev> dBm

:TRIGger:SEQuence:RFBurst:DELay 10 us

:TRIGger:SEQuence:RFBurst:DELay:STATe ON

:TRIGger:SEQuence:SLOPe POS

:TRIGger:SEQuence:HOLDoff 100 us

:TRIGger:SEQuence:HOLDoff:STATe ON

//Set to Single Mode

INITiate:CONTinuous OFF

:RADio:STANdard:DEVice MS

// Set BW, can be B1M25 | B3M5 | B5M | B7M | B8M75 | B10M

:RADio:STANdard:Y05 B5M

// Set the ratio of uplink / downlink

RADio:STANdard:DRATio 6.17771e01

// set the frame duration, can be 2.0e-03 | 2.5e-03 | 4.0e-03 | 5.0e-03

RADio:STANdard:FDURation 2.0e-03

// Map Select can be AUTO | CUST | FCH

:CALCulate:EVM:MAP:SELect:TYPE CUST

// set for single burst, can be MAP | SINGle | UZONe

:CALCulate:EVM:BURSt:TYPE SINGle

// set the Zone Interval

:CALCulate:EVM:ZONE:INTerval 18

// set the sub channel interval

:CALCulate:EVM:BURSt2:SUBChannel:INTerval 6

// set the symbol length

:CALCulate:EVM:BURSt2:SYMBol:INTerval 18

// Set the md type, can be QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

:CALCulate:EVM:BURSt2:MODulation:TYPE QAM64R3BY4

// Set the burst shape, can be WRAPped | RECTangle

:CALCulate:EVM:BURSt2:SHAPe WRAPped

// Start The measurement

:INIT:EVM

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:EVM<fetchIndex>?

// THE RESULTS FETCHED BACK FROM THE MEASUREMENT ARE DETERMINED BY THE <fetchIndex>. PLEASE VIEW THE COMMAND LISTING FOR DETAILS...


802.16 OFDMA (N6301A)

Programming a Power Stat CCDF Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlevel> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:PSTatistic

// Setup for PSTatistic Trigger

:SENSE:PSTatistic:TRIGger:SOURce RFBurst

:TRIGger:SEQuence:RFBurst:LEVel:ABSolute <triglev> dBm

:TRIGger:SEQuence:RFBurst:DELay 10 us

:TRIGger:SEQuence:RFBurst:DELay:STATe ON

:TRIGger:SEQuence:SLOPe POS

:TRIGger:SEQuence:HOLDoff 100 us

:TRIGger:SEQuence:HOLDoff:STATe ON

//Set to Single Mode

:INITiate:CONTinuous OFF

:SENSe:PSTatistic:SWEep:TIME <meastime>

:SENSe:PSTatistic:COUNts 10000000

:SENSe:PSTatistic:GAUSsian:STATe ON

:SENSe:PSTatistic:IF:GAIN:AUTO:STATe ON

:SENSe:PSTatistic:RTRace:STATe OFF

// Start The measurement

:INIT:PSTatistic

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:PSTatistic1?


802.16 OFDMA (N6301A)

Programming a Spectral Mask Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlev> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:SMASk

// Setup for Trigger

:SENSE:SMASk:TRIGger:SOURce RFBurst

:TRIGger:SEQuence:RFBurst:LEVel:ABSolute <triglev> dBm

:TRIGger:SEQuence:RFBurst:DELay 10 us

:TRIGger:SEQuence:RFBurst:DELay:STATe ON

:TRIGger:SEQuence:SLOPe POS

:TRIGger:SEQuence:HOLDoff 100 us

:TRIGger:SEQuence:HOLDoff:STATe ON

// set up a custom mask, spectral mask test is absolute

:CALCulate:SMASk:MDEFinition -30e6,-35,-10.5e6,-35,-10.5e6,-23,-6e6,-23,-6e6,-13,-5e6,-13,-5e6,9.91E+37,5e6,9.91E+37,5e6,-13,6e6,-13,6e6,-23,10.5e6,-23,10.5e6,-35,30e6,-35

// set up loss compensation

:CALCulate:SMASk:LCOMpensatio <level>

//Set to Single Mode

INITiate:CONTinuous OFF

:SENSe:SMASk:SWEep:TIME <meastime>

:SENSe:SMASk:MASK:STATe ON

:SENSe:SMASk <WindowType>

// Start The measurement

:INIT:SMASk

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:SMASk1?


802.16 OFDMA (N6301A)

Configuring a Signal Generator Bursted Waveform

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:FREQuency:CENTer <frequency>

:SOURce:POWer:LEVel:IMMediate:AMPLitude <powerlevel>

:SOURce:MMEMory:COPY "NVWFM:16e_8M75_DL_PUSC_QP","WFM1:16e_8M75_DL_PUSC_QP"

:SOURce:RADio:ARB:WAVeform "WFM1:16e_8M75_DL_PUSC_QP"

:SOURce:RADio:ARB:TRIGger:TYPE CONTINUOUS

:SOURce:RADio:ARB:CLOCk:SRATe 22.4 MHz

:SOURce:OUTPut:STATe ON

:SOURce:RADio:ARB:STATE ON


802.16 OFDMA (N6301A)

Configuring a Signal Generator CW Waveform

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:FREQuency:CENTer <frequency>

:SOURce:POWer:LEVel:IMMediate:AMPLitude <powerlevel>

:SOURce:OUTPut:STATe ON

:SOURce:RADio:ARB:STATE OFF


N6301A 802.16 OFDM Measurement Application Help

802.16 OFDM (N6301A)

N6301A 802.16 OFDM Measurement Application Help

Last Updated: March 28, 2008

This online help describes how to use the Agilent N6301A 802.16 OFDM Measurement Application. The Table of Contents on the left provides access to all of the information contained within this online help.

The help is organized into the following sections:

  • SCPI Commands provides details on all of the SCPI syntax available to control this application by remote program.

  • Front Panel Operation provides reference information about the application's screens.

© Agilent Technologies, Inc. 2007-2008


802.16 OFDM (N6301A)

Listing Of Commands

Last Updated: March 28, 2008

This book provides details of the SCPI commands in the N6301A 802.16 OFDM Measurement Application. For details of these commands refer to the subsystems in this section. Alternatively, for a complete list of the SCPI commands in this application, see Listing of Commands (802.16 OFDM).

Measurement Control

  • CALCulate Subsystem to perform data processing on measurement results.

  • CONFigure Subsystem to perform high level configuration functions.

  • FETCh Subsystem to get measurement results.

  • FORMat Subsystem to set a data format for transferring numeric and array information.

  • INITiate Subsystem to start a measurement.

  • MEASure? Subsystem to make measurements using the factory default test set settings.

  • READ? Subsystem to make measurements and retrieve the results.

  • [:SENSe] Subsystem for controls that directly affect device-specific settings of the device.

RF Control

  • SOURce Subsystem to control the test set's RF generator.

Related Topic: SCPI Commands (Test Set)


Listing Of Commands

802.16 OFDM (N6301A)

Last Updated: March 28, 2008

This topic lists all of the available SCPI commands in the N6301A 802.16 OFDMA Measurement Application.

It is recommended that you print this topic because it provides a useful syntax reference for all of the available General Purpose Application commands. To print:

  • Click the Print icon [image] on the toolbar above, or

  • Right-click in this topic pane and select Print...

The SCPI commands in this topic are categorized by subsystem:

  • CALCulate Subsystem

  • CONFigure Subsystem

  • DISPlay Subsystem

  • FETCh Subsystem

  • FORMat Subsystem

  • INITiate Subsystem

  • MEASure Subsystem

  • READ Subsystem

  • [:SENSe] Subsystem

  • SOURce Subsystem

  • TRIGger Subsystem

CALCulate Subsystem

  • CALCulate:ACPower:LIMit:STATe[?]

  • CALCulate:ACPower:MARKer:AOFF

  • CALCulate:ACPower:MARKer:COUPle[:STATe][?]

  • CALCulate:ACPower:MARKer{1:12}:CPEak[:STATe][?]

  • CALCulate:ACPower:MARKer{1:12}:FUNCtion:RESult?

  • CALCulate:ACPower:MARKer{1:12}:MAXimum

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:LEFT

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:NEXT

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:RIGHt

  • CALCulate:ACPower:MARKer{1:12}:MINimum

  • CALCulate:ACPower:MARKer{1:12}:MODE[?]

  • CALCulate:ACPower:MARKer{1:12}:PTPeak[?]

  • CALCulate:ACPower:MARKer{1:12}:REFerence[?]

  • CALCulate:ACPower:MARKer{1:12}:STATe[?]

  • CALCulate:ACPower:MARKer{1:12}:X[?]

  • CALCulate:ACPower:MARKer{1:12}:X:POSition[?]

  • CALCulate:ACPower:MARKer{1:12}:Y?

  • CALCulate:ACPower:OFFSet{1:2}:LIST:LIMit:NEGative[:UPPer]:DATA[?]

  • CALCulate:ACPower:OFFSet{1:2}:LIST:LIMit:POSitive[:UPPer]:DATA[?]

  • CALCulate:CLIMits:FAIL?

  • CALCulate:EVM:BURSt:MODulation:TYPE[?]

  • CALCulate:EVM:BURSt:NUMBer?

  • CALCulate:EVM:BURSt:POWer:MAP[?]

  • CALCulate:EVM:BURSt:SHAPe[?]

  • CALCulate:EVM:BURSt:STATe[?]

  • CALCulate:EVM:BURSt:SUBChannel:INTerval[?]

  • CALCulate:EVM:BURSt:SUBChannel:OFFSet[?]

  • CALCulate:EVM:BURSt:SYMBol:INTerval[?]

  • CALCulate:EVM:BURSt:SYMBol:OFFSet[?]

  • CALCulate:EVM:BURSt:TYPE[:SELect][?]

  • CALCulate:EVM:BURSt2:MODulation:TYPE[?]

  • CALCulate:EVM:BURSt2:SHAPe[?]

  • CALCulate:EVM:BURSt2:SUBChannel:INTerval[?]

  • CALCulate:EVM:BURSt2:SUBChannel:OFFSet[?]

  • CALCulate:EVM:BURSt2:SYMBol:INTerval[?]

  • CALCulate:EVM:BURSt2:SYMBol:OFFSet[?]

  • CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

  • CALCulate:EVM:EQUalizer:TMODe[?]

  • CALCulate:EVM:INFormation:BURSt[?]

  • CALCulate:EVM:LIMit{1:2}:FERRor[?]

  • CALCulate:EVM:LIMit{1:2}:FERRor:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:IQOFfset[?]

  • CALCulate:EVM:LIMit{1:2}:IQOFfset:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:PRCE[?]

  • CALCulate:EVM:LIMit{1:2}:PRCE:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:RCEPilot[?]

  • CALCulate:EVM:LIMit{1:2}:RCEPilot:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:AUTO[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QA16:R1B2[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QA16:R3B4[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QA64:R1B2[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QA64:R2B3[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QA64:R3B4[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QPSK:R1B2[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:QPSK:R3B4[?]

  • CALCulate:EVM:LIMit{1:2}:RRCE:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit{1:2}:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit{1:2}:TOFFset[?]

  • CALCulate:EVM:LIMit{1:2}:TOFFset:STATe[?]

  • CALCulate:EVM:MAP:CUSTom:NAME[?]

  • CALCulate:EVM:MAP:DETect

  • CALCulate:EVM:MAP:SELect:FECCode[?]

  • CALCulate:EVM:MAP:SELect:TYPE[?]

  • CALCulate:EVM:MARKer:AOFF

  • CALCulate:EVM:MARKer{1:12}:FUNCtion:RESult?

  • CALCulate:EVM:MARKer{1:12}:MAXimum

  • CALCulate:EVM:MARKer{1:12}:MAXimum:LEFT

  • CALCulate:EVM:MARKer{1:12}:MAXimum:NEXT

  • CALCulate:EVM:MARKer{1:12}:MAXimum:RIGHt

  • CALCulate:EVM:MARKer{1:12}:MINimum

  • CALCulate:EVM:MARKer{1:12}:MODE[?]

  • CALCulate:EVM:MARKer{1:12}:PTPeak

  • CALCulate:EVM:MARKer{1:12}:REFerence[?]

  • CALCulate:EVM:MARKer{1:12}:STATe[?]

  • CALCulate:EVM:MARKer{1:12}:TRACe[?]

  • CALCulate:EVM:MARKer{1:12}:X[?]

  • CALCulate:EVM:MARKer{1:12}:X:POSition[?]

  • CALCulate:EVM:MARKer{1:12}:X:SUBCarrier[?]

  • CALCulate:EVM:MARKer{1:12}:X:SYMBol[?]

  • CALCulate:EVM:MARKer{1:12}:Y?

  • CALCulate:EVM:MS:PBASe[?]

  • CALCulate:EVM:PILot[?]

  • CALCulate:EVM:PILot:TRACk:AMPLitude[?]

  • CALCulate:EVM:PILot:TRACk:PHASe[?]

  • CALCulate:EVM:PILot:TRACk:TIMing[?]

  • CALCulate:EVM:PINDex[?]

  • CALCulate:EVM:SPECtrum[?]

  • CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

  • CALCulate:EVM:SUBChannel:MASK[?]

  • CALCulate:EVM:SWEep:OFFSet[?]

  • CALCulate:EVM:SYMBol:ADJust[?]

  • CALCulate:EVM:UZONe:MODulation:TYPE[?]

  • CALCulate:EVM:UZONe2:MODulation:TYPE[?]

  • CALCulate:EVM:ZONE[?]

  • CALCulate:EVM:ZONE:INTerval[?]

  • CALCulate:EVM:ZONE:OFFSet[?]

  • CALCulate:PSTatistic:MARKer:AOFF

  • CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

  • CALCulate:PSTatistic:MARKer{1:12}:FUNCtion:RESult?

  • CALCulate:PSTatistic:MARKer{1:12}:MODE[?]

  • CALCulate:PSTatistic:MARKer{1:12}:REFerence[?]

  • CALCulate:PSTatistic:MARKer{1:12}:STATe[?]

  • CALCulate:PSTatistic:MARKer{1:12}:TRACe[?]

  • CALCulate:PSTatistic:MARKer{1:12}:X[?]

  • CALCulate:PSTatistic:MARKer{1:12}:X:POSition[?]

  • CALCulate:PSTatistic:MARKer{1:12}:Y?

  • CALCulate:PSTatistic:NSELect[?]

  • CALCulate:PSTatistic:STORe:REFerence

  • CALCulate:WAVeform:MARKer:AOFF

  • CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

  • CALCulate:WAVeform:MARKer{1:12}:FUNCtion[?]

  • CALCulate:WAVeform:MARKer{1:12}:FUNCtion:BAND:LEFT[?]

  • CALCulate:WAVeform:MARKer{1:12}:FUNCtion:BAND:RIGHt[?]

  • CALCulate:WAVeform:MARKer{1:12}:FUNCtion:BAND:SPAN[?]

  • CALCulate:WAVeform:MARKer{1:12}:FUNCtion:RESult[?]

  • CALCulate:WAVeform:MARKer{1:12}:MAXimum

  • CALCulate:WAVeform:MARKer{1:12}:MINimum

  • CALCulate:WAVeform:MARKer{1:12}:MODE[?]

  • CALCulate:WAVeform:MARKer{1:12}:REFerence[?]

  • CALCulate:WAVeform:MARKer{1:12}[:SET]:RLEVel

  • CALCulate:WAVeform:MARKer{1:12}:STATe[?]

  • CALCulate:WAVeform:MARKer{1:12}:TRACe[?]/p>

  • CALCulate:WAVeform:MARKer{1:12}:X[?]

  • CALCulate:WAVeform:MARKer{1:12}:X:POSition[?]

  • CALCulate:WAVeform:MARKer{1:12}:X:SPAN[?]

  • CALCulate:WAVeform:MARKer{1:12}:Y?

CONFigure Subsystem

  • CONFigure?

  • CONFigure:ACPower

  • CONFigure:ACPower:NDEFault

  • CONFigure:EVM

  • CONFigure:EVM:NDEFault

  • CONFigure:PSTatistic

  • CONFigure:PSTatistic:NDEFault

  • CONFigure:SMASk

  • CONFigure:SMASk:NDEFault

  • CONFigure:WAVeform

  • CONFigure:WAVeform:NDEFault

COUPle Subsystem

  • COUPle

DISPlay Subsystem

  • DISPlay:ACPower:ANNotation:TITLe:DATA[?]

  • DISPlay:ACPower:VIEW:WINDow:BGRaph[?]

  • DISPlay:ACPower:VIEW:WINDow:TRACe:Y[:SCALe]:COUPle[?]

  • DISPlay:ACPower:VIEW:WINDow:TRACe:Y[:SCALe]:PDIVision[?]

  • DISPlay:ACPower:VIEW:WINDow:TRACe:Y[:SCALe]:RLEVel[?]

  • DISPlay:ACPower:VIEW:WINDow:TRACe:Y[:SCALe]:RPOSition[?]

  • DISPlay:BACKlight[?]

  • DISPlay:BACKlight:INTensity[?]

  • DISPlay:ENABle[?]

  • DISPlay:ENABle:OPRiority[?]

FETCh subsystem

  • FETCh:ACP{1:4}?

  • FETCh:EVM{0:23}?

  • FETCh:PSTatistic{0:4}?

  • FETCh:SMASk{0:3}?

  • FETCh:WAVeform{0:2}?

FORMat Subsystem

  • FORMat:BORDer

  • FORMat[:TRACe][:DATA]

HCOPy Subsystem

HCOPy:ABORt

HCOPy[:IMMediate]

INITiate Subsystem

  • INITiate:ACPower

  • INITiate:CONTinuous

  • INITiate:CONTinuous:OPRiority

  • INITiate:EVM

  • INITiate[:IMMediate]

  • INITiate:PAUSe

  • INITiate:PSTatistic

  • INITiate:RESTart

  • INITiate:RESume

  • INITiate:SMASk

  • INITiate:WAVeform

INSTrument Subsystem

  • INSTrument:CATalog?

  • INSTrument:DEFault

  • INSTrument:NSELect

  • INSTrument[:SELect]

MEASure Subsystem

  • MEASure:ACP{1:4}?

  • MEASure:EVM{0:23}?

  • MEASure:PSTatistic{0:4}?

  • MEASure:SEMask{1:12}?

  • MEASure:SMASk{0:3}?

  • MEASure:WAVeform{0:2}?

MMEMory Subsystem

  • MMEMory:CATalog?

  • MMEMory:CDIRectory

  • MMEMory:COPY

  • MMEMory:DATA

  • MMEMory:DELete

  • MMEMory:LOAD:STATe

  • MMEMory:LOAD:TRACe

  • MMEMory:LOAD:ZMAP

  • MMEMory:MDIRectory

  • MMEMory:MOVE

  • MMEMory:RDIRectory

  • MMEMory:STORe:RESults

  • MMEMory:STORe:SCReen

  • MMEMory:STORe:SCReen:THEMe

  • MMEMory:STORe:STATe

  • MMEMory:STORe:TRACe

  • MMEMory:STORe:ZMAP

READ Subsystem

  • READ:ACP{1:4}?

  • READ:EVM{0:23}?

  • READ:PSTatistic{0:4}?

  • READ:SEMask{1:12}?

  • READ:SMASk{0:3}?

  • READ:WAVeform{0:2}?

SENSe Subsystem

  • [:SENSe]:ACPower:AVERage:COUNt[?]

  • [:SENSe]:ACPower:AVERage[:STATe][?]

  • [:SENSe]:ACPower:AVERage:TCONtrol[?]

  • [:SENSe]:ACPower:BANDwidth:INTegration{1:2}[?]

  • [:SENSe]:ACPower:BANDwidth[:RESolution][?]

  • [:SENSe]:ACPower:BWIDth:INTegration{1:2}[?]

  • [:SENSe]:ACPower:BWIDth[:RESolution][?]

  • [:SENSe]:ACPower:CARRier{1:2}:AUTO[:STATe][?]

  • [:SENSe]:ACPower:CARRier{1:2}:COUNt[?]

  • [:SENSe]:ACPower:CARRier{1:2}:CPSD[?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BANDwidth[:INTegration][?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BWIDth[:INTegration][?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:COUPle[?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:FILTer:ALPHa[?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:METHod[?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:PPResent[?]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:WIDTh[?]

  • [:SENSe]:ACPower:CARRier{1:2}[:POWer][?]

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier[?]

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier:AUTO[?]

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency[?]

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency:AUTO[?]

  • [:SENSe]:ACPower:FILTer[:RRC]:ALPHa[?]

  • [:SENSe]:ACPower:FILTer[:RRC][:STATe][?]

  • [:SENSe]:ACPower:FREQuency:SPAN[?]

  • [:SENSe]:ACPower:FREQuency:SPAN:FULL

  • [:SENSe]:ACPower:FREQuency:SPAN:PREVious

  • [:SENSe]:ACPower:LIMit[:STATe][?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:ABSolute[?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BANDwidth[:INTegration][?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BWIDth[:INTegration][?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST[:FREQuency][?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RCARrier[?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RPSDensity[?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:STATe[?]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:TEST[?]

  • [:SENSe]:ACPower:SWEep:BANDwidth[:RESolution][?]

  • [:SENSe]:ACPower:SWEep:BWIDth[:RESolution][?]

  • [:SENSe]:ACPower:SWEep:TIME[?]

  • [:SENSe]:ACPower:TRIGger:SOURce[?]

  • [:SENSe]:ACPower:TYPE[?]

  • [:SENSe]:ACPower:WTYPe[?]

  • [:SENSe]:ACPR:AVERage:COUNt[?]

  • [:SENSe]:ACPR:AVERage[:STATe][?]

  • [:SENSe]:ACPR:AVERage:TCONtrol[?]

  • [:SENSe]:ACPR:FILTer[:RRC]:ALPHa[?]

  • [:SENSe]:ACPR:FILTer[:RRC][:STATe][?]

  • [:SENSe]:ACPR:OFFSet{1:2}:LIST:ABSolute[?]

  • [:SENSe]:ACPR:OFFSet{1:2}:LIST:BANDwidth[?]

  • [:SENSe]:ACPR:OFFSet{1:2}:LIST:BWIDth[?]

  • [:SENSe]:ACPR:WTYPe[?]

  • [:SENSe]:EVM:AVERage:COUNt[?]

  • [:SENSe]:EVM:AVERage[:STATe][?]

  • [:SENSe]:EVM:AVERage:TCONtrol[?]

  • [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

  • [:SENSe]:EVM:TRIGger:SOURce[?]

  • [:SENSe]:FREQuency:CENTer[?]

  • [:SENSe]:FREQuency:CENTer:STEP:AUTO[?]

  • [:SENSe]:FREQuency:CENTer:STEP[:INCRement][?]

  • [:SENSe]:POWer:RANGe[?]

  • [:SENSe]:POWer[:RF]:MMW:PRESelector[:STATe][?]

  • [:SENSe]:POWer[:RF]:MW:PRESelector[:STATe][?]

  • [:SENSe]:POWer[:RF]:PCENter

  • [:SENSe]:POWer[:RF]:RANGe:OPTimize

  • [:SENSe]:PSTatistic:COUNts[?]

  • [:SENSe]:PSTatistic:GAUSsian[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

  • [:SENSe]:PSTatistic:RTRace[:STATe][?]

  • [:SENSe]:PSTatistic:SRTRace

  • [:SENSe]:PSTatistic:SWEep:CYCLes[?]

  • [:SENSe]:PSTatistic:SWEep:TIME[?]

  • [:SENSe]:PSTatistic:TRIGger:SOURce[?]

  • [:SENSe]:RADio:STANdard[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

  • [:SENSe]:RADio:STANdard:DEVice[?]

  • [:SENSe]:RADio:STANdard:DRATio[?]

  • [:SENSe]:RADio:STANdard:FDURation[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

  • [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

  • [:SENSe]:RESume

  • [:SENSe]:ROSCillator:SOURce[?]

  • [:SENSe]:ROSCillator:SOURce:TYPE[?]

  • [:SENSe]:SMASk:AVERage:COUNt[?]

  • [:SENSe]:SMASk:AVERage[:STATe][?]

  • [:SENSe]:SMASk:AVERage:TCONtrol[?]

  • [:SENSe]:SMASk:MASK[:STATe][?]

  • [:SENSe]:SMASk:SWEep:TIME[?]

  • [:SENSe]:SMASk:TRIGger:SOURce[?]

  • [:SENSe]:SMASk:WTYPe[?]

  • [:SENSe]:SUSPend

  • [:SENSe]:WAVeform:AVERage:COUNt[?]

  • [:SENSe]:WAVeform:AVERage[:STATe][?]

  • [:SENSe]:WAVeform:AVERage:TCONtrol[?]

  • [:SENSe]:WAVeform:AVERage:TYPE[?]

  • [:SENSe]:WAVeform:PONLy[:STATe][?]

  • [:SENSe]:WAVeform:SWEep:TIME[?]

  • [:SENSe]:WAVeform:TRIGger:SOURce[?]

SOURce Subsystem

  • SOURce:CALibration:DCFM

  • SOURce:CALibration:IQ:DC

  • SOURce:CALibration:IQ:DEFault

  • SOURce:CALibration:IQ:FULL

  • SOURce:CALibration:IQ:START[?]

  • SOURce:CALibration:IQ:STOP[?]

  • SOURce:CALibration:IQ:TYPE[?]

  • SOURce:CALibration[:USER]

  • SOURce:FREQuency:CONTrol[?]

  • SOURce:FREQuency[:MANual][?]

  • SOURce:MMEMory:CATalog?

  • SOURce:MMEMory:COPY

  • SOURce:MMEMory:DATA[?]

  • SOURce:MMEMory:DATA:UNPRotected

  • SOURce:MMEMory:DELete[:NAME]

  • SOURce:MMEMory:DELete:NVWFm

  • SOURce:MMEMory:DELete:WFM

  • SOURce:OUTPut[:STATe][?]

  • SOURce:POWer:ALC[:STATe][?]

  • SOURce:POWer:ATTenuation[?]

  • SOURce:POWer:ATTenuation:AUTO[?]

  • SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

  • SOURce:RADio:ARB:CLOCk:SRATe[?]

  • SOURce:RADio:ARB:DONE?

  • SOURce:RADio:ARB:MARKer:CLEar

  • SOURce:RADio:ARB:MARKer:CLEar:ALL

  • SOURce:RADio:ARB:MARKer:ROTate

  • SOURce:RADio:ARB:MARKer[:SET]

  • SOURce:RADio:ARB:MDEStination:ALCHold[?]

  • SOURce:RADio:ARB:MDEStination:PULSe[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer1|MARKer[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer2[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer3[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer4[?]

  • SOURce:RADio:ARB:RSCaling[?]

  • SOURce:RADio:ARB:SEQuence[:MWAVeform][?]

  • SOURce:RADio:ARB[:STATe][?]

  • SOURce:RADio:ARB:TRIGger[:SOURce][?]

  • SOURce:RADio:ARB:TRIGger:TYPE[?]

  • SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

  • SOURce:RADio:ARB:WAVeform[?]

  • SOURce:RADio:OPATh[?]

  • SOURce:READ:BBLock?

  • SOURce:READ:STRing?

  • SOURce:RESume

  • SOURce:SUSPend

  • SOURce:TRIGger

  • SOURce:WRITe:STRing

STATus Subsystem

  • STATus:OPERation:CONDition?

  • STATus:QUEStionable:INTegrity:CONDition?

SYSTem Subsystem

  • SYSTem:APPLication:CATalog[:NAME]?

  • SYSTem:APPLication:CATalog[:NAME]:COUNt?

  • SYSTem:APPLication:CATalog:OPTion?

  • SYSTem:APPLication:CATalog:REVision?

  • SYSTem:APPLication[:CURRent][:NAME]?

  • SYSTem:APPLication[:CURRent]:OPTion?

  • SYSTem:APPLication[:CURRent]:REVision?

  • SYSTem:COMMunicate:GPIB[:SELF]:ADDRess[?]

  • SYSTem:COMMunicate:LAN:ADDRess[?]

  • SYSTem:COMMunicate:LAN:DGATeway[?]

  • SYSTem:COMMunicate:LAN:HNAMe?

  • SYSTem:COMMunicate:LAN:SCPI:SICL:ENABle[?]

  • SYSTem:COMMunicate:LAN:SCPI:SOCKet:CONTrol?

  • SYSTem:COMMunicate:LAN:SCPI:SOCKet:ENABle[?]

  • SYSTem:COMMunicate:LAN:SCPI:TELNet:ENABle[?]

  • SYSTem:COMMunicate:LAN:SMASk[?]

  • SYSTem:COMMunicate:USB:CONNection?

  • SYSTem:COMMunicate:USB:PACKets?

  • SYSTem:COMMunicate:USB:STATus?

  • SYSTem:DATE[?]

  • SYSTem:DEFault

  • SYSTem:ERRor[:NEXT]?

  • SYSTem:ERRor:VERBose[?]

  • SYSTem:HELP:HEADers?

  • SYSTem:HID?

  • SYSTem:KLOCk[?]

  • SYSTem:LKEY[?]

  • SYSTem:LKEY:DELete

  • SYSTem:LKEY:LIST?

  • SYSTem:OPTions?

  • SYSTem:PDOWn

  • SYSTem:PON:ETIMe?

  • SYSTem:PON:MODE[?]

  • SYSTem:PON:TIME?

  • SYSTem:PON:TYPE[?]

  • SYSTem:PRESet

  • SYSTem:PRESet:PERSistent

  • SYSTem:PRESet:SAVE

  • SYSTem:PRESet:TYPE[?]

  • SYSTem:PRESet:USER

  • SYSTem:PRESet:USER:ALL

  • SYSTem:PRESet:USER:SAVE

  • SYSTem:PRINt:THEMe[?]

  • SYSTem:PRIority[?]

  • SYSTem:PRIority:CURRent?

  • SYSTem:PUP

  • SYSTem:PUP:PROCess

  • SYSTem:SOURce:LICense:INSTall

  • SYSTem:SOURce:LICense:REMove

  • SYSTem:TIME[?]

  • SYSTem:VERSion?

TRIGger Subsystem

  • TRIGger:ACPower[:SEQuence]:SOURce[?]

  • TRIGger:EVM[:SEQuence]:SOURce[?]

  • TRIGger:PSTatistic[:SEQuence]:SOURce[?]

  • TRIGger:SEMask[:SEQuence]:SOURce[?]

  • TRIGger[:SEQuence]:DELay[?]

  • TRIGger[:SEQuence]:DELay:STATe[?]

  • TRIGger[:SEQuence]:EXTernal:DELay[?]

  • TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

  • TRIGger[:SEQuence]:HOLDoff[?]

  • TRIGger[:SEQuence]:HOLDoff:STATe[?]

  • TRIGger[:SEQuence]:RFBurst:DELay[?]

  • TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

  • TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

  • TRIGger[:SEQuence]:RFBurst:SLOPe[?]

  • TRIGger[:SEQuence]:SLOPe[?]

  • TRIGger:SMASk[:SEQuence]:SOURce[?]

  • TRIGger:WAVeform[:SEQuence]:SOURce[?]

  • *CLS

  • *ESE

  • *ESR?

  • *IDN?

  • *OPC

  • *OPT?

  • *RCL

  • *RST

  • *SAV

  • *SRE

  • *STB?

  • *TRG

  • *TST?

  • *WAI


CALCulate Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

CALCulate Subsystem

Last Updated: March 28, 2008

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example, the CALCulate subsystem uses the markers to find the peaks and to read back their values in the Spectrum Monitor.

For details of the CALCulate commands refer to the topics in this section.


802.16 OFDM (N6301A)

CALCulate:ACPower

Last Updated: March 28, 2008

These commands provide data processing functions for the Adjacent Channel Power (ACP) measurement.

  • CALCulate:ACPower:LIMit:STATe[?]

  • CALCulate:ACPower:MARKer:AOFF

  • CALCulate:ACPower:MARKer:COUPle[:STATe][?]

  • CALCulate:ACPower:MARKer{1:12}:CPEak[:STATe][?]

  • CALCulate:ACPower:MARKer{1:12}:MAXimum

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:LEFT

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:NEXT

  • CALCulate:ACPower:MARKer{1:12}:MAXimum:RIGHt

  • CALCulate:ACPower:MARKer{1:12}:MINimum

  • CALCulate:ACPower:MARKer{1:12}:MODE[?]

  • CALCulate:ACPower:MARKer{1:12}:PTPeak

  • CALCulate:ACPower:MARKer{1:12}:REFerence[?]

  • CALCulate:ACPower:MARKer{1:12}:STATe[?]

  • CALCulate:ACPower:MARKer{1:12}:X[?]

  • CALCulate:ACPower:MARKer{1:12}:X:POSition[?]

  • CALCulate:ACPower:MARKer{1:12}:Y?

  • CALCulate:ACPower:OFFSet{1:2}:LIST:LIMit:NEGative[:UPPer]:DATA[?]

  • CALCulate:ACPower:OFFSet{1:2}:LIST:LIMit:POSitive[:UPPer]:DATA[?]

CALCulate:ACPower:LIMit:STATe[?]

Sets/queries the state of the limits test in the ACPower measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:LIMit:STATe?

Queries the limit test state.

CALCulate:ACPower:MARKer:AOFF

Turns all markers off.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer:AOFF

Turns all markers off

CALCulate:ACPower:MARKer:COUPle[:STATe][?]

Turns marker coupling on or off, or queries its state.

When this function is On, moving any marker causes an equal X axis movement of every other marker which is not Off. “Equal X axis movement” means that the difference between each marker’s X axis value (in the fundamental x-axis units of the trace that marker is on) and the X axis value of the marker being moved (in the same fundamental x-axis units) is preserved.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer:COUPle:STATe?

Queries the markers' coupled state

CALCulate:ACPower:MARKer{1:12}:CPEak[:STATe][?]

Turns Continuous Peak Search on or off, or queries its state.

When this function is on, a peak search is automatically performed for the selected marker after each sweep. The rules for finding the peak are exactly the same as for normal Peak Search including the peak criteria rules. If no valid peak is found, the “No Peak Found” warning is generated after each sweep. If a valid peak is found, the message “Peak Found” is displayed after each sweep.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer5:CPEak:STATe?

Queries marker 5's continuous peak search state

CALCulate:ACPower:MARKer{1:12}:MAXimum

Places the selected marker on the trace point with the maximum y-axis value.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer7:MAXimum

Places marker 7 on the trace point with the maximum y-axis value

CALCulate:ACPower:MARKer{1:12}:MAXimum:LEFT

Moves the selected marker to the nearest peak to the left of the current marker that meets all enabled peak criteria.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer7:MAXimum:LEFT

Moves marker 7 to the next peak to the left of its current position

CALCulate:ACPower:MARKer{1:12}:MAXimum:NEXT

Moves the selected marker to the peak that has the next highest amplitude.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer7:MAXimum:NEXT

Moves marker 7 to the next highest peak on the y-axis

CALCulate:ACPower:MARKer{1:12}:MAXimum:RIGHt

Moves the selected marker to the nearest peak to the right of the current marker that meets all enabled peak criteria.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer7:MAXimum:RIGHt

Moves marker 7 to the next peak to the right of its current position

CALCulate:ACPower:MARKer{1:12}:MINimum

Places the selected marker on the trace point with the minimum y-axis value.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer2:MAXimum

Places marker 2 on the trace point with the minimum y-axis value

CALCulate:ACPower:MARKer{1:12}:MODE[?]

Sets or queries the marker control mode.

Setting Range: NORMal | DELTa | FIXed | OFF

Query Range: NORMal | DELTa | FIXed | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer8:MODE?

Queries marker 8's control mode

CALCulate:ACPower:MARKer{1:12}:PTPeak

Finds the amplitude differences between the highest and lowest y-axis value.

This function is not available if marker coupling is switched on.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer3:MODE?

Calculates marker 3's peak-to-peak value

CALCulate:ACPower:MARKer{1:12}:REFerence[?]

Allows relative results to be calculated for marker functions. When used as a command, subsequent results for the marker in the command are calculated relative to the marker that is given as the argument.

Note that a marker cannot be relative to itself. If an attempt is made to set a marker relative to itself, a SCPI error message is generated: –221: “Settings conflict; marker cannot be relative to itself.”

Setting Range: 1-12

Query Range: 1-12

*RST Setting:

  • Marker1: 2

  • Marker2: 3

  • Marker3: 4

  • Marker4: 5

  • Marker5: 6

  • Marker6: 7

  • Marker7: 8

  • Marker8: 9

  • Marker9: 10

  • Marker10: 11

  • Marker11: 12

  • Marker12: 1

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer3:REFerence 5

Makes subsequent calculations on Marker3 relative to Marker5

CALCulate:ACPower:MARKer{1:12}:X[?]

Sets or queries the marker's X axis value in the current marker X Axis Scale unit. This command has no effect if the marker's control mode is Off.

The query returns the marker’s absolute X Axis value if the control mode is Normal, or the offset from the marker’s reference marker if the control mode is Delta. If the marker is Off the response is NaN (not a number, represented as 9.9e+37).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer12:X?

Queries the x-axis position of marker 12

CALCulate:ACPower:MARKer{1:12}:X:POSition[?]

Sets or queries the marker's X position in trace points. It has no effect if the control mode is Off

The query returns the marker’s absolute X Axis position if the control mode is Normal, or the offset from the marker’s reference marker if the control mode is Delta. If the marker is Off the response is NaN (not a number, represented as 9.9e+37).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer2:X:POSition 75

Set the x-axis position of marker 2 to 75

CALCulate:ACPower:MARKer{1:12}:Y?

Returns the marker's Y axis value in the current marker Y axis unit.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01.50 and above

Example:

CALCulate:ACPower:MARKer6:Y?

Queries the y-axis position of marker 6


802.16 OFDM (N6301A)

CALCulate:CLIMits

Last Updated: March 28, 2008

This command provides limit fail summary information. This function is available after the measurement result data is collected.

  • CALCulate:CLIMits:FAIL?

CALCulate:CLIMits:FAIL?

Queries a summary of all the individual LIMit:FAILs. If any of the individual LIMit:FAILs have a non-zero value, indicating a failure, the composite FAIL query returns a 1. If there are no failures then a 0 is returned. When all the failed LIMits have been CLEared, then the composite FAIL is also cleared. This query is useful if you only need to know whether a limit has passed or failed.

This query checks for the pass/fail result in the following measurements:

  • OFDM Modulation Analysis

Query Range: 0 | 1

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CALCulate:CLIMits:FAIL?

Returns a summary pass/fail indication of the individual limit results.


802.16 OFDM (N6301A)

CALCulate:EVM

Last Updated: March 28, 2008

These commands provide data processing functions for Modulation Analysis (EVM) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:BURSt[1]|2:NUMBer?

  • CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

  • CALCulate:EVM:BURSt[1]|2:SHAPe[?]

  • CALCulate:EVM:BURSt[1]|2:STATe[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

  • CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

  • CALCulate:EVM:BURSt:TYPE[:SELect][?]

  • CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

  • CALCulate:EVM:EQUalizer:TMODe[?]

  • CALCulate:EVM:INFormation:BURSt[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor[?]

  • CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset[?]

  • CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE[?]

  • CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot[?]

  • CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

  • CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

  • CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset[?]

  • CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

  • CALCulate:EVM:MAP:CUSTom:NAME[?]

  • CALCulate:EVM:MAP:DETect

  • CALCulate:EVM:MAP:SELect:FECCode[?]

  • CALCulate:EVM:MAP:SELect:TYPE[?]

  • CALCulate:EVM:MARKer:AOFF

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SUBCarrier[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SYMBol[?]

  • CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:EVM:MS:PBASe[?]

  • CALCulate:EVM:PILot[?]

  • CALCulate:EVM:PILot:TRACk:AMPLitude[?]

  • CALCulate:EVM:PILot:TRACk:PHASe[?]

  • CALCulate:EVM:PILot:TRACk:TIMing[?]

  • CALCulate:EVM:PINDex[?]

  • CALCulate:EVM:SPECtrum[?]

  • CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

  • CALCulate:EVM:SUBChannel:MASK[?]

  • CALCulate:EVM:SWEep:OFFSet[?]

  • CALCulate:EVM:SYMBol:ADJust[?]

  • CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

  • CALCulate:EVM:ZONE[?]

  • CALCulate:EVM:ZONE:INTerval[?]

  • CALCulate:EVM:ZONE:OFFSet[?]

CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

Sets/queries the Data Modulation Type to be used.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

Query Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

*RST Setting: QPSKR1BY2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:MODulation:TYPE QPSKR1BY2

Sets the Data Modulation Type to QPSK-1/2.

CALCulate:EVM:BURSt[1]|2:NUMBer?

Queries the number of bursts to be measured. In the auto-detect mode, this parameter changes when detection is performed correctly. In the predefined-mode, this parameter is calculated from the map file.

BURSt1 is for BS, 2 for MS. Default is BS.

Query Range: <nr1>

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt2:NUMBer?

Queries the number of bursts to be measured for the second burst.

CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

Sets/queries whether to automatically set boosting levels, or to use the values that are specified for the bursts.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:POWer:MAP OFF

Turns off the automatic setting of boosting levels.

CALCulate:EVM:BURSt[1]|2:SHAPe[?]

Sets/queries wrapped or rectangle burst shapes.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: WRAPped | RECTangle

Query Range: WRAP | RECT

*RST Setting: RECTangle

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SHAPe WRAPped

Sets the burst shape to wrapped.

CALCulate:EVM:BURSt[1]|2:STATe[?]

Sets/queries multiple data bursts for analysis when it is set to On.

BURSt1 is for BS, 2 for MS. Default is BS.

The number of elements is determined by the Number of Bursts provided by the CALCulate:EVM:BURSt[1]|2:NUMBer? query.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:STATe?

Queries the burst state for the modulation analysis measurement.

CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

Sets/queries the number of the subchannel logical interval for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

Query Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SUBChannel:INTerval 1

Sets the number of the subchannel logical interval for the burst region to 1.

CALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

Sets/queries the number of the Subchannel logical offset for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to Number of subchannels on current zone - 1

Query Range: 0 to Number of subchannels on current zone - 1

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SUBChannel:OFFSet 1

Sets the Subchannel logical offset for burst 1 to 1.

CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

Sets/queries the number of the OFDMA symbol interval for the burst position.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

Query Range: 1 to Number of subchannels on current zone - Burst Region Subchannel Offset

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt2:SYMBol:INTerval?

Queries the number of the OFDMA symbol interval for burst 2.

CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

Sets/queries the number of the OFDMA symbol offset for the burst region.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 500

Query Range: 0 to 500

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:SYMBol:OFFSet 1

Sets the OFDMA symbol offset for burst 1 to 1.

CALCulate:EVM:BURSt:TYPE[:SELect][?]

Sets/queries a method of burst analysis. You can choose between the burst map method or the single burst method.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: MAP | SINGle | UZONe

Query Range: MAP | SING | UZON

*RST Setting: MAP

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:BURSt:TYPE UZONe

Sets the burst analysis method to Uniform Zone (Manual).

CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

Sets/queries whether the spectral flatness result trace is smoothed.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:EQUalizer:SMOothing ON

Turns on smoothing for the spectral flatness result.

CALCulate:EVM:EQUalizer:TMODe[?]

When demodulating the 802.16 OFDMA signal, the analyzer uses an equalizer to correct for linear impairments in the signal path, such as multi-path. The analyzer supports three different methods to initialize, or "train", the equalizer: Preamble Only, Preamble, Data & Pilots and Preamble & Pilots Only. Selecting an appropriate method can help isolate problems that contribute to increased RCE (EVM).

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: SEQuence | SDATa | SPILot

Query Range: SEQ | SDAT | SPIL

*RST Setting: SDATa

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:EQUalizer:TMODe SDATa

Sets the training method to Preamble, Data & Pilots.

CALCulate:EVM:INFormation:BURSt[?]

Sets/queries which burst's info is returned by MEASure|READ|FETCh:EVM10?

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 1 to CALC:EVM:BURS:COUN?

Query Range: 1 to :CALC:EVM:BURS:COUN?

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:INFormation:BURSt 2

Sets the information relating to burst 2 to be returned by the MEASure|READ|FETCh:EVM10? queries.

CALCulate:EVM:LIMit[1]|2:FERRor[?]

Sets/queries the limit in ppm for the absolute Frequency Error measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 100

Query Range: 0 to 100

*RST Setting: 2.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit2:FERRor 4.00

Sets the limit in ppm for the absolute Frequency Error measurement pass/fail test to 4.00 ppm for burst 2.

CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

Sets/queries the limit state for the absolute Frequency Error measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:FERRor:STATe OFF

Turns off limits for the absolute Frequency Error measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:IQOFfset[?]

Sets/queries the limit in relative amplitude for the I/Q Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -15 dB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:IQOFfset 0

Sets a limit of 0 in relative amplitude for the I/Q Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

Sets/queries the limit state for the I/Q Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:IQOFfset:STATe OFF

Turns off limits for the I/Q Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:PRCE[?]

Sets/queries the limit for the Peak RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:PRCE -50

Sets the limit for the Peak RCE measurement pass/fail test to -50 dBm.

CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

Sets/queries the limit state for the Peak RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:PRCE:STATe 1

Turns on limits for the Peak RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RCEPilot[?]

Sets/queries the limit for the Pilot RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RCEPilot -50

Sets the limit for the Pilot RCE measurement pass/fail test to -50.

CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

Sets/queries the limit state for the Pilot RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RCEPilot:STATe?

Queries the limit state for the Pilot RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RRCE[?]

Sets/queries the limit for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: 0.00

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE -50

Sets the limit for the RMS RCE measurement pass/fail test to -50.

CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

Sets/queries the limit mode for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:AUTO OFF

Sets the limit mode for the RMS RCE measurement pass/fail test to Manual.

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

Sets/queries the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -20.5

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA16:R1B2 -10.0

Sets the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -10.0.

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

Sets/queries the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: -24.0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4 -10.0

Sets the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test to -10.0.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

Sets/queries the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 15

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R1B2

Sets the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

Sets/queries the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R2B3 -20

Sets the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

Sets/queries the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QA64:R3B4 -20

Sets/queries the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test to -20.

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

Sets/queries the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 15

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2 -25

Sets the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test to -25.

CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

Sets/queries the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: -100 to 0

Query Range: -100 to 0

*RST Setting: - 18

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:QPSK:R3B4?

Queries the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

Sets/queries the limit state for the RMS EVM measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:RRCE:STATe OFF

Turns off limits for the RMS EVM measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?]

Sets/queries the lower limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -2,-4,0,0,0,0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt -2,-4,0,0,0,0

Sets the lower limit level at the start subcarrier for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

Sets/queries the lower limit state at the start subcarrier for the selected offset.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe?

Queries the lower limit state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?]

Sets/queries the lower mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -2, -4, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP?

Queries the lower mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

Sets/queries the lower mask limit auto/manual state at the stop subcarrier state for the selected offset. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO AUTO,AUTO,AUTO,AUTO,AUTO,AUTO

Sets the lower mask limit auto/manual state at the stop subcarrier state to Auto for all offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

Sets/queries which offset side will be measured.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: BOTH | NEGative | POSitive, BOTH | NEGative |POSitive, BOTH |NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive

Query Range: BOTH | NEG | POS, BOTH | NEG |POS, BOTH |NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS

*RST Setting: BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE?

Queries which offset side will be measured.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?]

Sets/queries the start subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 1, 210, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt?

Queries the start subcarrier for the currently selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

Sets/queries the start subcarrier state for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe ON, ON, ON, OFF, OFF, OFF

Sets the start subcarrier state for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

Sets/queries the stop subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: 210, 420, 0, 0, 0, 0

*RST Setting: 210, 420, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP?

Queries the stop subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?]

Sets/queries the upper limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: 2, 2, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt 2, 2, 0, 0, 0, 0

Sets the upper limit level at the start subcarrier for the selected offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

Sets/queries the upper limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe?

Queries the upper limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?]

Sets/queries the upper mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: 2, 2, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP?

Queries the upper mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

Sets/queries the upper mask limit auto/manual state at the stop subcarrier for the selected offset. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, and results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Sets the upper mask limit auto/manual state at the stop subcarrier for the all offsets to Auto.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?]

Sets/queries the lower limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt?

Queries the lower limit level at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

Sets/queries the lower limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe 1, 0, 0, 0, 0, 0

Sets the lower limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?]

Sets/queries the lower mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP -0.1, -0.1, 0.00, 0.00, 0.00, 0.00

Sets the lower mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

Sets/queries the lower mask limit auto/manual state at the stop subcarrier for the selected offset. If set to Auto, the Lower Mask Stop power level limit is coupled to Lower Mask Start, which results in a flat limit line. If set to Man, Lower Mask Start and Lower Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO AUTO,AUTO,AUTO,AUTO,AUTO,AUTO

Sets the lower mask limit auto/manual state at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

Sets/queries which offset side will be measured.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: BOTH | NEGative | POSitive, BOTH | NEGative |POSitive, BOTH |NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive, BOTH | NEGative | POSitive

Query Range: BOTH | NEG | POS, BOTH | NEG |POS, BOTH |NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS, BOTH | NEG | POS

*RST Setting: BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE BOTH, BOTH, BOTH, BOTH, BOTH, BOTH

Sets which offset side will be measured for the 6 offsets.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?]

Sets/queries the start subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt?

Queries the start subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

Sets/queries the start subcarrier state for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe 0, 1, 0, 0, 0, 0

Sets the start subcarrier state for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

Sets/queries the stop subcarrier for the currently selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 integer values (-1024 to 1024).

Query Range: Comma separated list of 6 integer values (-1024 to 1024).

*RST Setting: 420, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP?

Queries the stop subcarrier for the currently selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?]

Sets/queries the upper limit level at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt 0.1, 0.1, 0.00, 0.00, 0.00, 0.00

Sets the upper limit level at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

Sets/queries the upper limit level state at the start subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 0, 0, 0, 0, 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe?

Queries the upper limit level state at the start subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?]

Sets/queries the upper mask limit at the stop subcarrier for the selected offset.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 real values (-100 dB to 100 dB).

Query Range: Comma separated list of 6 real values (-100 dB to 100 dB).

*RST Setting: -0.4, -0.4, -0.4, -0.4, -0.4, -0.4

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP?

Queries the upper mask limit at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

Sets/queries the upper mask limit auto/manual state at the stop subcarrier for the selected offset. The upper mask limit ranges from -100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

Query Range: Comma separated list of 6 auto/manual values (AUTO | MANual).

*RST Setting: AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO AUTO, AUTO, AUTO, AUTO, AUTO, AUTO

Sets the upper mask limit auto/manual state at the stop subcarrier for the selected offset.

CALCulate:EVM:LIMit[1]|2:TOFFset[?]

Sets/queries the limit for the Time Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 to 100e-3

Query Range: 0 to 100e-3

*RST Setting: 1e-6

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:TOFFset?

Queries the limit for the Time Offset measurement pass/fail test.

CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

Sets/queries the limit state for the Time Offset measurement pass/fail test.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:LIMit:TOFFset:STATe 1

Sets the limit state for the Time Offset measurement pass/fail test to OFF.

CALCulate:EVM:MAP:CUSTom:NAME[?]

Sets/queries the customized Map name.

Setting Range: Uppercase, Lowercase, Numeric, Symbol

Query Range: Uppercase, Lowercase, Numeric, Symbol

*RST Setting: Default Map

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:CUSTom:NAME "Agilent"

Sets the customized Map name to Agilent.

CALCulate:EVM:MAP:DETect

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:DETect

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

CALCulate:EVM:MAP:SELect:FECCode[?]

Sets/queries the coding type of the forward error correction that is used to decode the DL-MAP burst.

Setting Range: CC (Convolutional Code)|CTC (Conv Turbo Code)

Query Range: CC (Convolutional Code)|CTC (Conv Turbo Code)

*RST Setting: CC

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:SELect:FECCode CTC
Sets the coding type that is used for decoding the DL-MAP burst to Convolutional Turbo Code.

CALCulate:EVM:MAP:SELect:TYPE[?]

Sets/queries the Zone Definition which defines the zone information.

Setting Range: AUTO | CUSTom | FCH

Query Range: AUTO | CUST | FCH

*RST Setting: CUSTom

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MAP:SELect:TYPE?

Queries the Zone Definition.

CALCulate:EVM:MARKer:AOFF

Turns all markers off.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer:AOFF

Turns all markers off.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

Sets/queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: Result dependant on Markers setup and signal source.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum

Places the marker 2 on the trace point with the maximum y-axis value for that marker's trace.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

Moves the selected marker to the next peak to the left of the current marker.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer5:MAXimum:LEFT

Moves marker 5 to the next peak to the left of the current marker.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

Moves the selected marker to the peak that has the next highest amplitude that is less than the marker's current value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum:NEXT

Moves marker 2 to the peak that has the next highest amplitude that is less than the marker's current value.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

Moves the selected marker to the next peak to the right of the current marker.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:MAXimum:RIGHt

Moves marker 2 to the next peak on the right of the current marker.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

Moves the selected marker to the minimum y-axis value of the current trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer6:MINimum

Moves marker 6 to the minimum y-axis value of the current trace.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries the marker control mode.

If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

Default Active Function: The active function for the selected marker's current control mode. Note that if the current control mode is Off, there is no active function, and the active function is set to Off.

Active Function Display:

  • the marker Chip value in the IQ Measured Polar graph

  • the marker X axis value in any other graph

The value entered in the active function area will display the marker value to its full entered precision.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer10:PTPeak

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the marker that the selected marker will be relative to (that is, its reference marker).

A marker cannot be relative to itself so that choice is grayed out, and if sent from SCPI generates error ––221: &rdquor;Settings conflict; marker cannot be relative to itself.&rdquo;

When queried a single value will be returned (the specified marker numbers relative marker). A marker cannot be relative to itself so that choice is grayed out, and if sent from SCPI generates error ––221: &rdquor;Settings conflict; marker cannot be relative to itself.&rdquo;

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer7:REFerence?

Queries the marker that marker 7 will be relative to (that is, its reference marker).

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is Off to On, or 1, puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer3:STATe ON

Sets marker 3 to Normal mode and places it at the center of the screen.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Accesses a menu that allows you to assign a specified marker to the designated trace. Symbol Traces means that three traces for I/Q polar, Symbol Error Carrier, Symbol Error Symbol, Symbol Power Carrier, and Symbol Power Symbol can be assigned. If used, a marker pointer is placed on each trace. In this case, the three pointers will move at the same time, as coupled markers, whenever the X position of the Symbol Traces changes.

Setting Range: SYMBol | POLar | EVCarrier | RECarrier | EVSymbol | RESymbol | PCARrier | RPCarrier | PSYMbol | RPSymbol | FLATness | DFLatness | PVT | SPECtrum

Query Range: SYMB | POL | EVC | REC | EVS | RES | PCAR | RPC | PSYM | RPS | FLAT | DFL | PVT | SPEC

*RST Setting: SYMB

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer2:TRACe?

Queries the currently assigned trace for marker 2.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. It has no effect if the control mode is Off, but is the SCPI equivalent of entering an X value if the control mode is Normal or Delta.

If no suffix is sent it will use the fundamental units for the current marker X Axis Scale. If a suffix is sent that does not match the current marker X Axis Scale unit, an &rdquor;Invalid suffix&rdquo; error will be generated. The query returns the marker's absolute X Axis value if the control mode is Normal, or the offset from the marker's reference marker if the control mode is Delta. The query is returned in the fundamental units for the
current marker X Axis scale: Hz for Frequency and Inverse Time, seconds for Period and Time. If the marker is Off the response is not a number (NAN).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are set to Off, so a Marker X Axis Value query will return a not a number (NAN)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer3:X?

Queries the marker 3 X Axis value in the current marker X Axis Scale unit.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

The query returns the marker's absolute X Axis value in trace points if the control mode is Normal, or the offset from the marker's reference marker in trace points, if the control mode is Delta. The value is returned as a real number, not an integer, corresponding to the translation from X Axis Scale units to trace points (see &rdquor;Fractional Trace Points&rdquo;, above). If the marker is Off the response is not a number (NAN).

After a preset, all markers are set to Off, so Marker X Axis Value query will return a not a number (NAN).

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are set to Off, so a Marker X Axis Value query will return a not a number (NAN)

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer4:X:POSition?

Queries the X position of marker 4 in trace points.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SUBCarrier[?]

Sets/queries the marker X subcarrier in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -2147483648 to 2147483647

Query Range: -2147483648 to 2147483647

*RST Setting: After a preset, all markers are set to Off, so Marker X Axis Subcarrier Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer10:X:SUBCarrier?

Queries the X subcarrier in trace points for marker 10.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SYMBol[?]

Sets/queries the marker X symbol in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta - except in trace points rather than X Axis Scale units. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -2147483648 to 2147483647

Query Range: -2147483648 to 2147483647

*RST Setting: After a preset, all markers are set to Off, so Marker X Axis Symbol Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer9:X:SYMBol 1

Sets X symbol in trace points to 1 for marker 9.

CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Queries the marker Y Axis value in the current marker Y Axis unit.

Query Range: -9.9E+37 to 9.9E+37

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MARKer11:Y?

Queries the Y Axis value for marker 11 in the current marker Y Axis unit.

CALCulate:EVM:MS:PBASe[?]

Sets/queries the Uplink Permbase number for MS measurement. This parameter is needed to determine subcarrier allocation.

Setting Range: 0 to 69

Query Range: 0 to 69

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:MS:PBASe 1

Sets the Uplink Permbase number for the MS measurement to 1.

CALCulate:EVM:PILot[?]

Sets/queries whether or not to include the Pilot in RCE calculations.

Setting Range: INCLude | EXCLude

Query Range: INCL | EXCL

*RST Setting: EXCLude

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot INCLude

Sets the Pilot to be included in RCE calculations.

CALCulate:EVM:PILot:TRACk:AMPLitude[?]

Sets/queries whether the analyzer tracks amplitude changes in the pilot subcarriers. When Track Amplitude is selected, the analyzer applies pilot subcarrier amplitude error correction to the pilot and data subcarriers. This is in addition to Track Phase and Track Timing error correction, if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:AMPLitude 1

Sets the analyzer to track amplitude changes in the pilot subcarriers.

CALCulate:EVM:PILot:TRACk:PHASe[?]

Sets/queries whether the analyzer tracks phase changes in the pilot subcarriers. When Track Phase is selected, the analyzer applies pilot subcarrier phase error correction to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Timing error correction if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:PHASe 0

Turns off phase change tracking in the pilot subcarriers.

CALCulate:EVM:PILot:TRACk:TIMing[?]

Sets/queries whether the analyzer tracks timing changes in the pilot subcarriers. Track Timing applies pilot subcarrier timing error correction (frequency offset correction) to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Phase error correction if selected.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PILot:TRACk:TIMing?

Queries whether or not the analyzer is set to track timing changes in the pilot subcarriers.

CALCulate:EVM:PINDex[?]

Sets/queries the number that the Preamble Index specifies for the preamble sequence of the downlink subframe

Setting Range: 0 to 113

Query Range: 0 to 113

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:PINDex 1

Sets the Preamble Index to 1.

CALCulate:EVM:SPECtrum[?]

Sets/queries a spectrum to either normal or to inverted for demodulation related measurements. If set to INVert, the upper and lower spectrums are swapped. The invert function conjugates the spectrum, which is equivalent to taking the negative of the quadrature component in demodulation. The correct setting (Normal or Invert) depends on whether the signal at the input of the instrument has a high or a low side mix.

Setting Range: INVert | NORMal

Query Range: INV | NORM

*RST Setting: NORMal

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SPECtrum INVert

Sets the spectrum to inverted for demodulation related measurements.

CALCulate:EVM:SPECtrum:AMPFlatness:INTerval[?]

Sets/queries the Measurement Interval to calculate the average power for each subcarrier.

Setting Range: PAMBle | ALL

Query Range: PAMB | ALL

*RST Setting: ALL

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SPECtrum:AMPFlatness:INTerval?

Queries the Measurement Interval used for calculating the average power for each subcarrier.

CALCulate:EVM:SUBChannel:MASK[?]

Sets/queries which subchannel groups are allocated to the segment. The DL PUSC zone definition provides 6 subchannel groups which specify the number of used subchannels and how they are mapped to subcarriers for analysis of DL-PUSC data bursts.

Setting Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

Query Range: Comma separated list of 6 state values (0 | OFF | 1 | ON).

*RST Setting: 1, 1, 1, 1, 1, 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SUBChannel:MASK 1, 1, 1, 1, 1, 1

Sets the subchannel groups allocated to the segment.

CALCulate:EVM:SWEep:OFFSet[?]

Sets/queries the timing offset of the capture interval in frames. If the Capture Interval is 1 frame, Meas Offset is fixed at "0". If Average is set to On, the frame that is analyzed does not take into account this offset value during averaging. After this measurement is complete, changing the offset value will result in running post-processing to analyze the offset frame; the measurement results are then updted.(only for non-averaged results).

Setting Range: 0 to Capture Interval - 1

Query Range: 0 to Capture Interval - 1

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SWEep:OFFSet?

Queries the timing offset of the capture interval in frames.

CALCulate:EVM:SYMBol:ADJust[?]

Sets/queries the adjustment of the "useful symbol time period" (TFFT) within the "OFDMA extended symbol time period" (TS). Symbol Timing Adjust shifts the start of the TFFT period to earlier in the TS time period. You specify the amount of TFFT shift as a percentage of the TFFT length.

Setting Range: -12.5% to - 0%

Query Range: -12.5% to - 0%

*RST Setting: -3.125%

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:SYMBol:ADJust -3.100

Sets/queries the adjustment of the "useful symbol time period" (TFFT) to -3.100%.

CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

Sets/queries the Data Modulation Type to be used.

BURSt1 is for BS, 2 for MS. Default is BS.

Setting Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

Query Range: QPSKR1BY2 | QPSKR3BY4 | QAM16R1BY2 | QAM16R3BY4 | QAM64R1BY2 | QAM64R2BY3 | QAM64R3BY4

*RST Setting: QPSKR1BY2

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:UZONe:MODulation:TYPE?

Queries the Data Modulation Type.

CALCulate:EVM:ZONE[?]

Sets/queries the zone definition to be used.

Setting Range: 1 to a value determined by current map

Query Range: 1 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE 1

Sets the zone definition to 1.

CALCulate:EVM:ZONE:INTerval[?]

Sets/queries the zone definition to be used.

Setting Range: 1 to a value determined by current map

Query Range: 1 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE:INTerval?

Queries the zone definition.

CALCulate:EVM:ZONE:OFFSet[?]

Sets/queries the Zone Offset in symbols.

Setting Range: 0 to a value determined by current map

Query Range: 0 to a value determined by current map

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:EVM:ZONE:OFFSet?

Queries the Zone Offset.


802.16 OFDM (N6301A)

CALCulate:PSTatistic

Last Updated: March 28, 2008

These commands provide data processing functions for Power Stat CCDF (PST) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:PSTatistic:MARKer:AOFF

  • CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

  • CALCulate:PSTatistic:NSELect[?]

  • CALCulate:PSTatistic:STORe:REFerence

CALCulate:PSTatistic:MARKer:AOFF

Turns off all markers.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:AOFF

Turns off all markers.

CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

Sets/queries marker coupling. When this function is invoked, moving any marker causes an "equal X Axis movement" of every other marker which is active. By "equal X Axis movement" we mean that the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) is preserved, as is the X Axis value of the marker being moved (in the same fundamental X-axis units). NOTE: This may result in markers going off screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:COUPle

Turns on marker coupling.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:FUNCtion:RESult?

Queries the marker Y Axis value in the current marker Y Axis unit.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries a marker type for a given marker.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer2:MODE POSition

Sets marker 5 to position mode.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the reference marker that the selected marker will be relative to (that is, its reference marker).

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer12:REFerence 6

Sets the reference marker for marker 12 to marker 6.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is Off to On, or 1, puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer5:STATe?

Queries the state of marker 5.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Sets/queries the specified marker to the designated trace.

Setting Range: MEASured | GAUSsian | REFerence

Query Range: MEAS | GAUS | REF

*RST Setting: MEASured

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer3:TRACe GAUSsian

Sets marker 3 to the gaussian trace.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. This function has no effect if the control mode is Off, but is the remote command equivalent of entering an X value if the control mode is Normal or Delta. The value is set using relative amplitude.

Setting Range: 0.0 to 50.0

Query Range: 0.0 to 50.0

*RST Setting: After a preset, all Markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:X?

Queries the marker X Axis value in the current marker X Axis Scale unit.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points.

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all Markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer:X:POSition?

Queries the marker X position in trace points.

CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Sets/queries the marker Y Axis value in the current marker Y Axis unit.

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:MARKer7:Y?

Queries the Y Axis value for marker 7.

CALCulate:PSTatistic:NSELect[?]

Sets/queries the selected marker.

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:NSELect 12

Selects marker 12.

CALCulate:PSTatistic:STORe:REFerence

Copies the currently measured curve as the user-definable reference trace. The captured data will remain until the other mode is chosen. Pressing this key also refreshes the reference trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:PSTatistic:STORe:REFerence

Copies the currently measured curve as the user-definable reference trace.


802.16 OFDM (N6301A)

CALCulate:WAVeform

Last Updated: March 28, 2008

These commands provide data processing functions for Waveform (WAV) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:WAVeform:MARKer:AOFF

  • CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12[:SET]:RLEVel

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SPAN[?]

  • CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

CALCulate:WAVeform:MARKer:AOFF

Turns off all markers.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer:AOFF

Turns off all markers.

CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

Toggles the state of the markers to be coupled On or Off. When this function is true (On), moving any marker causes an equal X axis movement of every other marker which is not Off. "Equal X axis movement" refers to the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) and the X Axis value of the marker being moved (in the same fundamental x-axis units) are preserved.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

Sets/queries the marker control function type to, Marker Noise, Band/Interval Power, Band Interval Density, or Marker Function Off.

Setting Range: BPOWer | BDENsity | OFF

Query Range: BPOWer | BDENsity | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

Sets/queries the left edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]

Sets/queries the right edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

Sets/queries the right edge frequency or time value for the band of the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 5% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:RESult[?]

Queries the marker Y Axis value in the current marker Y Axis unit.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace and accesses a menu that enables you to select to do a minimum peak search.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum

Moves the selected marker to the minimum y-axis value on the current trace.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Sets/queries the marker control mode to Normal, Delta, Fixed or Off.

Setting Range: POSition | DELTa | OFF

Query Range: POS | DELT | OFF

*RST Setting: OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Sets/queries the marker that the selected marker will be relative to (that is, its reference marker).

Setting Range: 1 to 12

Query Range: 1 to 12

*RST Setting: 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 1

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12[:SET]:RLEVel

Sets the reference level to the marker Y value.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:STATe[?]

Sets/queries the state of a marker. Setting a marker which is OFF to state ON or 1 puts it in Normal mode and places it at the center of the screen.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Sets/queries the specified marker to the designated trace.

Setting Range: RFENvelope | IQ

Query Range: RFENvelope | IQ

*RST Setting: RFEN

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X[?]

Sets/queries the marker X Axis value in the current marker X Axis Scale unit. It has no effect if the control mode is Off, but is the SCPI equivalent of entering an X value if the control mode is Normal or Delta.

Setting Range: 9.9E+37 to 9.9E+37

Query Range: 9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:POSition[?]

Sets/queries the marker X position in trace points. It has no effect if the control mode is Off, but is the SCPI equivalent of entering a value if the control mode is Normal or Delta. The entered value is immediately translated into the current X Axis Scale units for setting the value of the marker.

Setting Range: -9.9E+37 to 9.9E+37

Query Range: -9.9E+37 to 9.9E+37

*RST Setting: After a preset, all markers are turned OFF, so Marker X Axis Value query will return a not a number (NAN).

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:X:SPAN[?]

Sets/queries the width of the frequency span for the selected marker.

Setting Range: 0 to 100 seconds

Query Range: 0 to 100 seconds

*RST Setting: 10% of Meas Time

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:Y?

Queries the marker Y Axis value in the current marker Y Axis unit.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:


802.16 OFDM (N6301A)

CALCulate:SMASk

Last Updated: March 28, 2008

These commands provide data processing functions for Spectral Mask (SMAS) measurements. These functions are available after the measurement result data is collected.

  • CALCulate:SMASk:LCOMpensatio[?]

  • CALCulate:SMASk:MDEFinition[?]

CALCulate:SMASk:LCOMpensatio[?]

Sets/queries loss or gain in the test fixture. A negative value compensates for a loss and a positive value compensates for a gain.

Setting Range: -999 dBm to 999 dBm

Query Range: -999 dBm to 999 dBm

*RST Setting: 0 dbm

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:SMASk:LCOMpensatio -20

Compensates for a 20 dBm loss.

CALCulate:SMASk:MDEFinition[?]

Allows you to define a custom mask. Spectral mask measurements detailing the percentage of failing points will be made relative to this mask. Mask definitions are relative to the centre frequency and must cover the range -30 MHz to +30 MHz

Setting Range: <mask points>: An array (comma delimited) of the offset frequency (from the center) and the absolute amplitude pairs to be connected to create the custom mask.

Query Range: Returns the current set of <mask points>

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CALCulate:SMASk:MDEFinition -30e6,-20,30e6,-15

Produces a mask consisting of two points connected at -30 MHz, -20 dBm and +30 MHz, -15 dBm.


802.16 OFDM (N6301A)

CONFigure Subsystem

Last Updated: March 28, 2008

Description

The CONFigure subsystem is used to perform high level configuration functions.

For details of the CONFigure commands, refer to the CONFigure topic in this section.


802.16 OFDM (N6301A)

CONFigure

Last Updated: March 28, 2008

These commands perform high level configuration functions.

  • CONFigure?

  • CONFigure:ACPower

  • CONFigure:ACPower:NDEFault

  • CONFigure:EVM

  • CONFigure:EVM:NDEFault

  • CONFigure:PSTatistic

  • CONFigure:PSTatistic:NDEFault

  • CONFigure:SMASk

  • CONFigure:SMASk:NDEFault

  • CONFigure:WAVeform

  • CONFigure:WAVeform:NDEFault

CONFigure?

Queries the name of the measurement that is currently running.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure?

Queries the name of the measurement that is currently running.

CONFigure:ACPower

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:ACPower

Restores all the measurement parameters to their default values.

CONFigure:ACPower:NDEFault

Stops the current measurement and changes to the Adjacent Channel Power measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

CONFigure:ACPower:NDEFault

Stops the current measurement and changes to the Adjacent Channel Power measurement. CONFigure:EVM

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:EVM

Restores all the measurement parameters to their default values.

CONFigure:EVM:NDEFault

Stops the current measurement and changes to the EVM measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Setting Range:

Query Range:

*RST Setting:

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:EVM:NDEFault

Stops the current measurement and changes to the EVM measurement.

CONFigure:PSTatistic

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:PSTatistic

Restores all the measurement parameters to their default values.

CONFigure:PSTatistic:NDEFault

Stops the current measurement and changes to the Power Stat CCDF measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:PSTatistic:NDEFault

Stops the current measurement and changes to the Power Stat CCDF measurement.

CONFigure:SMASk

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:SMASk

Restores all the measurement parameters to their default values.

CONFigure:SMASk:NDEFault

Stops the current measurement and changes to the Spectral Mask measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:SMASk:NDEFault

Stops the current measurement and changes to the Spectral Mask measurement.

CONFigure:WAVeform

Restores all the measurement parameters to their default values.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:WAVeform

Restores all the measurement parameters to their default values.

CONFigure:WAVeform:NDEFault

Stops the current measurement and changes to the Waveform measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

CONFigure:WAVeform:NDEFault

Stops the current measurement and changes to the Waveform measurement.


FETCh Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

FETCh? Subsystem

Last Updated: March 28, 2008

Description

The FETCh? query is a function that allows you to query results from a measurement that was previously INITiated. It does NOT begin a measurement. If no measurement is in progress it returns the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query hangs until the results are available, or the measurement fails or times out. The exact results returned by a FETCh? depends on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands, FETCh? is the primary way for you to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow you to send commands and not wait for completion.

For details of the FETCh? commands refer to the FETCh? subsystems in this section.

For details on commands that are used to perform data processing on measurement results, refer to the CALCulate Subsystem.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDM (N6301A)

FETCh:ACPower?

This command returns results for the Adjacent Channel Power measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:ACPower{1:3}?

FETCh:ACPower{1:3}?

Queries the Adjacent Channel Power measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

FETCh:ACP3?

Returns 24 limit result values.


802.16 OFDM (N6301A)

FETCh:EVM?

Last Updated: March 28, 2008

This command returns results for the Modulation Analysis measurement

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:EVM{0:20}?

FETCh:EVM{0:23}?

Queries the Modulation Analysis measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • 0 (reserved for future use)

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged IQ Gain Imbalance - a floating point number in dB

  • Max IQ Gain Imbalance - a floating point number in dB

  • Standard Deviation of IQ Gain Imbalance - a floating point number in dB

  • Average IQ Quadrature Error - a floating point number in degrees

  • Max IQ Quadrature Error- a floating point number in degrees

  • Standard Deviation of IQ Quadrature Error- a floating point number in degrees

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged Total Power - a floating point number in dBm.

  • Max Total Power - a floating point number in dBm

  • Standard Deviation of Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • Average Common Pilot Error (CPE) level - a floating point number in dB

  • Max Common Pilot Error (CPE) level a floating point number in dB

  • Standard Deviation of Common Pilot Error (CPE) level - a floating point number in dB

  • Nominal channel bandwidth of the signal - a floating point number in Hz

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary burst info data for the analysed signal. There is one group of five results for each burst in the analyzed waveform. Each group has the form:

  • Subframe info type (summarises whole input signal):

    • 0 = Preamble

    • 1 = FCH

    • 2 = Burst

    • 3 = Unknown

    • 4 = All (summary of whole input signal)

  • Modulation format

    • 0 = BPSK

    • 1 = QPSK

    • 2 = 16-QAM

    • 3 = 64-QAM

  • Length (in symbol times) of the described piece of the signal

  • Average power (in Volts peak squared)

  • RMS EVM (%)

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: reserved for future use

  • 22: reserved for future use

  • 23 I/Q array of idealised matrix, used to calculate EVM.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FETCh:EVM19?

Returns the FFT Spectrum trace results.


802.16 OFDM (N6301A)

FETCh:PSTatistic?

Last Updated: March 28, 2008

This command returns results for the Power Stat CCDF measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:PSTatistic{0:4}?

FETCh:PSTatistic{0:4}?

Queries the Power Stat CCDF measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10. Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FETCh:PSTatistic?

Returns 10 scalar results.


802.16 OFDM (N6301A)

FETCh:SMASk?

Last Updated: March 28, 2008

This command returns results for the Spectral Mask measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:SMASk{0:3}?

FETCh:SMASk{0:3}?

Queries the Spectral Mask measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FETCh:SMASk1?

Returns the percentage of points failing the mask.


802.16 OFDM (N6301A)

FETCh:WAVeform?

Last Updated: March 28, 2008

This command returns results for the Waveform measurement.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • FETCh:WAVeform{0:2}?

FETCh:WAVeform{0:2}?

Queries the Waveform measurement results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FETCh:WAVeform2?

Returns trace point values of the entire captured signal envelope trace data.


FORMat Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

FORMat Subsystem

Last Updated: March 28, 2008

Description

The FORMat subsystem is used to set a data format for transferring numeric and array information. This data format is used for both command and response data by those commands that are specifically designated to be affected by the FORMat subsystem.

For details of the FORMat commands, refer to the FORMat topic in this section.


802.16 OFDM (N6301A)

FORMat

Last Updated: March 28, 2008

These commands set a data format for transferring numeric and array information.

  • FORMat[:TRACe][:DATA][?]

  • FORMat:BORDer[?]

FORMat[:TRACe][:DATA][?]

Sets/queries the format of the trace data input and output across any remote port.

Setting Range: ASCii | REAL,32 | REAL,64

Query Range: ASC | REAL,32 | REAL,64

*RST Setting: ASCii

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FORMat?

Queries the format of the trace data input and output across any remote port.

FORMat:BORDer[?]

Sets/queries the binary data byte order for data transfer and other queries. It controls whether binary data is transferred in normal or swapped mode.

Setting Range: NORMal | SWAPped

Query Range: NORM | SWAP

*RST Setting: NORMal

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

FORMat:BORDer SWAPped

Sets the binary data byte order for data transfer and other queries to swapped.


802.16 OFDM (N6301A)

INITiate

Last Updated: March 28, 2008

These commands allow you to start and stop measurements.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • INITiate:ACPower

  • INITiate:CONTinuous[?]

  • INITiate:CONTinuous:OPRiority[?]

  • INITiate:EVM

  • INITiate[:IMMediate]

  • INITiate:PAUSe

  • INITiate:PSTatistic

  • INITiate:RESTart

  • INITiate:RESume

  • INITiate:SMASk

  • INITiate:WAVeform

INITiate:ACPower

Initiates (starts) the Adjacent Channel Power measurement.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

INITiate:ACPower

Initiates (starts) the Adjacent Channel Power measurement.

INITiate:CONTinuous[?]

Sets the test set for Continuous measurement operation. The single/continuous state affects all measurements.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF (Note: SYST:PRESet sets INIT:CONT to ON)

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:CONTinuous?

Queries the single/continuous state.

INITiate:CONTinuous:OPRiority[?]

Sets/queries the priority of the application process.

Setting Range: 1 to 5

Query Range: 1 to 5

*RST Setting: 2

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:CONTinuous:OPRiority 3

Sets the priority of the application process to 3.

INITiate:EVM

Initiates (starts) the EVM measurement.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:EVM

Initiates (starts) the EVM measurement.

INITiate[:IMMediate]

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

INITiate:PAUSe

Pauses a measurement after the current data acquisition is complete.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:PAUSe

Pauses a measurement after the current data acquisition is complete.

INITiate:PSTatistic

Initiates (starts) the Power Stat CCDF measurement.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:PSTatistic

Initiates (starts) the Power Stat CCDF measurement.

INITiate:RESTart

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:RESTart

Performs a Restart function on the current sweep, or measurement, or set of averaged/held sweeps or measurements.

INITiate:RESume

Resumes the measurement from the point it was at when paused.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:RESume

Resumes the measurement from the point it was at when paused.

INITiate:SMASk

Initiates (starts) the Spectral Mask measurement.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:SMASk

Initiates (starts) the Spectral Mask measurement.

INITiate:WAVeform

Initiates (starts) the Waveform measurement.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

INITiate:WAVeform

Initiates (starts) the Waveform measurement.


MEASure Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

MEASure? Subsystem

Last Updated: March 28, 2008

Description

The MEASure? subsystem allows you to make measurements using the factory default test set settings.

For details of the MEASure? commands refer to the MEASure? subsystems in this section.

For details on commands that are used to perform data processing on measurement results, refer to the CALCulate Subsystem.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDM (N6301A)

MEASure:ACPower?

Last Updated: March 28, 2008

This command allows you to make Adjacent Channel Power measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:ACPower{1:3}?

MEASure:ACPower{1:3}?

Queries the Adjacent Channel Power measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

MEASure:ACP3?

Initiates an adjacent channel power measurement with default settings and returns 24 limit result values.


802.16 OFDM (N6301A)

MEASure:EVM?

Last Updated: March 28, 2008

This command allows you to make Modulation Analysis measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:EVM{0:23}?

MEASure:EVM{0:23}?

Makes an EVM measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • 0 (reserved for future use)

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged IQ Gain Imbalance - a floating point number in dB

  • Max IQ Gain Imbalance - a floating point number in dB

  • Standard Deviation of IQ Gain Imbalance - a floating point number in dB

  • Average IQ Quadrature Error - a floating point number in degrees

  • Max IQ Quadrature Error- a floating point number in degrees

  • Standard Deviation of IQ Quadrature Error- a floating point number in degrees

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged Total Power - a floating point number in dBm.

  • Max Total Power - a floating point number in dBm

  • Standard Deviation of Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • Average Common Pilot Error (CPE) level - a floating point number in dB

  • Max Common Pilot Error (CPE) level a floating point number in dB

  • Standard Deviation of Common Pilot Error (CPE) level - a floating point number in dB

  • Nominal channel bandwidth of the signal - a floating point number in Hz

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary burst info data for the analysed signal. There is one group of five results for each burst in the analyzed waveform. Each group has the form:

  • Subframe info type (summarises whole input signal):

    • 0 = Preamble

    • 1 = FCH

    • 2 = Burst

    • 3 = Unknown

    • 4 = All (summary of whole input signal)

  • Modulation format

    • 0 = BPSK

    • 1 = QPSK

    • 2 = 16-QAM

    • 3 = 64-QAM

  • Length (in symbol times) of the described piece of the signal

  • Average power (in Volts peak squared)

  • RMS EVM (%)

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: reserved for future use

  • 22: reserved for future use

  • 23 I/Q array of idealised matrix, used to calculate EVM.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

MEASure:EVM18?

Returns the Demod Bit trace.


802.16 OFDM (N6301A)

MEASure:PSTatistic?

Last Updated: March 28, 2008

This command allows you to make Power Stat CCDF measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:PSTatistic{0:4}?

MEASure:PSTatistic{0:4}?

Makes a Power Stat CCDF measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10.Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

MEASure:PSTatistic0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


802.16 OFDM (N6301A)

MEASure:SMASk?

Last Updated: March 28, 2008

This command allows you to make Spectral Mask measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:SMASk{0:3}?

MEASure:SMASk{0:3}?

Makes a Spectral Mask measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

MEASure:SMASk?

Returns the percentage of points failing the mask.


MEASure:WAVeform?

802.16 OFDM (N6301A)

MEASure:WAVeform

Last Updated: March 28, 2008

This command allows you to make Waveform measurements using the factory default test set settings.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • MEASure:WAVeform{0:2}?

MEASure:WAVeform{0:2}?

Makes a Waveform measurement using the factory default test set settings.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

MEASure:WAVeform0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


READ Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

READ? Subsystem

Last Updated: March 28, 2008

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.

  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .

  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.

  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDM (N6301A)

READ:ACPower?

This command makes Adjacent Channel Power measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:ACPower{1:3}?

READ:ACPower{1:3}?

Queries the Adjacent Channel Power measurement results.

Query Range: The integer value you specify defines the type of results returned. The results are also modified depending on the measurement type.

Total Power Reference mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm)

    • 3. 0.0

    • 4. Reference carrier power (dBm)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm)

If the results are not available, –999.0 is returned

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

PSD Reference Mode

  • 1 or not specified: Returns the following 28 comma-separated scalar results:

    • 1. 0.0

    • 2. Total carrier power (dBm/Hz)

    • 3. 0.0

    • 4. Reference carrier power (dBm/Hz)

    • 5. Lower offset A - relative power (dB)

    • 6. Lower offset A - absolute power (dBm/Hz)

    • 7. Upper offset A - relative power (dB)

    • 8. Upper offset A - absolute power (dBm/Hz)

    • 9. Lower offset B - relative power (dB)

    • 10. Lower offset B - absolute power (dBm/Hz)

    • 11. Upper offset B - relative power (dB)

    • 12. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 25. Lower offset F - relative power (dB)

    • 26. Lower offset F - absolute power (dBm/Hz)

    • 27. Upper offset F - relative power (dB)

    • 28. Upper offset F - absolute power (dBm/Hz)

    • If the results are not available,–999.0 is returned.

If the results are not available, –999.0 is returned.

  • 2. Returns the following 48 comma-separated results

    • 1. Channel (1) - relative power (dB)

    • 2. Channel (1) - absolute power (dBm/Hz)

    • 3. Channel (2) - relative power (dB)

    • 4. Channel (2) - absolute power (dBm/Hz)

    • ...

    • 23. Channel (12) - relative power (dB)

    • 24. Channel (12) - absolute power (dBm/Hz)

    • 25. Lower offset A - relative power (dB)

    • 26. Lower offset A - absolute power (dBm/Hz)

    • 27. Upper offset A - relative power (dB)

    • 28. Upper offset A - absolute power (dBm/Hz)

    • 29. Lower offset B - relative power (dB)

    • 30. Lower offset B - absolute power (dBm/Hz)

    • 31. Upper offset B - relative power (dB)

    • 32. Upper offset B - absolute power (dBm/Hz)

    • ...

    • 45. Lower offset F - relative power (dB)

    • 46. Lower offset F - absolute power (dBm/Hz)

    • 47. Upper offset F - relative power (dB)

    • 48. Upper offset F - absolute power (dBm/Hz)

If the results are not available, –999.0 is returned.

  • 3. Returns the following 24 scalar values of the pass/fail (0 = passed, or 1 = failed) determined by testing the relative to the reference carrier and by testing the absolute power limit of the offset frequencies (measured as total power in dB):

    • 1. Lower offset A - relative limit result

    • 2. Lower offset A - absolute limit result

    • 3. Upper offset A - relative limit result

    • 4. Upper offset A - absolute limit result

    • 5. Lower offset B - relative limit result

    • 6. Lower offset B - absolute limit result

    • 7. Upper offset B - relative limit result

    • 8. Upper offset B - absolute limit result

    • ...

    • 21 Lower offset F - relative limit result

    • 22 Lower offset F - absolute limit result

    • 23 Upper offset F - relative limit result

    • 24 Upper offset F - absolute limit result

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01.50 and above

Example:

READ:ACP3?

Initiates an adjacent channel power measurement and returns 24 limit result values.


802.16 OFDM (N6301A)

READ:EVM?

Last Updated: March 28, 2008

This command makes Modulation Analysis measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:EVM{0:23}?

READ:EVM{0:23}?

Provides a sequential method to make EVM measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 1 or not specified: Returns the following comma-separated scalar results:

  • Averaged Total RMS RCE (EVM) in dB - a floating point number in dB

  • Averaged Total RMS RCE (EVM) in % - a floating point number in percentage

  • Max Total RMS RCE (EVM) in dB - a floating point number in dB

  • Max Total RMS RCE (EVM) in % - a floating point number in percentage

  • Standard Deviation of Total RMS RCE (EVM) in dB - a floating point number in dB

  • Standard Deviation of Total RMS RCE (EVM) in % - a floating point number in percentage

  • Averaged Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Averaged Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Max Peak RMS RCE Symbol Number - an integer number at which the peak RCE is detected.

  • 0 (reserved for future use)

  • Standard Deviation of Peak RMS RCE (EVM) in dB - a floating point number in dB. This is a result of composite subcarriers in each symbol.

  • Standard Deviation of Peak RMS RCE (EVM) in % - a floating point number in percentage. This is a result of composite subcarriers in each symbol.

  • Averaged Pilot RCE in dB - a floating point number in dB.

  • Averaged Pilot RCE in % - a floating point number in percentage.

  • Max Pilot RCE in dB - a floating point number in dB.

  • Max Pilot RCE in % - a floating point number in percentage.

  • Standard Deviation of Pilot RCE in dB - a floating point number in dB.

  • Standard Deviation of Pilot RCE in % - a floating point number in percentage.

  • Averaged RMS Frequency Error - a floating point number in Hz.

  • Max RMS Frequency Error - a floating point number in Hz.

  • Standard Deviation of Frequency Error - a floating point number in Hz.

  • Averaged IQ Origin Offset - a floating point number in dB.

  • Max IQ Origin Offset - a floating point number in dB.

  • Standard Deviation of IQ Origin Offset - a floating point number in dB.

  • Averaged IQ Gain Imbalance - a floating point number in dB

  • Max IQ Gain Imbalance - a floating point number in dB

  • Standard Deviation of IQ Gain Imbalance - a floating point number in dB

  • Average IQ Quadrature Error - a floating point number in degrees

  • Max IQ Quadrature Error- a floating point number in degrees

  • Standard Deviation of IQ Quadrature Error- a floating point number in degrees

  • Averaged Symbol Clock Error - a floating point number in ppm.

  • Max Symbol Clock Error - a floating point number in ppm.

  • Standard Deviation of Symbol Clock Error - a floating point number in ppm.

  • Averaged Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Max Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Standard Deviation of Sync Correlation - a floating point number with no units which denotes an indicator of the synchronization.

  • Averaged Time Offset - a floating point number in seconds.

  • Max Time Offset - a floating point number in seconds.

  • Standard Deviation of Time Offset - a floating point number in seconds.

  • Averaged Total Power - a floating point number in dBm.

  • Max Total Power - a floating point number in dBm

  • Standard Deviation of Total Power - a floating point number in dBm.

  • Channel power - a floating number in dBm.

  • OBW - a floating number in Hz

  • Average Common Pilot Error (CPE) level - a floating point number in dB

  • Max Common Pilot Error (CPE) level a floating point number in dB

  • Standard Deviation of Common Pilot Error (CPE) level - a floating point number in dB

  • Nominal channel bandwidth of the signal - a floating point number in Hz

  • Abs Max Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Max Subcarrier Power (dBc) - a floating point number in dBc.

  • Abs Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Abs Max Subcarrier Power Index - an integer number.

  • Abs Min Subcarrier Power (dBm) - a floating point number in dBm.

  • Abs Min Subcarrier Power (dBc) - - a floating point number in dBc.

  • Abs Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Abs Min Subcarrier Power Index - an integer number.

  • Diff Max Subcarrier Power - a floating point number in dB.

  • Diff Max Subcarrier Power to Upper Limit - a floating point number in dB.

  • Diff Max Subcarrier Power Index - an integer number.

  • Diff Min Subcarrier Power - a floating point number in dB.

  • Diff Min Subcarrier Power to Lower Limit - a floating point number in dB.

  • Diff Min Subcarrier Power Index - an integer number.

  • Sampling Frequency - a floating point number in Hz.

  • 2: Symbol Error trace returns series of floating point numbers (in dB) that represent each sample in the EVM trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 3: RMS Symbol Error vs Subcarrier returns series of floating point numbers (in dB) that represent error vector RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 4: RMS Symbol Error vs Symbol returns series of floating point numbers (in dB) that represent error vector RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 5: Symbol Power trace returns series of floating point numbers (in dBm) that represent each sample in the symbol power trace of used subcarriers and symbols in measured zone. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier/1st symbol

  • 2nd number: a value of 2nd subcarrier/1st symbol

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier/1st symbol

  • (Nsub+1)th number: a value of 1st subcarrier/2nd symbol

  • ...

  • (Nsym*Nsub)th number: a value of Nsub-th subcarrier/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 6: RMS Symbol Power vs Subcarrier returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across symbols vs subcarrier. The order of the trace is as follows:

  • 1st number: a value of 1st subcarrier

  • 2nd number: a value of 2nd subcarrier

  • ...

  • Nsub-th number: a value of Nsub-th subcarrier

  • 7: RMS Symbol Power vs Symbol returns series of floating point numbers (in dBm) that represent symbol power RMS'ed across subcarriers vs symbol. The order of the trace is as follows:

  • 1st number: a value of 1st symbol

  • 2nd number: a value of 2nd symbol

  • ...

  • Nsym-th number: a value of Nsym-th symbol

  • 8: IQ measured trace returns series of floating point numbers that alternately represent I and Q pairs of the corrected measured trace. The magnitude of each I and Q pair are normalized to 1.0 if "Normalized" is set to ON. The first number is the I sample of symbol 0 decision point and the second number is the Q sample of symbol 0 decision point. The order of the trace is as follows:

  • 1st number: a value of I-ch of 1st subcarrier/1st symbol

  • 2nd number: a value of Q-ch of 1st subcarrier/1st symbol

  • 3rd number: a value of I-ch of 2nd subcarrier/1st symbol

  • 4th number: a value of Q-ch of 2nd subcarrier/1st symbol

  • ...

  • (Nsub*2-1)-th number: a value of I-ch of Nsub-th subcar/1st symbol

  • (Nsub*2)-th number: a value of Q-ch of Nsub-th subcar/1st symbol

  • (Nsub*2+1)th number: a value of I-ch of Nsub-th subcar/2nd symbol

  • (Nsub*2+2)th number: a value of Q-ch of Nsub-th subcar/2nd symbol

  • ...

  • (Nsym*Nsub*2-1)th number: a value of I-ch of Nsub-th subcarr/Nsym-th sym

  • (Nsym*Nsub*2)th number: a value of Q-ch of Nsub-th subcarr/Nsym-th sym

  • Where Nsub denotes number of used subcarriers and Nsym denotes number of symbols of the measured zone.

  • 9: Channel Frequency Response (Spectral Flatness) - floating point numbers which denote the equalizer channel frequency response, which is the reciprocal of the equalizer frequency response. This has one point per subcarrier. The equalizer frequency response is normally estimated from the channel estimation sequence portion of the OFDMA preamble.

  • 10: Spectral Flatness Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness.

  • 11: Spectral Flatness Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness.

  • 12: Adjacent subcarrier power difference in dB (Spectral Flatness Diff) - computed by scanning through the Channel Frequency Response trace and taking the ratio of each bin to the previous bin. If the signal does not use all subcarriers, the trace assumes a smooth interpolation between the subcarriers that are used.

  • 13: Spectral Flatness Diff Upper Limit Mask - floating point numbers which denote the upper limit mask trace of spectral flatness diff.

  • 14: Spectral Flatness Diff Lower Limit Mask - floating point numbers which denote the lower limit mask trace of spectral flatness diff.

  • 15: Preamble Frequency Error - shows the total frequency error during the preamble portion of the OFDMA burst. Preamble Frequency Error is sampled at 256 times the subcarrier spacing.

  • 16: Common Pilot Error - shows the complex difference between the measured and ideal pilot subcarrier symbols. Residual phase and frequency settling that occurs following the preamble is measured via the Common Pilot Error.

  • 17: Data Burst Info - shows summary burst info data for the analysed signal. There is one group of five results for each burst in the analyzed waveform. Each group has the form:

  • Subframe info type (summarises whole input signal):

    • 0 = Preamble

    • 1 = FCH

    • 2 = Burst

    • 3 = Unknown

    • 4 = All (summary of whole input signal)

  • Modulation format

    • 0 = BPSK

    • 1 = QPSK

    • 2 = 16-QAM

    • 3 = 64-QAM

  • Length (in symbol times) of the described piece of the signal

  • Average power (in Volts peak squared)

  • RMS EVM (%)

  • 18: Demod Bit trace - shows Demod Bit Trace of the measured zone or burst.

  • 19: FFT Spectrum trace - shows FFT Spectrum Trace

  • 20: Time Domain trace - shows the time domain power trace of the burst.

  • 21: reserved for future use

  • 22: reserved for future use

  • 23 I/Q array of idealised matrix, used to calculate EVM.

Example:

READ:EVM19?

Returns the FFT Spectrum trace results.


802.16 OFDM (N6301A)

READ:PSTatistic?

Last Updated: March 28, 2008

This command makes Power Stat CCDF measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:PSTatistic{0:4}?

READ:PSTatistic{0:4}?

Provides a sequential method to make Power Stat CCDF measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1 or not specified: Returns 10 scalar results:

  • 1. Average input power (in dBm)

  • 2. Probability at the average input power level (in %)

  • 3. Power level that has 10% of the power

  • 4. Power level that has 1% of the power

  • 5. Power level that has 0.1% of the power

  • 6. Power level that has 0.01% of the power

  • 7. Power level that has 0.001% of the power

  • 8. Power level that has 0.0001% of the power

  • 9. Peak power (in dB)

  • 10. Count

  • 2: Returns a series of 5001 floating the current measured power stat trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 3: Returns a series of 5001 floating point numbers (in percent) that represent the Gaussian trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

  • 4: Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. This is the probability at particular power levels (average power), in the following order:

  • 1. Probability at 0.0 dB power

  • 2. Probability at 0.01 dB power

  • 3. Probability at 0.02 dB power

  • . . .

  • 1. Probability at 49.9 dB power

  • 2. Probability at 50.0 dB power

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:PSTatistic4?

Returns a series of 5001 floating point numbers (in percent) that represent the user-definable reference trace.


802.16 OFDM (N6301A)

READ:SMASk?

Last Updated: March 28, 2008

This command makes Spectral Mask measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:SMASk{0:3}?

READ:SMASk{0:3}?

Provides a sequential method to make Spectral Mask measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns an array of measured power values of length dependant on window type. The returned power is measured in dBm. This is equivalent to the Y-axis on the measured trace on the front panel display.

  • 1 or not specified: Returns the percentage of points failing the mask.

  • 2: Returns an array of frequency values of length dependant of windowing type. The returned frequency is measured is Hz. This is equivalent to the X-axis on the measured trace on the front panel display.

  • 3: Returns an array of mask absolute reference values to each frequency point of length dependant of windowing type. The returned is measured is in dBm. This is equivalent to the Y-axis on the mask on the front panel display.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:SMASk?

Returns the percentage of points failing the mask.


802.16 OFDM (N6301A)

READ:WAVeform?

Last Updated: March 28, 2008

This command makes Waveform measurements and retrieves the results.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

  • READ:WAVeform{0:2}?

READ:WAVeform{0:2}?

Provides a sequential method to make Waveform measurements and retrieve the results.

Query Range: The integer value you specify defines the type of results returned:

  • 0: Returns unprocessed I/Q trace data, as a series of trace point values, in volts. The I values are listed first in each pair, using the 0 through even-indexed values. The Q values are the odd-indexed values.

  • 1: Returns the following scalar results:

  • Sample Time is a floating point number representing the time between samples when using the trace queries (n=0, 2, and so forth).

  • Mean Power is the mean power (in dBm). This is the power across the entire trace. If averaging is on, the power is for the latest acquisition.

  • Mean Power Averaged is the power (in dBm) for N averages, if averaging is on. This is the power across the entire trace. If averaging is off, the value of the mean power averaged is the same as the value of the mean power.

  • Number of samples is the number of data points in the captured signal. This number is useful when performing a query on the signal (i.e. when n=0,2,etc.).

  • Peak-to-mean ratio has units of dB. This is the ratio of the maximum signal level to the mean power. Valid values are only obtained with averaging turned off. If averaging is on, the peak-to-mean ratio is calculated using the highest peak value, rather than the displayed average peak value.

  • Maximum value is the maximum of the most recently acquired data (in dBm).

  • Minimum value is the minimum of the most recently acquired data (in dBm).

  • 2: Returns trace point values of the entire captured signal envelope trace data. These data points are floating point numbers representing the power of the signal (in dBm). There are N data points, where N is the number of samples. The period between the samples is defined by the sample time.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

READ:WAVeform0?

Returns unprocessed I/Q trace data, as a series of trace point values, in volts.


:SENSe Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

[:SENSe] Subsystem

Last Updated: March 28, 2008

Description

The [:SENSe] setup commands are divided into several sections. Each section or subsystem deals with controls that directly affect device-specific settings of the device and not those related to the signal-oriented characteristics.

For details of the [:SENSe] commands refer to the [:SENSe] subsystems in this section.


802.16 OFDM (N6301A)

[:SENSe]:ACPower

Last Updated: March 28, 2008

These commands control the operation of the Adjacent Channel Power measurement

  • [:SENSe]:ACPower:AVERage:COUNt

  • [:SENSe]:ACPower:AVERage[:STATe]

  • [:SENSe]:ACPower:AVERage:TCONtrol

  • [:SENSe]:ACPower:BANDwidth:INTegration[1]|2

  • [:SENSe]:ACPower:BANDwidth[:RESolution]

  • [:SENSe]:ACPower:BWIDth:INTegration[1]|2

  • [:SENSe]:ACPower:BWIDth[:RESolution]

  • [:SENSe]:ACPower:CARRier[1]|2:AUTO[:STATe]

  • [:SENSe]:ACPower:CARRier[1]|2:COUNt

  • [:SENSe]:ACPower:CARRier[1]|2:CPSD

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BANDwidth[:INTegration]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:BWIDth[:INTegration]

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:COUPle

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:FILTer:ALPHa

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:METHod

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:PPResent

  • [:SENSe]:ACPower:CARRier{1:2}:LIST:WIDTh

  • [:SENSe]:ACPower:CARRier{1:2}[:POWer]

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier

  • [:SENSe]:ACPower:CARRier{1:2}:RCARrier:AUTO

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency

  • [:SENSe]:ACPower:CARRier{1:2}:RCFRequency:AUTO

  • [:SENSe]:ACPower:FILTer[:RRC]:ALPHa

  • [:SENSe]:ACPower:FILTer[:RRC][:STATe]

  • [:SENSe]:ACPower:FREQuency:SPAN

  • [:SENSe]:ACPower:FREQuency:SPAN:FULL/nquery/

  • [:SENSe]:ACPower:FREQuency:SPAN:PREVious/nquery/

  • [:SENSe]:ACPower:LIMit[:STATe]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:ABSolute

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BANDwidth[:INTegration]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:BWIDth[:INTegration]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST[:FREQuency]

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RCARrier

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:RPSDensity

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:STATe

  • [:SENSe]:ACPower:OFFSet{1:2}:LIST:TEST

  • [:SENSe]:ACPower:SWEep:BANDwidth[:RESolution]

  • [:SENSe]:ACPower:SWEep:BWIDth[:RESolution]

  • [:SENSe]:ACPower:SWEep:TIME

  • [:SENSe]:ACPower:TRIGger:SOURce

  • [:SENSe]:ACPower:TYPE

  • [:SENSe]:ACPower:WTYPe

[:SENSe]:ACPower:AVERage:COUNt[?]

Sets/queries the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Setting Range: 1 to 10000

Query Range: 1 to 10000

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage:COUNt 100

Sets the number of data acquisitions that will be averaged to 100.

[:SENSe]:ACPower:AVERage[:STATe][?]

Sets/queries the averaging state for the Adjacent Channel Power measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage ON

Turns on averaging for the ACP measurement.

[:SENSe]:ACPower:AVERage:TCONtrol[?]

Sets/queries the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: REPeat

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:AVERage:TCONtrol EXPonential

Sets termination control to exponential for the averaging function.

[:SENSe]:ACPower:BANDwidth|BWIDth:INTegration[1]|2[?]

Sets/queries the bandwidth of the "main" signal, that is the integration bandwidth used for the channel power.

INTegration1 is for BS (base station - that is, downlink testing), 2 for MS (mobile station uplink testing). If omitted, uses value "1".

Setting Range: 10kHz to 60MHz

Query Range: 10kHz to 60MHz

*RST setting: 10MHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ACPower:BWIDwidth:INTegration 12.0 MHz

Sets the integration bandwidth for the central signal to be 12MHz

[:SENSe]:ACPower:BANDwidth|BWIDth[:RESolution][?]

Sets/queries the resolution bandwidth used for the measurement.

Note that because of an FFT size change, this measurement can be made significantly faster than the default settings by using a resolution bandwidth of 110kHz.

Setting Range: 10kHz to 8MHz

Query Range: 10kHz to 8MHz

*RST setting: 110kHz

Example:

ACPower:BANDwidth:RESolution?

Queries the resolution bandwidth used for the measurement.

[:SENSe]:ACPower:CARRier[1]|2:AUTO[:STATe][?]

Sets/queries the multi-carrier power reference mode.

When set to Auto, the carrier power result reflects the measured power value in the selected reference carrier.

When set to Man, the result is referenced to the last measured value, or you may specify the reference for the multi-carrier power measurement. Relative values are displayed, referenced to the “Power Reference” value

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST setting: 1

Example:

ACPower:CARRier2:AUTO on

Sets the carrier power reference for uplink bursts to the measurement power in the selected reference carrier.

[:SENSe]:ACPower:CARRier[1]|2:COUNt[?]

Sets/queries the number of carriers to be measured.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 1 to 12

Query Range: 1 to 12

*RST setting: 1

Example:

ACPower:CARRier2:COUNt?

Queries the number of uplink carriers being measured.

[:SENSe]:ACPower:CARRier[1]|2:CPSD[?]

Sets/queries the power spectral density in the carrier (main channel) that is used to compute the relative power spectral density values for the offsets when Meas Type is set to PSD Ref.

When the PSD Ref state is set to Auto, this will be set to the measured carrier power spectral density.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -999dBm to 999dBm

Query Range: -999dBm to 999dBm

*RST setting: 0dBm

Example:

ACPower:CARRier2:CPSD 25dBm

Sets the carrier PSD to 25dBm

[:SENSe]:ACPower:CARRier[1]|2:LIST:BANDwidth|BWIDth[:INTegration][?]

Sets/queries the Measurement Noise Bandwidth used to calculate the power in the carriers.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 10kHz to 60MHz (per carrier)

Query Range: 10kHz to 60MHz (per carrier)

*RST Setting: 10MHz

Example:

SENSe:ACPower:CARRier2:LIST:BANDwidth 10MHz

Sets the bandwidth for a single carrier to 10MHz

[:SENSe]:ACPower:CARRier[1]|2:LIST:COUPle[?]

Sets/queries the carrier coupling settings state. If set to "on", couples carrier settings to carrier #1. The coupled parameters are Carrier Power Preset, Carrier Spacing, Measurement Noise Bandwidth, Method and Filter Alpha

When a setting is changed, the couple is set to Man automatically.

Carrier #1 is always set to couple and cannot be changed.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST setting: 1

Example:

SENSe:ACPower:CARRier2:LIST:COUPle?

Queries the carrier coupling settings state for uplink analysis

[:SENSe]:ACPower:CARRier[1]|2:LIST:FILTer:ALPHa[?]

Sets/queries the alpha value for the filter used in the current carrier configuration

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0.01 to 1.00

Query Range: 0.01 to 1.00

*RST setting: 0.22

Example:

SENSe:ACPower:CARRier2:LIST:FILTer:ALPHa 0.5

Sets the RRC filter's alpha value to 0.5

[:SENSe]:ACPower:CARRier[1]|2:LIST:METHod[?]

Sets/queries the carrier configuration method settings.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: IBW | RRC

Query Range: IBW | RRC

*RST setting: IBW

Example:

SENSe:ACPower:CARRier:LIST:METHod?

Queries the carrier configuration method settings for the base station measurement

[:SENSe]:ACPower:CARRier[1]|2:LIST:PPResent[?]

Configures the carriers for this measurement, or queries their configuration. It allows spaces to be inserted between carriers. Carriers with the power present parameter set to Yes are carriers, and those with the power present parameter set to No are spaces. Each carrier power present is set to Yes or No. The individual carriers can be set by selecting the desired carrier on the carrier menu key using the up down arrows, the knob, or numeric keypad, then toggling the carrier power present using the carrier power present menu key.

The query for this parameter returns the current values for all of the carriers. If a carrier is defined as having no power present, the power displayed will be relative to the reference carrier, otherwise the absolute power will be displayed.

If you change the carrier power present to no and that carrier is currently configured as the reference carrier, the next carrier to the left (or the right if there are no carriers to the left) will be assigned as the reference carrier. This also applies to the scenario where there are only two carriers configured as having power present and you configure only one carrier to have no power present.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: YES | NO

Query Range: YES | NO

*RST Setting: YES

Example:

SENSe:ACPower:CARRier2:LIST:PPResent?

Queries the carrier configuration for the uplink signal

[:SENSe]:ACPower:CARRier[1]|2:LIST:WIDTh[?]

Sets/queries the width of the carrier spacing. This will be the value applied to all the current slots, whether they are carriers or spaces.

Enter each carrier spacing value individually by selecting the desired carrier on the carrier menu key using the up down arrows, knob or numeric keypad, then enter the carrier width using the carrier spacing menu key.

Note that the number of parameters or results is coupled to the number of carriers ([:SENSe]:ACPower:CARRier[1]|2:COUNt). When setting, there must be the same number of parameters as there are carriers. When querying, the number of results you get back will be the same as the number of carriers.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 to 45MHz

Query Range: 0 to 45MHz

*RST Setting: 5MHz

Example:

SENSe:ACPower:CRRier:LIST:WIDTh 20MHz

Sets the carrier spacing width width to 20MHz

[:SENSe]:ACPower:CARRier[1]|2[:POWer][?]

Sets/queries the multi-carrier power reference value. This value is coupled to the value of the auto state.

When set to Auto, the carrier power result reflects the measured power value in the selected reference carrier.

When set to Man, the result is referenced to the last measured value, or you may specify the reference for the multi-carrier power measurement. Relative values are displayed, referenced to the "Power Reference" value.

This setting is only used when only when the Meas Type is TPRef.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -200dBm to 200dBm

Query Range: -200dBm to 200dBm

*RST Setting: 0dBm

Example:

SENSe:ACPower:CARRier2:POWer -20dBm

Sets the uplink reference value to -20dBm

[:SENSe]:ACPower:CARRier[1]|2:RCARrier[?]

Sets/queries the reference carrier. Relative power measurements are made from the reference carrier. Only has any effect if the reference carrier auto state is set to off.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 1 to number of available carriers

Query Range: 1 to number of available carriers

*RST Setting: 1

Example:

SENSe:ACPower:CARRier:RCARrier 5

Set the reference carrier for downlink measurements to carrier 5

[:SENSe]:ACPower:CARRier[1]|2:RCARrier:AUTO[?]

Sets/queries the reference carrier auto state.

If set to "on", the measurement selects the carrier with the highest power as the reference carrier and the Reference Carrier result is updated. If a value is entered when Reference Carrier auto state is set to "on", the reference carrier auto state is set to "off".

If set to "off", the value that you enter for the Reference Carrier is used as the reference carrier.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 1

Example:

SENSe:ACPower:CARRier2:AUTO 1

Switches on automatic detection of the reference carrier for uplink measurements

[:SENSe]:ACPower:CARRier[1]|2:RCFRequency[?]

Sets/queries the reference carrier frequency.

Changing the value of this setting only has any effect if the reference frequency auto state is set to "off".

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 2.15GHz to 3.8GHz

Query Range: 2.15GHz to 3.8GHz

Example:

SENSe:ACPower:CARRier:RCFRequency?

Queries the reference carrier frequency for a downlink measurement

[:SENSe]:ACPower:CARRier[1]|2:RCFRequency:AUTO[?]

Sets/queries the reference frequency auto state.

CARRier1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

If this setting is "on", the Reference Carrier Frequency is set thus:

Ref Freq1 = Instrument Center Frequency - (Total of all Carrier Widths / 2)

Ref Freq2 = Ref Freq1 + (Total of all Carrier Widths up to Ref Carrier)

Ref Freq = Ref Freq2 + (0.5 * Carrier Width of Ref Carrier)

If this setting is set to "off" and the reference carrier frequency changes the reference frequency is calculated using the following three steps;

Ctr Freq1 = Ref Freq - (0.5 * Carrier Width of Ref Carrier)

Ctr Freq2 = Ctr Freq1 - (Total of all Carrier Widths up to Ref Carrier)

Ctr Freq = Ctr Freq2 + (Total of all Carrier Widths / 2)

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 1

Example:

SENSe:ACPower:CARRier2:RCFRequency:AUTO 0

Switches off automatic reference frequency calculation for an uplink measurement

[:SENSe]:ACPower:FILTer[:RRC]:ALPHa[?]

Sets/queries the alpha value for the RRC filter

Setting Range: 0.01 to 1.00

Query Range: 0.01 to 1.00

*RST Setting: 0.22

Example:

SENSe:ACPower:FILTer:RRC:ALPHa 0.5

Sets the alpha value for the RRC filter to 0.5

[:SENSe]:ACPower:FILTer[:RRC][:STATe][?]

Sets/queries whether to use RRC filtering of the carriers and all adjacent channels. The alpha value (roll off) for the filter will be set to the value of the Filter Alpha parameter

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 0

Example:

SENSe:ACPower:FILTer:RRC:STATE?

Queries whether filtering is being used.

[:SENSe]:ACPower:FREQuency:SPAN[?]

Sets/queries the frequency span of the adjacent channel power measurement

Setting Range: 50MHz to 120MHz

Query Range: 50MHz to 120MHz

*RST Setting: 60MHz

Example:

SENSe:ACPower:FREQuency:SPAN 50e6

Sets the frequency span to 50MHz

[:SENSe]:ACPower:FREQuency:SPAN:FULL

Sets the frequency span to its maximum value.

Example:

SENSe:ACPower:FREQuency:SPAN:FULL

Sets the frequency span to its maximum value.

[:SENSe]:ACPower:FREQuency:SPAN:PREVious

Sets the span to the previous span setting. If no previous span value exists, then the span will remain unchanged.

Example:

[:SENSe]:ACPower:FREQuency:SPAN:PREVious

Sets the span to the previous span setting

[:SENSe]:ACPower:LIMit[:STATe][?]

Sets or queries whether limits checking is performed on the carriers

Setting Range: OFF | 0 | ON | 1

Query Range: 0 | 1

*RST Setting: 0

Example:

SENSe:ACPower:LIMit:STATe 1

Switches limit checking on

[:SENSe]:ACPower:OFFSet[1]|2:LIST:ABSolute[?]

Sets or queries the limits used for the measurement. There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -200dBm to 50dBm per offset

Query Range: -200dBm to 50dBm per offset

*RST Setting: 50, 50, 50, 50, 50, 50

Example:

SENSe:ACPower:OFFSet1:LIST:ABSolute?

Queries the list of power limits. Returns six values.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:BANDwidth|BWIDth[:INTegration][?]

Sets or queries the integration bandwidths for the offsets used in the measurement. There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 10kHz to 60Mhz per offset

Query Range: 10kHz to 60Mhz per offset

*RST Setting: 10MHz,10MHz,10MHz,10MHz,10MHz,10MHz

Example:

SENSe:ACPower:OFFSet1:LIST:BANDwidth:INTegration 10e6,10e6,10e6,10e6,10e6,10e6

Sets all six offsets to 10MHz integration bandwidths

[:SENSe]:ACPower:OFFSet[1]|2:LIST[:FREQuency][?]

Sets or queries the frequency difference between the center of the main channel and the center of the carrier. Setting the frequency offset to zero has the same effect as switching the offset off.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: 0 to 50MHz per offset

Query Range: 0 to 50Mhz per offset

*RST Setting: 10MHz,20MHz,0,0,0,0

Example:

SENSe:ACPower:OFFSet1:LIST:FREQuency?

Queries the offset frequencies. Returns six values.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:RCARrier[?]

Sets or queries the offset power limits expressed relative to the carrier power.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -150 to 50 dB per offset

Query Range: -150 to 50 dB per offset

*RST Setting: -50,-60,0,0,0,0

Example:

SENSe:ACPower:OFFSet1:LIST:RCARrier -40,-50,0,0,0,0

Sets the limits to -40 and -50 dB relative to the center carrier power.

[:SENSe]:ACPower:OFFSet[1]|2:LIST:RPSDensity[?]

Sets or queries the offset power limits expressed as power spectral density, relative to the centre carrier's PSD.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: -150 to 50 dB per offset

Query Range: -150 to 50 dB per offset

*RST Setting: -25,-35,0,0,0,0

Example:

SENSe:ACPower:OFFSET2:LIST:RPSDensity?

Queries the current power limits on the uplink. Returns six results

[:SENSe]:ACPower:OFFSet[1]|2:LIST:STATe[?]

Turns limit checking for each offset On or Off, or queries whether limits testing is being performed.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Setting Range: OFF | 0 | ON | 1 (for each offset)

Query Range: 0 | 1 (for each offset)

*RST Setting: 1,1,0,0,0,0

Example:

Switch limits checking on for offsets 1, 2 and 3

SENSe:ACPower:OFFSet:LIST:STATe 1,1,1,0,0,0

[:SENSe]:ACPower:OFFSet[1]|2:LIST:TEST[?]

Sets or queries the method used to test whether a signal is within allowed limits.

There are six arguments to the command (one for each offset), and six responses on a query.

OFFSet1 is for BS (base station - that is, downlink) testing, 2 for MS (mobile station uplink) testing. If omitted, uses value "1".

Each offset is set to one of the following values:

  • Absolute - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit.

  • Relative - Fail is shown if one of the relative ACP measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

  • AND - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit AND one of the relative ACPR measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

  • OR - Fail is shown if one of the absolute ACP measurement results is larger than the limit for Abs Limit OR one of the relative ACP measurement results is larger than the limit for Rel Lim (Car) or Rel Lim (PSD).

Setting Range: ABSolute | RELative | AND | OR

Query Range: ABSolute | RELative | AND | OR

*RST Setting: RELative,RELative,RELative,RELative,RELative,RELative

Example:

SENSe:ACPower:OFFSet2:LIST:TEST?

Queries the test methods used for testing the uplink signal. Returns six values.

[:SENSe]:ACPower:SWEep:BANDwidth|BWIDth[:RESolution][?]

Sets or queries the resolution bandwidth used for the measurement.

Setting Range: 10kHz to 8MHz

Query Range: 10kHz to 8MHz

*RST Setting: 110kHz

Example:

SENSe:ACPower:SWEep:BWIDth 110kHz

Sets the resolution bandwidth 10 110kHz

[:SENSe]:ACPower:SWEep:TIME[?]

Sets or queries the acquisition length used for the measurement.

Setting Range: 1us to 5ms

Query Range: 1us to 5ms

*RST Setting: 4.73ms

Example:

SENSe:ACPower:SWEep:TIME 3ms

Sets the acquisition duration to 3ms

[:SENSe]:ACPower:TRIGger:SOURce[?]

Sets/queries the trigger source for the Adjacent Channel Power measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SENSe:ACPower:TRIGger:SOURce EXTernal

Sets the trigger source to External for the ACP measurement.

[:SENSe]:ACPower:TYPE[?]

Sets or queries the reference used for the measurement. Total Pwr Ref (TPR) sets the reference to the total carrier power. PSD Ref (PSDR) sets the reference to the power spectral density of the carrier.

Setting Range: TPR | PSDR

Query Range: TPR | PSDR

*RST Setting: TPR

Example:

SENSe:ACPower:TYPE PSDR

Sets the reference type to PSD.

[:SENSe]:ACPower:WTYPe[?]

Sets or queries the FFT window type used in the measurement.

Setting Range: GAUSsian | HANNing | FLATtop | UNIForm

Query Range: GAUS | HANN | FLAT | UNIF

*RST Setting: GAUS

Example:

SENSe:ACPower:WTYPe?

Queries the FFT window type used for the measurement


802.16 OFDM (N6301A)

[:SENSe]:EVM

Last Updated: March 28, 2008

These commands control averaging, capturing and triggering settings for the Modulation Analysis measurement.

  • [:SENSe]:EVM:AVERage:COUNt[?]

  • [:SENSe]:EVM:AVERage[:STATe][?]

  • [:SENSe]:EVM:AVERage:TCONtrol[?]

  • [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

  • [:SENSe]:EVM:TRIGger:SOURce[?]

[:SENSe]:EVM:AVERage:COUNt[?]

Sets/queries the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Setting Range: 1 to 10000

Query Range: 1 to 10000

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

EVM:AVERage:COUNt 100

Sets the number of data acquisitions that will be averaged to 100.

[:SENSe]:EVM:AVERage[:STATe][?]

Sets/queries the averaging state for the EVM measurement.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

EVM:AVERage ON

Turns on averaging for the EVM measurement.

[:SENSe]:EVM:AVERage:TCONtrol[?]

Sets/queries the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: REPeat

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

EVM:AVERage:TCONtrol EXPonential

Sets termination control to exponential for the averaging function.

[:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

Sets/queries the data capture length in frames that will be used in the acquisition. If Average is set to On, all capture data are analyzed and their results are averaged until the average number count is reached.

Setting Range: 1

Query Range: 1

*RST Setting: 1

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

EVM:CAPTure:TIME?

Queries the data capture length in frames that will be used in the acquisition.

[:SENSe]:EVM:TRIGger:SOURce[?]

Sets/queries the trigger source for the EVM measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

EVM:TRIGger:SOURce RFBurst

Sets the trigger source for the EVM measurement to RF Burst.


802.16 OFDM (N6301A)

[:SENSe]:FREQuency

Last Updated: March 28, 2008

  • [:SENSe]:FREQuency:CENTer[?]

[:SENSe]:FREQuency:CENTer[?]

Sets/queries the center frequency of the spectrum analyzer.

Setting Range: 2.15 GHz to 3.8 GHz

Query Range: 2.15 GHz to 3.8 GHz

*RST Setting: 2.42 GHz

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

FREQuency:CENTer 2.80GHz

Sets the center frequency to 2.8 GHz.


802.16 OFDM (N6301A)

[:SENSe]:POWer

Last Updated: March 28, 2008

These commands control the input power range.

  • [:SENSe]:POWer:RANGe[?]

[:SENSe]:POWer:RANGe[?]

Sets/queries the input power range.

Setting Range: -60 to 25 dBm

Query Range: -60 to 25 dBm

*RST Setting: 0

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

POWer:RANGe -20DBM

Sets the input power range to -20 dBm.


802.16 OFDM (N6301A)

[:SENSe]:PSTatistic

Last Updated: March 28, 2008

These commands provide device-specific settings for the Power Stat CCDF measurement.

  • [:SENSe]:PSTatistic:COUNts[?]

  • [:SENSe]:PSTatistic:GAUSsian[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

  • [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

  • [:SENSe]:PSTatistic:RTRace[:STATe][?]

  • [:SENSe]:PSTatistic:SWEep:CYCLes[?]

  • [:SENSe]:PSTatistic:SWEep:TIME[?]

  • [:SENSe]:PSTatistic:TRIGger:SOURce[?]

[:SENSe]:PSTatistic:COUNts[?]

Sets/queries the accumulated number of sampling points for data acquisition. The range is 1.000 kpt (k point) to 2.00000 Gpt (G point) with 1 kpt resolution. Counts couples to Meas Cycles. When the value for counts is changed, the Meas Cycles value will be (Counts / SamplingFrequency * MeasInterval).

Setting Range: 1000 to 2000000000

Query Range: 1000 to 2000000000

*RST Setting: 10000000

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:COUNts 5001

Sets the accumulated number of sampling points for data acquisition to 5001.

[:SENSe]:PSTatistic:GAUSsian[:STATe][?]

Sets/queries the Gaussian trace display state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0| 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:GAUSsian OFF

Turns off the gaussian trace.

[:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

Sets/queries the Auto Rules for IF Gain. When Auto is active, the IF Gain is set to High Gain under any of the following conditions:

  • The input attenuator is set to 0 dB,

  • the preamp is turned On, or

  • the Max Mixer Level is 20 dBm or lower.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:IF:GAIN:AUTO ON

Turns on auto rules for IF Gain.

[:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

Sets/queries the range of IF gain. On sets the high gain option, which allows for better noise level measurements and Off sets low gain when measuring large signals.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:IF:GAIN 1

Turns on the high gain option.

[:SENSe]:PSTatistic:RTRace[:STATe][?]

Sets/queries the reference trace display state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:RTRace ON

Turns on the reference trace.

[:SENSe]:PSTatistic:SWEep:CYCLes[?]

Sets/queries the number of measurement cycles to calculate power statistic data. This number couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval). When the counts value cannot be divided by (Sampling Frequency * MeasInterval), this value is displayed as a decimal fraction.

Setting Range: 1 to a value dependant on the 1 sampling frequency

Query Range: 1 to a value dependant on the 1 sampling frequency

*RST Setting: Depends on the sampling frequency

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:SWEep:CYCLes?

Queries the number of measurement cycles to calculate power statistic data.

[:SENSe]:PSTatistic:SWEep:TIME[?]

Sets/queries the number of data points to be used as the measurement interval. This value couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

Setting Range: 100.0 us to 10.0 ms

Query Range: 100.0 us to 10.0 ms

*RST Setting: 1.0 ms

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:SWEep:TIME 2 ms

Sets the number of data points to 2.0 ms for the measurement interval.

[:SENSe]:PSTatistic:TRIGger:SOURce[?]

Sets/queries the trigger source for the Power Stat CCDF measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

PSTatistic:TRIGger:SOURce RFBurst

Sets the trigger source to RF Burst for the Power Stat CCDF measurement.


802.16 OFDM (N6301A)

[:SENSe]:RADio

Last Updated: March 28, 2008

These commands allow you to change various OFDM parameters.

  • [:SENSe]:RADio:STANdard[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

  • [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

  • [:SENSe]:RADio:STANdard:DEVice[?]

  • [:SENSe]:RADio:STANdard:DRATio[?]

  • [:SENSe]:RADio:STANdard:FDURation[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

  • [:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

  • [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

  • [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

[:SENSe]:RADio:STANdard[?]

Sets/queries the radio standard.

Setting Range: WM80216E05 | WIBRO

Query Range: WM80216E05 | WIBRO

*RST Setting: WM80216E05

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard WIBRO

sets the radio standard to WiBro.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

Sets/queries the bandwidth ratio. Bandwidth ratio is defined as the ratio between the OFDM FFT sample rate and the nominal channel bandwidth. The 802.16 Standard specifies that the BW Ratio be set to 8/7 or 28/25 depending on the nominal bandwidth of the test signal.

Setting Range: R8BY7 | R28BY25

Query Range: R8BY7 | R28BY25

*RST Setting: R28BY25

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:BWRatio R8BY7

Sets the bandwidth ratio to 8/7.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio:FRACtion[?]

Sets/queries the bandwidth ratio - fractional number parameter. This parameter is represented as a fractional number that contains two values; the first value is the numerator and the second is the denominator value of the BW Ratio. This functionality is only available with SCPI control and is recommended only for the advanced user.

Setting Range: 1 to 1000

Query Range: 1 to 1000

*RST Setting: 28,25

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:BWRatio:FRACtion 11,10

Sets the bandwidth ratio - fractional number parameter to numerator 11 and denominator 10.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

Sets/queries the FFT size parameter. OFDM supports a scalable frame structure where the FFT size scales with bandwidth to keep subcarrier spacing fixed. Four FFT "NFFT" sizes are specified by the OFDM standard: 128, 512, 1024 and 2048.

Setting Range: 128, 512, 1024, 2048

Query Range: 128, 512, 1024, 2048

*RST Setting: 1024

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:NFFT?

Queries the FFT size parameter.

[:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:VALue[?]

Sets/queries the nominal bandwidth parameter. This specifies the nominal channel bandwidth. OFDM supports a scalable frame structure where the FFT size scales according to the bandwidth to keep subcarrier spacing fixed. The OFDM standard specifies four FFT "NFFT" sizes" (128, 512, 1024 and 2048) and, in addition, supports many nominal bandwidths. You can use the Preset to Standard to set the Nominal Bandwidth to a standard default value or you can specify an arbitrary value with this command.

Setting Range: 31.25 kHz to 200 MHz

Query Range: 31.25 kHz to 200 MHz

*RST Setting: 10 MHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:BANDwidth:VALue 9.996 MHz

Sets the nominal bandwidth parameter to 9.996 MHz.

[:SENSe]:RADio:STANdard:DEVice[?]

Sets/queries the device to be used.

Setting Range: BTS | MS

Query Range: BTS | MS

*RST Setting: BTS

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:DEVice MS

Sets the device to mobile station.

[:SENSe]:RADio:STANdard:DRATio[?]

Downlink Ratio, expressed as a percentage, is the ratio of the downlink subframe length (including the TTG) to the frame length. Downlink Ratio defines where the uplink subframe starts relative to the start of the frame. A 30% Downlink Ratio means that 30% of the frame length is downlink subframe and 70% is uplink subframe.

Setting Range: 0% to 100%

Query Range: 0% to 100%

*RST Setting: 50.0%

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:DRATio 49.0

Sets the downlink ratio to 49%.

[:SENSe]:RADio:STANdard:FDURation[?]

The Frame Duration parameter specifies OFDM frame duration in units of time. You can use the Radio Standard or Radio Device preset to set the Frame Duration to a value specified in the OFDM standard or you can specify an arbitrary value manually in the Frame Duration parameter.

Setting Range: 2 ms to 20 ms

Query Range: 2 ms to 20 ms

*RST Setting: 5.0 ms

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:FDURation?

Queries the Frame Duration parameter value.

[:SENSe]:RADio:STANdard:GINTerval:RATio[?]

IEEE 802.16 OFDM supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary.

Setting Range: R1BY32 | R1BY16 | R1BY8 | R1BY4

Query Range: R1BY32 | R1BY16 | R1BY8 | R1BY4

*RST Setting: R1BY8

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:GINTerval:RATio?

Queries the current guard interval setting.

[:SENSe]:RADio:STANdard:GINTerval:RATio:FRACtion[?]

IEEE 802.16 OFDM supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary. For advanced user, the Guard Interval can be set to a value other than the standard values (1/4, 1/8, 1/16 or 1/32). This parameter is represented as a fractional number that contains two values; the first value is the numerator and the second is the denominator value of the Guard Interval. NOTE: This functionality is only available with SCPI control and is recommended only for the advanced user.

Setting Range: 0 to 1000

Query Range: 0 to 1000

*RST Setting: 1, 8

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:GINTerval:RATio:FRACtion 3, 18

Sets the guard interval as a fractional number 3 (numerator), 18 (denominator)

[:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

Sets/queries the WiBro mode.

Setting Range: B4M375 | B8M75 | B17M5

Query Range: B4M375 | B8M75 | B17M5

*RST Setting: B8M75

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:WIBRo B4M375

Sets the WiBro mode to B4M375.

[:SENSe]:RADio:STANdard:Y05[:PROFile][?]

Sets/queries the 802.16e-2005 mode. This changes a range of settings which includes FFT, BW ratio, guard interval, frame duration and DL ratio.

Setting Range: B1M25 | B3M5 | B5M | B7M | B8M75 | B10M | B14M | B15M | B17M5 | B20M | B28M

Query Range: B1M25 | B3M5 | B5M | B7M | B8M75 | B10M | B14M | B15M | B17M5 | B20M | B28M

*RST Setting: B10M (802.16e-2005 mode)

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

RADio:STANdard:Y05 B3M5

Sets/queries the 802.16e-2005 mode to B3M5.


802.16 OFDM (N6301A)

[:SENSe]:RESume

Last Updated: March 28, 2008

  • [:SENSe]:RESume

[:SENSe]:RESume

Regains the application visa lock on the test set so that other applications (such as glacier) can use it.

Test Set Requirements: N6301A 802.16 OFDMA Measurement Application Version A.01 and above

Example:

RESume

Regains the application visa lock on the test set.


802.16 OFDM (N6301A)

[:SENSe]:ROSCillator

Last Updated: March 28, 2008

These commands set and query reference settings.

  • [:SENSe]:ROSCillator:SOURce?

  • [:SENSe]:ROSCillator:SOURce:TYPE[?]

[:SENSe]:ROSCillator:SOURce?

Returns the current switch setting. This means:

  • If it was set to SENSe but there is no external reference so the instrument is actually using the internal reference, then this query returns INTernal and not SENSe.

  • If it was set to SENSe and there is an external reference present, the query returns EXTernal and not SENSe.

  • If it was set to EXTernal, then the query returns "EXTernal"

  • If it was set to INTernal, then the query returns INTernal

Setting Range: EXTernal | INTernal | SENSe

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ROSCillator:SOURce?

Returns the current switch setting.

[:SENSe]:ROSCillator:SOURce:TYPE[?]

Sets/queries the frequency reference as being the internal reference, external reference or sensing the presence of an external reference. When the frequency reference is set to internal, the internal 10 MHz reference is used even if an external reference is connected.

Setting Range: INTernal | EXTernal | SENSe

Query Range: INT | EXT | SENS

*RST Setting: This is unaffected by Preset but is set to SENSe on a "Restore Input/Output Defaults" or "Restore System Defaults->All".

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

ROSCillator:SOURce:TYPE EXTernal

Sets the frequency reference to External.


802.16 OFDM (N6301A)

[:SENSe]:SMASk

Last Updated: March 28, 2008

These commands provide device-specific settings for the Spectral Mask measurement.

  • [:SENSe]:SMASk:MASK[:STATe][?]

  • [:SENSe]:SMASk:SWEep:TIME[?]

  • [:SENSe]:SMASk:TRIGger:SOURce[?]

  • [:SENSe]:SMASk:WTYPe[?]

[:SENSe]:SMASk:MASK[:STATe][?]

Sets/queries the operating state of the mask.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SMASk:MASK OFF

Turns off the mask.

[:SENSe]:SMASk:SWEep:TIME[?]

Sets/queries how long the measurement is performed.

Setting Range: 1.000 us to 5.192 ms

Query Range: 1.000 us to 5.192 ms

*RST Setting: 2.000000 ms

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SMASk:SWEep:TIME 3.0 ms

Sets the sweep time to 3.0 ms.

[:SENSe]:SMASk:TRIGger:SOURce[?]

Sets/queries the trigger source for the Spectral Mask measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SMASk:TRIGger:SOURce RFBurst

Sets the trigger source for the Spectral Mask measurement to RF Burst.

[:SENSe]:SMASk:WTYPe[?]

Sets/queries the window type for the spectral mask measurement.

Setting Range: GAUSsian | FLATtop | HANNing | UNIForm

Query Range: GAUS | FLAT | HANN | UNIF

*RST Setting: GAUSsian

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SMASk:WTYPe?

Queries the window type for the spectral mask measurement.


802.16 OFDM (N6301A)

[:SENSe]:SUSPend

Last Updated: March 28, 2008

  • [:SENSe]:SUSPend

[:SENSe]:SUSPend

Releases the application visa lock on the test set so that other applications (such as glacier) can use it.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SUSPend

Releases the application visa lock on the test set.


802.16 OFDM (N6301A)

[:SENSe]:WAVeform

Last Updated: March 28, 2008

These commands provide device-specific settings for the Waveform measurement.

  • [:SENSe]:WAVeform:AVERage:COUNt[?]

  • [:SENSe]:WAVeform:AVERage[:STATe][?]

  • [:SENSe]:WAVeform:AVERage:TCONtrol[?]

  • [:SENSe]:WAVeform:AVERage:TYPE[?]

  • [:SENSe]:WAVeform:PONLy[:STATe][?]

  • [:SENSe]:WAVeform:SWEep:TIME[?]

  • [:SENSe]:WAVeform:TRIGger:SOURce[?]

[:SENSe]:WAVeform:AVERage:COUNt[?]

Sets/queries the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Setting Range: 1 to 20001

Query Range: 1 to 20001

*RST Setting: 10

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:COUNt 20

Sets/queries the number of sweeps (average counts) to 20.

[:SENSe]:WAVeform:AVERage[:STATe][?]

Sets/queries the averaging state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:AVERage ON

Turns on averaging.

[:SENSe]:WAVeform:AVERage:TCONtrol[?]

Sets/queries the averaging mode. When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep. When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Setting Range: EXPonential | REPeat

Query Range: EXP | REP

*RST Setting: EXPonential

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:TCONtrol REPeat

Sets the averaging mode to repeat.

[:SENSe]:WAVeform:AVERage:TYPE[?]

Sets/queries the type of averaging.

Setting Range: LOG | MAXimum | MINimum | RMS | SCALar

Query Range: LOG | MAX | MIN | RMS | SCAL

*RST Setting: RMS

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:AVERage:TYPE MAXimum

Sets the type of averaging to Maximum.

[:SENSe]:WAVeform:PONLy[:STATe][?]

Sets/queries the waveform measurement to only return the power result. This makes the measurement quicker.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:PONLy ON

Sets the waveform measurement to only return the power result.

[:SENSe]:WAVeform:SWEep:TIME[?]

Sets/queries how long the measurement is performed. X Scale only changes the representation of the display

Setting Range: 1.000 s to 100.00 s

Query Range: 1.000 s to 100.00 s

*RST Setting: 2.000000 ms

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:SWEep:TIME?

Queries the sweep time.

[:SENSe]:WAVeform:TRIGger:SOURce[?]

Sets/queries the trigger source for the Waveform measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

WAVeform:TRIGger:SOURce EXTernal

Sets the trigger source to External for the Waveform measurement.


SOURce Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

SOURce Subsystem

Last Updated: March 28, 2008

Description

The SOURce subsystem is used to control the test set's RF generator.

For details of the :SOURce commands refer to the :SOURce subsystems in this section.


802.16 OFDM (N6301A)

SOURce:CALibration

Last Updated: March 28, 2008

These commands perform calibration operations.

  • SOURce:CALibration[:USER]

  • SOURce:CALibration:DCFM

  • SOURce:CALibration:IQ:DC

  • SOURce:CALibration:IQ:DEFault

  • SOURce:CALibration:IQ:FULL

  • SOURce:CALibration:IQ:START[?]

  • SOURce:CALibration:IQ:STOP[?]

  • SOURce:CALibration:IQ:TYPE[?]

SOURce:CALibration[:USER]

Performs an IQ calibration according to the IQ calibration type.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration

Performs an IQ calibration according to the IQ calibration type.

SOURce:CALibration:DCFM

Performs a DCFM or DCΦM calibration depending on the currently active modulation. This calibration eliminates any dc or modulation offset of the carrier signal.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:DCFM

Performs a DCFM or DCΦM calibration depending on the currently active modulation.

SOURce:CALibration:IQ:DC

Performs a one to two second adjustment that is not traceable to a standard. However, it will minimize errors associated with IQ gain, quadrature, and offset voltages. This adjustment minimizes errors for the current signal generator setting and at a single frequency. The DC adjustment is volatile and must be repeated with each signal generator setting change. This command can be sent while the RF On/Off is set to Off and the adjustment will still be valid when the RF is enabled. IQ must be on to perform this adjustment.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:DC

Performs a one to two second adjustment that is not traceable to a standard.

SOURce:CALibration:IQ:DEFault

Restores the original factory calibration data for the internal I/Q modulator.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:DEFault

Restores the original factory calibration data for the internal I/Q modulator.

SOURce:CALibration:IQ:FULL

Performs an adjustment to the I/Q offset, gain and quadrature for the full- frequency range (regardless of the start and stop frequency settings) and stores the results in the signal generator&rsquo;s firmware.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:FULL

Performs an adjustment to the I/Q offset, gain and quadrature for the full- frequency range (regardless of the start and stop frequency settings) and stores the results in the signal generator&rsquo;s firmware.

SOURce:CALibration:IQ:START[?]

Sets/queries the start frequency and automatically sets the calibration type to User for an I/Q calibration.

Setting Range: 100 kHz to 6 GHz

Query Range: 100 kHz to 6 GHz

*RST Setting: 100 kHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:START?

Queries the start frequency.

SOURce:CALibration:IQ:STOP[?]

Sets/queries the stop frequency and automatically sets the calibration type to User for an I/Q calibration.

Setting Range: 100 kHz to 6 GHz

Query Range: 100 kHz to 6 GHz

*RST Setting: 1 GHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:STOP?

Queries the stop frequency.

SOURce:CALibration:IQ:TYPE[?]

Sets/queries the IQ calibration type.

Setting Range: DC | USER | FULL

Query Range: DC | USER | FULL

*RST Setting: DC

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:CALibration:IQ:TYPE USER

Sets the IQ calibration type to User.


802.16 OFDM (N6301A)

SOURce:MMEMory

Last Updated: March 28, 2008

These commands perform operations on file systems.

  • SOURce:MMEMory:CATalog?

  • SOURce:MMEMory:COPY

  • SOURce:MMEMory:DATA

  • SOURce:MMEMory:DATA:UNPRotected

  • SOURce:MMEMory:DELete[:NAME]

  • SOURce:MMEMory:DELete:NVWFm

  • SOURce:MMEMory:DELete:WFM

SOURce:MMEMory:CATalog?

Outputs a list of the files from the specified file system. The variable "<msus>" (mass storage unit specifier) represents "<file system>".

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:CATalog?

Outputs a list of the files from the specified file system.

SOURce:MMEMory:COPY "NVWFM:<source_file_name>","WFM1:<destination_file_name>"
[,"NVWFM:<source_file_name>"][,"WFM1:<destination_file_name>"]

Allows you to transfer files between volatile memory (WFM1) and non-volatile memory (NVWF1).

When copying files between volatile memory and non-volatile memory on the test set, this command returns immediately to the calling program. However, the work is still being performed in the background. This can result in a timeout in the SCPI parser, incorrectly generating an error message. In order to ensure the command performs as intended, you should set the timeout to a value sufficiently long (the exact value depends on how many files are being copied) and perform a SYST:ERR? query after every copy. This holds off the SCPI until the SOURce:MMEMory:COPY command is complete and the test set is ready to use.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:COPY "NVWFM:16E_10M_DL_PUSC_MULT","WFM1:16E_10M_DL_PUSC_MULT"

Copies the source file from non-volatile to volatile memory.

SOURce:MMEMory:DATA "<file name>",<datablock>
SOURce:MMEMory:DATA? "<file name>"

This command loads <datablock> into the memory location "<file name>". The query returns the <datablock> associated with the "<file name>".

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DATA? "myfile1.txt"

Returns the datablock associated with myfile1.txt.

SOURce:MMEMory:DATA:UNPRotected "<file_name>",<data_block>

Allows you to download data and store it in a file on the instrument with the ability to retrieve it. This command is intended for downloading waveform data; however you can use it to download other types of data. Data_File is the filename. The directory path is not needed. The path "/USER/SECUREWAVE" is implied.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

SOURce:MMEMory:DELete[:NAME] "<file_name>",["<msus>"]

Allows you to delete files from volatile memory (WFM1) or non-volatile memory (NVWF1). This command clears the user file system of "<file name>" with the option of specifying the file system separately. The variable "<msus>" (mass storage unit specifier) represents the file system. If the optional variable "<msus>" is omitted, the file name needs to include the file system extension. You can also use this command to delete sequence files using the prefix SEQ.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Examples:

SOURce:MMEMory:DELete "WFM1:16E_10M_DL_PUSC_MULT"

Removes the file "16E_10M_DL_PUSC_MULT" from volatile memory.

SOURce:MMEMory:DELete "SEQ:16E_PER_1000.seq"

Deletes the sequence file "16E_PER_1000.seq".

SOURce:MMEMory:DELete:NVWFm

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DELete:NVWFm

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

SOURce:MMEMory:DELete:WFM

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:MMEMory:DELete:WFM

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).


802.16 OFDM (N6301A)

SOURce:OUTPut

Last Updated: March 28, 2008

  • SOURce:OUTPut[:STATe][?]

SOURce:OUTPut[:STATe][?]

Sets/queries operating state of the RF signal present at the RF OUTPUT connector.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:OUTPut?

Queries operating state of the RF signal present at the RF OUTPUT connector.


802.16 OFDM (N6301A)

SOURce:POWer

Last Updated: March 28, 2008

These commands control source power functions.

  • SOURce:POWer:ALC[:STATe][?]

  • SOURce:POWer:ATTenuation[?]

  • SOURce:POWer:ATTenuation:AUTO[?]

  • SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

SOURce:POWer:ALC[:STATe][?]

Sets/queries the automatic leveling control (ALC) circuit state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:POWer:ALC 1

Turns on the automatic leveling control (ALC) circuit.

SOURce:POWer:ATTenuation[?]

Sets/queries the signal generator&rsquo;s attenuator level. Before setting the attenuator level, set the &rdquor;:ATTenuation:AUTO&rdquo; function to Off which will disable ALC control.

Setting Range: 0 dB to 115 dB

Query Range: 0 dB to 115 dB

*RST Setting: 115 dB

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:POWer:ATTenuation 10DB

Sets the signal generator&rsquo;s attenuator level to 10 dB.

SOURce:POWer:ATTenuation:AUTO[?]

Sets/queries the state of the attenuator auto mode function.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 1 | ON

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:POWer:ATTenuation:AUTO?

Queries the state of the attenuator auto mode function.

SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

Sets/queries the output power.

Setting Range: -110 dBm to 16 dBm

Query Range: -110 dBm to 16 dBm

*RST Setting: -110 dBm

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:POWer:LEVel:IMMediate:AMPLitude -30

Sets the output power to -30 dBm.


802.16 OFDM (N6301A)

SOURce:RADio

Last Updated: March 28, 2008

These commands configure arbitrary waveform generator functions.

  • SOURce:RADio:ARB[:STATe][?]

  • SOURce:RADio:ARB:CLOCk:SRATe[?]

  • SOURce:RADio:ARB:DONE?

  • SOURce:RADio:ARB:MARKer[:SET]

  • SOURce:RADio:ARB:MARKer:CLEar

  • SOURce:RADio:ARB:MARKer:CLEar:ALL

  • SOURce:RADio:ARB:MARKer:ROTate

  • SOURce:RADio:ARB:MDEStination:ALCHold[?]

  • SOURce:RADio:ARB:MDEStination:PULSe[?]

  • SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

  • SOURce:RADio:ARB:RSCaling[?]

  • SOURce:RADio:ARB:SEQuence[:MWAVeform]

  • SOURce:RADio:ARB:TRIGger[:SOURce][?]

  • SOURce:RADio:ARB:TRIGger:TYPE[?]

  • SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

  • SOURce:RADio:ARB:WAVeform

SOURce:RADio:ARB[:STATe][?]

Sets/queries the arbitrary waveform generator function state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB?

Queries the arbitrary waveform generator function state.

SOURce:RADio:ARB:CLOCk:SRATe[?]

Sets/queries the sample clock rate.

Setting Range: 1 Hz to 100 MHz

Query Range: 1 Hz to 100 MHz

*RST Setting: 100 MHz

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:CLOCk:SRATe?

Queries the sample clock rate.

SOURce:RADio:ARB:DONE?

Queries if the ARB has finished playing the selected recording.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:DONE?

Queries if the ARB has finished playing the selected recording.

SOURce:RADio:ARB:MARKer[:SET] "<file_name>",<marker>,<first_point>,<last_point>,<skip_count>

Sets/queries a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command. The instrument provides four independent markers. Two of the markers route output signals to rear- panel event connectors, Marker- 1 to Event1 BNC and Marker- 2 to Aux I/O. A marker consists of marker points placed at defined sample points in a waveform segment. This means that a marker point cannot be less than one or greater than the last sample point in the waveform. Marker points are cumulative, so multiple command executions with different range values, without first clearing the existing points, places additional marker points on the waveform. Because of this cumulative behaviour, it is a good practice to clear existing marker points prior to setting new points. This will eliminate unexpected marker pulses. Refer to &rdquor;:MARKer:CLEar&rdquo; and &rdquor;:MARKer:CLEar:ALL&rdquo; for information on clearing marker points.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer "Test_Data",1,40,100,2

Sets marker 1 on the first point, 40, the last point, 100, and every third point (skip 2) between 40 and 100 (assuming the Test_Data file has at least 100 points).

SOURce:RADio:ARB:MARKer:CLEar "<file_name>",<marker>,<first_point>,<last_point>

Clears a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB modulation formats use this command.

Setting Range: <marker>: 1&endash;4 <first_Point>: 1&endash;number of waveform points <last_point>: <first_Point>&endash;number of waveform points

*RST Setting: <marker>: 1 <first_Point>: 1 <last_point>: 200

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:CLEar "Test_Data",1,1,300

Clears marker 1 from the first point through the 300th point in the Test_Data file.

SOURce:RADio:ARB:MARKer:CLEar:ALL "<file_name>",<marker>

Clears all marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command. With all marker points cleared, the event output signal level is set low.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:CLEar:ALL "Test_Data",1

Clears marker 1 from the all waveform points in the Test_Data file.

SOURce:RADio:ARB:MARKer:ROTate "<file_name>",<rotate_count>

Shifts the marker points for all markers in a waveform segment earlier or later by the value of the <rotate_count> variable. The dual ARB player and all of the ARB formats use this command.

Setting Range: &endash; (n &endash; 1) to (n &endash; 1) n = number of points in the waveform

Query Range: &endash; (n &endash; 1) to (n &endash; 1) n = number of points in the waveform

*RST Setting: No rotation

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MARKer:ROTate "Test_Data",100

Shifts all markers set in the Test_Data file 100 points later.

SOURce:RADio:ARB:MDEStination:ALCHold[?]

Sets/queries the marker ALC hold function for the selected marker. Use the ALC hold function when you have a waveform signal that incorporates idle periods, or when the increased dynamic range encountered with RF blanking is not desired. The ALC leveling circuitry responds to the marker signal during the marker pulse (marker signal high), averaging the modulated signal level during this period. The ALC hold function operates during the low periods of the marker signal. The marker polarity determines when the marker signal is high. For a positive polarity, this is during the marker points. For a negative polarity, this is when there are no marker points. CAUTION: Incorrect automatic level control (ALC) sampling can create a sudden unlevelled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Setting Range: NONE | M1 | M2 | M3 | M4

Query Range: NONE | M1 | M2 | M3 | M4

*RST Setting: NONE

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MDEStination:ALCHold M1

Sets/queries the marker ALC hold function for marker 1.

SOURce:RADio:ARB:MDEStination:PULSe[?]

Sets/queries the marker pulse/RF blanking function for the selected marker. This function automatically uses the ALC hold function, so there is no need to select both the ALC hold and pulse/RF blanking functions for the same marker. CAUTION The pulse function incorporates ALC hold. Incorrect automatic level control (ALC) sampling can create a sudden unleveled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Setting Range: NONE | M1 | M2 | M3 | M4

Query Range: NONE | M1 | M2 | M3 | M4

*RST Setting: NONE

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MDEStination:PULSe M3

Sets the marker pulse/RF blanking function for marker 3.

SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

Sets/queries the polarity for the selected marker. For a positive marker polarity, the marker signal is high during the marker points. For a negative marker polarity, the marker signal is high during the period of no marker points.

Setting Range: NEGative | POSitive

Query Range: NEG | POS

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:MPOLarity:MARKer2?

Queries the polarity for marker 2.

SOURce:RADio:ARB:RSCaling[?]

Sets/queries the scaling value in percent that is applied to a waveform while it is playing. The variable <value> is expressed as a percentage. Runtime scaling does not alter the waveform data file. This feature is used to avoid DAC overflow. The scaling is compensated for at the modulator (that is, when the modulator is the optimized path).

Setting Range: 1% to 100%

Query Range: 1% to 100%

*RST Setting: 70%

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:RSCaling 80

Applies an 80% scaling factor to the selected waveform.

SOURce:RADio:ARB:SEQuence[:MWAVeform] <filename>,<waveform1>,<reps>,NONE|M1|M2|M3|M4|M1M2|
M1M3|M1M4|M2M3|M2M4|M3M4|M1M2M3|M1M2M4|M1M3M4|M2M3M4|M1M2M3M4|ALL,
{,<waveform2>,<reps>,NONE|M1|M2|M3|M4|M1M2|M1M3|M1M4|M2M3|M2M4|M3M4|M1M2M3|M1M2M4|M1M3M4|M2M3M4|M1M2M3M4|ALL,}
SOURce:RADio:ARB:SEQuence[:MWAVeform? <filename>

This command creates a waveform sequence. A waveform sequence is made up of segments and other sequences. Any number of segments, up to a segment count limit of 1024, can be used to create a sequence. The count limit is determined by the number of segments in the waveform sequence. Repeated segments are included in the count limit.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:SEQuence "SEQ:Test_Data","WFM1:ramp_test_wfm",25,M1M4,"WFM1:sine_test_wfm",100,ALL

creates a waveform sequence file named Test_Data. This file consists of the factory- supplied waveform segments, ramp_test_wfm and sine_test_wfm. The waveform is stored in the signal generator&rsquo;s SEQ: directory.

- The first segment, ramp_test_wfm, has 25 repetitions with markers 1 and 4 enabled.

- The second segment, sine_test_wfm, has 100 repetitions with all four markers enabled.

SOURce:RADio:ARB:TRIGger[:SOURce][?]

Sets/queries the trigger source.

Setting Range: KEY | EXT | BUS

Query Range: KEY | EXT | BUS

*RST Setting: EXT

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger?

Queries the trigger source.

SOURce:RADio:ARB:TRIGger:TYPE[?]

Sets/queries the trigger mode (type) that controls the waveform&rsquo;s playback.

Setting Range: CONTinuous | SINGle

Query Range: CONT | SING

*RST Setting: CONTinuous

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger:TYPE:CONTinous[:TYPE][?]

Sets/queries the waveform&rsquo;s response to a trigger signal while using the continuous trigger mode:

  • FREE Turning the ARB format on immediately triggers the waveform. The waveform repeats until you turn the format off, select another trigger, or choose another waveform file.

  • TRIGger The waveform waits for a trigger before play begins. When the waveform receives the trigger, it plays continuously until you turn the format off, select another trigger, or choose another waveform file.

  • RESet The waveform waits for a trigger before play begins. When the waveform receives the trigger, it plays continuously. Subsequent triggers reset the waveform to the beginning. For a waveform sequence, this means to the beginning of the first segment in the sequence.

Setting Range: FREE | TRIGger | RESet

Query Range: FREE | TRIGger | RESet

*RST Setting: FREE

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:TRIGger:TYPE:CONTinous FREE

Sets the waveform&rsquo;s response to Free.

SOURce:RADio:ARB:WAVeform "WFM1:file_name"|"SEQ:file_name"
:SOURce:RADio:ARB:WAVeform?

Sets/queries the waveform file or sequence, for the AWG to play. The file must be present in volatile memory (WFM1) or in the SEQ directory. If a file is in non-volatile memory (NVWFM), use the command &rdquor;SOUR:MMEM:COPY[:NAME]&rdquo; to copy the file to WFM1. Any specified values in the header are applied to the ARB upon selection. Unspecified fields in the header cause no change in the ARB state.

Setting Range: "WFM1:file_name" This variable names a waveform file residing in volatile memory (WFM1:). "SEQ:file_name" This variable names a sequence file residing in the catalog of sequence files.

Query Range: "WFM1:file_name" This variable names a waveform file residing in volatile memory (WFM1:). "SEQ:file_name" This variable names a sequence file residing in the catalog of sequence files.

*RST Setting: No waveform selected

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RADio:ARB:WAVeform "WFM1:Test_Data"

Selects the file Test_Data from the list of files in volatile waveform memory, WFM1, and applies its file header settings.


802.16 OFDM (N6301A)

SOURce:RESume

Last Updated: March 28, 2008

  • SOURce:RESume

SOURce:RESume

Resumes the VISA lock over the arbitrary waveform generator.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:RESume

Resumes the VISA lock over the arbitrary waveform generator.


802.16 OFDM (N6301A)

SOURce:SUSPend

Last Updated: March 28, 2008

  • SOURce:SUSPend

SOURce:SUSPend

Suspends the VISA lock over the arbitrary waveform generator.

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

SOURce:SUSPend

Suspends the VISA lock over the arbitrary waveform generator.


TRIGger Subsystem (802.16 OFDM)

802.16 OFDM (N6301A)

TRIGger Subsystem

Last Updated: March 28, 2008

The TRIGger subsystem is used to automatically control trigger settings.

For details of the TRIGger commands, refer to the TRIGger topic in this section.


802.16 OFDM (N6301A)

TRIGger

Last Updated: March 28, 2008

These commands set up trigger parameters.

  • TRIGger:EVM[:SEQuence]:SOURce[?]

  • TRIGger[:SEQuence]:EXTernal:DELay[?]

  • TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

  • TRIGger[:SEQuence]:HOLDoff[?]

  • TRIGger[:SEQuence]:HOLDoff:STATe[?]

  • TRIGger:PSTatistic[:SEQuence]:SOURce[?]

  • TRIGger[:SEQuence]:RFBurst:DELay[?]

  • TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

  • TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

  • TRIGger[:SEQuence]:RFBurst:SLOPe[?]

  • TRIGger[:SEQuence]:SLOPe[?]

  • TRIGger:SMASk[:SEQuence]:SOURce[?]

  • TRIGger:WAVeform[:SEQuence]:SOURce[?]

TRIGger:EVM[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the current EVM measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:EVM:SOURce RFBurst

Sets the trigger source for the current EVM measurement to RF Burst.

TRIGger[:SEQuence]:EXTernal:DELay[?]

Controls a time delay during which the analyzer will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the test set in time domain or FFT, but not in swept spans.

Setting Range: -150 ms to 500 ms

Query Range: -150 ms to 500 ms

*RST Setting: 1.000 us

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:EXTernal:DELay 100MS

Sets the time delay to 100 ms.

TRIGger[:SEQuence]:EXTernal:DELay:STATe[?]

Sets/queries the external trigger delay state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | 1

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:EXTernal:DELay:STATe ON

Sets the external trigger delay state to On.

TRIGger[:SEQuence]:HOLDoff[?]

Sets/queries the holdoff time between triggers. When the trigger condition is satisfied, the trigger occurs, the delay begins, and the holdoff time begins. New trigger conditions will be ignored until the holdoff time expires. For a free-running trigger, the holdoff value is the minimum time between triggers.

Setting Range: 0 s to 0.5 s

Query Range: 0 s to 0.5 s

*RST Setting: 100 ms

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:HOLDoff 110MS

Sets the holdoff time between triggers to 110 ms.

TRIGger[:SEQuence]:HOLDoff:STATe[?]

Sets/queries the trigger holdoff state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:HOLDoff:STATe ON

Sets the trigger holdoff state to On.

TRIGger:PSTatistic[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the current Power Stat CCDF measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXT | IMM | RFB

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:PSTatistic:SOURce EXTernal

Sets the the trigger source for the current Power Stat CCDF measurement to external.

TRIGger[:SEQuence]:RFBurst:DELay[?]

Controls a time delay during which the analyzer will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the instrument in time domain or FFT, but not in swept spans.

Setting Range: -150 ms to 500 ms

Query Range: -150 ms to 500 ms

*RST Setting: 1.000 us

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:RFBurst:DELay 1.5US

Sets the time delay to 1.5 microseconds for RF Burst triggering.

TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

Sets/queries the RF Burst trigger delay state.

Setting Range: 0 | OFF | 1 | ON

Query Range: 0 | OFF | 1 | ON

*RST Setting: 0 | OFF

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:RFBurst:DELay:STATe ON

Sets the RF Burst trigger delay state to On.

TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

Sets/queries the absolute trigger level for the RF burst envelope. See key notes regarding the relative trigger level.

Setting Range: -200 dBm to 100 dBm

Query Range: -200 dBm to 100 dBm

*RST Setting: -20 dBm

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute -30DBM

Sets the absolute trigger level for the RF burst envelope to -30 dBm.

TRIGger[:SEQuence]:RFBurst:SLOPe[?]

Sets/queries the trigger slope. It is set positive to trigger on a rising edge and negative to trigger on a falling edge.

Setting Range: POSitive | NEGative

Query Range: POSitive | NEGative

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger[:SEQuence]:RFBurst:SLOPe

Sets the RF Burst trigger polarity to positive (triggers on a rising edge).

TRIGger[:SEQuence]:SLOPe[?]

Sets/queries whether to trigger on a positive (rising) or negative (falling) edge. For use with an RF Burst trigger.

Setting Range: POSitive | NEGative

Query Range: POSitive | NEGative

*RST Setting: POSitive

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:SLOPe?

Queries the current trigger slope setting.

[?]

Sets/queries the trigger source for the Spectral Mask measurement.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXTernal | IMMediate | RFBurst

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:SMASk:SOURce IMMediate

Sets the trigger source for the Spectral Mask measurement to immediate.

TRIGger:WAVeform[:SEQuence]:SOURce[?]

Sets/queries the trigger source for the Waveform measurement to external.

Setting Range: EXTernal | IMMediate | RFBurst

Query Range: EXTernal | IMMediate | RFBurst

*RST Setting: IMMediate

Test Set Requirements: N6301A 802.16 OFDM Measurement Application Version A.01 and above

Example:

TRIGger:WAVeform[:SEQuence]:SOURce EXTernal

Sets the trigger source for the Waveform measurement to external.


Front Panel Operation (802.16 OFDM)

802.16 OFDM (N6301A)

Front Panel Operation

Last Updated: March 28, 2008

The test set can be operated using front panel controls and a large video display to perform generator and analyzer functions and obtain measurement results.

For details of 802.16 OFDM Application front panel operation, refer to the books and topics in this section.

Related Topic: Front Panel Operation (Test Set)


802.16 OFDM (N6301A)

ANALYZER SETUP Functions

Last Updated: March 28, 2008

This section describes generic test set setup functionality. These functions can change depending on the currently selected Measurement. This is common test set functionality information that can be used as reference material to better understand some of the unique features that are available in the different measurements in this mode.

For more details, refer to the topics in this section.


802.16 OFDM (N6301A)

AMPTD, Y Scale

Last Updated: March 28, 2008

Some Amplitude features are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Amplitude front-panel key activates the Amplitude menu and selects Reference Level as the active function.

Ref Value

Sets the value for the absolute power reference. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]

Scale/Div

Sets the units per division of the vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center, or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]


802.16 OFDM (N6301A)

Frequency

Last Updated: March 28, 2008

This key accesses a menu allowing you to set Frequency parameters for the current measurement. All measurements in 802.16 OFDM mode have the same menu structure.

Key Path: Front-panel key

Center Freq

Allows you to specify the center frequency of the spectrum analyzer.

Key Path: FREQ Channel

SCPI Command: [:SENSe]:FREQuency:CENTer[?]

Source Freq

Allows you to set the source frequuncy mode to manual or automatic. If set to manual you can specify the frequency.

Key Path: FREQ

SCPI Command:


802.16 OFDM (N6301A)

New Topic

Last Updated: March 28, 2008

The Input/Output features are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

Other functions related to the input/output connections can be found under Trig (trigger input controls) and System (LAN and other I/O bus configurations).

Virtually all the input/output settings are NOT a part of mode preset. They can be set to their default value by one of the three ways - by using the Restore Input/Output Defaults key on the first page of the input/output menu, by using the System->Restore System Defaults->Input/Output Settings or by using the System -> Restore System Defaults->All. Also, they survive Preset and Power cycle.

A very few of the Input/Output settings do respond to a Mode Preset; for example, if the Calibrator is on it turns off on a Preset, and if DC coupling is in effect it switches to AC on a Preset. These exceptions are made in the interest of reliability and usability, which overrides the need for absolute consistency. Exceptions are noted in the SCPI table for the excepted functions.

Freq Ref In

Specifies the frequency reference as being the internal reference, external reference or sensing the presence of an external reference. When the frequency reference is set to internal, the internal 10 MHz reference is used even if an external reference is connected.

When the frequency reference is set to external, the test set will use the external reference. However, if there is no external signal present, or it is not within the proper amplitude range, an error condition detected message is generated. When the external signal becomes valid, the error is cleared.

If Sense is selected, the test set checks whether a signal is present at the external reference connector and will automatically switch to the external reference when a signal is detected. When no signal is present, it automatically switches to the internal reference. No message is generated as the reference switches between external and internal. The monitoring of the external reference occurs approximately on 1 millisecond intervals, and never occurs in the middle of a measurement acquisition, only at the end of the measurement (end of the request).

If for any reason the test set's frequency reference is not able to obtain lock, Status bit 2 in the Questionable Frequency register will be true and an error condition detected message is generated. When lock is regained, Status bit 2 in the Questionable Frequency register will be cleared and an error message is cleared will be sent.

If an external frequency reference is being used, you must enter the frequency of the external reference if it is not exactly 10 MHz. The External Ref Freq key is provided for this purpose.

Key Path: Input/Output

SCPI Commands: [:SENSe]:ROSCillator:SOURce:TYPE[?]

Sense

The external reference is used if a valid signal is sensed at the Ext Ref input. Otherwise the internal reference is used.

Key Path: Input/Output, Freq Ref In

Internal

The internal reference is used.

Key Path: Input/Output, Freq Ref In

Restore Input/Output Defaults

This selection causes the group of settings and data associated with Input/Output key to be a reset to their default values. This level of Restore System Defaults does not affect any other system settings or mode settings and does not cause a mode switch. All the features described in this section are reset using this key.

Key Path: Input/Output


802.16 OFDM (N6301A)

SPAN, X Scale

Last Updated: March 28, 2008

Span features are unique to each Measurement. See the specific Measurement for more information.
The front panel key accesses keys to control span (or X-axis) settings.

Key Path: Front panel key


802.16 OFDM (N6301A)

Trace/Detector

Last Updated: March 28, 2008

Trace/Detector features are unique to each Measurement. See the specific Measurement for more information.

The front panel key accesses keys to control Trace and Detector settings.

Key Path: Front panel key


802.16 OFDM (N6301A)

View/Display

Last Updated: March 28, 2008

The View/Display key opens up the View menu for the current measurement. This menu includes the Display key for controlling items on the display. The Display functions are common across multiple Modes and Measurements and are described in this section. See each measurement description for information on data views that are unique to that Measurement.

Views are different ways of looking at data, usually different ways of looking at the same data, especially when the data represents a time record that is being digitally processed with an FFT and/or other digital signal processing algorithms. In some modes, like the Spectrum Analyzer mode, we are mostly concerned with swept spectrum analysis, and those views may represent different ways of looking at the same signal.

Key Path: Front-panel key

Display

This is a menu common to all measurements for configuring items on the display. Keys not relevant to a given measurement should be grayed out. Keys not relevant to any measurement in a mode should be blanked. The Display menu settings are specific to the measurement selected under the Meas key, except for those settings under the System Display Settings key.

Key Path: View/Display

Annotation

Turns on/off various parts of the display annotation. The annotation is divided up into four categories:

  • Meas Bar: This is the measurement bar at the top of the screen. When the Meas Bar is off, the graticule area expands to fill the area formerly occupied by the Meas Bar.

  • Screen Annotation: this is the annotation and annunciation around the graticule, including any annotation on lines (such as the display line, the threshold line, etc.). This does NOT include the marker number or the N dB result. When off, the graticule expands to fill the entire graticule area.

  • Trace annotation: these are the labels on the traces, showing their detector (or their math mode).

  • Active Function annotation: this is the active function display in the meas bar, and all of the active function values displayed on softkeys.

Key Path: View/Display, Display

Meas Bar On/Off

This function turns the Measurement Bar on and off, including the settings panel. When off, the graticule area expands to fill the area formerly occupied by the Measurement Bar.

Key Path: View/Display, Display, Annotation

Screen

This controls the display of the annunciation and annotation around the graticule, including any annotation on lines (such as the display line, the threshold line, etc.) and the y-axis annotation. This does NOT include marker annotation (or the N dB result). When off, the graticule expands to fill the entire graticule area, leaving only the 1.5% gap above the graticule as described in the Trace/Detector chapter.

Key Path: View/Display, Display, Annotation

Trace

Turns on and off the labels on the traces, showing their detector (or their math mode) as described in the Trace/Detector section.

If trace math is being performed with a trace, then the trace math annotation will replace the detector annotation.

Key Path: View/Display, Display, Annotation

Active Function Values On/Off

Turns on/off the active function display in the Meas Bar, and all of the active function values displayed on the softkeys.

Note that all of the softkeys that have active functions have these numeric values blanked when this function is on. This is a security feature.

Key Path: View/Display, Display, Annotation

Title

Displays softkeys that enable you to change or clear a title on your display.

Key Path: View/Display, Display

Change Title

Writes a title into the &rdquor;measurement name&rdquo; field in the banner (for example, &rdquor;Swept SA&rdquo;.

Press Change Title to enter a new title through the alpha editor. Press Enter or Return to complete the entry. Press ESC to cancel the entry and preserve your existing title.

The display title will replace the measurement name. It remains for this measurement until you press Change Title again, or you recall a state, or a Preset is performed. A title can also be cleared by pressing Title, Clear Title.

Pressing this key cancels any active function.

When a title is edited the previous title remains intact (it is not cleared) and the cursor goes at the end so that characters can be added or BKSP can be used to go back over previous characters.

Key Path: View/Display, Display, Title

Clear Title

Clears a title from the front-panel display. Once cleared, the title cannot be retrieved. After the title is cleared, the current Measurement Name replaces it in the title bar.

Key Path: View/Display, Display, Title

Graticule

Pressing Graticule turns the display graticule On or Off. It also turns the graticule y-axis annotation on and off.

Key Path: View/Display, Display

System Display Settings

These settings are &rdquor;Mode Global&rdquo; –– they affect all modes and measurements and are reset only by Restore Misc Defaults or Restore System Defaults under System.

Key Path: View/Display, Display, System Display Settings

Annotation On/Off

This is a Mode Global override of the meas local annotation settings. When it is OFF, it forces Screen Annotation, Meas Bar, Trace and Active Function Values settings to be OFF for all measurements in all modes. This provides the security based &rdquor;annotation off&rdquo; function of previous analyzers, hence it uses the legacy SCPI. Command.

When it is OFF, Screen, Meas Bar, Trace and Active Function Values keys under the Display, Annotation menu are grayed out and forced to OFF. When it is ON, it allows the local annotation settings to be set on a measurement by measurement basis.

To implement this feature properly will require overriding but not changing the local settings for the current measurement. If the measurement changes, the settings for the new measurement must likewise be overridden but not changed. Then if this function turns off, the settings will be returned to their local values.

Key Path: View/Display, Display, System Display Settings, Annotation

Theme

This key allows you to change the Display theme. This is similar to the Themes selection under Page Setup and Save Screen Image. The four themes are detailed below.

  • TDColor –– 3D is the standard color theme with filling and shading

  • TDMonochrome –– is similar to 3D color, but only black is used

  • FCOLor –– flat color is intended for inkjet printers to conserve ink. It uses a white background instead of black.

  • FMONochrome –– is like flat color, but only black is used

Key Path: View/Display, Display, System Display Settings, Theme

Backlight On/Off

Allows you to turn the backlight on or off. This setting interacts with settings under the Windows &rdquor;Power&rdquo; menu.

When the backlight is off, pressing ESC, TAB, SPACE, ENTER, UP, DOWN, LEFT, RIGHT, DEL, BKSP, CTRL, or ALT turns the backlight on without affecting the application. Pressing any other key will turn backlight on and could potentially perform the action as well.

Note that pressing this softkey (Backlight On/Off) will turn the backlight back on, simply because a key has been pressed, and then will turn it back off as the key action is taken. So the display will flash and go back to being off.

Key Path: View/Display, Display, System Display Settings

SCPI Command: DISPlay:BACKlight[?]

Backlight Intensity

An active function used to set the backlight intensity. It goes from 0 to 100 where 100 is full on and 0 is off. This value is independent of the values set under the Backlight on/off key.

Key Path: View/Display, Display, System Display Settings

SCPI Command: DISPlay:BACKlight:INTensity[?]

Full Screen

When Full Screen is pressed the measurement window expands horizontally over the entire test set display. The screen graticule area expands to fill the available display area.

It turns off the display of the softkey labels, however the menus and active functions still work. (Though it would obviously be very hard to navigate without the key labels displayed.) Pressing Full Screen again while Full Screen is in effect cancels Full Screen.

Note that the banner and status lines are unaffected. You can get even more screen area for your data display by turning off the Meas Bar (in the Display menu) which also turns off the settings panel. Full Screen is a Mode Global function. Therefore it is not cancelled by the Preset key.

Key Path: Front panel key


802.16 OFDM (N6301A)

Source

Last Updated: March 28, 2008

This Source key accesses a menu of functions that enable you to generate signals through the internal Arbitrary Waveform Generator.

RF Output

Toggles the operating state of the RF signal present at the RF OUTPUT connector.

Key Path: Source

SCPI Command: SOURce:OUTPut[:STATe][?]

Amplitude

Sets the output power.

Key Path: Source

SCPI Command: SOURce:POWer:LEVel:IMMediate:AMPLitude[?]

ALC State

This command enables or disables the automatic leveling control (ALC) circuit.

Key Path: Source

SCPI Command: SOURce:POWer:ALC[:STATe][?]

Select Waveform

This command selects a waveform file or sequence, for the AWG to play. The file must be present in volatile memory (WFM1) or in the SEQ directory. If a file is in non-volatile memory (NVWFM), use the command &rdquor;SOUR:MMEM:COPY[:NAME]&rdquo; to copy the file to WFM1. Any specified values in the header are applied to the ARB upon selection. Unspecified fields in the header cause no change in the ARB state.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:WAVeform

Marker Polarity

Sets the polarity for the selected marker. For a positive marker polarity, the marker signal is high during the marker points. For a negative marker polarity, the marker signal is high during the period of no marker points.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?]

File Seg/Seq

Allows you to select a segment (seg) or sequence (seq) file from the non-volatile memory (NVWFM).

Waveform segments or sequences can only be selected if they are loaded in non-volatile memory.

Key Path: Source

File Load/Store

Allows the user to transfer files from volatile memory (WFM1) to non-volatile memory (NVWF1) or vice versa.

When copying a waveform file from volatile to non- volatile memory, the marker file and file header, associated with the waveform file, will automatically be copied at the same time.

Key Path: Source

SCPI Command: SOURce:MMEMory:COPY

Store Segment To Int Media

Allows you to transfer files from non-volatile memory (NVWF1) to volatile memory (WFM1).

Key Path: Source

Load Segment From Int Media

Allows you to transfer files from volatile memory (WFM1) to non-volatile memory (NVWF1).

Key Path: Source

Store All To Int Media

Allows you to transfer all files from non-volatile memory (NVWF1) to volatile memory (WFM1).

Key Path: Source

Load All From Int Media

Front panel access key allows the user to transfer all files from volatile memory (WFM1) to non-volatile memory (NVWF1).

Key Path: Source

Delete Segment

Allows you to delete files from volatile memory (WFM1) or non-volatile memory (NVWF1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete[:NAME]

Delete All Seg From BBG Mem

Clears the user file system of all arbitrary waveform files stored in volatile memory (WFM1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete:WFM

Delete All Seg From Int Mem

Clears the user file system of all arbitrary waveform files stored in non-volatile memory (NVWFM1).

Key Path: Source

SCPI Command: SOURce:MMEMory:DELete:NVWFm

Refresh List

Refreshes list of file system showing all arbitrary waveform files stored in non-volatile (NVWFM1) and volatile (WFM1) memory.

Key Path: Source

Delete Sequence

Allows the user to delete sequences from memory.

Key Path: Source

ARB On/Off

Enables or disables the arbitrary waveform generator function.

Although you can configure and engage a CW output, no modulation is available at the RF OUTPUT connector until this command is executed.

Key Path: Source

SCPI Command: SOURce:RADio:ARB[:STATe][?]

ARB Sample Rate

This command adjusts the sample clock rate.

SCPI Command: SOURce:RADio:ARB:CLOCk:SRATe[?]

ARB Runtime Scaling

This command adjusts the scaling value in percent that is applied to a waveform while it is playing. The variable <value> is expressed as a percentage. Runtime scaling does not alter the waveform data file. This feature is used to avoid DAC overflow. The scaling is compensated for at the modulator (that is, when the modulator is the optimized path).

Key Path: Source

SCPI Command: SOURce:RADio:ARB:RSCaling[?]

Trigger Type

This command sets the trigger mode (type) that controls the waveform&rsquo;s playback.

Triggers control the playback by telling the test set when to play the modulating signal (waveform). Depending on the trigger settings for the test set, the waveform playback can occur once, or continuously.

A trigger signal comprises both positive and negative signal transitions (states), which are also called high and low periods. You can configure the test set to trigger on either state of the trigger signal. It is common to have multiple triggers, also referred to as trigger occurrences or events, occur when the signal generator requires only a single trigger. In this situation, the test set recognizes the first trigger and ignores the rest.

When you select a trigger mode, you may lose the signal (carrier plus modulating) from the RF output until you trigger the waveform. This is because the instrument sets the I and Q signals to zero volts prior to the first trigger event, which suppresses the carrier. After the first trigger event, the waveform&rsquo;s final I and Q levels determine whether you will see the carrier signal or not (zero = no carrier, other values = carrier visible). At the end of most files, the final I and Q points are set to a value other than zero.

There are four parts to configuring the trigger:

  • Choosing the trigger type, which controls the waveform&rsquo;s transmission.

  • Setting the waveform&rsquo;s response to triggers:

  • CONTinuous

  • SINGle

  • Selecting the trigger source (see TRIGger[:SOURce]), which determines how the test set receives its trigger signal, internally or externally.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:TRIGger:TYPE[?]

Trigger Source

This command sets the trigger source.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:TRIGger[:SOURce][?]

Marker Routing

Opens a menu with marker routing options.

Pulse/RF Blank

Enables or disables the marker pulse/RF blanking function for the selected marker.

This function automatically uses the ALC hold function, so there is no need to select both the ALC hold and pulse/RF blanking functions for the same marker.

The pulse function incorporates ALC hold. Incorrect automatic level control (ALC) sampling can create a sudden unleveled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Key Path: Source

SCPI Command: SOURce:RADio:ARB:MDEStination:PULSe[?]

ALC Hold

Enables or disables the marker ALC hold function for the selected marker.

Use the ALC hold function when you have a waveform signal that incorporates idle periods, or when the increased dynamic range encountered with RF blanking is not desired. The ALC leveling circuitry responds to the marker signal during the marker pulse (marker signal high), averaging the modulated signal level during this period.

The ALC hold function operates during the low periods of the marker signal. The marker polarity determines when the marker signal is high. For a positive polarity, this is during the marker points. For a negative polarity, this is when there are no marker points. For setting a marker&rsquo;s polarity, see SOURce:RADio:ARB:MPOLarity:MARKer[1]|2|3|4[?].

Incorrect automatic level control (ALC) sampling can create a sudden unlevelled condition that may create a spike in the RF output potentially damaging a DUT or connected instrument. Ensure that you set markers to let the ALC sample over an amplitude that accounts for the high power levels within the signal.

Set Markers

Accesses a menu with ARB marker options.

Key Path: Source, Set Markers

Marker

Sets the active ARB marker.

Key Path: Source, Set Markers

SCPI Command: SOURce:RADio:ARB:MARKer[:SET]

Set Marker On Points Range

Sets a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4). The AWG and all of the ARB formats use this command.

The test set provides four independent markers. Two of the markers route output signals to rear- panel event connectors, Marker- 1 to Event1 BNC and Marker- 2 to Aux I/O. A marker consists of marker points placed at defined sample points in a waveform segment. This means that a marker point cannot be less than one or greater than the last sample point in the waveform. Marker points are cumulative, so multiple command executions with different range values, without first clearing the existing points, places additional marker points on the waveform. Because of this cumulative behaviour, it is a good practice to clear existing marker points prior to setting new points. This will eliminate unexpected marker pulses. Refer to &rdquor;:MARKer:CLEar&rdquo; and &rdquor;:MARKer:CLEar:ALL&rdquo; for information on clearing marker points.

For waveforms generated on the test set (baseband generator), the test set automatically places a marker point at the first waveform sample for markers one and two.

NOTE If using the front panel, once <first_point>,<last_point> and <skip_count> have been defined the user must press the &rdquor;Apply To Waveform&rdquo; soft key.

NOTE You can set markers for either positive or negative polarity. The following discussions for this command assume positive marker polarity. When using negative marker polarity, the marker pulses occur during the periods of no marker points.

There are three ways to place marker points using this command:

  • consecutive marker points over a range that collectively create a single marker pulse that spansthe range

  • equally spaced marker points over a range, so that a marker pulse occurs at each sample point that coincides with a marker point (Using this method, you can configure a clock signal by setting the <skip_count> variable to one.)

  • a single marker point placed at a specific sample point in the waveform, which outputs a single pulse relative to the marker point location (To configure a single marker point, set the first and last points to the same number.)

The following list describes the command variables:

  • "<file_name>" This variable specifies the name of the waveform file in volatile waveform memory (WFM1).

  • <marker> This variable selects the marker number; an integer value from one to four.

  • <first_point> This variable defines the first point in the range over which the marker is placed. This number must be greater than or equal to one, and less than or equal to the total number of waveform points.

If you enter a value for either the first marker point or the last marker point that would make the first marker point occur after the last, the last marker point is automatically adjusted to match the first marker point.

  • <last_point> This variable defines the last point in the range over which the marker will be placed. This value must be greater than or equal to the first point, and less than or equal to the total number of waveform points.

  • <skip_count> This variable defines the marker point pattern across the range. A zero value means the marker points occur consecutively across the range. A value greater than zero creates a repeating marker point pattern across the range, where the gap between the marker points is equal to the <skip_count> value. The gaps begin after the first marker point. Each marker point in the pattern, which is only one point wide, produces a marker pulse.

SOURce:RADio:ARB:MARKer[:SET]

Set Marker Off Points Range

Clears a single marker point or a range of marker points on a waveform segment for the selected marker (1&endash;4).

The AWG and all of the ARB modulation formats use this setting.

Key Path: Source, Set Markers

SCPI Command: SOURce:RADio:ARB:MARKer:CLEar

IQ Calibration

Accesses a menu with calibration options.

Execute Cal

Performs an IQ calibration according to the IQ calibration type.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration[:USER]

Calibration Type

Sets the IQ calibration type.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:TYPE[?]

Start Frequency

Sets the start frequency and automatically sets the calibration type to User for an I/Q calibration.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:START[?]

Stop Frequency

Sets the stop frequency and automatically sets the calibration type to User for an I/Q calibration.

Key Path: Source, IQ Calibration

SCPI Command: SOURce:CALibration:IQ:STOP[?]


802.16 OFDM (N6301A)

MARKER Functions

Last Updated: March 28, 2008

Marker

Some Marker operation is common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Marker key accesses the Marker menu. A marker can be placed on a trace to allow the value of the trace at the marker point to be determined precisely. The functions in this menu include a 1-of-N selection of the control mode Normal, Delta, Fixed, or Off for the selected marker. If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules.

Markers may also be used in pairs to read the difference (or delta) between two data points. They can be used in Marker Functions to do advanced data processing, or to specify operating points in functions like Signal Track and N dB Points.

Marker Fctn

Some Marker Functions are common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

The Marker Function key opens up a menu of keys that allow you to control the Marker Functions of the instrument. Marker Functions perform post-processing operations on marker data. Band Functions are Marker Functions that allow you to define a band of frequencies around the marker. The band defines the region of data used for the numerical calculations. These marker functions also allow you to perform mathematical calculations on trace and marker data and report the results of these calculations in place of the normal marker result.

Unlike regular markers, marker function markers are not placed directly on the trace. They are placed at a location which is relative to the result of the function calculation.

Marker To

Some Marker operation is common across multiple Modes and Measurements. These common features are described in this section. See the Measurement description for information on features that are unique.

Peak Search

Pressing the Peak Search key displays the Peak Search menu and places the selected marker on the trace point with the maximum y-axis value for that marker's trace. The Peak Search features allow you to define specific search criteria to determine which signals can be considered peaks, excluding unwanted signals from the search.

If Same as "Next Peak" Criteria is selected, and either Pk Excursion or Pk Threshold are on, a signal must meet those criteria. If no valid peak is found, a message is generated and the marker is not moved. When Highest Peak is on, or both Pk Excursion and Pk Threshold are off, the marker is always placed at the point on the trace with the maximum y-axis value, even if that point is on the very edge of the trace (exception: negative frequencies and signals close to the LO are not searched at all).

Pressing Peak Search with the selected marker off causes the selected marker to be set to Normal at the center of the screen, then a peak search is immediately performed.


802.16 OFDM (N6301A)

MEASUREMENT Functions

Last Updated: March 28, 2008

Some of the content described in this section is not directly applicable to the 802.16 OFDMA Mode. This is common test set functionality information that can be used as reference material. It provides additional information about some of the unique features that are available in the measurements in this mode.

For more details, refer to the topics in this section.


802.16 OFDM (N6301A)

Meas

Last Updated: March 28, 2008

The information in this section is common to all measurements. For key and remote command information on each measurement, refer to the section which describes the measurement of interest.

Measurements available under the Meas key are specific to the current Mode.

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.

When viewing Help for measurements, note the following:

You cannot get help for a measurement by pressing one of the measurement softkeys. One way to get help for a measurement is through the Help table of contents, which contains a book for each measurement. To see help for a measurement, click its book in the table of contents. For example, click the “ACP Measurement” book in the table of contents to display help for the ACP measurement.

Operation for some keys differ between measurements. The information displayed in Help
pertains to the current measurement. To see how a key operates in a different measurement, exit Help (press the Cancel Esc key), select the measurement, then reenter Help (press the Help key) and press that key.

Key Path: Front Panel Key

Command Interactions: MEASure, CONFigure, FETCh, INITiate and READ

Each one-button measurement has a group of commands that work together to make the measurement fast, but flexible.

Measurement Group of Commands

Measure Commands

MEASure:<measurement>[n]?

This is a fast single-command way to make a measurement using the factory default test set settings. These are the settings and units that conform to the Mode Setup settings (e.g. radio standard) that you have currently selected.

  • Stops the current measurement (if any) and sets up the test set for the specified measurement using the factory defaults

  • Initiates the data acquisition for the measurement

  • Blocks other SCPI communication, waiting until the measurement is complete before returning results.

  • If the function does averaging, it is turned on and the number of averages is set to 10.

  • After the data is valid it returns the scalar results, or the trace data, for the specified measurement. The type of data returned may be defined by an [n] value that is sent with the command.

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available.

ASCII is the default format for the data output. (Older versions of Spectrum Analysis and Phase Noise mode measurements only use ASCII.) The binary data formats should be used for handling large blocks of data since they are smaller and faster than the ASCII format. Refer to the FORMat:DATA command for more information.

If you need to change some of the measurement parameters from the factory default settings you can set up the measurement with the CONFigure command. Use the commands in the SENSe:<measurement> and CALCulate:<measurement> subsystems to change the settings. Then you can use the READ? command to initiate the measurement and query the results.

If you need to repeatedly make a given measurement with settings other than the factory defaults, you can use the commands in the SENSe:<measurement> and CALCulate:<measurement> subsystems to set up the measurement. Then use the READ? command to initiate the measurement and query results.

Measurement settings persist if you initiate a different measurement and then return to a previous one. Use READ:<measurement>? if you want to use those persistent settings. If you want to go back to the default settings, use MEASure:<measurement>?.

Configure Commands

CONFigure:<measurement>

This command stops the current measurement (if any) and sets up the test set for the specified measurement using the factory default test set settings. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON. If you change any measurement settings after using the CONFigure command, the READ command can be used to initiate a measurement without changing the settings back to their defaults. In the Swept SA measurement in Spectrum Analyzer mode the CONFigure command also turns the averaging function on and sets the number of averages to 10 for all measurements.

:CONFigure:NDEFault<measurement> stops the current measurement and changes to the specified measurement. It does not change the settings to the defaults. It does not initiate the taking of measurement data unless INIT:CONTinuous is ON.

The CONFigure? query returns the current measurement name.

Fetch Commands

FETCh:<measurement>[n]?

This command puts selected data from the most recent measurement into the output buffer. Use FETCh if you have already made a good measurement and you want to return several types of data (different [n] values, for example, both scalars and trace data) from a single measurement. FETCh saves you the time of re-making the measurement. You can only FETCh results from the measurement that is currently active, it will not change to a different measurement. An error is reported if a measurement other than the current one, is specified. If you need to get new measurement data, use the READ command, which is equivalent to an INITiate followed by a FETCh.

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available. The binary data formats should be used for handling large blocks of data since they are smaller and transfer faster then the ASCII format. (FORMat:DATA) FETCh may be used to return results other than those specified with the original READ or MEASure command that you sent.

INITiate Commands

INITiate:<measurement>

This command is not available for measurements in all the test set modes:

  • Initiates a trigger cycle for the specified measurement, but does not output any data. You must then use the FETCh<meas> command to return data. If a measurement other than the current one is specified, the test set will switch to that measurement and then initiate it.

For example, suppose you have previously initiated the ACP measurement, but now you are running the channel power measurement. If you send INIT:ACP? it will change from channel power to ACP and will initiate an ACP measurement.

  • Does not change any of the measurement settings. For example, if you have previously started the ACP measurement and you send INIT:ACP? it will initiate a new ACP measurement using the same test set settings as the last time ACP was run.

  • If your selected measurement is currently active (in the idle state) it triggers the measurement, assuming the trigger conditions are met. Then it completes one trigger cycle. Depending upon the measurement and the number of averages, there may be multiple data acquisitions, with multiple trigger events, for one full trigger cycle. It also holds off additional commands on GPIB until the acquisition is complete.

READ Commands

READ:<measurement>[n]?

  • Does not preset the measurement to the factory default settings. For example, if you have previously initiated the ACP measurement and you send READ:ACP? it will initiate a new measurement using the same test set settings.

  • Initiates the measurement and puts valid data into the output buffer. If a measurement other than the current one is specified, the test set will switch to that measurement before it initiates the measurement and returns results.

For example, suppose you have previously initiated the ACP measurement, but now you are running the channel power measurement. Then you send READ:ACP? It will change from channel power back to ACP and, using the previous ACP settings, will initiate the measurement and return results.

Blocks other SCPI communication, waiting until the measurement is complete before returning the results:

If the optional [n] value is not included, or is set to 1, the scalar measurement results will be returned. If the [n] value is set to a value other than 1, the selected trace data results will be returned. See each command for details of what types of scalar results or trace data results are available. The binary data formats should be used when handling large blocks of data since they are smaller and faster then the ASCII format. (FORMat:DATA)

Note: It is recommended that READ is not used for measurements where there is an RF Burst trigger that may not be correctly generated (for example, if the Device Under Test fails). Where an RF Burst trigger is used, it is recommended that INIT and FETCh is used, as described above.


802.16 OFDM (N6301A)

Meas Setup

Last Updated: March 28, 2008

Meas Control features are unique to each Measurement. See the specific Measurement for more information.

Key Path: Front panel key


802.16 OFDM (N6301A)

Mode

Last Updated: March 28, 2008

The Mode key allows you to select the available measurement applications. The application software must be loaded and licensed for it to be available. Measurement applications are a collection of measurement capabilities packaged together to provide an test set personality that is specific to your measurement needs. Each mode software product is ordered separately by Model Number. The default measurement mode is the first listing in the menu.

Key operation can be different between modes. The information displayed in Help is about the current mode.

To access Help for a different Mode you must first exit Help (by pressing the Cancel (Esc) key). Then select the desired mode and re-access Help.

A list of the valid mode choices is returned with the INST:CAT? Query. Once a test set mode is selected, only the commands that are valid for that mode can be executed.

Key Path: Front panel key

SCPI Commands: INSTrument:CATalog?, INSTrument:DEFault, INSTrument:NSELect[?], INSTrument[:SELect][?], SYSTem:APPLication:CATalog[:NAME]?, SYSTem:APPLication:CATalog[:NAME]:COUNt?, SYSTem:APPLication:CATalog:OPTion?, SYSTem:APPLication:CATalog:REVision?, SYSTem:APPLication[:CURRent][:NAME]?, SYSTem:APPLication[:CURRent]:OPTion?, SYSTem:APPLication[:CURRent]:REVision?


802.16 OFDM (N6301A)

Mode Setup

Last Updated: March 28, 2008

Key Path: Front panel

Radio Device

Allows you to specify the device to be used. Radio device BTS is called BS in the WiMAX-OFDMA mode. BS is used in
front panel and BTS is used for the remote command.

Key Path: Mode Setup

SCPI Command: [:SENSe]:RADio:STANdard:DEVice[?]

Radio Standard

The following standards for WiMAX are supported:

  • IEEE 802.16e––2005

  • WiBro (Korean mobile WiMAX-OFDMA service

Key Path: Mode Setup

SCPI Command: [:SENSe]:RADio:STANdard[?]

Preset Profile

802.16e––2005 mode

Key Path: Mode Setup, Radio Std, 802.16e––2005

SCPI Command: [:SENSe]:RADio:STANdard:Y05[:PROFile][?]

WiBro mode

Key Path: Mode Setup, Radio Std, WiBro

SCPI Command: [:SENSe]:RADio:STANdard:WIBRo[:PROFile][?]

FFT Size

OFDMA supports a scalable frame structure where the FFT size scales with bandwidth to keep subcarrier spacing fixed. Four FFT &rdquor;NFFT&rdquo; sizes are specified by the OFDMA standard: 128, 512, 1024 and 2048.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:NFFT[?]

BW Ratio

BW Ratio is defined as the ratio between the OFDMA FFT sample rate and the nominal channel bandwidth. The 802.16 Standard specifies that the BW Ratio be set to 8/7 or 28/25 depending on the nominal bandwidth of the test signal.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:BANDwidth[:CONFigure]:BWRatio[?]

Guard Interval

IEEE 802.16 OFDMA supports multiple Guard Interval implementations. Each measurement changes its defaults according to the selected standard or device, if necessary.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:GINTerval:RATio[?]

Frame Duration

The Frame Duration parameter specifies OFDMA frame duration in units of time.

You can use the Radio Standard or Radio Device preset to set the Frame Duration to a value specified in the OFDMA standard or you can specify an arbitrary value manually in the Frame Duration parameter.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:FDURation[?]

Downlink Ratio

Downlink Ratio, expressed as a percentage, is the ratio of the downlink subframe length (including the TTG) to the frame length. Downlink Ratio defines where the uplink subframe starts relative to the start of the frame. A 30% Downlink Ratio means that 30% of the frame length is downlink subframe and 70% is uplink subframe.

Key Path: Mode Setup, Radio Std

SCPI Command: [:SENSe]:RADio:STANdard:DRATio[?]


802.16 OFDM (N6301A)

Restart

Last Updated: March 28, 2008

The Restart function restarts the current sweep, or measurement, or set of averaged/held sweeps or measurements.

The Restart function is accessed in several ways:

  • Pressing the Restart key

  • Sending the remote command INIT:IMMediate

  • Sending the remote command INIT:RESTart

The Restart function first aborts the current sweep/measurement as quickly as possible. It then resets the sweep and trigger systems, sets up the measurement and initiates a new data measurement sequence with a new data acquisition (sweep) taken once the trigger condition is met.

If the analyzer is in the process of aligning when Restart is executed, the alignment finishes before the restart function is performed.

Even when set for Single operation, multiple sweeps may be taken when Restart is pressed (for example, when averaging/holding is on). Thus when we say that Restart "restarts a measurement," we may mean:

  • It restarts the current sweep

  • It restarts the current measurement

  • It restarts the current set of sweeps if any trace is in Trace Average, Max Hold or Min Hold

  • It restarts the current set of measurements if Averaging, or Max Hold, or Min Hold is on for the measurement depending on the current settings.

With Average/Hold Number (in Meas Setup menu) set to 1, or Averaging off, or no trace in Trace Average or Hold, a single sweep is equivalent to a single measurement. A single sweep is taken after the trigger condition is met; and the analyzer stops sweeping once that sweep has completed. However, with Average/Hold Number >1 and at least one trace set to Trace Average, Max Hold, or Min Hold (SA Measurement) or Averaging on (most other measurements), multiple sweeps/data acquisitions are taken for a single measurement. The trigger condition must be met prior to each sweep. The sweep is stopped when the average count k equals the number N set for Average/Hold Number . A measurement average usually applies to all traces, marker results, and numeric results; but sometimes it only applies to the numeric results.

Once the full set of sweeps has been taken, the analyzer will go to idle state. To take one more sweep without resetting the average count, increment the average count by 1, by pressing the step up key while Average/Hold Number is the active function, or sending the remote command CALC:AVER:TCON UP.

SCPI Status Bits/OPC Dependencies: This is an Overlapped command. The STATus:OPERation register bits 0 through 8 are cleared.
The STATus:QUEStionable register bit 9 (INTegrity sum) is cleared. The SWEEPING bit is set. The MEASURING bit is set.

SCPI Commands: INITiate[:IMMediate], INITiate:RESTart


802.16 OFDM (N6301A)

Cont (Continuous Measurement/Sweep)

Last Updated: March 28, 2008

Sets the test set for Continuous measurement operation. The single/continuous state is Meas Global so the setting will affect all measurements.

Key Path: Front panel key

SCPI Command: INITiate:CONTinuous[?]

With Avg Number (in Meas Setup menu) set to Off or set to On with a value of 1, a sweep is taken after the trigger condition is met; and the test set continues to take new sweeps after the current sweep has completed and the trigger condition is again met. However, with Avg Number set to On with a value >1, multiple sweeps (data acquisitions) are taken for the measurement. The trigger condition must be met prior to each sweep. The sweep is not stopped when the average count k equals the number N set for Avg Number is reached, but the number k stops incrementing. A measurement average usually applies to all traces, marker results, and numeric results. But sometimes it only applies to the numeric results.

If the test set is in Single measurement, pressing the Continuous key does not change k and does not cause the sweep to be reset; the only action is to put the test set into Continuous measurement operation.

If it's already in continuous sweep:

  • the INIT:CONT 1 command has no effect

  • the INIT:CONT 0 command will place the test set in Single Sweep but will have no effect on the current sequence until k=N, at which point the current sequence will stop and the test set will go to the idle state.


802.16 OFDM (N6301A)

Single (Single Measurement/Sweep)

Last Updated: March 28, 2008

This section describes the keys in the Sweep, Control and Capture menu that are common to multiple Modes and Measurements. See the Measurement descriptions for information on features that are unique.

The Meas Uncal (measurement uncalibrated) warning is given in the Status Bar in
the lower right corner of the screen when the manual sweep time entered is shorter
than what is computed by the test set.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Front panel key

SCPI Commands: INITiate:PAUSe, INITiate:RESume


802.16 OFDM (N6301A)

Sweep/Control

Last Updated: March 28, 2008

This section describes the keys in the Sweep, Control and Capture menu that are common to multiple Modes and Measurements. See the Measurement descriptions for information on features that are unique.

The Meas Uncal (measurement uncalibrated) warning is given in the Status Bar in
the lower right corner of the screen when the manual sweep time entered is shorter
than what is computed by the test set.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Front panel key

SCPI Commands: INITiate:PAUSe, INITiate:RESume


802.16 OFDM (N6301A)

Trigger

Last Updated: March 28, 2008

The Trig front panel key accesses the Trigger menu which contains keys to control the selection of the Trigger source and settings.

The Trigger settings are common for all Measurements and these features are described in this section. The selection of the Trigger Source is unique for each Measurement. See the measurement description for information on trigger source and any other unique features.

The trigger functions let you select the trigger settings for a sweep or measurement. When using a trigger source other than Free Run, the test set will begin a sweep only with the selected trigger conditions are met. A trigger event is defined as the point at which your trigger source signal meets the specified trigger level and polarity requirements (if any). In FFT measurements, the trigger controls when the data is acquired for FFT conversion.

For each source in the Trigger menu, a setup menu exists which can be accessed by pressing the key for that trigger source a second time. For example, one press of Video selects the Video trigger as the source. The Video key becomes highlighted and the hollow arrow on the key turns black. Now a second press of the key takes you into the Video Trigger Setup menu. The setup menus (there is one for each trigger source) allow you to set all of the settings for that trigger source as desired. Each source's trigger settings (for example, level, delay and slope) are the same for the Trigger menu, the Gate Source menu, and the Sync Source menu that is part of the Periodic Timer Trigger Setup menu. That is, if Ext1 trigger level is set to 1 v in the Trigger menu, it will appear as 1 v in both the Gate Source and the Sync Source menus. For this reason, the only SCPI node that exists for the settings is the TRIGger[:SEQuence] menu.

The trigger settings are common to all applications (modes). However, each application may have its own ranges and default value settings. Also, some applications may have trigger features that are unavailable because they don't make sense for that particular application.

The trigger source is uniquely selected for each measurement in the application. The trigger source setting is the only trigger parameter that is meas local, applying only to the current measurement.

Key Path: Front-panel key

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

SCPI Status Bits/OPC Dependencies: The Status Operation Register bit 5 &rdquor;Waiting for Trigger&rdquo; is set at the same time as the Sweeping or Measuring bit is set. It is cleared when the trigger actually occurs (that is, after the trigger event occurs and all the applicable trigger criteria have been met).

Trigger Setup Parameters

The following examples show trigger setup parameters using an external trigger source.

Example 1 illustrates the trigger conditions with negative slope and no trigger occurs during trigger Holdoff time.

Example 2 illustrates the trigger conditions with positive slope, trigger delay, and auto trigger time.

Free Run

Pressing this key, when it is not selected, selects free-run triggering. Free run triggering occurs immediately after the sweep/measurement is initiated.

Key Path: Trigger, Free Run

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

External

Pressing this key, when it is not selected, selects an external input signal as the trigger. A new sweep/measurement will start when the external trigger condition is met using the ANALYZER TRIG IN connector on the rear panel.

Pressing this key, when it is already selected, accesses the external trigger setup menu.

Key Path: Trigger, External

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

RF Burst (Wideband)

Pressing this key, when it is not selected, selects the RF Burst as the trigger. A new sweep/measurement will start when an RF burst envelope signal is identified from the signal at the RF Input connector. Pressing this key, when it is already selected, accesses the RF Burst trigger setup menu.

Key Path: Trigger, RF Burst (Wideband)

SCPI Commands: TRIGger:EVM[:SEQuence]:SOURce[?], TRIGger:PSTatistic[:SEQuence]:SOURce[?], TRIGger:SMASk[:SEQuence]:SOURce[?], TRIGger:WAVeform[:SEQuence]:SOURce[?]

Trigger Level

Sets the absolute trigger level for the RF burst envelope. See key notes regarding the relative trigger level.

Key Path: Trigger, RF Burst (Wideband), Trigger Level

SCPI Command: TRIGger[:SEQuence]:RFBurst:LEVel:ABSolute[?]

Trigger Slope

It is set positive to trigger on a rising edge and negative to trigger on a falling edge.

Key Path: Trigger, RF Burst (Wideband), Trig Slope

SCPI Command: TRIGger[:SEQuence]:RFBurst:SLOPe[?]

Trig Delay

Controls a time delay during which the test set will wait to begin a sweep after meeting the trigger criteria. You can use negative delay to pre-trigger the test set in time domain or FFT, but not in swept spans.

Key Path: Trigger, RF Burst (Wideband), Trig Delay

SCPI Commands: TRIGger[:SEQuence]:RFBurst:DELay[?], TRIGger[:SEQuence]:RFBurst:DELay:STATe[?]

Trig Holdoff

Sets the holdoff time between triggers. When the trigger condition is satisfied, the trigger occurs, the delay begins, and the holdoff time begins. New trigger conditions will be ignored until the holdoff time expires. For a free-running trigger, the holdoff value is the minimum time between triggers.

Key Path: Trigger, Trig Holdoff

SCPI Commands: TRIGger[:SEQuence]:HOLDoff[?], TRIGger[:SEQuence]:HOLDoff:STATe[?]


802.16 OFDM (N6301A)

Power Stat CCDF Measurement

Last Updated: March 28, 2008

Many of the digitally modulated signals now look noise-like in the time and frequency domain. This means that statistical measurements of the signals can be a useful characterization. Power Complementary Cumulative Distribution Function (CCDF) curves characterize the higher level power statistics of a digitally modulated signal. The curves can be useful in determining design parameters for digital communications systems.

The power statistics CCDF measurement can be affected by many factors. For example, modulation filtering, modulation format, combining the multiple signals at different frequencies, number of active codes, and correlation between symbols on different codes with spread spectrum systems will all affect measurement results. These factors are all related to modulation and signal parameters. External factors such as signal compression and expansion by nonlinear components, group delay distortion from filtering, and power control within the observation interval also affect the measurement.

The power measured in power statistics CCDF curves is actually instantaneous envelope power defined by the equation:

P = (I + Q) / Zo

(Where I & Q are the quadrature voltage components of the waveform and Zo is the characteristic impedance).

A CCDF curve is defined by how much time the waveform spends at or above a given power level. The percent of time the signal spends at or above the level defines the probability for that particular power level. For capturing a lower probability down to 0.0001%, this measurement is made in the single mode by pressing Single. To make the power statistics CCDF measurement, the test set uses digital signal processing (DSP) to sample the input signal in the channel bandwidth. The Gaussian distribution line as the band-limited Gaussian noise CCDF reference line, the user-definable reference trace, and the currently measured trace can be displayed on a semi-log graph. If the currently measured trace is above the user reference trace, it means that the higher peak power levels against the average power are included in the input signal.

Key Path: Meas

SCPI Commands: [:SENSe]:PSTatistic, CONFigure:PSTatistic, CONFigure:PSTatistic:NDEFault, INITiate:PSTatistic, FETCh:PSTatistic{0:4}?, MEASure:PSTatistic{0:4}?, READ:PSTatistic{0:4}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDM (N6301A)

Measurement Results and Views

Last Updated: March 28, 2008

The Power Stat CCDF measurement consists of single view. This is common for both Uplink (MS) and Downlink (BTS). There are two windows, Metrics (left) and graph display (right).

Graph window

Marker Operation: Yes

Corresponding Trace:

  • Yellow: Series of 5001 floating the current measured power stat trace. (n=2) Initially all markers refer this trace.

  • Light Blue: Series of 5001 floating point numbers (in percent) that represent the Gaussian trace. (n=3)

  • Violet: series of 5001 floating point numbers (in percent) that represent the user-definable reference trace. (n=4)

The Gaussian and Reference trace/line can be removed using the features under the Trace/Detector key

Metrics window

Name | Corresponding Results | Explanation
Average Power [dBm] | n=1 1st Average input power | 99.99 dBm
Average Power [%] | n=1 2nd Probability at the average input power leve | 99.99 %
10.0% [dB] | n=1 3rd Power level that has 10% of the power | 99.99 dB
1.0% [dB] | n=1 4th Power level that has 1% of the power | 99.99 dB
0.1% [dB] | n=1 5th Power level that has 0.1% of the power | 99.99 dB
0.01% [dB] | n=1 6th Power level that has 0.01% of the power | 99.99 dB
0.001% [dB] | n=1 7th Power level that has 0.001% of the power | 99.99 dB
Peak [dB] | n=1 9th Peak power | 99.99 dB
Peak[dBm] | This is not available using remote commands. | 99.99 dBm


802.16 OFDM (N6301A)

Spen X Scale

Last Updated: March 28, 2008

The SPAN X Scale key accesses the menu to set the desired horizontal scale.

Key Path: Front-panel key

Scale/Div

Enables you to enter a time value to change the horizontal scale.

Key Path: Front-panel key


802.16 OFDM (N6301A)

AMPTD Y Scale

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to set the vertical scale parameters. The parameter values are measurement independent except all Attenuation values, and the Internal Preamp selection that are the same across all measurements.

Key Path: Front panel key

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]


802.16 OFDM (N6301A)

View/Display

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to control the test set display as well as turn the bar graph On and Off.

Key Path: Front-panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see View/Display under ANALYZER SETUP Functions for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see View/Display under ANALYZER SETUP Functions for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title


802.16 OFDM (N6301A)

Trace/Detector

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to control the storage and manipulation of the reference trace, as well as controls the display of the trace data.

Key Path: Front panel key

Store Ref Trace

Copies the currently measured curve as the user-definable reference trace. The captured data will remain until the other mode is chosen. Pressing this key also refreshes the reference trace.

Key Path: Trace/Detector

SCPI Command: CALCulate:PSTatistic:STORe:REFerence

Ref Trace

Toggles the reference trace display between On and Off.

Key Path: Trace/Detector

SCPI Command: [:SENSe]:PSTatistic:RTRace[:STATe][?]

Gaussian Line

Toggles the Gaussian trace display between On and Off.

Key Path: Trace/Detector

SCPI Command: [:SENSe]:PSTatistic:GAUSsian[:STATe][?]


BW

802.16 OFDM (N6301A)


802.16 OFDM (N6301A)

Sweep/Control

Last Updated: March 28, 2008

Enables you to pause the power statistics CCDF measurement after the current data acquisition is complete. When Paused, the label on the menu key changes to Resume. Press the Resume key to resume the measurement where it was when it was paused.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete. When Paused, the label on the key changes to Resume. Press the Resume key to resume the measurement where it was when it was paused.

Key Path: Sweep/Control


802.16 OFDM (N6301A)

Meas Setup

Last Updated: March 28, 2008

Accesses the functions that allow you to change the settings for your measurement requirements.

Key Path: Front panel key

Counts

Sets the accumulated number of sampling points for data acquisition. The range is 1.000 kpt (k point) to
2.00000 Gpt (G point) with 1 kpt resolution. Counts couples to Meas Cycles. When the value for counts is changed, the Meas Cycles value will be (Counts / SamplingFrequency * MeasInterval).

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:COUNts[?]

Meas Cycles

Set the number of measurement cycles to calculate power statistic data. This number couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

When the counts value cannot be divided by (Sampling Frequency * MeasInterval), this value is displayed as a decimal fraction.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:SWEep:CYCLes[?]

Meas Interval

Sets the number of data points to be used as the measurement interval. This value couples to Counts. The Counts value is (MeasCycles * Sampling Frequency * MeasInterval).

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:SWEep:TIME[?]

IF Gain

Sets the IF Gain function to Auto, Low Gain or High Gain. These settings affect sensitivity and IF overloads.

Key Path: Meas Setup

IF Gain Auto

Activates the Auto Rules for IF Gain When Auto is active, the IF Gain is set to High Gain under any of the following conditions:

  • the input attenuator is set to 0 dB

  • the preamp is turned On

  • the Max Mixer Level is 20 dBm or lower

For other settings, Auto sets the IF Gain to Off.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:IF:GAIN:AUTO[:STATe][?]

IF Gain State

Selects the range of IF gain. On sets the high gain option, which allows for better noise level measurements and Off sets low gain when measuring large signals.

Key Path: Meas Setup

SCPI Command: [:SENSe]:PSTatistic:IF:GAIN[:STATe][?]

Meas Preset

Restores all measurement settings to their default values.

Key Path: Meas Setup

SCPI Command: CONFigure:PSTatistic


802.16 OFDM (N6301A)

Trigger

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to select and control the trigger source for the current measurement

See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:PSTatistic[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the &rdquor;Measurement Functions&rdquo; section for more information on trigger settings.

Key Path: Trigger


802.16 OFDM (N6301A)

Marker

Last Updated: March 28, 2008

Accesses a menu that enables you to select, set up and control the markers for the current measurement. See the Marker Function section for more information.

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Marker Type

Sets the marker control mode to Normal, Delta, Fixed or Off.

If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

The Active function for the selected marker's current control mode is the default active function. If the current control mode is Off, there is no active function and the active function is turned off. The active function display is the marker X axis value entered in the active function area will display the marker value to its full entered precision.

All interactions and dependencies detailed under the key description are enforced when the remote command is sent.

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses the marker properties menu.

Key Path: Marker

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Relative To

Sets the reference marker that the selected marker will be relative to.

Key Path: Marker, Properties

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Assigns the specified marker to the designated trace. The trace choices are: Measured, Gaussian, or Reference.

Key Path: Marker, Properties

SCPI Command: CALCulate:PSTatistic:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Couple Markers

When this function is true, moving any marker causes an equal X axis movement of every other marker which is not Off. By &rdquor;equal X axis movement&rdquo; we mean that we preserve the difference between each marker's X axis value (in the fundamental x-axis units of the trace that marker is on) and the X axis value of the marker being moved (in the same fundamental x-axis units).

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer:COUPle[:STATe][?]

All Markers Off

Turns off all markers.

Key Path: Marker

SCPI Command: CALCulate:PSTatistic:MARKer:AOFF


802.16 OFDM (N6301A)

Peak Search

Last Updated: March 28, 2008

There is no 'Peak Search' functionality supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


802.16 OFDM (N6301A)

Marker To

Last Updated: March 28, 2008

There is no 'Marker To' functionality supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


802.16 OFDM (N6301A)

Marker Function

Last Updated: March 28, 2008

There are no 'Marker Function' supported in Power Stat CCDF. The front-panel key will display a blank menu when pressed.

Key Path: Front panel key


Spectral Mask Measurement

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


AMPTD Y Scale

802.16 OFDM (N6301A)

AMPTD Y Scale (Spectral Mask)

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to set the vertical scale parameters.

Key Path: Front panel key

Ref Value

Sets the absolute power reference value. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Input Range

Sets the input power range.

Key Path: AMPTD Y Scale

SCPI Command: [:SENSe]:POWer:RANGe[?]

Scale/Div

Sets the units per division of vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Scale/Div (RF Envelope View)

Sets the scale per division for the RF Envelope result waveform (time domain) measurements in the graph window.

Key Path: AMPTD Y Scale

Scale/Div (I/Q Waveform View)

Sets the scale per division for the I/ Q signal waveform graph.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Ref Position (RF Envelope View)

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off. When the Restart front panel key is pressed, this function automatically determines the scale per division and reference values based on the measurement results.

Key Path: AMPTD Y Scale


Meas Setup

802.16 OFDM (N6301A)

Meas Setup (Spectral Mask)

Last Updated: March 28, 2008

Displays the setup menu keys that enable you to control the parameters for the current measurement.

Key Path: Front panel key

Avg/Hold Number

Sets the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Key Path: Meas Setup

Avg Mode

Enables you to set the averaging mode.

When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep.

When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Key Path: Meas Setup

Avg Type

Selects the type of averaging.

Key Path: Meas Setup

Meas Time

Sets how long the measurement is performed. X Scale only changes the representation of the display.

Key Path: Meas Setup

SCPI Command: [:SENSe]:SMASk:SWEep:TIME[?]

Mask

Accesses a menu that allows you to control the mask.

Key Path: Meas Setup

Loss Comp

Allows you to set loss or gain in the test fixture.

Key Path: Meas Setup, Mask

SCPI Command: CALCulate:SMASk:LCOMpensatio[?]

Mask State

Turns the mask on or off.

Key Path: Meas Setup, Mask

SCPI Command: [:SENSe]:SMASk:MASK[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More

SCPI Command: CONFigure:WAVeform


View/Display

802.16 OFDM (N6301A)

View/Display (Spectral Mask)

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to control the test set display as well as turn the bar graph On and Off.

Key Path: Front-panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title


Trigger

802.16 OFDM (N6301A)

Trigger (Spectral Mask)

Last Updated: March 28, 2008

Accesses a menu that allows you to set triggering parameters for the current measurement. See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:SMASk[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the Measurement Functions section for more information on trigger settings.

Key Path: Trigger


Waveform Measurement

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


SPAN X Scale

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


802.16 OFDM (N6301A)

AMPTD Y Scale

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to set the vertical scale parameters.

Key Path: Front panel key

Ref Value

Sets the absolute power reference value. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Ref Value (RF Envelope View)

Sets the Y Scale reference value (in dBm) when the RF Envelope View is active. By default, the measurement determines the reference value with Auto Scaling. Entering a reference value manually turns Auto Scaling off.

Key Path: AMPTD Y Scale

Ref Value (I/Q Waveform View)

Sets the Y Scale reference value (in volts) when the I/Q Waveform View is active. By default, the measurement determines the reference value with Auto Scaling. Entering a reference value manually turns Auto Scaling off.

Key Path: AMPTD Y Scale

Scale/Div

Sets the units per division of vertical scale in the logarithmic display. However, since the Auto Scaling is defaulted to On, this value is automatically determined by the measurement result. When you set a value manually, Auto Scaling automatically changes to Off.

Key Path: AMPTD Y Scale

Scale/Div (RF Envelope View)

Sets the scale per division for the RF Envelope result waveform (time domain) measurements in the graph window.

Key Path: AMPTD Y Scale

Scale/Div (I/Q Waveform View)

Sets the scale per division for the I/ Q signal waveform graph.

Key Path: AMPTD Y Scale

Ref Position

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Ref Position (RF Envelope View)

Positions the reference level at the top, center or bottom of the Y Scale display. Changing the reference position does not change the reference level value.

Key Path: AMPTD Y Scale

Auto Scaling

Toggles the Auto Scaling function between On and Off. When the Restart front panel key is pressed, this function automatically determines the scale per division and reference values based on the measurement results.

Key Path: AMPTD Y Scale


View/Display

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


802.16 OFDM (N6301A)

Trace/Detector

Last Updated: March 28, 2008

There is no 'Trace/Detector' functionality supported in the Waveform measurement. The front panel key will display a blank menu key when pressed.


802.16 OFDM (N6301A)

Meas Setup

Last Updated: March 28, 2008

Displays the setup menu keys that enable you to control the parameters for the current measurement.

Key Path: Front panel key

Avg/Hold Number

Sets the number of sweeps (average counts) that will be averaged. After the specified number of sweeps, the averaging mode (terminal control) setting determines the averaging action.

Key Path: Meas Setup

SCPI Commands: [:SENSe]:WAVeform:AVERage:COUNt[?], [:SENSe]:WAVeform:AVERage[:STATe][?]

Avg Mode

Enables you to set the averaging mode.

When set to Exponential (Exp) the measurement averaging continues using the specified number of averages to compute each averaged value. The average will be displayed at the end of each sweep.

When set to Repeat, the measurement resets the average counter each time the specified number of averages is reached.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:AVERage:TCONtrol[?]

Avg Type

Selects the type of averaging.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:AVERage:TYPE[?]

Meas Time

Sets how long the measurement is performed. X Scale only changes the representation of the display.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:SWEep:TIME[?]

Power Only

Sets the waveform measurement to only return the power result. This makes the measurement quicker.

Key Path: Meas Setup

SCPI Command: [:SENSe]:WAVeform:PONLy[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More

SCPI Command: CONFigure:WAVeform


802.16 OFDM (N6301A)

Trigger

Last Updated: March 28, 2008

Accesses a menu of functions that enable you to select and control the trigger source for the current measurement

See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:WAVeform[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the Measurement Functions section for more information on trigger settings.

Key Path: Trigger


802.16 OFDM (N6301A)

Sweep/Control

Last Updated: March 28, 2008

Accesses settings that affect the sweep viewed in the display.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Sweep/Control


802.16 OFDM (N6301A)

Marker

Last Updated: March 28, 2008

Accesses a menu that enables you to select, set up and control the markers for the current measurement. See the Marker Function section for more information.

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Marker Type

Sets the marker control mode to Normal, Delta, Fixed or Off.

All interactions and dependencies detailed under the key description are enforced when the remote command is sent. If the selected marker is Off, pressing Marker sets it to Normal and places it at the center of the screen on the trace determined by the Marker Trace rules. At the same time, Marker X Axis Value appears on the Active Function area.

The default active function is the active function for the currently selected marker control mode. If the current control mode is Off, there is no active function and the active function is turned off.

Key Path: Marker

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses a menu that enables you to select the active marker, the reference marker and the trace for the current measurement.

Key Path: Marker

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker

Relative To

Selects the marker the selected marker will be relative to (its reference marker).

Key Path: Marker, Properties

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Assigns the specified marker to the designated trace.

Key Path: Marker, Properties

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

Couple Markers

Toggles the state of the markers to be coupled On or Off. When this function is true (On), moving any marker causes an equal X axis movement of every other marker which is not Off. &rdquor;Equal X axis movement&rdquo; refers to the difference between each marker's X Axis value (in the fundamental x-axis units of the trace that marker is on) and the X Axis value of the marker being moved (in the same fundamental x-axis units) are preserved.

Key Path: Marker, More

SCPI Command: CALCulate:WAVeform:MARKer:COUPle[:STATe][?]

All Markers Off

Turns all markers off.

Key Path: Marker, More

SCPI Command: CALCulate:WAVeform:MARKer:AOFF


802.16 OFDM (N6301A)

Peak Search

Last Updated: March 28, 2008

Min Search

Moves the selected marker to the minimum y-axis value on the current trace.

Key Path: Peak Search

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum


802.16 OFDM (N6301A)

Marker To

Last Updated: March 28, 2008

There is no 'Marker To' functionality supported in Waveform measurements. The front-panel key will display a blank menu key when pressed.


802.16 OFDM (N6301A)

Marker Function

Last Updated: March 28, 2008

Accesses a menu of marker functions that perform post-processing operations on markers based on the measurement specifications. Marker functions are distinct from Measurement functions, which automatically perform complex sequences of setup, data acquisition, and display operations in order to measure specified signal characteristics. Marker Functions are specified for each individual marker and may be turned on individually for each marker.

The Marker Function menu controls which marker functions are turned on and allows you to adjust the setup parameters for each function. These parameters include the following, but only one parameter can be assigned to a given marker:

  • Marker Noise

  • Band/Interval Power

  • Band/Interval Density

  • Marker Function Off

Key Path: Front panel key

Select Marker

Displays the menu keys that enable you to select, set up and control the markers for the current measurement.

Key Path: Marker Function

Marker Function Type

Sets the marker control function type to, Marker Noise, Band/Interval Power, Band Interval Density, or Marker Function Off.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion[?]

Band Adjust

Accesses a menu that enables you to set the frequency span width and the left and right edge, or time values, for the band or interval of the selected marker.

Key Path: Marker Function

Band/Interval Span for Time Domain

Sets the width of the frequency span for the selected marker. Changing the Band/Interval Span necessarily changes the Band/Interval Left and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:SPAN[?]

Band/Interval Left for Time Domain

Sets the left edge frequency or time value for the band of the selected marker. Changing the Band/Interval Left necessarily changes the Band/Interval Span and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:LEFT[?]

Band/Interval Right for Time Domain

Sets the right edge frequency or time value for the band of the selected marker. Changing the Band/Interval Left necessarily changes the Band/Interval Span and Band/Interval Right values.

Key Path: Marker Function

SCPI Command: CALCulate:WAVeform:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:FUNCtion:BAND:RIGHt[?]


802.16 OFDM (N6301A)

OFDM Modulation Analysis Measurement

Last Updated: March 28, 2008

Invokes Modulation Analysis measurement, including Spectrum Flatness measurement.

For more details, refer to the topics in this section.

Key Path: Meas

SCPI Commands: [:SENSe]:EVM, CONFigure:EVM, CONFigure:EVM:NDEFault, INITiate:EVM, FETCh:EVM{0:20}?, MEASure:EVM{0:20}?, READ:EVM{0:20}?

When the trigger type is set to RF burst for a given measurement, the recommended method to initiate the measurement and retrieve the results is as follows:

1. Initiate the measurement using the appropriate INIT:<meas_name> command.

2. Check the STATus:OPERation:CONDition? value and loop until Bit 4 (numeric value 16) is equal to 0.

3. Use the appropriate FETCh:<meas_name>? query to get the result(s)

The above method is recommended because under some conditions, if an RF burst does not occur, the test set may hang up, and a VISA ViClear command will not clear the test set as expected. Using the INIT->FETCh method, rather than READ or MEASure allows the measurement status to be verified before attempting to retrieve the measurement results.


802.16 OFDM (N6301A)

SPAN X Scale

Last Updated: March 28, 2008


802.16 OFDM (N6301A)

AMPTD Y Scale

Last Updated: March 28, 2008

The AMPTD Y Scale key accesses the menus that allows you to set the desired vertical scale and associated settings. The settings available vary depending on the active window focus.

Key Path: Front panel key

Input Range

Allows you to enter the input power range.

Key Path: AMPTD Y Scale, Input Range

SCPI Command: [ :SENSe]:POWer:RANGe[?]


802.16 OFDM (N6301A)

View/Display

Last Updated: March 28, 2008

Accesses a menu that allows you to select from the following measurement view and display settings:
NOTE: the view setting options depend on the measurement view that is active.

  • I/Q Measured Polar Constellation - Provides a combination view of an I/Q Symbol Constellation graph and the summary data.

  • Zone & Data Burst Info –– Provides a combination view of a Zone list table, the selected map graph, and the Data Burst list table.

  • Symbol Error (Quad View) –– Provides a combination view of a Symbol Error vs. Subcarrier graph, Symbol Error vs. Symbol graph, I/Q Symbol Constellation graph, and Zone Definition Map graph.

  • Symbol Power (Quad View) –– Provides a combination view of a Symbol Power vs. Subcarrier graph, Symbol Power vs. Symbol graph, IQ Measured Constellation, and Zone Definition Map graph.

  • Peak/Average Metrics –– Provides a table of the summary for the measurement result and information at the selected burst.

  • Spectral Flatness –– Provides a combination view of a Spectral Flatness graph and a Differential Spectral Flatness graph, and summary data.

  • Power vs Time & Spectrum –– Provides a combination view of a Power vs Time graph and a Power vs. Spectrum graph.

Key Path: Front panel key

Display

Accesses the menu that allows you to set parameters that affect the display. All measurements have identical Display menu functionality for each key in the Display menu.

Key Path: View/Display

Annotation

Turns the screen annotation to On or Off for all windows. Note that softkey annotation will remain in the display. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Graticule

Allows you to set display graticules On and Off. Since this functionality is mode global, see Mode functionality section for details.

Key Path: View/Display

Title

Invokes the Title menu that contains Change Title and Clear Title functions.

Key Path: View/Display

Change Title

Allows you to modify the title. This table is for SCPI definition purpose only and SCPI command and Preset/Default value are defined according to the current measurement.

Clear Title

Allows you to clear a title from the front-panel display. Once cleared, the title cannot be retrieved.

Key Path: View/Display, Display, Title

I/Q Measured Polar Constln

Provides a combination view of an I/Q Symbol Constellation graph and the summary data.

Key Path: View/Display

Zone & Data Burst Info

Provides a combination view of a Zone list table, the selected map graph, and the Data Burst list table.

Key Path: View/Display

Symbol Error (Quad View)

Provides a combination view of a Symbol Error vs. Subcarrier graph, Symbol Error vs. Symbol graph, I/Q Symbol Constellation graph, and Zone Definition Map graph.

Key Path: View/Display

Symbol Power (Quad View)

Provides a combination view of a Symbol Power vs. Subcarrier graph, Symbol Power vs. Symbol graph, IQ Measured Constellation, and Zone Definition Map graph.

Key Path: View/Display

Peak/Average Metrics

Provides a table of the summary for the measurement result and information at the selected burst.

Key Path: View/Display

Spectral Flatness

Provides a combination view of a Spectral Flatness graph and a Differential Spectral Flatness graph, and summary data.

Key Path: View/Display, More

Power vs Time & Spectrum

Provides a combination view of a Power vs Time graph and a Power vs. Spectrum graph.

Key Path: View/Display, More

OBW Line

Allows you to display OBW values and range.

Key Path: View/Display, Power vs Spectrum

Inactive Subchannels in EVM

Lets you include the inactive subchannels in the EVM traces (this only applies to Data Burst Analysis mode). This parameter does not affect the EVM calculation. If this parameter is set to &rdquor;Include&rdquo;, the EVM results will include the EVM value of the Unmodulated subchannels, and I/Q Meas will include the Unmodulated subcarriers' constellation.

Key Path: View/Display, I/Q Measured Polar Contln


802.16 OFDM (N6301A)

Trace/Detector

Last Updated: March 28, 2008

There is no 'Trace/Detector' functionality supported in Modulation Analysis so this front-panel key will display a blank softkey when pressed.

Key Path: Trace Detector


802.16 OFDM (N6301A)

Meas Setup

Last Updated: March 28, 2008

Accesses menus that allow you to set measurement setup parameters.

Key Path: Front panel key

Avg/Hold Num

Set the number of data acquisitions that will be averaged. After the specified number of average counts, the averaging mode setting determines the averaging action.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:AVERage:COUNt[?], [:SENSe]:EVM:AVERage[:STATe][?]

Avg Mode

Selects the type of termination control used for the averaging function. This determines the averaging action after the specified number of data acquisitions (average count) is reached.

When Measure is set at Cont, data acquisitions will continue indefinitely. After N averages, exponential averaging is used with a
weighting factor of N (the displayed average count stops at N). Exponential averaging weights new data more than old data, which
allows tracking of slow-changing signals.

When Measure is set at Cont, data acquisitions will continue indefinitely. After N averages is reached, all previous result data is
cleared and the average count is set back to 1. This is equivalent to being in Measure Single and pressing the Restart key when the
Single measurement finishes.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:AVERage:TCONtrol[?]

Capture Interval

Sets the data capture length in frames that will be used in the acquisition. If Average is set to On, all capture data are analyzed and their results are averaged until the average number count is reached.

Key Path: Meas Setup

SCPI Command: [:SENSe]:EVM:CAPTure:TIME[:FRAMe][?]

Meas Offset

Sets the timing offset of the capture interval in frames. If the Capture Interval is 1 frame, Meas Offset is fixed at &rdquor;0&rdquo;. If Average is set to On, the frame that is analyzed does not take into account this offset value during averaging. After this measurement is complete, changing the offset value will result in running post-processing to analyze the offset frame; the measurement results are then updated (only for non-averaged results).

Key Path: Meas Setup

SCPI Command: CALCulate:EVM:SWEep:OFFSet[?]

Limits

Accesses measurement setup limit parameters.

Key Path: Meas Setup

RMS RCE

Accesses RMS RCE measurement setup limit parameters.

Key Path: Meas Setup, Limits

Limits

Sets the limit state for the RMS EVM measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:STATe[?]

Composite

Sets the limit for RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Commands: CALCulate:EVM:LIMit[1]|2:RRCE[?], CALCulate:EVM:LIMit[1]|2:RRCE:AUTO[?]

QPSK––1/2

Sets the limit of the QPSK coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R1B2[?]

QPSK––3/4

Sets the limit of the QPSK coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QPSK:R3B4[?]

16QAM––1/2

Sets the limit of the 16QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R1B2[?]

16QAM––3/4

Sets the limit of the 16QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA16:R3B4[?]

64QAM––1/2

Sets the limit of the 64QAM coding rate 1/2 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R1B2[?]

64QAM––2/3

Sets the limit of the 64QAM coding rate 2/3 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R2B3[?]

64QAM––3/4

Sets the limit of the 64QAM coding rate 3/4 burst for the RMS RCE measurement pass/fail test.

Key Path: Meas Setup, Limits, RMS RCE, More

SCPI Command: CALCulate:EVM:LIMit[1]|2:RRCE:QA64:R3B4[?]

Peak RCE

Sets the limit for the Peak RCE measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:PRCE[?], CALCulate:EVM:LIMit[1]|2:PRCE:STATe[?]

Pilot RCE

Sets the limit for the Pilot RCE measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:RCEPilot[?], CALCulate:EVM:LIMit[1]|2:RCEPilot:STATe[?]

Frequency Error

Sets the limit in ppm for the absolute Frequency Error measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:FERRor[?], CALCulate:EVM:LIMit[1]|2:FERRor:STATe[?]

Time Offset

Sets the limit for the Time Offset measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:TOFFset[?], CALCulate:EVM:LIMit[1]|2:TOFFset:STATe[?]

I/Q Offset

Sets the limit state for the I/Q Offset measurement pass/fail test.

Key Path: Meas Setup, Limits

SCPI Commands: CALCulate:EVM:LIMit[1]|2:IQOFfset[?], CALCulate:EVM:LIMit[1]|2:IQOFfset:STATe[?]

Abs Spectral Flatness

Accesses menu that allows you to set absolute spectral flatness measurement setup parameters.

Key Path: Meas Setup, Limits, More

Offset

Selects the offset pairs (upper and lower) that the softkeys affect, and displays the memory selection menu from A to F. The memory selection menu allows you to store up to 5 sets of limit values for the offset pairs, such as Start Subcarrier/ Stop Subcarrier, Upper Mask Start/Upper Mask Stop, and Lower Mask Start/Lower. Press Offset until the letter of the desired offset (A, B, C, D, E, or F) is underlined. Only one selection at a time is shown on this softkey label.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

Start Subcarrier

Specifies the start subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STATe[?]

Stop Subcarrier

Allows you to specify the stop subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SUBCarrier:STOP[?]

Offset Side

Specifies which offset side will be measured.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:SIDE[?]

Upper Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STATe[?]

Upper Mask Stop

Sets the upper mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from ––100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, and results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:UPPer:STOP:AUTO[?]

Lower Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STATe[?]

Lower Mask Stop

Sets the lower mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from ––100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Abs Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:ABS:OFFSet:LIST:LOWer:STOP:AUTO[?]

Diff Spectral Flatness

Accesses a menu that allows you to set differential spectral flatness measurement setup parameters.

Key Path: Meas Setup, Limits, More

Offset

Selects the offset pairs (upper and lower) that the selected softkeys will affect, and displays the memory selection menu from A to F. The memory selection menu allows you to store up to 5 sets of limit values for the offset pairs, such as Start Subcarrier, Stop Subcarrier, Upper Mask Start, Upper Mask Stop, Lower Mask Start, Lower Mask Stop and Offset Side. Press Offset until the letter of the desired offset (A, B, C, D, E, or F) is underlined. Only one selection at a time is shown on this softkey label.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

Start Subcarrier

Specifies the start subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STATe[?]

Stop Subcarrier

Allows you to specify the stop subcarrier for the currently selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SUBCarrier:STOP[?]

Offset Side

Specifies which offset side will be measured.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness

SCPI Command: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:SIDE[?]

Upper Mask Start

Sets the upper limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STATe[?]

Upper Mask Stop

Sets the upper mask limit at the stop subcarrier for the selected offset. The upper mask limit ranges from ––100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Upper Mask Stop power level limit is coupled to Upper Mask Start, which results in a flat limit line. If set to Man, Upper Mask Start and Upper Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:UPPer:STOP:AUTO[?]

Lower Mask Start

Sets the lower limit level at the start subcarrier for the selected offset.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STARt[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STATe[?]

Lower Mask Stop

Sets the lower mask limit at the stop subcarrier for the selected offset. The lower mask limit ranges from ––100 to +100 dB. You can also toggle this function between Auto and Man settings. If set to Auto, the Lower Mask Stop power level limit is coupled to Lower Mask Start, which results in a flat limit line. If set to Man, Lower Mask Start and Lower Mask Stop take different values and result in a sloped limit line.

Key Path: Meas Setup, Limits, More, Diff Spectral Flatness, More

SCPI Commands: CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP[?], CALCulate:EVM:LIMit[1]|2:SPECtrum:AMPFlatness:DIFF:OFFSet:LIST:LOWer:STOP:AUTO[?]

Zone/Data Burst Map

Selects the Zone Definition which defines the zone information.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:MAP:SELect:TYPE[?]

Custom Map

This key displays the name of the custom Zone Burst map currently employed by the Modulation Analysis measurement. If you Recall a Zone Burst Map, the file name will appear on the key label.

Key Path: Meas Setup, Zone/Data Burst Map

Change Map Name

Sets the customized Map name.

Key Path: Meas Setup, More, Zone Data Burst Map, Custom Map

SCPI Command: CALCulate:EVM:MAP:CUSTom:NAME[?]

Auto Detect Now

Detects Map information automatically using DL-MAP/UL-MAP and DCD/UCD.

Key Path: Meas Setup, More, Zone Data Burst Map

SCPI Command: CALCulate:EVM:MAP:DETect

Zone Num

Selects the zone definition to be used.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE[?]

Burst Analysis

Selects a method of burst analysis. You can choose between the burst map method or the single burst method.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:BURSt:TYPE[:SELect][?]

Burst Map

Analyzes a frame according to the defined map information.

Key Path: Meas Setup, Data Burst Analysis

Use Defined Boosting Level

Selects whether to automatically set boosting levels, or to use the values that are specified for the bursts.

Key Path: Meas Setup, Data Burst Analysis, Burst Map

SCPI Command: CALCulate:EVM:BURSt[1]|2:POWer:MAP[?]

Single Burst

Accesses single burst parameters.

Key Path: Meas Setup, Data Burst Analysis

Subchan Offset

Set the number of the Subchannel logical offset for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: C ALCulate:EVM:BURSt[1]|2:SUBChannel:OFFSet[?]

Burst Region Subchannel Interval

Set the number of the subchannel logical interval for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SUBChannel:INTerval[?]

Symbol Offset

Set the number of the OFDMA symbol offset for the burst region.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SYMBol:OFFSet[?]

Symbol Interval

Set the number of the OFDMA symbol interval for the burst position.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SYMBol:INTerval[?]

Burst Shape

Selects between wrapped or rectangle burst shapes.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:SHAPe[?]

Data Mod Type

Selects the Data Modulation Type to be used.

Key Path: Meas Setup, More, Burst Analysis, Single Burst

SCPI Command: CALCulate:EVM:BURSt[1]|2:MODulation:TYPE[?]

Uniform Zone

Defines a single burst as a Uniform Zone.

Key Path: Meas Setup, More, Burst Analysis

Data Mod Type

Selects the Data Modulation Type to be used.

Key Path: Meas Setup, More, Burst Analysis, Uniform Zone

SCPI Command: CALCulate:EVM:UZONe[1]|2:MODulation:TYPE[?]

Zone Offset

Allows you to set the Zone Offset in symbols.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE:OFFSet[?]

Zone Interval

Allows you to set Zone Interval in symbols.

Key Path: Meas Setup, More

SCPI Command: CALCulate:EVM:ZONE:INTerval[?]

Data Burst Select

The test set allows single or multiple burst analysis. To select all data burst for analysis, press 'All On' key. To select a single data burst for analysis, press 'Single' key on a selected Data Burst Num. To select multiple data bursts for analysis, turn on a selected Data Burst Num.

Key Path: Meas Setup, More

Data Burst Num

Allows you to select multiple data bursts for analysis when it is set to On.

Key Path: Meas Setup, More, Data Burst Select

SCPI Command: CALCulate:EVM:BURSt[1]|2:STATe[?]

All On

Allows you to select all data burst for analysis.

Key Path: Meas Setup, More, Data Burst Select

Single

Allows you to select a single data burst for analysis.

Key Path: Meas Setup, More, Data Burst Select

Preamble Index

Sets the number that the Preamble Index specifies for the preamble sequence of the downlink subframe. This parameter is available only in BS mode.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:PINDex[?]

Subchannel Group Bitmask

Specifies which subchannel groups are allocated to the segment. The DL PUSC zone definition provides 6 subchannel groups which specify the number of used subchannels and how they are mapped to subcarriers for analysis of DL-PUSC data bursts. This parameter is available only in BS mode.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:SUBChannel:MASK[?]

UL Permbase

Sets the Uplink Permbase number for MS measurement. This parameter is needed to determine subcarrier allocation.

Key Path: Meas Setup, More, More

SCPI Command: CALCulate:EVM:MS:PBASe[?]

Advanced

Accesses advanced features. These features are recommended for use only by advanced users.

Key Path: Meas Setup, More

Pilot in RMS/Pk RCE

Lets you include the Pilot in RCE calculations.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:PILot[?]

Spectrum

Sets a spectrum to either normal or to inverted for demodulation related measurements. If set to INVert, the upper and lower spectrums are swapped.

The invert function conjugates the spectrum, which is equivalent to taking the negative of the quadrature component in demodulation. The correct setting (Normal or Invert) depends on whether the signal at the input of the test set has a high or a low side mix.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:SPECtrum[?]

Symbol Timing Adjust

Symbol Timing Adjust allows you to adjust the &rdquor;useful symbol time period&rdquo; (TFFT) within the &rdquor;OFDMA extended symbol time period&rdquo; (TS). Symbol Timing Adjust shifts the start of the TFFT period to earlier in the TS time period. You specify the amount of TFFT shift as a percentage of the TFFT length.

The extended OFDMA symbol time period (TS) consists of a guard interval (TGI) plus a &rdquor;useful symbol time period&rdquo; (T

FFT). Within the TS, the test set performs the demodulation and data analysis on only one TFFT time period. The Symbol Time Adjust parameter allows you to move the TFFT within the TS.

Typically, the TGI time period is ignored and only the TFFT time period is used. The Symbol Time Adjust parameter causes the demodulation start time to begin earlier within each extended symbol time. The minimum Symbol Time Adjust value is equal to &rdquor;-(guard interval)/100&rdquo;, the maximum value is &rdquor;0&rdquo; (full guard interval).

The Symbol Time Adjust parameter is reset to the default value whenever the Guard Interval is changed. The default value is ––3.125%, if the guard interval is 1/16 or greater. The default value is equal to TGI*100/2 (half the guard interval) when the guard interval is less than 1/16.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:SYMBol:ADJust[?]

Pilot Tracking

802.16 OFDMA performs demodulation relative to the data in pilot carriers embedded in the signal. These pilot carriers replace data-carrying elements of the signal and allow some kinds of impairments to be removed or &rdquor;tracked out&rdquo;.

Many impairments will be common to all pilot carriers and can be measured and displayed as &rdquor;common pilot error&rdquo;.

In addition, several specific tracking functions can be individually switched on and off in the demodulation performed by this measurement. This is a very useful troubleshooting approach, since modulation errors can be examined with and without the benefit of particular types of pilot tracking.

Key Path: Meas Setup, More, More, Advanced

Track Amplitude

Track Amplitude specifies whether the test set tracks amplitude changes in the pilot subcarriers. When Track Amplitude is selected, the test set applies pilot subcarrier amplitude error correction to the pilot and data subcarriers. This is in addition to Track Phase and Track Timing error correction, if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:AMPLitude[?]

Track Phase

The Track Phase parameter specifies whether the test set tracks phase changes in the pilot subcarriers. When Track Phase is selected, the test set applies pilot subcarrier phase error correction to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Timing error correction if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:PHASe[?]

Track Timing

The Track Timing parameter specifies whether the test set tracks timing changes in the pilot subcarriers. Track Timing applies pilot subcarrier timing error correction (frequency offset correction) to the pilot and data subcarriers. This is in addition to Track Amplitude and Track Phase error correction if selected.

Key Path: Meas Setup, More, More, Advanced, Pilot Tracking

SCPI Command: CALCulate:EVM:PILot:TRACk:TIMing[?]

Equalizer Training

When demodulating the 802.16 OFDMA signal, the test set uses an equalizer to correct for linear impairments in the signal path, such as multi-path. The test set supports three different methods to initialize, or &rdquor;train&rdquo;, the equalizer: Preamble Only, Preamble, Data & Pilots and Preamble & Pilots Only. Selecting an appropriate method can help isolate problems that contribute to increased RCE (EVM).

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:EQUalizer:TMODe[?]

Equalizer Smoothing

This parameter determines whether a spectral flatness result trace are smoothed.

Key Path: Meas Setup, More, More, Advanced

SCPI Command: CALCulate:EVM:EQUalizer:SMOothing[:STATe][?]

Meas Preset

Restores all the measurement parameters to their default values.

Key Path: Meas Setup, More, More

SCPI Command: CONFigure:EVM


802.16 OFDM (N6301A)

Trigger

Last Updated: March 28, 2008

Accesses a menu that allows you to set triggering parameters for the current measurement. See Trigger in the Measurement Functions section for more information.

Key Path: Front panel key

SCPI Command: TRIGger:EVM[:SEQuence]:SOURce[?]

Trig Holdoff

Toggles the trigger hold off feature between On and Off. See Trigger in the &rdquor;Measurement Functions&rdquo; section for more information on trigger settings.

Key Path: Trigger


802.16 OFDM (N6301A)

Sweep/Control

Last Updated: March 28, 2008

Accesses settings that affect the sweep viewed in the display.

Key Path: Front panel key

Pause/Resume

Pauses a measurement after the current data acquisition is complete.

When Paused, the label on the key changes to Resume. Pressing Resume un-pauses the measurement.

Key Path: Front panel key


802.16 OFDM (N6301A)

Marker

Last Updated: March 28, 2008

Sets the marker control mode as described under Normal, Delta and Off, below. All interactions and dependencies detailed under the key description are enforced when the remote command is sent.

Key Path: Front panel key

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MODE[?]

Properties

Accesses a menu that enables you to select the active marker, the reference marker and the trace for the current measurement.

Key Path: Marker

Select Marker

Key Path: Marker

Relative To

Selects the marker that the selected marker will be relative to - its reference marker.

Key Path: Marker, Properties

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:REFerence[?]

Marker Trace

Accesses a menu that allows you to assign a specified marker to the designated trace.

Symbol Traces means that three traces for I/Q polar, Symbol Error Carrier, Symbol Error Symbol, Symbol Power Carrier, and Symbol Power Symbol can be assigned. If used, a marker pointer is placed on each trace. In this case, the three pointers will move at the same time, as coupled markers, whenever the X position of the Symbol Traces changes.

Key Path: Marker, Properties

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:TRACe[?]

All Markers Off

Turns all markers off.

Key Path: Marker, More

SCPI Command: CALCulate:EVM:MARKer:AOFF


802.16 OFDM (N6301A)

Peak Search

Last Updated: March 28, 2008

Accesses menus that allow you to set peak search parameters.

Key Path: Front panel key

Peak Search

Places the selected marker on the trace point with the maximum y-axis value for that marker's trace.

Key Path: Front panel key

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum

Next Peak

Moves the selected marker to the peak that has the next highest amplitude that is less than the marker's current value.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:NEXT

Next Pk Right

Moves the selected marker to the next peak to the right of the current marker.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:RIGHt

Next Pk Left

Moves the selected marker to the next peak to the left of the current marker.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MAXimum:LEFT

Marker Delta

Performs the same function as the Delta 1-of-N selection key in the Marker menu. This sets the control mode for the selected marker to Delta mode. The softkey allows you to conveniently perform a peak search and change the marker's control mode to Delta without having to access two separate menus.

Key Path: Peak Search

Pk-Pk Search

Finds and displays the amplitude and frequency (or time, if in zero span) differences between the highest and lowest y-axis value.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:PTPeak

Min Search

Moves the selected marker to the minimum y-axis value of the current trace.

Key Path: Peak Search

SCPI Command: CALCulate:EVM:MARKer[1]|2|3|4|5|6|7|8|9|10|11|12:MINimum


802.16 OFDM (N6301A)

Marker To

Last Updated: March 28, 2008

There is no 'Marker To' functionality supported in Modulation Analysis so this front-panel key will display a blank softkey when pressed.


802.16 OFDM (N6301A)

Marker Function

Last Updated: March 28, 2008

There are no 'Marker Functions' supported in Mod Analysis so this front-panel key will display a blank softkey when pressed.


802.16 OFDM (N6301A)

Programming Examples for Individual Measurements

Last Updated: March 28, 2008

The test set is programmable through GPIB.

For details on programming specific measurements, see the individual programming examples in this section.

For details on any specific SCPI command, see SCPI Commands (802.16 OFDMA).


802.16 OFDM (N6301A)

Programming a Burst Power Measurement

Last Updated: March 28, 2008

Example Code

*CLS

:SENSe:POWer:RANGe <inputpowerlevel> dBm

:SENSe:FREQuency:CENTer <frequency>

:CONFigure:WAVeform

// Setup for WAVeform Trigger

:SENSE:WAVeform:TRIGger:SOURce RFBurst

:TRIGger:SEQuence:RFBurst:LEVel:ABSolute <triglev> dBm

:TRIGger:SEQuence:RFBurst:DELay 10 us

:TRIGger:SEQuence:RFBurst:DELay:STATe ON

:TRIGger:SEQuence:SLOPe POS

:TRIGger:SEQuence:HOLDoff 50 us

:TRIGger:SEQuence:HOLDoff:STATe ON

//Set to Single Mode

:INITiate:CONTinuous OFF

:SENSe:WAVeform:SWEep:TIME <meastime>

// Results should be quicker if we only display the Power results

:SENSe:WAVeform:PONLy:STATe ON

// Start The measurement

:INIT:WAVeform

// Wait for measurement to complete

do

{

Status = int.Parse( Send_Query( "STAT:OPER:COND?" ), System.Globalization.CultureInfo.InvariantCulture );

} while ( ( Status & 0x10 ) != 0 );

// Now fetch back the results now that we know the measurement has completed

:FETch:WAVeform1?


[:SENSe]:ACPower

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


SCPI Commands (802.16 OFDM)

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


FETCh:ACPower?

802.16 OFDMA (N6301A)

Template for N6301A Help

Last Updated: March 11, 2008

The items in the Template for N6301A Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


Input/Output

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


N6301A 802.16 OFDM Measurement Application Help

This online help describes how to use the Agilent N6301A 802.16 OFDM Measurement Application. The Table of Contents on the left, provides access to all of the information contained within this online help.

The help is organized into the following sections:

  • SCPI Commands provides details on all of the SCPI syntax available to control this application by remote program.

  • Front Panel Operation provides reference information about the application's screens.

© Agilent Technologies, Inc. 2007-2008


SOURce:POWer

802.16 OFDM (N6301A)

Template for N6301A Fixed Wimax Help

Last Updated: March 11, 2008

The items in the Template for N6301A Fixed Wimax Helparea allow you to ???. Click on an item to get more details:

  • Item 1

  • Item 2

Item 1

Description of item 1.

Item 2

Description of item 2.


Notices

© Agilent Technologies, Inc. 2007-2008

No part of this Help file may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Warranty

The material contained in this document is provided ”as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as ”Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a ”commercial item” as defined in FAR 2.101(a) or as ”Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Safety Notices

The following general safety precautions must be observed during all phases of operation of this instrument. Failure to comply with these precautions or with specific warnings elsewhere in this manual violates safety standards of design, manufacture, and intended use of the instrument. Agilent Technologies Inc. assumes no liability for the customer’s failure to comply with these requirements.

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

Intended Use

This equipment is for indoor use only.

Any interruption of the protective (grounding) conductor (inside of outside the instrument) or disconnecting the protective earth terminal will cause a potential shock hazard that could result in personal injury. (Grounding one conductor of a two conductor outlet is not sufficient protection). In addition, verify that a common ground exists between the unit under test and this instrument prior to energising either unit.

Whenever it is likely that the protection has been impaired, the test set must be made inoperative and be secured against any unintended operation.

If this test set is to be powered via an auto-transformer (for voltage reduction) make sure that the common terminal is connected to neutral (that is, the grounded side of the mains supply).

No Operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electric shock do not remove covers.

Capacitors inside the test set may still be charged even if the test set has been disconnected from its source of supply.

Before Applying Power Protective Earthing Installation Warning

This is a Safety Class 1 Product (provided with a protective earthing ground, incorporated in the power cord). The mains plug shall only be inserted in a socket outlet provided with a protective earth contact. Any interruption of the protective conductor inside or outside of the instrument is likely to make the instrument dangerous. Intentional interruption is prohibited. If you energize this instrument by an auto transformer (for voltage reduction or mains isolation), the common terminal must be connected to the earth terminal of the power source.

Install the instrument so that the detachable power cord is readily identifiable and is easily reached by the operator. The detachable power cord is the instrument disconnecting device. It disconnects the mains circuits from the mains supply before other parts of the instrument. The front panel switch is only a standby switch and is not a LINE switch.

Do Not Remove The Instrument Cover

Operating personnel must not remove instrument covers. Only qualified service personnel must make component replacement and internal adjustments. Instruments that appear damaged or defective should be made inoperative and secured against unintended operation until qualified service personnel can repair them.

Do Not Operate In An Explosive Atmosphere

Do not operate the instrument in the presence of flammable gases or fumes.

Sound Emission

Herstellerbesch einigung

Diese Information steht im Zusammenhang mit den Anforderungen der Maschinenlarminformationsverordnung vom 18 Januar 1991.

  • Sound Pressure LpA < 70 dB.

  • Am Arbeitsplatz.

  • Normaler Betrieb.

  • Nach DIN 45635 T. 19 (Typprufung).

Manufacturers Declaration

This statement is provided to comply with the requirements of the German Sound DIN 45635 T. 19 (Typprufung).

  • Sound Pressure LpA < 70 dB.

  • At operator position.

  • Normal operation.

  • According to ISO 7779 (Type Test).

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation.

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe Reader ® is a U.S. registered trademark of Adobe System Incorporated.

Java™ is a U.S. trademark of Sun Microsystems, Inc.

MATLAB ® is a U.S. registered trademark of Math Works, Inc.

Norton Ghost™ is a U.S. trademark of Symantec Corporation.